dump-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. %define _sbindir /sbin
  2. # XXX --enable-kerberos needs krcmd
  3. %define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
  4. Summary: Programs for backing up and restoring ext2/ext3 filesystems.
  5. Summary(ja): ext2/ext3 ファイルシステムをバックアップ/リストアするプログラム
  6. Name: dump
  7. Version: 0.4b41
  8. Release: 2%{?_dist_release}
  9. License: BSD
  10. Group: Applications/Archiving
  11. URL: http://dump.sourceforge.net
  12. Source: dump-%{version}.tar.gz
  13. Patch1: dump-dmfix.patch
  14. #Patch2: dump-immutable.patch
  15. #Patch3: dump-0.4b41-libtinfo.patch
  16. BuildRoot: %{_tmppath}/%{name}-root
  17. BuildPrereq: libtermcap-devel
  18. BuildPrereq: e2fsprogs-devel >= 1.18, readline-devel >= 4.1
  19. BuildPrereq: zlib-devel, device-mapper-devel
  20. # This Prereq is now required because we only ship static binaries, and
  21. # need to ensure the "disk" group is created before installation (#60461)
  22. Prereq: setup
  23. Requires: rmt
  24. Obsoletes: dump-static
  25. #Provides: dump-static
  26. Packager: daisuke, kazutaka
  27. %description
  28. The dump package contains both dump and restore. Dump examines files
  29. in a filesystem, determines which ones need to be backed up, and
  30. copies those files to a specified disk, tape, or other storage medium.
  31. The restore command performs the inverse function of dump; it can
  32. restore a full backup of a filesystem. Subsequent incremental backups
  33. can then be layered on top of the full backup. Single files and
  34. directory subtrees may also be restored from full or partial backups.
  35. Install dump if you need a system for both backing up filesystems and
  36. restoring filesystems after backups.
  37. %description -l ja
  38. dump パッケージは dump と restore の両方を含んでいます。dump はファイル
  39. システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
  40. たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
  41. コピーします。
  42. restore コマンドは dump とは反対の処理を行います。restore コマンドを使
  43. うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
  44. プからの増分バックアップを適用することもできます。フルバックアップ、ま
  45. たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
  46. を復元することもできます。
  47. もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
  48. ストールしてください。
  49. %package -n rmt
  50. Summary: Provides certain programs with access to remote tape devices.
  51. Summary(ja): リモートテープ装置のアクセスに必要なプログラム
  52. Group: Applications/Archiving
  53. %description -n rmt
  54. The rmt utility provides remote access to tape devices for programs
  55. like dump (a filesystem backup program), restore (a program for
  56. restoring files from a backup), and tar (an archiving program).
  57. %description -n rmt -l ja
  58. rmt ユーティリティは、dump (ファイルシステムのバックアップ)や restore
  59. (バックアップからの復元)、tar (アーカイブの作成/展開) といったプログラ
  60. ムに、テープ装置へのリモートアクセスを提供します。
  61. %prep
  62. %setup -q
  63. %patch1 -p1 -b .dmfix
  64. #%patch2 -p1 -b .orig
  65. #%patch3 -p1 -b .libtinfo
  66. %build
  67. %configure %{myoptions} --disable-static --enable-rmt
  68. %ifarch alpha
  69. RPM_OPT_FLAGS=""
  70. %endif
  71. make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
  72. -Wmissing-prototypes -Wno-char-subscripts "
  73. %install
  74. rm -rf %{buildroot}
  75. mkdir -p %{buildroot}%{_sbindir}
  76. mkdir -p %{buildroot}%{_mandir}/man8
  77. %makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
  78. pushd $RPM_BUILD_ROOT
  79. ln -sf dump .%{_sbindir}/rdump
  80. # ln -sf dump .%{_sbindir}/rdump.static
  81. # ln -sf dump .%{_sbindir}/dump.static
  82. ln -sf restore .%{_sbindir}/rrestore
  83. # ln -sf restore .%{_sbindir}/rrestore.static
  84. # ln -sf restore .%{_sbindir}/restore.static
  85. chmod ug-s .%{_sbindir}/rmt
  86. mkdir -p .%{_sysconfdir}
  87. > .%{_sysconfdir}/dumpdates
  88. ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
  89. strip $RPM_BUILD_ROOT/sbin/* $RPM_BUILD_ROOT/usr/sbin/* || :
  90. popd
  91. %clean
  92. rm -rf %{buildroot}
  93. %files
  94. %defattr(-,root,root)
  95. %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
  96. %doc dump.lsm
  97. %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
  98. %attr(0755,root,root) /sbin/dump
  99. /sbin/rdump
  100. %attr(0755,root,root) /sbin/restore
  101. /sbin/rrestore
  102. #/sbin/*.static
  103. %{_mandir}/man8/dump.*
  104. %{_mandir}/man8/rdump.*
  105. %{_mandir}/man8/restore.*
  106. %{_mandir}/man8/rrestore.*
  107. %files -n rmt
  108. %defattr(-,root,root)
  109. %attr(0755,root,root)
  110. %{_sbindir}/rmt
  111. %{_sysconfdir}/rmt
  112. %{_mandir}/man8/rmt.*
  113. %changelog
  114. * Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
  115. - spec in UTF-8
  116. - change configure option to --disable-static
  117. - remove -static stuffs
  118. * Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
  119. - add Patch1 based on fedora development to build with device-mapper
  120. - add japanese summary and description.
  121. - apply new versioning policy.
  122. * Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
  123. - new upstream release
  124. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
  125. - spec file was in SJIS. fixed.
  126. * Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
  127. - new upstream release
  128. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
  129. - update upstream release based on rawhide package.
  130. - rebuild on new environment.
  131. * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
  132. - rebuilt against fixed statically linked system libraries
  133. * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
  134. - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
  135. * Mon Oct 7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
  136. - All-arch rebuild
  137. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  138. - automated rebuild
  139. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  140. - automated rebuild
  141. * Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
  142. - Updated to dump 0.4b28
  143. - Removed atomic_read/write patch, not needed anymore
  144. * Fri Mar 1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
  145. - BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
  146. - Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
  147. with included kernel headers. atomic_read is a function on s390 and as
  148. such, cannot be #undef'd
  149. * Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
  150. - Added prereq on "setup" to ensure disk group is created prior to this
  151. package being installed
  152. - Somehow the dump package changelog got hosed, and part of the spec file
  153. regressed. I believe it is fixed now.
  154. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
  155. - Updated to dump 0.4b27-1
  156. * Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
  157. - Bumped release up a couple notches to rebuild in rawhide
  158. * Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
  159. - Rebuilt 0.4b25 for erratum release. Fixes various bugs that have been
  160. reported in bugzilla which are logged below. Also fixes a bug caused by
  161. linking statically to a faulty system library.
  162. - Added Provides dump-static line
  163. * Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
  164. - Added missing zlib buildprereq
  165. - Rebuild in new environment
  166. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  167. - automated rebuild
  168. * Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
  169. - Updated to version 0.4b25-1
  170. - Added homepage URL for RFE (#54601)
  171. - Also fixed in this release are (#21272, #52663, #56616)
  172. - Dropped time.h patch as it is unneeded now
  173. * Tue Nov 6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
  174. - Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
  175. explicitly state the minimum required deps and fix (#51900)
  176. * Sat Sep 8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
  177. - Kill the static subpackage - the standard binaries are now static
  178. This removes /usb/sbin/*. The static versions are now in /sbin
  179. (#53433)
  180. - Obsolete dump-static
  181. * Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
  182. - Move non-static binaries to /usr/sbin (#49520)
  183. * Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
  184. - Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
  185. * Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
  186. - Added BuildPrereq: libtermcap-devel (#44734)
  187. * Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
  188. - Removed release tag from buildroot dirname - messy.
  189. - Broke all lines over multiple lines for readability in specfile.
  190. - Added --enable-largefile configure flags
  191. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
  192. - 0.4b22
  193. * Mon May 7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
  194. - Added BuildPrereq: e2fsprogs-devel (#27428)
  195. * Mon Apr 9 2001 Bill Nottingham <notting@redhat.com>
  196. - fix ia64
  197. * Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
  198. - fix build with current glibc
  199. * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  200. - change copyright: UCB to License: BSD
  201. * Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  202. - update to 0.4b21.
  203. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  204. - update to 0.4b20.
  205. * Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
  206. - dump 0.4b20 released, first packaging.
  207. * Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
  208. - remove setuid bits for Red Hat 5.x errata.
  209. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  210. - rebuild to cope with glibc locale binary incompatibility, again
  211. * Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
  212. - fix for dumping files between 2 and 4 gigs (#16466)
  213. * Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
  214. - don't use -O2 on alpha because of compiler ICE
  215. * Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
  216. - update to 0.4b19.
  217. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  218. - summaries from specspo.
  219. * Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
  220. - support LABEL= in fstab
  221. * Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
  222. - if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
  223. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  224. - rebuild to cope with glibc locale binary incompatibility
  225. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  226. - automatic rebuild
  227. * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
  228. - whoops I had dump commented out of the file list. fixed.
  229. - dropped suid bits on the static binaries.
  230. - fix char buffer size issue (#11880)
  231. * Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
  232. - dropped SUID bits
  233. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  234. - update to 0.4b17.
  235. - FHS packaging.
  236. * Thu Jun 1 2000 Stelian Pop <pop@cybercable.fr>
  237. - dump 0.4b17 released, first packaging.
  238. * Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
  239. - dump 0.4b16 released, first packaging.
  240. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  241. - use posix signal handling to preserve dump functionality with libc5.
  242. * Thu Mar 2 2000 Bill Nottingham <notting@redhat.com>
  243. - update to 0.4b15
  244. * Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
  245. - dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
  246. * Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
  247. - dump 0.4b14 released, first packaging.
  248. * Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com>
  249. - compress man pages.
  250. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  251. - update to 0.4b13.
  252. * Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
  253. - dump 0.4b13 released, first packaging.
  254. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
  255. - update to 0.4b12.
  256. * Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
  257. - dump 0.4b12 released, first packaging.
  258. * Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
  259. - dump 0.4b11 released, first packaging.
  260. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  261. - intergrate Stelian's fixes (Thanks!).
  262. * Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
  263. - dump 0.4b10 released, first packaging.
  264. * Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
  265. - make static versions also for rescue purposes.
  266. * Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
  267. - dump 0.4b9 released, first packaging.
  268. * Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
  269. - dump 0.4b8 released, first packaging.
  270. * Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
  271. - dump 0.4b7 released, first packaging.
  272. * Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
  273. - dump 0.4b6 released, first packaging.
  274. * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
  275. - recompile with e2fsprogs = 1.15 (#4962).
  276. * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
  277. - workaround egcs bug (#4281) that caused dump problems (#2989).
  278. - use sigjmp_buf, not jmp_buf (#3260).
  279. - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
  280. - use glibc21 err/glob rather than the internal compatibility routines.
  281. - wire $(OPT) throughout Makefile's.
  282. - fix many printf problems, mostly lint clean.
  283. - merge SuSE, Debian and many OpenBSD fixes.
  284. * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
  285. - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
  286. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  287. - auto rebuild in the new build environment (release 6)
  288. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  289. - strip binaries.
  290. * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
  291. - Fix dangling symlinks (#1551).
  292. * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
  293. - Top O' the morning, build root's fixed for man pages.
  294. * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
  295. - upgraded to dump 0.4b4, massaged patches.
  296. * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
  297. - added patch from Derrick J Brashear for traverse.c to stop bread errors
  298. * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
  299. - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
  300. - mark /etc/dumpdates as noreplace.
  301. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  302. - add build root.
  303. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  304. - translations modified for de, fr, tr
  305. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  306. - added a patch for resolving linux/types.h and sys/types.h conflicts
  307. * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
  308. - added prototype of llseek() so dump would work on large partitions
  309. * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
  310. - made all symlinks relative instead of absolute
  311. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  312. - built against glibc
  313. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  314. - Moved rmt to its own package.
  315. * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
  316. - Added endian cleanups for SPARC
  317. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  318. - Made /etc/dumpdates writeable by group disk.