global-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. #%define priority 30
  2. Summary: GNU GLOBAL is a source code tag system
  3. Summary(ja): GNU GLOBAL ソースコードタグシステム
  4. Name: global
  5. Version: 5.7.7
  6. Release: 1%{?_dist_release}
  7. License: GPLv3
  8. Group: Development/Tools
  9. URL: http://www.gnu.org/software/global/
  10. Source0: ftp://ftp.gnu.org/pub/gnu/global/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: perl
  13. Requires(post,preun): /sbin/install-info
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. GNU GLOBAL is a source code tag system that works the same way across diverse
  18. environments. It supports C, C++, Yacc and Java source code.
  19. %description -l ja
  20. GNU GLOBAL はソースコードに索引付けを行います.
  21. C, C++, Yacc, Java のソースコードをサポートします.
  22. %prep
  23. %setup -q
  24. %build
  25. %configure
  26. make
  27. %install
  28. rm -rf %{buildroot}
  29. %makeinstall
  30. # gctags command conflicts emacs package.
  31. #%__mv %{buildroot}%{_bindir}/gctags %{buildroot}%{_bindir}/gctags.global
  32. #%__mv %{buildroot}%{_mandir}/man1/gctags.1 %{buildroot}%{_mandir}/man1/gctags.global.1
  33. pushd $RPM_BUILD_ROOT%{_datadir}/gtags
  34. rm -f AUTHORS BOKIN_* COPYING ChangeLog DONORS FAQ \
  35. INSTALL LICENSE NEWS README THANKS
  36. popd
  37. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  38. %clean
  39. rm -rf %{buildroot}
  40. %post
  41. #/sbin/update-alternatives --install /usr/bin/gctags gctags /usr/bin/gctags.global %{priority}
  42. #/sbin/update-alternatives --config gctags
  43. /sbin/install-info %{_infodir}/global.info.* %{_infodir}/dir
  44. %preun
  45. if [ $1 = 0 ]; then
  46. # /sbin/update-alternatives --remove gctags /usr/bin/gctags.global
  47. /sbin/install-info --delete %{_infodir}/global.info.* %{_infodir}/dir
  48. fi
  49. %files
  50. %defattr(-,root,root)
  51. %doc AUTHORS BOKIN_* COPYING ChangeLog DONORS FAQ INSTALL
  52. %doc LICENSE NEWS README THANKS
  53. %doc globash.rc gtags.conf gtags.el gtags.pl
  54. %{_bindir}/*
  55. %{_mandir}/man?/*
  56. %{_datadir}/gtags
  57. %{_infodir}/global.info*
  58. %changelog
  59. * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.7.7-1
  60. - new upstream release
  61. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.7.5-1
  62. - new upstream release
  63. - spec in UTF-8
  64. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.7.1-1
  65. - new upstream release
  66. * Fri Jan 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.6.2-0vl1
  67. - new upstream release
  68. * Wed Aug 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.6-0vl1
  69. - new upstream release
  70. * Tue Oct 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.2-0vl1
  71. - new upstream release
  72. * Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.8.7-0vl1
  73. - new upstream release
  74. - this version is not necessary to use alternatives
  75. * Wed Aug 6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 4.6-0vl2
  76. - use alternatives for gctags
  77. - fix typo in URL
  78. * Fri Aug 1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 4.6-0vl1
  79. - update to 4.6
  80. - rename gctags.1 to gctags.global.1
  81. * Sat Jul 19 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 4.5.3-0vl1
  82. - update to 4.5.3
  83. - changed URL
  84. - removed gctags.1* (conflict emacs package)
  85. * Mon May 5 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 4.5.2-0vl1
  86. - Initial build.