self-build-gstreamer-plugins-ffmpeg-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154
  1. %define pkgname gstreamer-plugins-ffmpeg
  2. %define name self-build-%{pkgname}
  3. %define version 0.10.10
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2+ and LGPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. # (build)requies of target package.
  16. Requires: gstreamer >= 0.10.0
  17. Requires: gstreamer-plugins-base >= 0.10.0
  18. Requires(post): gstreamer-devel >= 0.10.0
  19. Requires(post): gstreamer-plugins-base-devel >= 0.10.0
  20. Requires(post): liboil-devel
  21. Requires(post): bzip2-devel
  22. ## Use internal ffmpeg
  23. # Requires(post): self-build-ffmpeg
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. GStreamer is a streaming media framework, based on graphs of filters which
  29. operate on media data. Applications using this library can do anything
  30. from real-time sound processing to playing videos, and just about anything
  31. else media-related. Its plugin-based architecture means that new data
  32. types or processing capabilities can be added simply by installing new
  33. plugins.
  34. This package provides FFmpeg-based GStreamer plug-ins.
  35. If you install this package, it automaticaly downloads source
  36. code, compile it, and create rpm packages of
  37. %{pkgname}-%{version}.
  38. And the created rpm packages are automatically installed
  39. if installation is executed by apt-get command or synaptic
  40. package manager.
  41. [Note]
  42. This package requires many other packages to compile
  43. targetsoftware. So it consume more disk space than usual.
  44. Also installation takes logner time because of compilation.
  45. (This will take a few minutes to quarter or half of an hour,
  46. depends on building environment)
  47. [About self-build package]
  48. For some kind of software, distributing of binary package
  49. may viorate the patent or law. Therefore we chose self-build
  50. packge, create binary package on your machine, for such kind
  51. of softwares instead of distributing binary package.
  52. Please obey the national law when you use the created binary
  53. packages. And if you want to use the softwares using patented
  54. thechnology, it may be required to get a permission, make an
  55. agreement or purchas a license. Please consider it with your
  56. purpose or way of use and take appropriate action.
  57. %description -l ja
  58. GStreamer はメディアデータ操作用の filter graph をベースにし
  59. たストリーミングメディアフレームワークです。 このライブラリを
  60. 使用すればアプリケーションは、サウンドのリアルタイム処理から
  61. ビデオ再生まで、メディアに関係する全ての機能が利用できます。
  62. また Gstremer はプラグイン方式を採用していることから、新しい
  63. 種類のデータや機能への対応が、プラグインを追加することで簡単
  64. に実現できます。
  65. このパッケージは ffmpeg ベースの GStreamer プラグインを提供し
  66. ます。
  67. このパッケージをインストールすると、自動的にソースコードをダ
  68. ウンロードしてコンパイルし、%{pkgname}-%{version}
  69. の rpm パッケージを作成します。
  70. また apt-get コマンドや synaptic パッケージマネージャから実行
  71. した場合は、作成された rpm パッケージのインストールも自動的に
  72. 行います。
  73. [注意]
  74. コンパイルに必要な多くの関連パッケージを要求するので通常より
  75. ディスクの領域を多く消費します。
  76. またインストール時にコンパイルを行うため、通常より時間がかか
  77. る場合があります。(環境にもよりますが数分から数十分程度)
  78. [self-build パッケージについて]
  79. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  80. 違反する可能性があるものがあります。その為、このような問題が
  81. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  82. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  83. ジという方法を採っています。
  84. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  85. アのライセンス、および利用する国の各種法令に従ってください。
  86. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  87. センスの購入などが必要となる場合がありますので、利用する目的
  88. や形態に応じて各自で判断し適切な対応を取ってください。
  89. %prep
  90. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  91. %install
  92. %{__rm} -rf ${RPM_BUILD_ROOT}
  93. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  94. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  95. %clean
  96. %{__rm} -rf ${RPM_BUILD_ROOT}
  97. %posttrans
  98. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 15000
  99. %files
  100. %defattr(-,root,root)
  101. %{_datadir}/%{name}/*
  102. %changelog
  103. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.10-1
  104. - new upstream release
  105. - renamed %%{Source0} to gstreamer-plugins-ffmpeg-vl.spec
  106. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.9-1
  107. - new upstream release
  108. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  109. - new upstream release
  110. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-2
  111. - added BuildArch: noarch
  112. - avoided to execute self-build-rpm.sh on RPM transaction
  113. - moved %%post actions to %%posttrans
  114. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-1
  115. - new upstream release
  116. - corrected %%description
  117. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.6-1
  118. - initial build
  119. ### end of file