self-build-lame-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. %define pkgname lame
  2. %define name self-build-%{pkgname}
  3. %define version 3.98.3
  4. %define release 1%{?_dist_release}
  5. #% define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
  6. %define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source1: %{pkgname}-noexecstack.patch
  14. Source2: %{pkgname}-pmake.patch
  15. License: GPL
  16. Group: Restricted Software
  17. Requires(post): self-build-setup >= 0.8
  18. # (build)requies of target package.
  19. Requires(post): ncurses
  20. Requires(post): ncurses-devel
  21. Requires(post): gtk+
  22. Requires(post): gtk+-devel
  23. %ifarch %{ix86} x86_64
  24. Requires(post): nasm
  25. %endif
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Packager: munepi
  28. %description
  29. Lame is an open source developing mp3 encoder.
  30. If you install this package, it automaticaly downloads source
  31. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  32. And the created rpm packages are automatically installed
  33. if installation is executed by apt-get command or synaptic
  34. package manager.
  35. [Note]
  36. This package requires many other packages to compile
  37. targetsoftware. So it consume more disk space than usual.
  38. Also installation takes logner time because of compilation.
  39. (This will take a few minutes to quarter or half of an hour,
  40. depends on building environment)
  41. [About self-build package]
  42. For some kind of software, distributing of binary package
  43. may viorate the patent or law. Therefore we chose self-build
  44. packge, create binary package on your machine, for such kind
  45. of softwares instead of distributing binary package.
  46. Please obey the national law when you use the created binary
  47. packages. And if you want to use the softwares using patented
  48. thechnology, it may be required to get a permission, make an
  49. agreement or purchas a license. Please consider it with your
  50. purpose or way of use and take appropriate action.
  51. %description -l ja
  52. lame はオープンソースで開発されている mp3 エンコーダです。
  53. このパッケージをインストールすると、自動的にソースコードを
  54. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  55. パッケージを作成します。
  56. また apt-get コマンドや synaptic パッケージマネージャから実行
  57. した場合は、作成された rpm パッケージのインストールも自動的に
  58. 行います。
  59. [注意]
  60. コンパイルに必要な多くの関連パッケージを要求するので通常より
  61. ディスクの領域を多く消費します。
  62. またインストール時にコンパイルを行うため、通常より時間がかか
  63. る場合があります。(環境にもよりますが数分から数十分程度)
  64. [self-build パッケージについて]
  65. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  66. 違反する可能性があるものがあります。その為、このような問題が
  67. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  68. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  69. ジという方法を採っています。
  70. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  71. アのライセンス、および利用する国の各種法令に従ってください。
  72. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  73. センスの購入などが必要となる場合がありますので、利用する目的
  74. や形態に応じて各自で判断し適切な対応を取ってください。
  75. %prep
  76. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  77. %install
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  80. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  81. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  82. %{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  83. %clean
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %posttrans
  86. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 65000
  87. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  88. %{pkgname}-mp3x-%{version}-%{release} \
  89. %{pkgname}-devel-%{version}-%{release}
  90. %files
  91. %defattr(-,root,root)
  92. %{_datadir}/%{name}
  93. %changelog
  94. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.3-1
  95. - new upstream release
  96. - renamed %%{Source0} to lame-vl.spec
  97. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-2
  98. - rebuilt to add signature
  99. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-1
  100. - new upstream release
  101. * Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-5
  102. - dropped BuildArch: noarch
  103. (because if BuildArch: noarch, %%ifarch is invalid)
  104. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-4
  105. - added BuildArch: noarch
  106. - avoided to execute self-build-rpm.sh on RPM transaction
  107. - moved %%post actions to %%posttrans
  108. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-3
  109. - spec in utf8
  110. - remove *.la
  111. * Wed May 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-2
  112. - change %%{__make} option to -j1 in Source0 <BTS:VineLinux:611>
  113. - remove trailing /* in %%files <BTS:VineLinux:622>
  114. * Sat May 03 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-1
  115. - run pre-allocate-rpm.sh in %%post
  116. - set PreReq: self-build-setup >= 0.8
  117. - apply new versioning policy
  118. * Thu Nov 01 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl3
  119. - update description about self-build package
  120. * Mon Oct 22 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl2
  121. - unset BuildArch: noarch
  122. * Thu Oct 18 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl1
  123. - initial build for Vine Linux
  124. (using same version number of target software)