self-build-libdca-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. %define pkgname libdca
  2. %define name self-build-%{pkgname}
  3. %define version 0.0.5
  4. %define release 4%{?_dist_release}
  5. %define sourceurl0 http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source1: libdca-0.0.5-relsymlinks.patch
  13. License: GPLv2+
  14. Group: Restricted Software
  15. Requires(post): self-build-setup >= 0.9.9
  16. # (build)requies of target package.
  17. Requires(post): automake, libtool
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Packager: munepi
  21. %description
  22. libdca is a free library for decoding DTS Coherent Acoustics
  23. streams. It is released under the terms of the GPL license.
  24. The DTS Coherent Acoustics standard is used in a variety of
  25. applications, including DVD, DTS audio CD and radio broadcasting.
  26. If you install this package, it automaticaly downloads source
  27. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  28. And the created rpm packages are automatically installed
  29. if installation is executed by apt-get command or synaptic
  30. package manager.
  31. [Note]
  32. This package requires many other packages to compile
  33. targetsoftware. So it consume more disk space than usual.
  34. Also installation takes logner time because of compilation.
  35. (This will take a few minutes to quarter or half of an hour,
  36. depends on building environment)
  37. [About self-build package]
  38. For some kind of software, distributing of binary package
  39. may viorate the patent or law. Therefore we chose self-build
  40. packge, create binary package on your machine, for such kind
  41. of softwares instead of distributing binary package.
  42. Please obey the national law when you use the created binary
  43. packages. And if you want to use the softwares using patented
  44. thechnology, it may be required to get a permission, make an
  45. agreement or purchas a license. Please consider it with your
  46. purpose or way of use and take appropriate action.
  47. %description -l ja
  48. libdca は DTS Coherent Acoustics ストリームをデコードするため
  49. のフリーなライブラリです.GPL の下でリリースされています.
  50. DTS Coherent Acoustics は DVD や DTS オーディオ,ラジオ放送に
  51. 含まれており、多様なアプリケーションで使われています.
  52. このパッケージをインストールすると、自動的にソースコードを
  53. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  54. の rpm パッケージを作成します。
  55. また apt-get コマンドや synaptic パッケージマネージャから実行
  56. した場合は、作成された rpm パッケージのインストールも自動的に
  57. 行います。
  58. [注意]
  59. コンパイルに必要な多くの関連パッケージを要求するので通常より
  60. ディスクの領域を多く消費します。
  61. またインストール時にコンパイルを行うため、通常より時間がかか
  62. る場合があります。(環境にもよりますが数分から数十分程度)
  63. [self-build パッケージについて]
  64. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  65. 違反する可能性があるものがあります。その為、このような問題が
  66. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  67. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  68. ジという方法を採っています。
  69. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  70. アのライセンス、および利用する国の各種法令に従ってください。
  71. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  72. センスの購入などが必要となる場合がありますので、利用する目的
  73. や形態に応じて各自で判断し適切な対応を取ってください。
  74. %prep
  75. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  76. %install
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  80. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  81. %clean
  82. %{__rm} -rf ${RPM_BUILD_ROOT}
  83. %posttrans
  84. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 30000
  85. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  86. %{pkgname}-devel-%{version}-%{release}
  87. %files
  88. %defattr(-,root,root)
  89. %{_datadir}/%{name}
  90. %changelog
  91. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-4
  92. - renamed %%{Source0} to libdca-vl.spec
  93. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.5-3
  94. - added BuildArch: noarch
  95. - avoided to execute self-build-rpm.sh on RPM transaction
  96. - moved %%post actions to %%posttrans
  97. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.5-2
  98. - spec in utf8
  99. - remove *.la
  100. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.5-1
  101. - run pre-allocate-rpm.sh in %%post
  102. - set PreReq: self-build-setup >= 0.8
  103. - apply new versioning policy
  104. * Tue Feb 19 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.5-0vl1
  105. - initial build for Vine Linux 4.2
  106. ### end of file