libdvbpsi-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. ## -*- coding: utf-8-unix -*-
  2. %define real_name libdvbpsi5
  3. Summary: Library for MPEG TS and DVB PSI tables decoding and generation
  4. Name: libdvbpsi
  5. Version: 0.1.6
  6. Release: 2%{?_dist_release}
  7. License: GPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.videolan.org/developers/libdvbpsi.html
  10. Source0: http://download.videolan.org/pub/libdvbpsi/%{version}/%{real_name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: graphviz doxygen
  13. %description
  14. libdvbpsi is a very simple and fully portable library designed for
  15. MPEG TS and DVB PSI table decoding and generation.
  16. %package devel
  17. Summary: Development package for %{name}
  18. Group: Development/Libraries
  19. Requires: %{name} = %{version}-%{release}
  20. %description devel
  21. libdvbpsi is a very simple and fully portable library designed for
  22. MPEG TS and DVB PSI table decoding and generation.
  23. This package contains development files for %{name}
  24. %prep
  25. %setup -q -n %{real_name}-%{version}
  26. %build
  27. %configure \
  28. --disable-dependency-tracking \
  29. --disable-static
  30. %__make %{?_smp_mflags}
  31. %__make doc
  32. %install
  33. %__rm -rf $RPM_BUILD_ROOT
  34. %__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  35. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  36. %clean
  37. %__rm -rf $RPM_BUILD_ROOT
  38. %post -p /sbin/ldconfig
  39. %postun -p /sbin/ldconfig
  40. %files
  41. %defattr(-,root,root,-)
  42. %doc AUTHORS COPYING ChangeLog README
  43. %{_libdir}/%{name}.so.*
  44. %files devel
  45. %defattr(-,root,root,-)
  46. %doc doc/doxygen/html
  47. %{_includedir}/dvbpsi/
  48. %{_libdir}/lib*.so
  49. %changelog
  50. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-2
  51. - change release to sync with self-build-libdvbpsi
  52. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-1
  53. - built based on RPM Fusion development
  54. * Sat Oct 17 2009 kwizart < kwizart at gmail.com > - 0.1.6-6
  55. - Rebuild
  56. * Sun Apr 5 2009 kwizart < kwizart at gmail.com > - 0.1.6-5
  57. - Rebuild
  58. * Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 0.1.6-4
  59. - rebuild for new F11 features
  60. * Mon Aug 04 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.1.6-3
  61. - rebuild
  62. * Tue Feb 26 2008 kwizart < kwizart at gmail.com > - 0.1.6-2
  63. - Rebuild for gcc43
  64. * Mon Oct 22 2007 kwizart < kwizart at gmail.com > - 0.1.6-1
  65. - Update to 0.1.6
  66. * Sun Oct 14 2007 kwizart < kwizart at gmail.com > - 0.1.5-3
  67. - Rpmfusion Merge Review
  68. * Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.1.5-2
  69. - Drop Epoch completely
  70. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  71. - switch to new release field
  72. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  73. - add dist
  74. * Tue Jul 12 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 0:0.1.5-0.lvn.1
  75. - 0.1.5.
  76. - Build with dependency tracking disabled.
  77. - Miscellaneous specfile cleanups.
  78. * Mon May 17 2004 Dams <anvil[AT]livna.org> - 0:0.1.3-0.lvn.4
  79. - Added url in Source0
  80. * Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:0.1.3-0.fdr.3
  81. - Removed comment after scriptlets
  82. * Mon Aug 18 2003 Dams <anvil[AT]livna.org> 0:0.1.3-0.fdr.2
  83. - Moved some doc to devel package
  84. * Sat Aug 16 2003 Dams <anvil[AT]livna.org> 0:0.1.3-0.fdr.1
  85. - Added post/postun scriptlets
  86. - Using RPM_OPT_FLAGS
  87. - Updated to 0.1.3
  88. * Sun Jun 29 2003 Dams <anvil[AT]livna.org>
  89. - Initial build.