self-build-libdvbpsi-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118
  1. %define pkgname libdvbpsi
  2. %define name self-build-%{pkgname}
  3. %define version 0.1.6
  4. %define release 2%{?_dist_release}
  5. %define real_name libdvbpsi5
  6. %define sourceurl0 http://download.videolan.org/pub/libdvbpsi/%{version}/%{real_name}-%{version}.tar.bz2
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. License: GPLv2+
  14. Group: Restricted Software
  15. # Requires(posttrans) not yet implemented. So we use (post) instead.
  16. Requires(post): self-build-setup >= 0.9.9
  17. Requires(post): graphviz
  18. Requires(post): doxygen
  19. BuildArch: noarch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Packager: munepi
  22. %description
  23. libdvbpsi is a very simple and fully portable library designed for
  24. MPEG TS and DVB PSI table decoding and generation.
  25. If you install this package, it automaticaly downloads source
  26. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  27. And the created rpm packages are automatically installed
  28. if installation is executed by apt-get command or synaptic
  29. package manager.
  30. [Note]
  31. This package requires many other packages to compile
  32. targetsoftware. So it consume more disk space than usual.
  33. Also installation takes logner time because of compilation.
  34. (This will take a few minutes to quarter or half of an hour,
  35. depends on building environment)
  36. [About self-build package]
  37. For some kind of software, distributing of binary package
  38. may viorate the patent or law. Therefore we chose self-build
  39. packge, create binary package on your machine, for such kind
  40. of softwares instead of distributing binary package.
  41. Please obey the national law when you use the created binary
  42. packages. And if you want to use the softwares using patented
  43. thechnology, it may be required to get a permission, make an
  44. agreement or purchas a license. Please consider it with your
  45. purpose or way of use and take appropriate action.
  46. %description -l ja
  47. libdvbpsi は MPEG TS と DVB PSI テーブル復号と生成のために設計された
  48. とても単純で完全な汎用ライブラリです。
  49. このパッケージをインストールすると、自動的にソースコードを
  50. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  51. パッケージを作成します。
  52. また apt-get コマンドや synaptic パッケージマネージャから実行
  53. した場合は、作成された rpm パッケージのインストールも自動的に
  54. 行います。
  55. [注意]
  56. コンパイルに必要な多くの関連パッケージを要求するので通常より
  57. ディスクの領域を多く消費します。
  58. またインストール時にコンパイルを行うため、通常より時間がかか
  59. る場合があります。(環境にもよりますが数分から数十分程度)
  60. [self-build パッケージについて]
  61. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  62. 違反する可能性があるものがあります。その為、このような問題が
  63. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  64. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  65. ジという方法を採っています。
  66. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  67. アのライセンス、および利用する国の各種法令に従ってください。
  68. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  69. センスの購入などが必要となる場合がありますので、利用する目的
  70. や形態に応じて各自で判断し適切な対応を取ってください。
  71. %prep
  72. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  73. %install
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  76. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  77. %clean
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %posttrans
  80. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 95000
  81. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  82. %{pkgname}-devel-%{version}-%{release}
  83. %files
  84. %defattr(-,root,root)
  85. %{_datadir}/%{name}
  86. %changelog
  87. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-2
  88. - renamed %%{Source0} to libdvbpsi-vl.spec
  89. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-1
  90. - initial bulid for self-build