self-build-libdvdnav-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. %define pkgname libdvdnav
  2. %define name self-build-%{pkgname}
  3. %define version 4.1.3
  4. %define release 5%{?_dist_release}
  5. %define source0path MPlayer/releases/dvdnav/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. Requires(post): doxygen
  16. Requires(post): libdvdread-devel >= 4.1.3-1
  17. BuildArch: noarch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Packager: munepi
  20. %description
  21. libdvdnav provides a simple library for reading DVD video discs.
  22. The code is based on Ogle and used in, among others, the Xine dvdnav plug-in.
  23. If you install this package, it automaticaly downloads source
  24. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  25. And the created rpm packages are automatically installed
  26. if installation is executed by apt-get command or synaptic
  27. package manager.
  28. [Note]
  29. This package requires many other packages to compile
  30. targetsoftware. So it consume more disk space than usual.
  31. Also installation takes logner time because of compilation.
  32. (This will take a few minutes to quarter or half of an hour,
  33. depends on building environment)
  34. [About self-build package]
  35. For some kind of software, distributing of binary package
  36. may viorate the patent or law. Therefore we chose self-build
  37. packge, create binary package on your machine, for such kind
  38. of softwares instead of distributing binary package.
  39. Please obey the national law when you use the created binary
  40. packages. And if you want to use the softwares using patented
  41. thechnology, it may be required to get a permission, make an
  42. agreement or purchas a license. Please consider it with your
  43. purpose or way of use and take appropriate action.
  44. %description -l ja
  45. libdvdnavはDVDビデオディスクを読み取るためのシンプルなライブラリを
  46. 提供しています。
  47. そのコードは Ogle をベースにしていて、他の間で、xine dvdnav プラグインで、
  48. 使用されています。
  49. このパッケージをインストールすると、自動的にソースコードを
  50. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  51. パッケージを作成します。
  52. また apt-get コマンドや synaptic パッケージマネージャから実行
  53. した場合は、作成された rpm パッケージのインストールも自動的に
  54. 行います。
  55. [注意]
  56. コンパイルに必要な多くの関連パッケージを要求するので通常より
  57. ディスクの領域を多く消費します。
  58. またインストール時にコンパイルを行うため、通常より時間がかか
  59. る場合があります。(環境にもよりますが数分から数十分程度)
  60. [self-build パッケージについて]
  61. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  62. 違反する可能性があるものがあります。その為、このような問題が
  63. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  64. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  65. ジという方法を採っています。
  66. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  67. アのライセンス、および利用する国の各種法令に従ってください。
  68. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  69. センスの購入などが必要となる場合がありますので、利用する目的
  70. や形態に応じて各自で判断し適切な対応を取ってください。
  71. %prep
  72. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  73. %install
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  76. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  77. %clean
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %posttrans
  80. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  81. http://www{1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} 15000
  82. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  83. %{pkgname}-devel-%{version}-%{release}
  84. %files
  85. %defattr(-,root,root)
  86. %{_datadir}/%{name}/*
  87. %changelog
  88. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 4.1.3-5
  89. - renamed %%{Source0} to libdvdnav-vl.spec
  90. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-4
  91. - added BuildArch: noarch
  92. - avoided to execute self-build-rpm.sh on RPM transaction
  93. - moved %%post actions to %%posttrans
  94. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-3
  95. - added BuildRequires: doxygen
  96. * Sat Dec 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
  97. - added PreReq: libdvdread-devel >= 4.1.3-1
  98. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
  99. - initial bulid based on Fedora package