self-build-libmpeg2-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. %define pkgname libmpeg2
  2. %define name self-build-%{pkgname}
  3. %define version 0.5.1
  4. %define release 4%{?_dist_release}
  5. %define sourceurl0 http://libmpeg2.sourceforge.net/files/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. Requires(post): SDL-devel
  16. %if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl6"
  17. Requires(post): libXt-devel
  18. Requires(post): libXv-devel
  19. %endif
  20. %if %{?_dist_release} == "vl4"
  21. Requires(post): XOrg-devel
  22. %endif
  23. BuildArch: noarch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Packager: munepi
  26. %description
  27. libmpeg2 is a free library for decoding mpeg-2 and mpeg-1 video
  28. streams. It is released under the terms of the GPL license.
  29. If you install this package, it automaticaly downloads source
  30. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  31. And the created rpm packages are automatically installed
  32. if installation is executed by apt-get command or synaptic
  33. package manager.
  34. [Note]
  35. This package requires many other packages to compile
  36. targetsoftware. So it consume more disk space than usual.
  37. Also installation takes logner time because of compilation.
  38. (This will take a few minutes to quarter or half of an hour,
  39. depends on building environment)
  40. [About self-build package]
  41. For some kind of software, distributing of binary package
  42. may viorate the patent or law. Therefore we chose self-build
  43. packge, create binary package on your machine, for such kind
  44. of softwares instead of distributing binary package.
  45. Please obey the national law when you use the created binary
  46. packages. And if you want to use the softwares using patented
  47. thechnology, it may be required to get a permission, make an
  48. agreement or purchas a license. Please consider it with your
  49. purpose or way of use and take appropriate action.
  50. %description -l ja
  51. libmpeg2 はmpeg-1/2ビデオストリームをデコードするための
  52. フリーなライブラリです.
  53. このパッケージをインストールすると、自動的にソースコードを
  54. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  55. パッケージを作成します。
  56. また apt-get コマンドや synaptic パッケージマネージャから実行
  57. した場合は、作成された rpm パッケージのインストールも自動的に
  58. 行います。
  59. [注意]
  60. コンパイルに必要な多くの関連パッケージを要求するので通常より
  61. ディスクの領域を多く消費します。
  62. またインストール時にコンパイルを行うため、通常より時間がかか
  63. る場合があります。(環境にもよりますが数分から数十分程度)
  64. [self-build パッケージについて]
  65. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  66. 違反する可能性があるものがあります。その為、このような問題が
  67. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  68. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  69. ジという方法を採っています。
  70. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  71. アのライセンス、および利用する国の各種法令に従ってください。
  72. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  73. センスの購入などが必要となる場合がありますので、利用する目的
  74. や形態に応じて各自で判断し適切な対応を取ってください。
  75. %install
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %clean
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %posttrans
  82. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 60000
  83. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  84. %{pkgname}-devel-%{version}-%{release} \
  85. mpeg2dec-%{version}-%{release}
  86. %files
  87. %defattr(-,root,root)
  88. %{_datadir}/%{name}/*
  89. %changelog
  90. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-4
  91. - renamed %%{Source0} to libmpeg2-vl.spec
  92. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.1-3
  93. - added BuildArch: noarch
  94. - avoided to execute self-build-rpm.sh on RPM transaction
  95. - moved %%post actions to %%posttrans
  96. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.1-2
  97. - initial bulid for self-build