self-build-mplayer-codecs-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. %define pkgname mplayer-codecs
  2. %define name self-build-%{pkgname}
  3. %define version 20071007
  4. %define release 6%{?_dist_release}
  5. %ifarch %{ix86}
  6. %define source0path MPlayer/releases/codecs/essential-%{version}.tar.bz2
  7. %endif
  8. %ifarch ppc
  9. %define source0path MPlayer/releases/codecs/essential-ppc-%{version}.tar.bz2
  10. %endif
  11. %ifarch x86_64
  12. %define source0path MPlayer/releases/codecs/essential-amd64-%{version}.tar.bz2
  13. %endif
  14. Summary: Package to automatically build %{pkgname} rpm package
  15. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  16. Name: %{name}
  17. Version: %{version}
  18. Release: %{release}
  19. Source0: %{pkgname}-vl.spec
  20. License: GPL
  21. Group: Restricted Software
  22. Requires(post): self-build-setup >= 0.9.9
  23. Requires: libstdc++3
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Packager: munepi
  26. %description
  27. Binary codecs for MPlayer.
  28. If you install this package, it automaticaly downloads source
  29. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  30. And the created rpm packages are automatically installed
  31. if installation is executed by apt-get command or synaptic
  32. package manager.
  33. [Note]
  34. This package requires many other packages to compile
  35. targetsoftware. So it consume more disk space than usual.
  36. Also installation takes logner time because of compilation.
  37. (This will take a few minutes to quarter or half of an hour,
  38. depends on building environment)
  39. [About self-build package]
  40. For some kind of software, distributing of binary package
  41. may viorate the patent or law. Therefore we chose self-build
  42. packge, create binary package on your machine, for such kind
  43. of softwares instead of distributing binary package.
  44. Please obey the national law when you use the created binary
  45. packages. And if you want to use the softwares using patented
  46. thechnology, it may be required to get a permission, make an
  47. agreement or purchas a license. Please consider it with your
  48. purpose or way of use and take appropriate action.
  49. %description -l ja
  50. MPlayer 用のバイナリ Codec です。
  51. このパッケージをインストールすると、自動的にソースコードを
  52. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  53. の rpm パッケージを作成します。
  54. また apt-get コマンドや synaptic パッケージマネージャから実行
  55. した場合は、作成された rpm パッケージのインストールも自動的に
  56. 行います。
  57. [注意]
  58. コンパイルに必要な多くの関連パッケージを要求するので通常より
  59. ディスクの領域を多く消費します。
  60. またインストール時にコンパイルを行うため、通常より時間がかか
  61. る場合があります。(環境にもよりますが数分から数十分程度)
  62. [self-build パッケージについて]
  63. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  64. 違反する可能性があるものがあります。その為、このような問題が
  65. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  66. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  67. ジという方法を採っています。
  68. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  69. アのライセンス、および利用する国の各種法令に従ってください。
  70. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  71. センスの購入などが必要となる場合がありますので、利用する目的
  72. や形態に応じて各自で判断し適切な対応を取ってください。
  73. %prep
  74. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  75. %install
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %clean
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %posttrans
  82. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  83. http://www{1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} 2250
  84. %files
  85. %defattr(-,root,root)
  86. %{_datadir}/%{name}/*
  87. %changelog
  88. * Sun Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 20071007-6
  89. - renamed %%{Source0} to mplayer-codecs-vl.spec
  90. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-5
  91. - added Requires: libstdc++3
  92. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-4
  93. - dropped BuildArch: noarch
  94. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-3
  95. - added BuildArch: noarch
  96. - avoided to execute self-build-rpm.sh on RPM transaction
  97. - moved %%post actions to %%posttrans
  98. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-2
  99. - spec in utf8
  100. - fixed %%release for new versioning policy in mplayer-codecs.spec
  101. - dropped ttfontdir variable in mplayer-codecs.spec
  102. * Sun Jun 08 2008 Atsushi SHICHI <ats777@gmail.com> 20071007-1
  103. - build with new versioning policy.
  104. - fix <BTS:VineLinux:603>.
  105. - add ">= 0.7-1" to "PreReq: self-build-setup".
  106. - add mirror URLs to self-build-rpm.sh.
  107. * Sun Mar 2 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-0vl2
  108. - change source download URL. (see <BTS:VineLinux:603>)
  109. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 20071007-0vl1
  110. - initial build for Vine Linux.