parole-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. # by default don't build the browser plugin
  2. # use bcond_without to change the default
  3. %bcond_with mozilla
  4. Name: parole
  5. Version: 0.2.0.2
  6. Release: 1%{?_dist_release}
  7. Summary: Media player for the Xfce desktop
  8. Summary(ja): Xfce デスクトップのメディアプレーヤー
  9. Group: Applications/Multimedia
  10. License: GPLv2+
  11. URL: http://goodies.xfce.org/projects/applications/parole
  12. Source0: http://archive.xfce.org/src/apps/parole/0.1/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gtk2-devel >= 2.16.0
  15. BuildRequires: glib2-devel >= 2.16.0
  16. BuildRequires: gstreamer-devel
  17. BuildRequires: gstreamer-plugins-base-devel >= 0.10.11
  18. BuildRequires: dbus-devel >= 0.60
  19. BuildRequires: dbus-glib-devel >= 0.70
  20. BuildRequires: libxfcegui4-devel >= 4.6.0
  21. BuildRequires: libxfce4util-devel >= 4.6.0
  22. BuildRequires: libnotify-devel >= 0.4.1
  23. BuildRequires: taglib-devel >= 1.4
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: gettext
  26. BuildRequires: intltool
  27. %if %{with mozilla}
  28. BuildRequires: xulrunner-devel
  29. %endif
  30. BuildRequires: gtk-doc
  31. Requires: gstreamer-plugins-good
  32. %description
  33. Parole is a modern simple media player based on the GStreamer framework and
  34. written to fit well in the Xfce desktop. Parole features playback of local
  35. media files, DVD/CD and live streams. Parole is extensible via plugins.
  36. The project still in its early developments stage, but already contains the
  37. following features:
  38. * Audio playback
  39. * Video playback with optional subtitle
  40. * Playback of live sources
  41. %description -l ja
  42. Parole は GStreamer フレームワークに基づき Xfce デスクトップに
  43. 馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
  44. Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
  45. 特色とします。
  46. Parole はプラグインを介して拡張が可能です。
  47. このプロジェクトはまだ開発の初期段階ですが、
  48. 既に以下の機能がふくまれています。
  49. * オーディオの再生
  50. * 任意のサブタイトルがあるビデオの再生
  51. * ライブストリームの再生
  52. %package devel
  53. Summary: Development files for %{name}
  54. Summary(ja): %{name} の開発ファイル
  55. Group: Development/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: gtk-doc
  58. %description devel
  59. The %{name}-devel package contains header files for developing plugins for
  60. %{name}.
  61. %description devel -l ja
  62. %{name}-devel パッケージ は %{name} のプラグインを開発するための
  63. ヘッダファイルを含みます。
  64. %if %{with mozilla}
  65. %package mozplugin
  66. Summary: Browser plugin for %{name}
  67. Group: Application/Internet
  68. Requires: %{name} = %{version}-%{release}
  69. %description mozplugin
  70. Parole is a modern simple media player based on the GStreamer framework and
  71. written to fit well in the Xfce desktop. This plugin allows it to be embedded
  72. in a web browser.
  73. %endif
  74. %prep
  75. %setup -q
  76. %build
  77. %configure --disable-static --enable-gtk-doc \
  78. %if %{with mozilla}
  79. --enable-browser-plugin
  80. %else
  81. --disable-browser-plugin
  82. %endif
  83. make %{?_smp_mflags} V=1
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. make install DESTDIR=$RPM_BUILD_ROOT
  87. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  88. %find_lang %{name}
  89. desktop-file-install \
  90. --delete-original \
  91. --dir=%{buildroot}%{_datadir}/applications \
  92. %{buildroot}/%{_datadir}/applications/%{name}.desktop
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post
  96. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  97. update-mime-database %{_datadir}/mime &> /dev/null || :
  98. %postun
  99. if [ $1 -eq 0 ] ; then
  100. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  101. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  102. fi
  103. update-mime-database %{_datadir}/mime &> /dev/null || :
  104. %posttrans
  105. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  106. %files -f %{name}.lang
  107. %defattr(-,root,root,-)
  108. %doc AUTHORS COPYING README TODO THANKS
  109. %{_bindir}/%{name}
  110. %dir %{_libdir}/%{name}-0/
  111. %{_libdir}/%{name}-0/*.so
  112. %{_datadir}/applications/%{name}.desktop
  113. %{_datadir}/icons/hicolor/*
  114. %{_datadir}/%{name}/
  115. %files devel
  116. %defattr(-,root,root,-)
  117. %doc %{_datadir}/gtk-doc/html/Parole-Plugins/
  118. %{_includedir}/%{name}/
  119. %if %{with mozilla}
  120. %files mozplugin
  121. %defattr(-,root,root,-)
  122. %{_libexecdir}/%{name}-media-plugin
  123. %{_libdir}/mozilla/plugins/%{name}-player.so
  124. %endif
  125. %changelog
  126. * Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
  127. - new upstream release
  128. * Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
  129. - new upstream release
  130. * Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
  131. - new upstream release
  132. - added BuildRequires: glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
  133. * Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
  134. - new upstream release
  135. - added BuildRequires: gstreamer-devel
  136. - splitted mozplugin package
  137. * Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
  138. - new upstream release
  139. - dropt all pathces
  140. * Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
  141. - initial build for VineSeed
  142. * Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
  143. - BuildRequire taglib-devel and fix libnotify requirement
  144. * Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
  145. - Update to 0.1.90
  146. - Loads of additional translations
  147. * Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
  148. - Initial package