rsync-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341
  1. %bcond_with systemd
  2. Summary: A program for synchronizing files over a network.
  3. Summary(ja): ネットワーク越しにファイルを同期させるプログラム
  4. Name: rsync
  5. Version: 3.2.3
  6. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  7. Group: network
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: GPLv3+
  12. URL: https://rsync.samba.org/
  13. Source: https://download.samba.org/pub/rsync/src/rsync-%{version}.tar.gz
  14. Source1: https://download.samba.org/pub/rsync/src/rsync-patches-%{version}.tar.gz
  15. Source2: rsyncd.socket
  16. Source3: rsyncd.service
  17. Source4: rsyncd.conf
  18. Source5: rsyncd.sysconfig
  19. Source6: rsyncd@.service
  20. Source100: rsync.xinetd
  21. #Added temporarily until new rebase
  22. Patch0: rsync-3.2.2-ssl-verify-hostname.patch
  23. #Added due to rhbz#1873975 - default-acls test fail on s390x due to libacl
  24. Patch1: rsync-3.2.2-runtests.patch
  25. # security fixes
  26. # none
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: libacl-devel libattr-devel popt-devel
  29. BuildRequires: lz4-devel openssl-devel libzstd-devel
  30. BuildRequires: acl attr
  31. %description
  32. Rsync uses a quick and reliable algorithm to very quickly bring
  33. remote and host files into sync. Rsync is fast because it just
  34. sends the differences in the files over the network (instead of
  35. sending the complete files). Rsync is often used as a very powerful
  36. mirroring process or just as a more capable replacement for the
  37. rcp command. A technical report which describes the rsync algorithm
  38. is included in this package.
  39. Install rsync if you need a powerful mirroring program.
  40. %description -l ja
  41. rsync は高速で信頼性の高いアルゴリズムを使い,遠隔ホスト上のファイルと
  42. 高速に同期させることが出来ます.rsync が高速に動作するのは,ネットワーク
  43. 上に流れるデータがファイルの差分だけだからです (ファイル全体をやりとり
  44. するのではなく).rsync は強力なミラリングツールとしても,rcp コマンドの
  45. 代替としても使うことが出来ます.rsync のアルゴリズムに関する技術情報は
  46. このパッケージに同梱されています.
  47. 強力なミラープログラムが必要ならば rsync をインストールして下さい.
  48. %package daemon
  49. Summary: Service for anonymous access to rsync
  50. Group: servers
  51. BuildArch: noarch
  52. Requires: %{name} = %{version}-%{release}
  53. %if %{with systemd}
  54. %{?systemd_requires}
  55. %else
  56. Requires: xinetd
  57. %endif
  58. %description daemon
  59. Rsync can be used to offer read only access to anonymous clients. This
  60. package provides the anonymous rsync service.
  61. %prep
  62. %setup -q -b 1
  63. #Enable --copy-devices parameter
  64. patch -p1 -i patches/copy-devices.diff
  65. %patch0 -p1 -b .verify-hostname
  66. %patch1 -p1 -b .runtests
  67. # security fixes
  68. # none
  69. %build
  70. %configure --disable-xxhash
  71. make %{?_smp_mflags} CCOPTFLAGS="$RPM_OPT_FLAGS"
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. %makeinstall
  75. install -D -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/rsyncd.conf
  76. %if %{with systemd}
  77. install -D -m644 %{SOURCE3} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.service
  78. install -D -m644 %{SOURCE2} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.socket
  79. install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
  80. install -D -m644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/rsyncd
  81. %else
  82. mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
  83. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT/etc/xinetd.d/rsync
  84. %endif
  85. %check
  86. make check
  87. chmod -x support/*
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %if %{with systemd}
  91. %post daemon
  92. %systemd_post rsyncd.service
  93. %preun daemon
  94. %systemd_preun rsyncd.service
  95. %postun daemon
  96. %systemd_postun_with_restart rsyncd.service
  97. %endif
  98. %files
  99. %defattr(-,root,root)
  100. %license COPYING
  101. %doc README* tech_report.tex support/
  102. %doc NEWS* TODO
  103. %{_bindir}/%{name}
  104. %{_bindir}/%{name}-ssl
  105. %config(noreplace) %{_sysconfdir}/rsyncd.conf
  106. %{_mandir}/man1/%{name}.1*
  107. %{_mandir}/man1/%{name}-ssl.1*
  108. %{_mandir}/man5/rsyncd.conf.5*
  109. %files daemon
  110. %if %{with systemd}
  111. %{_unitdir}/rsyncd.socket
  112. %{_unitdir}/rsyncd.service
  113. %{_unitdir}/rsyncd@.service
  114. %config(noreplace) %{_sysconfdir}/sysconfig/rsyncd
  115. %else
  116. %config(noreplace) /etc/xinetd.d/rsync
  117. %endif
  118. %changelog
  119. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-1
  120. - updated to 3.2.3.
  121. - re-impoerted all patches from rawhide.
  122. - added systemd support (disabled as default).
  123. * Wed Oct 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
  124. - updated to 3.1.2.
  125. - imported Patch1-3 from rawhide.
  126. - dropped Patch100-130.
  127. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.2-1
  128. - update to 3.1.2
  129. - add patch100-130 to fix security issue from debian
  130. - use make reconfigure in build section
  131. * Sat Nov 14 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-2
  132. - added Patch100 to fix CVE-2014-9512
  133. * Fri Nov 07 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-1
  134. - new upstream release
  135. - deleted Patch100 to merge source
  136. * Wed Jun 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.1.0-2
  137. - add Patch100 to fix CVE-2014-2855
  138. * Sat Nov 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.0-1
  139. - new upstream release
  140. * Fri Jan 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.9-1
  141. - new upstream release
  142. * Sun May 22 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.8-1
  143. - new upstream release with security fixes
  144. - drop patch100 (is included in new release)
  145. * Sat Apr 2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.7-2
  146. - add Patch100 for fix CVE-2011-1097 (filelist)
  147. - change specfile name (-vl)
  148. * Sat Jan 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.7-1
  149. - new upstream release
  150. * Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.6-1
  151. - new upstream release
  152. - changed License tag
  153. - added Patch0 from Debian
  154. - added BuildRequires: libattr-devel popt-devel
  155. - added patch -p1 -i patches/copy-devices.diff in %setup
  156. (to enable --copy-devices parameter)
  157. * Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.4-2
  158. - added BuildRequires: libacl-devel (to enable ACL)
  159. * Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
  160. - new upstream release
  161. - add rsync-patches (replaces patch1,2)
  162. use xattr.patch and acls.patch for backword compatibility
  163. * Sun Apr 13 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.2-1
  164. - new upstream release
  165. - add patch1,2 for backward compatibility from fc
  166. - new versioning policy
  167. * Tue Aug 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.9-0vl2
  168. - add Patch10 for CVE-2007-4091
  169. (rsync "f_name()" Function Directory Name Handling Off-By-One Vulnerability)
  170. * Wed Jan 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.9-0vl1
  171. - new upstream release
  172. - add Vendor/Distribution tag
  173. * Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  174. - new upstream release
  175. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  176. - new upstream release
  177. - drop obsolete patch1 which is merged in upstream.
  178. * Tue Aug 17 2004 SATO Masakiyo <info@pocomoco.net> 2.6.2-0vl2
  179. - added patch1 for a path-sanitizing bug
  180. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  181. - new upstream release
  182. * Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  183. - new upstream release
  184. * Fri Dec 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-0vl1
  185. - new upstream release
  186. - security fix
  187. * Mon Apr 21 2003 IWAI Masaharu <iwai@alib.jp> 2.5.6-0vl1
  188. - new upstream release
  189. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  190. - new upstream release
  191. * Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 2.5.4-0vl1
  192. - updated to 2.5.4, which contains additional fix for zlib double-free bug.
  193. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5.3-0vl1
  194. - upstream release
  195. * Sat Jan 26 2002 Toru Sagami <sagami@vinelinux.org> 2.5.2-0vl1
  196. - SECURITY FIXES:
  197. * Signedness security patch from Sebastian Krahmer
  198. - added more docs
  199. * Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
  200. - 2.5.1-0vl1
  201. * Sun Dec 2 2001 Yoichi Imai <yoichi@silver-forest.com>
  202. - 2.5.0-0vl1
  203. - update to 2.5.0
  204. - edit maxdel.patch for 2.5.0
  205. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  206. - 2.4.6-2vl1
  207. - based on 2.4.6-2 from Rawhide
  208. - added Japanese summary and description
  209. * Sat Sep 30 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  210. - add xinetd configuration
  211. * Tue Sep 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  212. - 2.4.6
  213. * Mon Jul 31 2000 Bill Nottingham <notting@redhat.com>
  214. - update to 2.4.4 - fixes yet another problem with rsh transport
  215. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  216. - automatic rebuild
  217. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  218. - rebuild in new build env.
  219. * Mon Apr 10 2000 Bill Nottingham <notting@redhat.com>
  220. - update to 2.4.3
  221. * Tue Apr 4 2000 Bill Nottingham <notting@redhat.com>
  222. - update to 2.4.2
  223. * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
  224. - fix maxdelete behavior so it isn't sent to older servers.
  225. * Mon Jan 31 2000 Jeff Johnson <jbj@redhat.com>
  226. - update to 2.4.1.
  227. * Fri Dec 17 1999 Bill Nottingham <notting@redhat.com>
  228. - update to 2.3.2
  229. * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
  230. - add "max. delete" patch to limit damage when server is hosed.
  231. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  232. - update to 2.3.1.
  233. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  234. - auto rebuild in the new build environment (release 2)
  235. * Tue Mar 16 1999 Jeff Johnson <jbj@redhat.com>
  236. - update to 2.3.0.
  237. * Sat Mar 13 1999 Jeff Johnson <jbj@redhat.com>
  238. - update to 2.3.0 beta.
  239. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  240. - update to 2.2.1
  241. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  242. - updated to 2.1.1
  243. * Mon Aug 17 1998 Erik Troan <ewt@redhat.com>
  244. - updated to 2.1.0
  245. * Thu Aug 06 1998 Erik Troan <ewt@redhat.com>
  246. - buildrooted and attr-rophied
  247. - removed tech-report.ps; the .tex should be good enough
  248. * Mon Aug 25 1997 John A. Martin <jam@jamux.com>
  249. - Built 1.6.3-2 after finding no rsync-1.6.3-1.src.rpm although there
  250. was an ftp://ftp.redhat.com/pub/contrib/alpha/rsync-1.6.3-1.alpha.rpm
  251. showing no packager nor signature but giving
  252. "Source RPM: rsync-1.6.3-1.src.rpm".
  253. - Changes from 1.6.2-1 packaging: added '$RPM_OPT_FLAGS' to make, strip
  254. to '%build', removed '%prefix'.
  255. * Thu Apr 10 1997 Michael De La Rue <miked@ed.ac.uk>
  256. - rsync-1.6.2-1 packaged. (This entry by jam to credit Michael for the
  257. previous package(s).)