shotwell-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. Name: shotwell
  2. Version: 0.18.1
  3. Release: 1%{?_dist_release}
  4. Summary: A photo manager for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
  12. # http://trac.yorba.org/ticket/3379
  13. Source1: shotwell-icons.tar.bz2
  14. # http://redmine.yorba.org/issues/5181
  15. Patch0: shotwell-usrmove.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: GConf2-devel
  18. BuildRequires: LibRaw-devel
  19. BuildRequires: LibRaw-static
  20. BuildRequires: WebKit3-gtk-devel
  21. BuildRequires: dbus-glib-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: gtk3-devel
  25. #BuildRequires: gstreamer-devel
  26. #BuildRequires: gstreamer-plugins-base-devel
  27. BuildRequires: gstreamer1-devel
  28. BuildRequires: gstreamer1-plugins-base-devel
  29. BuildRequires: json-glib-devel
  30. BuildRequires: libexif-devel
  31. BuildRequires: libgee-devel
  32. BuildRequires: libgee-vala
  33. BuildRequires: libgphoto2-devel
  34. BuildRequires: eudev-libgudev1-devel
  35. BuildRequires: libgexiv2-devel >= 0.2.0
  36. BuildRequires: libsoup-devel
  37. BuildRequires: libxml2-devel
  38. BuildRequires: lcms2-devel
  39. BuildRequires: sqlite3-devel
  40. BuildRequires: unique3-devel
  41. BuildRequires: vala-devel >= 0.9.5
  42. BuildRequires: rest-devel
  43. BuildRequires: gnome-doc-utils
  44. # used by shotwell-settings-migrator
  45. Requires: dconf
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: kudoh
  49. %description
  50. Shotwell is a new open source photo manager designed for the GNOME desktop
  51. environment. It allows you to import photos from your camera, view and edit
  52. them, and share them with others.
  53. %description -l ja
  54. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  55. 画像管理ツールです。
  56. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  57. 他の人々と共有するなどができます。
  58. %prep
  59. %setup -q -n %{name}-%{version}
  60. %patch0 -p1 -b .usrmove
  61. %build
  62. # We can't use the configure macro: it's not a standard autotools configure script
  63. export CFLAGS="%{optflags}"
  64. export LIB=%{_lib}
  65. # HACK: Remove fatal-warnings to succeed build with vala 0.13.
  66. #sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
  67. ./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
  68. #sed -i -e 's/\\n/\n/g' configure.mk
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  73. export XDG_DISABLE_MAKEFILE_UPDATES=1
  74. # otherwise gettext always returns English text regardless of LANGUAGE asked
  75. export LANG=en_US.utf8
  76. make install DESTDIR=$RPM_BUILD_ROOT
  77. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  78. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  79. # put hi-res icons in place
  80. (
  81. cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  82. rm -rf 16x16 24x24 scalable
  83. tar xf %{SOURCE1}
  84. )
  85. %find_lang %{name} --all-name
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  90. update-desktop-database &> /dev/null || :
  91. %postun
  92. if [ $1 -eq 0 ] ; then
  93. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  94. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  95. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  96. fi
  97. update-desktop-database &> /dev/null || :
  98. %posttrans
  99. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %files -f %{name}.lang
  102. %defattr(-,root,root,-)
  103. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  104. %{_bindir}/shotwell
  105. %{_libexecdir}/shotwell/shotwell-settings-migrator
  106. %{_libexecdir}/shotwell/shotwell-video-thumbnailer
  107. %{_libdir}/shotwell/plugins/builtin
  108. %{_datadir}/GConf/gsettings/shotwell.convert
  109. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
  110. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
  111. %{_datadir}/gnome/help/
  112. %{_datadir}/shotwell
  113. %{_datadir}/appdata/shotwell.appdata.xml
  114. %{_datadir}/applications/shotwell.desktop
  115. %{_datadir}/applications/shotwell-viewer.desktop
  116. %{_datadir}/icons/hicolor/*
  117. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  118. %exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
  119. %changelog
  120. * Thu Jul 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.1-1
  121. - new upstream release
  122. - change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
  123. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.0-1
  124. - new upstream release
  125. - add BuildRequires: gnome-doc-utils
  126. * Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-4
  127. - rebuild with LibRaw-0.16.0
  128. * Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-3
  129. - rebuilt with LibRaw-0.15.4
  130. * Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-2
  131. - rebuild with exiv2-0.24
  132. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
  133. - new upstream release
  134. - remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
  135. - change BuildRequires: libgee-devel instead of libgee06-devel
  136. - add BuildRequires: libgee-vala
  137. * Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
  138. - build with libgphoto2 2.5.0-1
  139. * Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
  140. - new upstream release
  141. - changed archive typr to xz
  142. - changed BuildRequires: libgee-devel to libgee06-devel
  143. - changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
  144. gstreamer1-devel and gstreamer1-plugins-base-devel
  145. - added Requires: dconf
  146. - added Patch0,1 from Fedora
  147. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
  148. - rebuild with exiv2-0.23
  149. * Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
  150. - new upstream release
  151. - dropt Source2
  152. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
  153. - new upstream release
  154. - remove Patch0
  155. - change BuildRequires: gtk3-devel instead of gtk2-devel
  156. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  157. - change BuildRequires: unique3-devel instead of unique-devel
  158. - remove BuildRequires: hal-devel
  159. - add BuildRequires: rest-devel, lcms2-devel
  160. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
  161. - new upstream release
  162. * Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
  163. - new upstream release
  164. * Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
  165. - new upstream release
  166. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
  167. - new upstream release
  168. - add Patch0 (shotwell-0.11.1-vala-0.14.patch)
  169. - add BuildRequires: gstreamer-plugins-base-devel
  170. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  171. - rebuilt with libgexiv2-0.2.2-2
  172. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  173. - new upstream release
  174. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  175. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  176. - update Summary and description
  177. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  178. - add hi-res icons (SOURCE1)
  179. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  180. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  181. - dropt Patch0
  182. - added BuildRequires: LibRaw-static
  183. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  184. - add Patch1 (shotwell-0.8.1-vala.patch)
  185. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  186. - new upstream release
  187. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  188. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  189. - rebuilt with rpm-4.8.1 for pkg-config
  190. - fixed %%changelog in Tue Sep 14 2010
  191. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  192. - new upstream release
  193. - changed source URL
  194. - added Patch0 to work around desktop file incorrect comment
  195. - changed BuildRequires: vala-devel >= 0.9.5
  196. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  197. - new upstream release
  198. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  199. - new upstream release
  200. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  201. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  202. - fixed LIB_DIRS in libraw-config (for lib64)
  203. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  204. - new upstream release
  205. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  206. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  207. - new upstream release
  208. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  209. - new upstream release
  210. - added BuildRequires: libgudev1-devel
  211. - applied new naming policy to spec
  212. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  213. - new upstream release
  214. - proved Japanese description
  215. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  216. - new upstrema release
  217. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  218. - intial build for VineSeed
  219. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  220. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  221. - Update to 0.3.2
  222. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  223. - Version 0.3.0
  224. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  225. - Rebuild against new libgee
  226. * Wed Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  227. - Bring icon cache handling in sync with current guidelines
  228. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  229. - Initial packaging