PyOpenGL-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. Name: PyOpenGL
  4. Version: 3.0.0
  5. Release: 4%{_dist_release}
  6. Summary: Python bindings for OpenGL
  7. License: BSD
  8. Group: System Environment/Libraries
  9. URL: http://pyopengl.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/pyopengl/%{name}-%{version}.tar.gz
  11. Patch0: PyOpenGL-3.0.0a6-shebang.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: python-devel python-setuptools
  14. BuildArch: noarch
  15. Requires: python-numeric python-setuptools
  16. Requires: freeglut
  17. # in some other repositories this is named python-opengl
  18. Provides: python-opengl = %{version}-%{release}
  19. Obsoletes: python-opengl < %{version}-%{release}
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. PyOpenGL is the cross platform Python binding to OpenGL and related APIs. It
  24. includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3 and WGL 4. It also
  25. includes support for dozens of extensions (where supported in the underlying
  26. implementation).
  27. PyOpenGL is interoperable with a large number of external GUI libraries
  28. for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
  29. %package Tk
  30. Summary: %{name} OpenGL Tk widget
  31. Group: System Environment/Libraries
  32. Requires: %{name} = %{version}-%{release}, tkinter
  33. %description Tk
  34. %{name} Togl (Tk OpenGL widget) 1.6 support.
  35. %package doc
  36. Summary: Documentation files for %{name}
  37. Group: Development/Languages
  38. Requires: %{name} = %{version}-%{release}
  39. %description doc
  40. Documentation files for %{name}.
  41. %prep
  42. %setup -q
  43. %patch0 -p1 -z .shebang
  44. %build
  45. python setup.py build
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. python setup.py install -O1 --skip-build --root="$RPM_BUILD_ROOT" \
  49. --prefix="%{_prefix}"
  50. chmod -x $RPM_BUILD_ROOT%{python_sitelib}/%{name}-%{version}-py%{pyver}.egg-info
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %files
  54. %defattr(-,root,root,-)
  55. ##doc license.txt
  56. %{python_sitelib}/*OpenGL*
  57. %exclude %{python_sitelib}/OpenGL/Tk
  58. %files Tk
  59. %defattr(-,root,root,-)
  60. %{python_sitelib}/OpenGL/Tk
  61. %files doc
  62. %defattr(-,root,root,-)
  63. %doc documentation/*
  64. %changelog
  65. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-4
  66. - rebuild with python-2.7.2
  67. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.0.0-3
  68. - rebuilt with rpm-4.8.1-3
  69. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.0-2
  70. - rebuilt with python-2.6.4
  71. * Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  72. - new upstream release 3.0.0
  73. - remove Requires: XOrg-gl (libGL should be pulled by freeglut)
  74. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0.b1.2
  75. - rebuilt with python-2.5.2
  76. * Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.0-0.b1.1
  77. - Initial build for Vine Linux
  78. * Mon Dec 31 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.5.b1
  79. - New upstream release 3.0.0b1
  80. * Thu Aug 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.4.a6
  81. - Change BuildRequires python-setuptools to python-setuptools-devel for
  82. the python-setuptools package split
  83. * Fri Apr 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.3.a6
  84. - Add missing freeglut, libGL and libGLU requires (bz 236159)
  85. * Thu Mar 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.2.a6
  86. - Remove tests from the package (bz 234121)
  87. - Add -Tk subpackage (bz 234121)
  88. - Remove shebang from files with shebang instead of chmod +x (bz 234121)
  89. - Better description
  90. * Sat Mar 24 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.1.a6
  91. - Initial Fedora Extras package