PyQt-vl.spec 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. %define pyexeclib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
  2. %define name PyQt
  3. %define version 3.18.1
  4. %define release 3%{?_dist_release}
  5. Summary: Python bindings for Qt.
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. License: GPL
  10. Group: Development/Languages
  11. Source: http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/%{name}-x11-gpl-%{version}.tar.gz
  12. URL: http://www.riverbankcomputing.co.uk/pyqt
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: python-devel sip-devel qt-devel
  15. Requires: python
  16. %description
  17. Python bindings for the Qt C++ class library.
  18. %package devel
  19. Summary: Files needed to build other bindings based on Qt
  20. Group: Development/Libraries
  21. Requires: %{name} = %{version}
  22. Requires: sip-devel qt-devel
  23. %description devel
  24. Files needed to build other bindings for C++ classes that inherit from any
  25. of the Qt classes (e.g. KDE or your own).
  26. %prep
  27. %setup -q -n %{name}-x11-gpl-%{version}
  28. %build
  29. mkdir -p $RPM_BUILD_ROOT%{pyexeclib}
  30. python configure.py -d %{pyexeclib} <<EOF
  31. yes
  32. EOF
  33. # note that -j2 does not work
  34. make
  35. %install
  36. rm -rf $RPM_BUILD_ROOT
  37. make DESTDIR=$RPM_BUILD_ROOT install
  38. mkdir -p $RPM_BUILD_ROOT%{_datadir}/sip/qt
  39. cp -r sip/* $RPM_BUILD_ROOT%{_datadir}/sip/qt/
  40. %clean
  41. rm -rf %{buildroot}
  42. %files
  43. %defattr(-, root, root, 755)
  44. %doc NEWS README ChangeLog THANKS
  45. %doc doc/PyQt.html
  46. %{_bindir}/*
  47. %{pyexeclib}/*
  48. %files devel
  49. %defattr(-,root,root)
  50. %doc examples*
  51. %{_datadir}/sip/*
  52. %changelog
  53. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-3
  54. - rebuilt with python-2.7.2
  55. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.18.1-2
  56. - rebuilt with python-2.6.4
  57. * Thu Nov 12 2009 Ryoichi INAGAKI <owa@bg.wakwak.com> 3.18.1-1
  58. - new upstream release
  59. - removed qscintilla dependency
  60. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 3.17.3-1vl5
  61. - rebuilt with python-2.5.2
  62. - added pyexeclib macro
  63. - applied new versioning policy
  64. * Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 3.17.3-0vl2
  65. - changed source url
  66. - fixed python site-packages path (for lib64)
  67. * Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.17.3-0vl1
  68. - updated to 3.16
  69. - rebuilt with new toolchain
  70. * Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.16-0vl1
  71. - updated to 3.16
  72. - changed Group to Development/Languages
  73. - rebuild with python-2.4.3, sip-4.4.5, qscinteilla-1.6
  74. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.13-0vl2
  75. - rebuild with python-2.4.1
  76. * Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.13-0vl1
  77. - initial release for VineLinux