PyQt4-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  2. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  4. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.0)
  5. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  6. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  7. %define qt4qmake %{_qt4_prefix}/bin/qmake
  8. Name: PyQt4
  9. Summary: Python bindings for Qt4
  10. Summary(ja): Qt4 の Python バインディング
  11. Version: 4.9
  12. Release: 2%{?_dist_release}
  13. # GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
  14. License: GPLv3 or GPLv2 with exceptions
  15. Group: Development/Languages
  16. URL: http://www.riverbankcomputing.com/software/pyqt/
  17. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
  18. Patch1: PyQt-x11-gpl-4.8.4-64bit.patch
  19. # HACK! FIXME: ping upstream why this isn't working right. -- Rex
  20. Patch2: PyQt-x11-gpl-4.5.2-QT_SHARED.patch
  21. Patch4: PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
  22. # Vine Patch
  23. Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: dbus-devel dbus-python-devel
  26. BuildRequires: findutils
  27. BuildRequires: libXext-devel
  28. BuildRequires: phonon-devel
  29. BuildRequires: python-devel
  30. # beware of PyQt4/qscintilla bootstap issues
  31. #BuildRequires: qscintilla
  32. BuildRequires: qt4-devel >= 4.5.0
  33. BuildRequires: qt-assistant-adp-devel
  34. BuildRequires: sip-devel >= 4.13.1
  35. Requires: sip >= 4.13.1
  36. Requires: dbus-python
  37. Requires: qt4
  38. %description
  39. These are Python bindings for Qt4.
  40. %package devel
  41. Summary: Files needed to build other bindings based on Qt4
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: qt4-devel >= 4.5.0
  45. Requires: qt-assistant-adp-devel
  46. Requires: sip-devel >= 4.13.1
  47. %description devel
  48. Files needed to build other bindings for C++ classes that inherit from any
  49. of the Qt4 classes (e.g. KDE or your own).
  50. %prep
  51. %setup -q -n PyQt-x11-gpl-%{version}
  52. %ifarch x86_64
  53. %patch1 -p1 -b .64bit
  54. %endif
  55. %patch2 -p1 -b .QT_SHARED
  56. #patch100 -p1 -b .phononpath_vine
  57. ## permissions
  58. # mark examples non-executable
  59. find examples/ -name "*.py" | xargs chmod a-x
  60. chmod a+rx pyuic/uic/pyuic.py
  61. %build
  62. CFLAGS="${CFLAGS:-%optflags}" \
  63. CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
  64. %{__python} configure.py \
  65. --confirm-license \
  66. --qmake=%{qt4qmake} \
  67. --no-qsci-api \
  68. --verbose
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
  73. # HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
  74. rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
  75. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
  76. $RPM_BUILD_ROOT%{_bindir}/pyuic4
  77. ln -s %{_bindir}/pyuic4 \
  78. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %files
  82. %defattr(-,root,root,-)
  83. %doc NEWS README
  84. %doc OPENSOURCE-NOTICE.TXT
  85. %doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
  86. %doc LICENSE.GPL3
  87. %{python_sitearch}/PyQt4/
  88. %exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
  89. # fixme? -> sitearch? -- Rex
  90. %{python_sitelib}/dbus/mainloop/qt.so
  91. %{_qt4_plugindir}/designer/*
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %doc doc/*
  95. %doc examples/
  96. %{_bindir}/pylupdate4
  97. %{_bindir}/pyrcc4
  98. %{_bindir}/pyuic4
  99. %{python_sitearch}/PyQt4/uic/pyuic.py*
  100. %{_datadir}/sip/PyQt4/
  101. #{_qt4_prefix}/qsci/api/python/PyQt4.api
  102. %changelog
  103. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
  104. - rebuild with python-2.7.2
  105. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
  106. - new upstream release
  107. - aaded BR: qt-assistant-adp-devel
  108. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
  109. - update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
  110. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
  111. - new upstream release
  112. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
  113. - re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
  114. - remove %%sip_ver
  115. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
  116. - rebuilt with qt4-4.7.2
  117. * Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
  118. - update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
  119. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
  120. - new upstream release
  121. - built with sip-4.12.1 and qt4-4.7.1
  122. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
  123. - rebuild with qt4-4.6.3
  124. - fix %qtver (from 4.6.1 to 4.6.3)
  125. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  126. - new upstream release
  127. - rebuilt with sip-4.10.5 and qt4-4.6.3
  128. * Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
  129. - new upstream release
  130. - updated Patch100
  131. * Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
  132. - updated Patch100 to build phonon module
  133. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
  134. - new upstream release
  135. - rebuilt with python-2.6.4
  136. - dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
  137. * Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
  138. - now BuildRequires sip-devel >= 4.9 (was 4.8.2)
  139. * Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
  140. - new upstream release
  141. - added BR: libXext-devel
  142. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
  143. - added Patch100 for building phonon modules
  144. * Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
  145. - Initial build for Vine
  146. * Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
  147. - PyQt4-4.5.4
  148. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  150. * Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
  151. - PyQt4-4.5.2
  152. * Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
  153. - fix build with qt-4.5.2
  154. - PyQt4-devel multilib conflict (#509415)
  155. * Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
  156. - PyQt-4.5.1
  157. * Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
  158. - PyQt-4.5
  159. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
  160. - fix generation of sip_ver
  161. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
  162. - PyQt-4.5-snapshot-20090520
  163. * Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
  164. - rebuild for phonon bindings (#497680)
  165. * Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
  166. - move designer plugins to main/runtime (#487622)
  167. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  169. * Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
  170. - rebuild against qt-4.5rc1
  171. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
  172. - Rebuild for Python 2.6
  173. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
  174. - PyQt-4.4.4
  175. * Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
  176. - PyQt-4.4.3
  177. * Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
  178. - PyQt4 is built without QtWebKit support (#451490)
  179. * Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
  180. - PyQt-4.4.2
  181. * Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
  182. - PyQt-4.4
  183. - License: GPLv3 or GPLv2 with exceptions
  184. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
  185. - respin (gcc43)
  186. * Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
  187. - PyQt-4.3.3
  188. * Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
  189. - dbus support (#395741)
  190. * Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
  191. - PyQt-4.3.1
  192. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
  193. - drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
  194. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
  195. - fix QtDesigner plugin install
  196. * Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
  197. - 64bit QtDesigner patch
  198. * Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
  199. - -devel: Requires: qt4-devel
  200. * Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
  201. - use %%python_sitearch
  202. - License: GPLv2
  203. * Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
  204. - fix python_sitelib typo (wrt chrpath call)
  205. - move %%_bindir stuff to -devel
  206. - mark %%doc examples non-executable
  207. - add shebang to %%_bindir/pyuic4
  208. * Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
  209. - remove rpath from QtDesigner.so
  210. - BR: qt4-devel > 4.3.0-8
  211. * Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
  212. - PyQt4-4.2
  213. * Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
  214. - fix build against multilib'd qt4
  215. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
  216. - PyQt4-4.1.1
  217. - BR: sip-devel >= 4.5.1
  218. * Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
  219. - PyQt4-4.1
  220. * Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
  221. - don't own %%_datadir/sip (bug #206633)
  222. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
  223. - BR: qt4-devel < 4.2
  224. * Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
  225. - fix reference(s) to qmake(4)
  226. * Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
  227. - PyQt-4.0.1
  228. * Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
  229. - PyQt-4.0(final)
  230. - BR: sip-devel >= 4.4.4 (see bug #199430)
  231. * Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
  232. - drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
  233. - drop usage of (undefined) %%sip_min
  234. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
  235. - cleanup for Extras
  236. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
  237. - 4.0beta1
  238. * Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
  239. - respin for sip-4.4.3
  240. - use sip-abi, sip-abi-min
  241. * Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
  242. - 20060421 snapshot
  243. * Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
  244. - first try, using 20060417 snapshot