epydoc-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. Summary: Automatic API documentation generation tool for Python
  3. Summary(ja): Python 用の自動 API ドキュメント生成ツール
  4. Name: epydoc
  5. Version: 3.0.1
  6. Release: 3%{?_dist_release}
  7. Group: Development/Tools
  8. License: MIT
  9. URL: http://epydoc.sourceforge.net/
  10. Source0: http://dl.sf.net/epydoc/epydoc-%{version}.tar.gz
  11. Source1: epydocgui.desktop
  12. Patch0: epydoc-3.0.1-nohashbang.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. Requires: tkinter
  15. BuildRequires: python-devel
  16. BuildRequires: desktop-file-utils
  17. BuildArch: noarch
  18. %description
  19. Epydoc is a tool for generating API documentation for Python modules,
  20. based on their docstrings. For an example of epydoc's output, see the
  21. API documentation for epydoc itself (html, pdf). A lightweight markup
  22. language called epytext can be used to format docstrings, and to add
  23. information about specific fields, such as parameters and instance
  24. variables. Epydoc also understands docstrings written in
  25. ReStructuredText, Javadoc, and plaintext.
  26. %prep
  27. %setup -q
  28. %patch0 -p1 -b .nohashbang
  29. %build
  30. %{__python} setup.py build
  31. %install
  32. %{__rm} -rf %{buildroot}
  33. %{__python} setup.py install -O1 --skip-build --root=%{buildroot}
  34. desktop-file-install \
  35. --vendor="" \
  36. --dir=%{buildroot}%{_datadir}/applications \
  37. --mode=0644 \
  38. %{SOURCE1}
  39. # Also install the man pages
  40. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  41. %{__install} -p -m 0644 man/*.1 %{buildroot}%{_mandir}/man1/
  42. # Prevent having *.pyc and *.pyo in _bindir
  43. %{__mv} %{buildroot}%{_bindir}/apirst2html.py %{buildroot}%{_bindir}/apirst2html
  44. %clean
  45. %{__rm} -rf %{buildroot}
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc LICENSE.txt README.txt doc/
  49. %{_bindir}/apirst2html
  50. %{_bindir}/epydoc
  51. %{_bindir}/epydocgui
  52. %{python_sitelib}/epydoc/
  53. %{python_sitelib}/epydoc-*.egg-info
  54. %{_datadir}/applications/epydocgui.desktop
  55. %{_mandir}/man1/*.1*
  56. %changelog
  57. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-3
  58. - rebuild with python-2.7.2
  59. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.1-2
  60. - rebuilt with python-2.6.4
  61. * Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-1
  62. - initial build for Vine Linux
  63. * Sat Mar 22 2008 Matthias Saou <http://freshrpms.net/> 3.0.1-1
  64. - Update to 3.0.1.
  65. - Update nohashbang patch.
  66. - Include new apirst2html script, but remove .py extension to avoid .pyc/pyo.
  67. - Include egg-info file.
  68. * Tue Jun 19 2007 Matthias Saou <http://freshrpms.net/> 2.1-8
  69. - Remove desktop file prefix and X-Fedora category.
  70. - Include patch to remove #! python from files only meant to be included.
  71. * Mon Dec 11 2006 Matthias Saou <http://freshrpms.net/> 2.1-7
  72. - Rebuild against python 2.5.
  73. - Remove no longer needed explicit python-abi requirement.
  74. - Change python build requirement to python-devel, as it's needed now.
  75. * Wed Sep 6 2006 Matthias Saou <http://freshrpms.net/> 2.1-6
  76. - No longer ghost the .pyo files, as per new python guidelines (#205374).
  77. * Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 2.1-5
  78. - FC6 rebuild.
  79. - Add %%{?dist} tag.
  80. - Update summary line.
  81. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  82. - rebuilt
  83. * Mon Dec 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 2.1-3
  84. - Change to noarch.
  85. - Get Python site-packages dir from distutils, should fix x86_64 build.
  86. - Require python-abi and tkinter.
  87. - %%ghost'ify *.pyo.
  88. - Fix man page permissions.
  89. - Add menu entry for epydocgui.
  90. * Tue Nov 16 2004 Matthias Saou <http://freshrpms.net/> 2.1-2
  91. - Bump release to provide Extras upgrade path.
  92. * Thu Oct 21 2004 Matthias Saou <http://freshrpms.net/> 2.1-1
  93. - Picked up and rebuilt.
  94. - Added doc and man pages.
  95. * Fri May 07 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  96. - 2.1-0.fdr.1: Initial package