geany-plugins-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837
  1. %global geany_plug_docdir %{_defaultdocdir}/%{name}-%{version}
  2. %global req_geany_ver 0.21
  3. Name: geany-plugins
  4. Version: 0.21
  5. Release: 2%{?_dist_release}
  6. Summary: Plugins for Geany
  7. Summary(ja): Geany のプラグイン集
  8. Group: Development/Tools
  9. License: GPLv3
  10. URL: http://plugins.geany.org/
  11. Source0: http://plugins.geany.org/geany-plugins/geany-plugins-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: ctpl-devel >= 0.2
  14. #BuildRequires: devhelp-devel
  15. BuildRequires: enchant-devel
  16. BuildRequires: geany-devel >= %{req_geany_ver}
  17. BuildRequires: gettext
  18. BuildRequires: gdk-pixbuf2-devel
  19. BuildRequires: glib2-devel
  20. BuildRequires: gpgme-devel
  21. BuildRequires: gtk2-devel
  22. BuildRequires: gtkspell-devel
  23. BuildRequires: intltool
  24. BuildRequires: libtool
  25. BuildRequires: lua-devel
  26. BuildRequires: libxml2-devel >= 2.6.27
  27. BuildRequires: pango-devel
  28. BuildRequires: pkgconfig
  29. BuildRequires: python-docutils
  30. BuildRequires: vte-devel
  31. BuildRequires: WebKit-gtk-devel
  32. Requires: %{name}-addons %{name}-geanydoc %{name}-geanygdb %{name}-geanylatex
  33. Requires: %{name}-geanylipsum %{name}-geanylua %{name}-geanyprj %{name}-geanysendmail
  34. Requires: %{name}-geanyvc %{name}-shiftcolumn %{name}-spellcheck
  35. Requires: %{name}-codenav %{name}-treebrowser %{name}-geanyextrasel
  36. Requires: %{name}-geanyinsertnum %{name}-pretty-print %{name}-geanygendoc
  37. Requires: %{name}-updatechecker %{name}-webhelper
  38. Requires: %{name}-debugger %{name}-xmlsnippets %{name}-geanymacro %{name}-geanynumberedbookmarks
  39. Requires: %{name}-geanypg %{name}-gproject %{name}-tableconvert
  40. %description
  41. Plugins for Geany. Plugins included are:
  42. * Addons (Various small Addons)
  43. * Code navigation (Navigate through your source code easily)
  44. * Debugger (Enables debugging in Geany)
  45. * Geanydoc (Call specific documentation from within Geany)
  46. * Geanyextrasel (Additional features for selecting code)
  47. * GeanyGenDoc (Automatically generate documentation source code)
  48. * GeanyGDB (Integration with GDB)
  49. * Geanyinsertnum (Insert huge number ranges with small efforts)
  50. * GeanyLaTeX (Improved Support for LaTeX documents)
  51. * GeanyLipsum (Inserting blocks of Lorem Ipsum text)
  52. * Geanylua (Support for Scripting with Lua)
  53. * GeanyMacro (User defined Macros for Geany)
  54. * GeanyNumberedBookmarks (Provide users with 10 numbered Bookmarks)
  55. * GeanyPG (Encrypt, decrypt and verify signatures with GnuPG)
  56. * Geanyprj (Alternate project management for Geany)
  57. * GeanySendMail (Sending of documents from within Geany)
  58. * GeanyVC (Support for various Version Control Systems)
  59. * GProject (Extension of Geany's Project Management)
  60. * Pretty-Print (XML Pretty Printer)
  61. * Shiftcolumn (Moving blocks of text horizontally)
  62. * Spellcheck (Spell checking of documents or marked text)
  63. * Tableconvert (Helps on converting a tabulator separated selection into a table)
  64. * Treebrowser (Alternate file browser with tree view of folders)
  65. * Updatechecker (Automatically check for Geany updates)
  66. * Webhelper (Preview and Debug Web documents from within Geany using WebKit)
  67. * XMLSnippets (Extends XML/HTML tag autocompletion provided by Geany)
  68. This package is meta package to install all geany-plugins.
  69. %description -l ja
  70. Geany のプラグインです。プラグインには以下のものが含まれています。
  71. * Addons (色々と小さなアドオン)
  72. * Code navigation (ソースコード間を簡単に移動)
  73. * Debugger (Geany でデバッグを有効化)
  74. * Geanydoc (geany から固有のドキュメントを呼び出す)
  75. * Geanyextrasel (コード選択のための追加機能)
  76. * GeanyGenDoc (ソースコードから自動的にドキュメントの元を生成)
  77. * GeanyGDB (GDB 統合環境を提供)
  78. * GeanyLaTex (LaTeX ドキュメントのサポートを改善)
  79. * GeanyLipsum (Lorem Ipsum テキストのブロックを挿入)
  80. * GeanySendMail (Geany からドキュメントの送信を許可)
  81. * GeanyVC (色々なバージョン管理システムのサポート)
  82. * GProject (Geany のプロジェクト管理拡張)
  83. * Geanyinsertnum (僅かな労力で膨大な範囲の番号を挿入)
  84. * Geanylua (lua スクリプトのサポートを提供)
  85. * GeanyMacro (Geany のユーザー定義マクロ)
  86. * GeanyNumberedBookmarks (ユーザーに 10 個の番号付ブックマークを提供)
  87. * GeanyPG (GnuPG で暗号化・復号化及び署名を検証する)
  88. * Geanyprj (geany の代替プロジェクト管理)
  89. * Shiftcolumn (テキストブロックを水平方向に移動)
  90. * Spellcheck (ドキュメントのスペルチェック)
  91. * Tableconvert (テーブルにタブで区切られた選択項目を変換する際役立つ)
  92. * Treebrowser (フォルダの内容をツリービューする代替ファイルブラウザ)
  93. * Pretty-Print (XML Pretty Printer)
  94. * Updatechecker (Geany の更新を自動的にチェック)
  95. * Webhelper (WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行)
  96. * XMLSnippets (Geany により提供される拡張 XML/HTML タグの自動補完)
  97. このパッケージは、geany-plugins をすべてインストールするための
  98. メタパッケージです。
  99. %package common
  100. Summary: Common files used by all geany plugins
  101. Summary(ja): すべての Geany プラグインに用いられる共通ファイル
  102. Group: Development/Tools
  103. Requires: geany >= %{req_geany_ver}
  104. %description common
  105. This package contains some common files which are used by every Geany plugin,
  106. e.g. language translations.
  107. %description common -l ja
  108. このパッケージには、例えば翻訳ファイルなどの
  109. すべての Geany プラグイン で用いられる共通ファイルが含まれています。
  110. %package addons
  111. Summary: Miscellaneous Addons for Geany
  112. Summary(ja): Geany のその他のアドオン
  113. Group: Development/Tools
  114. Requires: geany >= %{req_geany_ver}
  115. Requires: geany-plugins-common = %{version}-%{release}
  116. Obsoletes: geany-plugin-addons
  117. %description addons
  118. This plugins consists of various small addons too small to justify their own
  119. plugin, but are useful to have. The following functionality is implemented:
  120. * Doclist: This addon places a new item in the toolbar and when clicked offers
  121. a menu listing all open files plus the 'Close All' and 'Close Other
  122. Documents' menu items. This can be useful to quickly access open files and
  123. switch to them.
  124. * OpenURI: Adds 'Open URI' and 'Copy URI' menu items to the editor menu when
  125. the word under the cursor looks like a URI. 'Open URI' uses the browser
  126. command configured in Geany to open it.
  127. * Tasks:The tasks plugin goes through a file being edited and picks out lines
  128. with "TODO" or "FIXME" in them. It collects the text after those words and
  129. puts them in a new "Tasks" tab in the message window. Clicking on a task in
  130. that tab takes you to the line in the file where the task was defined.
  131. * Systray: Adds a status icon to the notification area (systray) and provides
  132. a simple popup menu with some basic actions. It can also be used to quickly
  133. show and hide the Geany main window.
  134. %package codenav
  135. Summary: Navigate through your source code easily
  136. Summary(ja): ソースコード間を簡単に移動
  137. Group: Development/Tools
  138. Requires: geany >= %{req_geany_ver}
  139. Requires: geany-plugins-common = %{version}-%{release}
  140. %description codenav
  141. This plugin adds some facilities for navigating in the code.
  142. Actually, it will make it possible to:
  143. - switch between header and implementation
  144. - go to a file by typing its name
  145. %package debugger
  146. Summary: enables debugging in Geany
  147. Group: Development/Tools
  148. Requires: geany-plugins-common = %{version}-%{release}
  149. Requires: vte >= 0.24
  150. %description debugger
  151. Plugin enables debugging in Geany. Currently supports GDB only, but was
  152. developed with multiple debuggers support in mind, so the other backends
  153. support is planned as well.
  154. %package geanyextrasel
  155. Summary: Additional features for selecting code
  156. Summary(ja): コード選択のための追加機能
  157. Group: Development/Tools
  158. Requires: geany >= %{req_geany_ver}
  159. Requires: geany-plugins-common = %{version}-%{release}
  160. %description geanyextrasel
  161. Geanyextrasel provides some special features for selecting code, e.g. from
  162. opening brace to closed brace and so on. This plugin will be very useful for
  163. you if you're a programmer and working with much sourcecodes.
  164. %package geanygdb
  165. Summary: Debugger Plugin for Geany using GDB
  166. Summary(ja): GDB を使った Geany のデバッガプラグイン
  167. Group: Development/Tools
  168. Requires: geany >= %{req_geany_ver}
  169. Requires: geany-plugins-common = %{version}-%{release}
  170. Requires: gdb
  171. Obsoletes: geany-plugin-gdb
  172. %description geanygdb
  173. GeanyGDB plugin provides an integrated debugging environment for the
  174. GNU debugger (gdb).
  175. %description geanygdb -l ja
  176. GeanyGDB プラグインは GNU debugger (gdb) のための
  177. 統合的デバッグ環境を提供します。
  178. %package geanylatex
  179. Summary: to improve LaTeX support plugin for Geany
  180. Summary(ja): Geany のための LaTeX サポート改善プラグイン
  181. Group: Development/Tools
  182. Requires: geany >= %{req_geany_ver}
  183. Requires: geany-plugins-common = %{version}-%{release}
  184. Requires: texlive
  185. Obsoletes: geany-plugin-latex
  186. %description geanylatex
  187. This plugin improves LaTeX support in Geany. It provides several templates for
  188. new documents, help with adding labels and inserting special characters,
  189. and much more.
  190. %description geanylatex -l ja
  191. このプラグインは Geany で LaTeX のサポートを改善するプラグインです。
  192. 新しい文書のためのいくつかのテンプレート、
  193. ラベルの追加や特殊文字の挿入機能などを提供します。
  194. %package geanylipsum
  195. Summary: Lorem Ipsum generator for Inserting Placeholder Text
  196. Group: Development/Tools
  197. Requires: geany >= %{req_geany_ver}
  198. Requires: geany-plugins-common = %{version}-%{release}
  199. %description geanylipsum
  200. GeanyLipsum is a Lorem Ipsum generator for inserting placeholder text into a
  201. document.
  202. %package geanylua
  203. Summary: Support developing Lua Scripting for Geany
  204. Summary(ja): Geany で Lua スクリプト開発をサポート
  205. Group: Development/Tools
  206. Requires: geany >= %{req_geany_ver}
  207. Requires: geany-plugins-common = %{version}-%{release}
  208. Requires: lua
  209. %description geanylua
  210. This plugin provides extensive support for developing in the lua programming
  211. language.
  212. %description geanylua -l ja
  213. このプラグインは、lua プログラミング言語で開発するための
  214. 広範なサポートを提供します。
  215. %package geanymacro
  216. Summary: User defined Macros for Geany
  217. Group: Development/Tools
  218. Requires: geany-plugins-common = %{version}-%{release}
  219. %description geanymacro
  220. GeanyMacro is a plugin to provide user defined macros for Geany. It started
  221. out as part of the ConText feature parity plugin, which was split into
  222. individual plugins to better suit Geany's ethos of being as light as
  223. possible while allowing users to select which features they want to add to
  224. the core editor. The idea was taken from a Text Editor for Windows called
  225. ConText.
  226. This plugin alows you to record and use your own macros. Macros are
  227. sequences of actions that can then be repeated with a single key
  228. combination. So if you had dozens of lines where you wanted to delete the
  229. last 2 characters, you could simple start recording, press End, Backspace,
  230. Backspace, down line and then stop recording. Then simply trigger the macro
  231. and it would automaticaly edit the line and move to the next. You could then
  232. just repeatedly trigger the macro to do as many lines as you want.
  233. %package geanynumberedbookmarks
  234. Summary: Provide users 10 numbered Bookmarks
  235. Group: Development/Tools
  236. Requires: geany-plugins-common = %{version}-%{release}
  237. %description geanynumberedbookmarks
  238. GeanyNumberedBookmarks is a plugin to provide users with 10 numbered
  239. bookmarks (in addition to the usual bookmarks). It started out as part of
  240. the ConText feature parity plugin, which was split into individual plugins
  241. to better suit Geany's ethos of being as light as possible while allowing
  242. users to select which features they want to add to the core editor. The idea
  243. was taken from a Text Editor for Windows called ConText.
  244. Normally if you had more than one bookmark, you would have to cycle through
  245. them until you reached the one you wanted. With this plugin you can go
  246. straight to the bookmark that you want with a single key combination.
  247. %package geanypg
  248. Summary: encrypt, decrypt and verify signatures with GnuPG
  249. Group: Development/Tools
  250. Requires: geany-plugins-common = %{version}-%{release}
  251. Requires: gpgme
  252. %description geanypg
  253. GeanyPG is a plugin for Geany that allows the user to encrypt, decrypt and
  254. verify signatures with GnuPG.
  255. %package geanysendmail
  256. Summary: Send E-Mails from within Geany
  257. Summary(ja): Geany 内から E-Mail を送信するプラグイン
  258. Group: Development/Tools
  259. Requires: geany >= %{req_geany_ver}
  260. Requires: geany-plugins-common = %{version}-%{release}
  261. %description geanysendmail
  262. GeanySendMail is a little plugin to send a document as attachment using the
  263. preferred mail client from inside Geany. It is similar to the envelope symbol
  264. of most office tools and requires a mail client that supports remote calls.
  265. %package geanyvc
  266. Summary: Version Control plugin for Geany
  267. Summary(ja): Geany のバージョン管理プラグイン
  268. Group: Development/Tools
  269. Requires: geany >= %{req_geany_ver}
  270. Requires: geany-plugins-common = %{version}-%{release}
  271. Obsoletes: geany-plugin-vc
  272. Provides: geanyvc = %{version}-%{release}
  273. %description geanyvc
  274. Geanyvc is a plugin that provides a uniform way of accessing different version
  275. control systems from within the Geany IDE. Currently, support for the following
  276. version control systems is provided:
  277. * Bazaar
  278. * Git
  279. * Mercurial
  280. * Subversion
  281. * SVK
  282. * CVS
  283. %description geanyvc -l ja
  284. Geanyvc は Geany IDE から異なるバージョン管理システムにアクセスする
  285. 均一的方法を提供するプラグインです。
  286. 現在、サポートするバージョン管理システムは以下の通りです。
  287. * Bazaar
  288. * Git
  289. * Mercurial
  290. * Subversion
  291. * SVK
  292. * CVS
  293. %package geanyinsertnum
  294. Summary: Insert huge number ranges with small efforts
  295. Summary(ja): 僅かな労力で膨大な範囲の番号を挿入
  296. Group: Development/Tools
  297. Requires: geany >= %{req_geany_ver}
  298. Requires: geany-plugins-common = %{version}-%{release}
  299. %description geanyinsertnum
  300. Geanyinsertnum replaces a (possibly zero-width) rectangular selection with
  301. integer numbers, using start/step/base etc. specified by the user. For
  302. practical reasons, the number of lines is limited to 500000.
  303. %package shiftcolumn
  304. Summary: Move Blocks of Text horizontally
  305. Summary(ja): テキストブロックを水平方向に移動
  306. Group: Development/Tools
  307. Requires: geany >= %{req_geany_ver}
  308. Requires: geany-plugins-common = %{version}-%{release}
  309. %description shiftcolumn
  310. Shiftcolumn allows you to move blocks of text horizontally in Geany.
  311. %description shiftcolumn -l ja
  312. Shiftcolumn は Geany 内でテキストブロックを水平方向に移動させることが
  313. できます。
  314. %package spellcheck
  315. Summary: Spellcheck Text in Geany using the Enchant Library
  316. Summary(ja): Enchant ライブラリを使い Geany でスペルチェック
  317. Group: Development/Tools
  318. Requires: geany >= %{req_geany_ver}
  319. Requires: geany-plugins-common = %{version}-%{release}
  320. Requires: enchant
  321. %description spellcheck
  322. Spellcheck checks the selected text (or the whole document) with the spellcheck
  323. library Enchant.
  324. %description spellcheck -l ja
  325. Spellcheck は、選択したテキスト(または文書全体)のスペルチェックを
  326. スペルチェックライブラリの Enchant で行います。
  327. %package geanydoc
  328. Summary: Call documentation from within Geany
  329. Summary(ja): Geany 内からドキュメントを呼び出す
  330. Group: Development/Tools
  331. Requires: geany >= %{req_geany_ver}
  332. Requires: geany-plugins-common = %{version}-%{release}
  333. %description geanydoc
  334. Geanydoc allows you to execute specific commands on the word under the cursor.
  335. This word is passed as an argument to the command. The output of the command
  336. can either be placed into a special buffer called "DOC" or can be used to
  337. execute an external program. Geanydoc is intended to be used for searching
  338. through API documentation.
  339. %package geanygendoc
  340. Summary: Automatically generate documentation source code
  341. Group: Development/Tools
  342. Requires: geany >= %{req_geany_ver}
  343. Requires: geany-plugins-common = %{version}-%{release}
  344. %description geanygendoc
  345. GeanyGenDoc is a plugin for Geany that aims to automatically generate
  346. documentation comment basis from the source code.
  347. You may also want to install the following packages which enable
  348. some extra features:
  349. - Docutils (http://docutils.sourceforge.net/) -- or another implementation of
  350. rst2html -- is needed to (re)generate the HTML manual.
  351. %package geanyprj
  352. Summary: Provides an alternate project management tool for Geany
  353. Summary(ja): Geany で代替プロジェクト管理ツールを提供
  354. Group: Development/Tools
  355. Requires: geany >= %{req_geany_ver}
  356. Requires: geany-plugins-common = %{version}-%{release}
  357. %description geanyprj
  358. Geanyprj provides an alternate project management approach to Geany's built-in
  359. project facility. The idea is to be less a "session manager" as the built-in
  360. project management does: It allows/requires you to manually open and close
  361. project and allows you to store project files in different locations from
  362. project sources.
  363. Geanyprj takes a different approach:
  364. It never saves session information, so that project files can be stored in
  365. version control without constant noise from changes of opened files or cursor
  366. position. You also will never have to open/close projects manually. If a
  367. *.geanyprj file is found somewhere up in path it will be opened automatically.
  368. %package treebrowser
  369. Summary: Alternate file browser plugin providing a tree view of directories.
  370. Summary(ja): ディレクトリのツリービューを提供する代替ファイルブラウザプラグイン
  371. Group: Development/Tools
  372. Requires: geany >= %{req_geany_ver}
  373. Requires: geany-plugins-common = %{version}-%{release}
  374. %description treebrowser
  375. The tree browser plugin for Geany provides an alternate way to browse through
  376. your files. It displays files and directories in a tree view and has more
  377. features than the file browser plugin delivered with Geany itself.
  378. %package pretty-print
  379. Summary: XML pretty printing plugin for Geany
  380. Group: Development/Tools
  381. Requires: geany >= %{req_geany_ver}
  382. Requires: geany-plugins-common = %{version}-%{release}
  383. Requires: libxml2 >= 2.6.27
  384. %description pretty-print
  385. Plugin for Geany to easily beautify XML code.
  386. %package gproject
  387. Summary: Extension of Geany's project management
  388. Group: Development/Tools
  389. Requires: geany-plugins-common = %{version}-%{release}
  390. %description gproject
  391. GProject is an extension of Geany's project management displaying a tree of
  392. files belonging to the project in the sidebar. In addition, it enables quick
  393. swapping between header and source files, searching project files by name
  394. and more. The plugin was created with big projects in mind so everything
  395. works fast enough even with projects consisting of hundreds of thousands of
  396. files.
  397. %package tableconvert
  398. Summary: Helps on converting a tabulator separated selection into a table
  399. Group: Development/Tools
  400. Requires: geany-plugins-common = %{version}-%{release}
  401. %description tableconvert
  402. Tableconvert is a plugin which helps on converting a tabulator separated
  403. selection into a table.
  404. %package updatechecker
  405. Summary: Automatically check for Geany updates
  406. Summary(ja): Geany の更新を自動的にチェック
  407. Group: Development/Tools
  408. Requires: geany-plugins-common = %{version}-%{release}
  409. BuildRequires: libsoup-devel
  410. %description updatechecker
  411. UpdateChecker is a plugin for Geany, which is able to check whether there is
  412. a more recent version of Geany available.
  413. %package webhelper
  414. Summary: Preview and Debug Web documents from within Geany using WebKit
  415. Summary(ja): WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行
  416. Group: Development/Tools
  417. Requires: geany-plugins-common = %{version}-%{release}
  418. BuildRequires: WebKit-gtk-devel >= 1.1.18
  419. %description webhelper
  420. WebHelper is a plugin for Geany that provides some web development
  421. facilities, such as a web page preview and some debugging tools (web
  422. inspector).
  423. Prominent features:
  424. * A basic web view, allowing to display any web page (using WebKit)
  425. * Possible automatic reloading of the web view upon document saving
  426. * A web inspector/debugging tool for the web view's content (including a
  427. JavaScript console, a viewer and editor of processed HTML and CSS, a network
  428. usage analysis tool and many more, thanks to WebKit).
  429. %package xmlsnippets
  430. Summary: Extends XML/HTML tag autocompletion provided by Geany
  431. Group: Development/Tools
  432. Requires: geany-plugins-common = %{version}-%{release}
  433. %description xmlsnippets
  434. This plugin extends XML/HTML tag autocompletion provided by Geany. It
  435. automatically inserts a matching snippet after you type an opening tag.
  436. %prep
  437. %setup -q
  438. %build
  439. %configure --docdir=%{geany_plug_docdir}
  440. make %{?_smp_mflags}
  441. %install
  442. rm -rf $RPM_BUILD_ROOT
  443. make install -p DESTDIR=$RPM_BUILD_ROOT
  444. # Remove static library *.la files
  445. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' \;
  446. # Remove zero-length files
  447. find $RPM_BUILD_ROOT -type f -empty -delete
  448. %find_lang %{name}
  449. %clean
  450. rm -rf $RPM_BUILD_ROOT
  451. %files
  452. %files common -f %{name}.lang
  453. %defattr(-,root,root,-)
  454. %dir %{_libdir}/%{name}/
  455. %dir %{_datadir}/%{name}/
  456. %files addons
  457. %defattr(-,root,root,-)
  458. %doc %{geany_plug_docdir}/addons
  459. %{_libdir}/geany/addons.so
  460. %files codenav
  461. %defattr(-,root,root,-)
  462. %doc %{geany_plug_docdir}/codenav
  463. %{_libdir}/geany/codenav.so
  464. %files debugger
  465. %defattr(-,root,root,-)
  466. %doc %{geany_plug_docdir}/debugger
  467. %{_datadir}/%{name}/debugger/
  468. %{_libdir}/geany/debugger.so
  469. %files geanydoc
  470. %defattr(-,root,root,-)
  471. %doc %{geany_plug_docdir}/geanydoc/
  472. %{_libdir}/geany/geanydoc.so
  473. %files geanyextrasel
  474. %defattr(-,root,root,-)
  475. %doc %{geany_plug_docdir}/geanyextrasel/
  476. %{_libdir}/geany/geanyextrasel.so
  477. %files geanygdb
  478. %defattr(-,root,root,-)
  479. %doc %{geany_plug_docdir}/geanygdb/
  480. %{_libdir}/geany/geanygdb.so
  481. %{_libexecdir}/geany-plugins/geanygdb/ttyhelper
  482. %files geanygendoc
  483. %defattr(-,root,root,-)
  484. %doc %{geany_plug_docdir}/geanygendoc/
  485. %{_libdir}/geany/geanygendoc.so
  486. %{_datadir}/%{name}/geanygendoc/
  487. %files geanyinsertnum
  488. %defattr(-,root,root,-)
  489. %doc %{geany_plug_docdir}/geanyinsertnum/
  490. %{_libdir}/geany/geanyinsertnum.so
  491. %files geanylatex
  492. %defattr(-,root,root,-)
  493. %doc %{geany_plug_docdir}/geanylatex/
  494. %{_libdir}/geany/geanylatex.so
  495. %files geanylipsum
  496. %defattr(-,root,root,-)
  497. %doc %{geany_plug_docdir}/geanylipsum/
  498. %{_libdir}/geany/geanylipsum.so
  499. %files geanylua
  500. %defattr(-,root,root,-)
  501. %doc %{geany_plug_docdir}/geanylua/
  502. %{_libdir}/geany/geanylua.so
  503. %{_datadir}/%{name}/geanylua/
  504. %{_libdir}/%{name}/geanylua/
  505. %files geanymacro
  506. %defattr(-,root,root,-)
  507. %doc %{geany_plug_docdir}/geanymacro/
  508. %{_libdir}/geany/geanymacro.so
  509. %files geanynumberedbookmarks
  510. %defattr(-,root,root,-)
  511. %doc %{geany_plug_docdir}/geanynumberedbookmarks/
  512. %{_libdir}/geany/geanynumberedbookmarks.so
  513. %files geanypg
  514. %defattr(-,root,root,-)
  515. %doc %{geany_plug_docdir}/geanypg/
  516. %{_libdir}/geany/geanypg.so
  517. %files geanyprj
  518. %defattr(-,root,root,-)
  519. %doc %{geany_plug_docdir}/geanyprj/
  520. %{_libdir}/geany/geanyprj.so
  521. %files geanysendmail
  522. %defattr(-,root,root,-)
  523. %doc %{geany_plug_docdir}/geanysendmail/
  524. %{_libdir}/geany/geanysendmail.so
  525. %files gproject
  526. %defattr(-,root,root,-)
  527. %doc %{geany_plug_docdir}/gproject/
  528. %{_datadir}/icons/hicolor/16x16/apps/gproject-*.png
  529. %{_libdir}/geany/gproject.so
  530. %files geanyvc
  531. %defattr(-,root,root,-)
  532. %doc %{geany_plug_docdir}/geanyvc/
  533. %{_libdir}/geany/geanyvc.so
  534. %files pretty-print
  535. %defattr(-,root,root,-)
  536. %{_libdir}/geany/pretty-print.so
  537. %files shiftcolumn
  538. %defattr(-,root,root,-)
  539. %doc %{geany_plug_docdir}/shiftcolumn/
  540. %{_libdir}/geany/shiftcolumn.so
  541. %files spellcheck
  542. %defattr(-,root,root,-)
  543. %doc %{geany_plug_docdir}/spellcheck/
  544. %{_libdir}/geany/spellcheck.so
  545. %files tableconvert
  546. %defattr(-,root,root,-)
  547. %doc %{geany_plug_docdir}/tableconvert/
  548. %{_libdir}/geany/tableconvert.so
  549. %files treebrowser
  550. %defattr(-,root,root,-)
  551. %doc %{geany_plug_docdir}/treebrowser/
  552. %{_libdir}/geany/treebrowser.so
  553. %files updatechecker
  554. %defattr(-,root,root,-)
  555. %doc %{geany_plug_docdir}/updatechecker/
  556. %{_libdir}/geany/updatechecker.so
  557. %files webhelper
  558. %defattr(-,root,root,-)
  559. %doc %{geany_plug_docdir}/webhelper/
  560. %{_libdir}/geany/webhelper.so
  561. %files xmlsnippets
  562. %defattr(-,root,root,-)
  563. %doc %{geany_plug_docdir}/xmlsnippets/
  564. %{_libdir}/geany/xmlsnippets.so
  565. %changelog
  566. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-2
  567. - added BuildRequires: vte-devel, WebKit-gtk-devel, gtk2-devel, glib2-devel,
  568. gdk-pixbuf2-devel, pango-devel, python-docutils
  569. - fixed %%changelog in Sat Oct 29 2011
  570. * Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-1
  571. - new upstream release
  572. - added new plugins
  573. - Debugger, GeanyPG, GeanyMacro, GeanyNumberedBookmarks, GProject, Tableconvert, XMLSnippets
  574. - added BuildRequires: gpgme-devel
  575. * Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.20-1
  576. - new upstream release
  577. - added geany-plugins-updatechecker and geany-plugins-webhelper
  578. * Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-3
  579. - added geany-plugins-geanygendoc
  580. - added BuildRequires: ctpl-devel >= 0.2
  581. - changed geany-plugins-latex Requires: tetex to Requires: texlive
  582. - removed zero-length documentation files
  583. * Sun Jul 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-2
  584. - correct license to GPLv3+
  585. - added BuildRequires: libxml2-devel >= 2.6.27
  586. - added Requires: geany-plugins-codenav, geany-plugins-treebrowser,
  587. geany-plugins-geanyextrasel, geany-plugins-geanyinsertnum, geany-plugins-pretty-print
  588. * Mon Jun 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-1
  589. - new upstream release
  590. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-3
  591. - fixed Requires geany-plugins
  592. - applied new naming policy to spec
  593. * Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-2
  594. - fixed Obsoletes geany-plugin-addons, geany-plugin-gdb, geany-plugin-latex, geany-plugin-vc
  595. (see [BTS:VineLinux:0894])
  596. - proved Summary(ja)
  597. * Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-1
  598. - initial build for Vine Linux (instead of now provided some geany-plugins)
  599. * Sat Oct 31 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.18-1
  600. - update to new upstream release
  601. * Sat Aug 16 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-6
  602. - build against and require geany 0.18
  603. * Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.17.1-5
  604. - Use bzipped upstream tarball.
  605. * Sat Jul 25 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-4
  606. - write BuildRequires at the beginning of this file
  607. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-3
  608. - remove Requires: geany from the main package
  609. - change Group to Development/Tools
  610. - add release to the geanyvc Provides
  611. - entirely remove %%files stanza for the main package
  612. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-2
  613. - fix the required geany version also in the subpackages
  614. - remove the requires to sub-packages to avoid building the metapackage since
  615. all geany plugins also can be installed by something like
  616. 'yum install geany-plugins-*'
  617. - fix the requires of geany-plugins-common to include the release
  618. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-1
  619. - bump upstream version to 0.17.1
  620. - fix required geany version to be 0.16 at the present
  621. * Sat Jul 18 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-5
  622. - add Requires for metapackage
  623. - rename subpackages back to geany-plugins-* instead of geany-plugin-*
  624. * Fri Jul 17 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-4
  625. - readd the geany_plug_docdir global to fix the versioned directory issue for
  626. documentation files
  627. - replace geany-plugins with %%{name} to be more consistent with macro usage
  628. - remove zero-length documentation files
  629. - fix the changelog
  630. - remove static *.la-files
  631. - split up packages
  632. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-3
  633. - add %%{_datadir}/geany-plugins/geanylua/ to %%files-section
  634. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-2
  635. - fix %%files-section again, thanks to Jonathan for the hint.
  636. * Tue Jul 14 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-1
  637. - update URL to plugins.geany.org
  638. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.2
  639. - Add Obsoletes for geanyvc
  640. - Add more BuildRequires and Requires
  641. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.1
  642. - Update to 0.17 (first upstream release of tarball)
  643. - Fix handling of docs
  644. - Spec file cleanups
  645. * Mon Jun 22 2009 Pingou <pingou@pingoured.fr> 0.1-1
  646. - First RPM for Fedora