gnash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # ghelp/omf/scrollkeeper support
  3. # not working as of version 0.8.7
  4. %define scrollkeeper 0
  5. # kde and klash support
  6. %define kde_support 0
  7. Name: gnash
  8. Version: 0.8.7
  9. Release: 5%{?_dist_release}
  10. Summary: GNU flash movie player
  11. Group: Applications/Multimedia
  12. License: GPLv3+
  13. URL: http://www.gnu.org/software/gnash/
  14. Source0: http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
  15. Source1: http://www.getgnash.org/gnash-splash.swf
  16. Source2: gnash.desktop
  17. # register KComponentData properly in KDE 4 KPart
  18. Patch0: gnash-0.8.3-fix-kde4-port.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: libxml2-devel libpng-devel libjpeg-devel libogg-devel
  21. BuildRequires: libboost-devel curl-devel freetype-devel fontconfig-devel
  22. BuildRequires: libboost-date-time libboost-serialization libboost-thread
  23. BuildRequires: SDL-devel
  24. BuildRequires: agg-devel
  25. BuildRequires: python-devel
  26. BuildRequires: libXv-devel
  27. %if %{kde_support}
  28. #BuildRequires: kde-filesystem
  29. BuildRequires: kdelibs-devel
  30. %endif
  31. BuildRequires: gtkglext-devel
  32. BuildRequires: docbook2X
  33. #BuildRequires: %{_bindir}/docbook2pdf
  34. BuildRequires: gstreamer-devel >= 0.10%
  35. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  36. %if %{scrollkeeper}
  37. BuildRequires: scrollkeeper
  38. %endif
  39. BuildRequires: giflib-devel
  40. BuildRequires: gettext
  41. BuildRequires: desktop-file-utils
  42. BuildRequires: speex-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: pygtk2-devel
  45. BuildRequires: libtool-ltdl-devel
  46. BuildRequires: dejagnu
  47. %if %{scrollkeeper}
  48. Requires(post): scrollkeeper
  49. Requires(postun): scrollkeeper
  50. %endif
  51. Requires(post): /sbin/ldconfig
  52. Requires(postun): /sbin/ldconfig
  53. Requires(post): /sbin/install-info
  54. Requires(preun): /sbin/install-info
  55. %description
  56. Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
  57. supports SWF v7, with better SWF v8 and v9 support under heavy development.
  58. Gnash includes initial parser support for SWF v8 and v9. Not all
  59. ActionScript 2 classes are implemented yet, but all of the most heavily
  60. used ones are. Many ActionScript 2 classes are partially implemented;
  61. there is support for all of the commonly used methods of each
  62. class.
  63. %package plugin
  64. Summary: Web-client flash movie player plugin
  65. Requires: %{name} = %{version}-%{release}
  66. # this doesn't prevent wrong dependencies, in case a package
  67. # provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
  68. # and another unrelated webbrowser is installed, like w3m-el.
  69. # Moreover konqueror could provide webclient some day
  70. #Requires: %{_libdir}/mozilla/plugins webclient
  71. Requires: webclient
  72. Group: Applications/Internet
  73. %description plugin
  74. The gnash flash movie player plugin for firefox or mozilla.
  75. %if %{kde_support}
  76. %package klash
  77. Summary: Konqueror flash movie player plugin
  78. Requires: %{name} = %{version}-%{release}
  79. Group: Applications/Multimedia
  80. %description klash
  81. The gnash flash movie player plugin for Konqueror.
  82. %endif
  83. %package cygnal
  84. Summary: Streaming media server
  85. Requires: %{name} = %{version}-%{release}
  86. Group: Applications/Multimedia
  87. %description cygnal
  88. Cygnal is a streaming media server that's Flash aware.
  89. %package devel
  90. Summary: Gnash header files
  91. Requires: %{name} = %{version}-%{release}
  92. Group: Development/Libraries
  93. %description devel
  94. Gnash header files can be used to write external Gnash extensions or to embed
  95. the Gnash GTK+ widget into a C/C++ application.
  96. %package -n python-gnash
  97. Summary: Gnash Python bindings
  98. Requires: %{name} = %{version}-%{release}
  99. Group: Applications/Multimedia
  100. %description -n python-gnash
  101. Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
  102. application.
  103. %prep
  104. %setup -q
  105. %patch0 -p1 -b .fix-kde4
  106. %if %{kde_support}
  107. # Hack as autoreconf breaks build
  108. sed -i -e 's!kapp.h!kapplication.h!g' configure
  109. sed -i -e 's!libkdeui.la!libkdeui.so!g' configure
  110. # Currently kde4-gnash (from kde4 branch) links against various KDE libraries,
  111. # but only needs Qt -- remove the superfluous linkage
  112. sed -i -e 's!\$(KDE4_LIBS)!!g' gui/Makefile.in
  113. %endif
  114. # we don't want any builtin ltdl built, configure wants always either
  115. # ltdl-install or ltdl-convenience, hack that out
  116. sed -i -e 's/test x"\${enable_ltdl_convenience-no}" != xno/false/g' configure
  117. # and don't build the loader part of libltdl either
  118. sed -i -e 's/\$(LT_DLLOADERS)//g' libltdl/Makefile.in
  119. # link to the system libltdl instead of the bundled one
  120. # this is hardcoded in the makefiles, so --without-included-ltdl doesn't help
  121. sed -i -e 's!\$(top_builddir)/libltdl/libltdlc.la!-lltdl!g' \
  122. */Makefile.in */*/Makefile.in
  123. # delete bundled libltdl stuff to make sure it's not used
  124. rm -f libltdl/*.[ch] libltdl/*/*.[ch]
  125. iconv -f latin1 -t utf8 < AUTHORS > AUTHORS.utf8
  126. touch -r AUTHORS AUTHORS.utf8
  127. mv AUTHORS.utf8 AUTHORS
  128. %build
  129. %configure --disable-static --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
  130. --enable-docbook --enable-ghelp --enable-media=GST \
  131. --disable-dependency-tracking --disable-rpath \
  132. --enable-cygnal \
  133. --enable-sdkinstall \
  134. --enable-python \
  135. %if %{kde_support}
  136. --enable-gui=gtk,kde4,sdl,fb \
  137. --with-kde4-prefix=%{_kde4_prefix} \
  138. --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
  139. --with-kde4-incl=%{_kde4_includedir} \
  140. %else
  141. --enable-gui=gtk,sdl,fb \
  142. %endif
  143. --without-included-ltdl
  144. %if %{kde_support}
  145. # make sure the Qt 4 moc etc. tools are found
  146. export PATH=%{_qt4_prefix}/bin:$PATH
  147. #doesn't work currently: %%{?_smp_mflags}
  148. # override KDE4_LIBS because configure doesn't detect it properly
  149. make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
  150. %else
  151. #doesn't work currently: %%{?_smp_mflags}
  152. make
  153. %endif
  154. %install
  155. rm -rf $RPM_BUILD_ROOT
  156. make install install-plugins \
  157. DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
  158. %if %{kde_support}
  159. KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
  160. KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
  161. KDE4_CONFIGDIR=%{_kde4_configdir} \
  162. KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
  163. %endif
  164. rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
  165. %if %{kde_support}
  166. # KDE 4 doesn't need the .la file anymore, thankfully
  167. rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
  168. %endif
  169. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  170. rm -rf __dist_docs
  171. mkdir __dist_docs
  172. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnash/* __dist_docs/
  173. rmdir $RPM_BUILD_ROOT%{_datadir}/doc/gnash
  174. cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnash/
  175. mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
  176. # a wrapper to avoid gnash erroring out if there is no argument.
  177. # Instead open gnash-splash.swf.
  178. # this should not be needed in the next version.
  179. # FIXME: Do we still need this with 0.8.7?
  180. cat > $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper << EOF
  181. #! /bin/sh
  182. if [ "z\$1" = 'z' ]; then
  183. gnash %{_datadir}/gnash/gnash-splash.swf
  184. else
  185. gnash "\$@"
  186. fi
  187. EOF
  188. chmod a+x $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper
  189. sed -e 's;/usr/libexec;%{_libexecdir};' %{SOURCE2} > gnash.desktop
  190. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
  191. desktop-file-install --vendor="fedora" \
  192. --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
  193. gnash.desktop
  194. mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  195. cp -p ./gui/images/GnashG.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  196. %find_lang %{name}
  197. %clean
  198. rm -rf $RPM_BUILD_ROOT
  199. %post
  200. /sbin/ldconfig
  201. %if %{scrollkeeper}
  202. scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
  203. %endif
  204. /sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  205. /sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
  206. update-desktop-database &> /dev/null || :
  207. touch --no-create %{_datadir}/icons/hicolor
  208. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  209. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  210. fi
  211. %preun
  212. if [ $1 = 0 ]; then
  213. /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  214. /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
  215. fi
  216. %postun
  217. /sbin/ldconfig
  218. %if %{scrollkeeper}
  219. scrollkeeper-update -q || :
  220. %endif
  221. update-desktop-database &> /dev/null || :
  222. touch --no-create %{_datadir}/icons/hicolor
  223. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  224. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  225. fi
  226. %files -f %{name}.lang
  227. %defattr(-,root,root,-)
  228. %doc README AUTHORS COPYING NEWS
  229. %doc __dist_docs/*
  230. %config(noreplace) %{_sysconfdir}/gnashpluginrc
  231. %config(noreplace) %{_sysconfdir}/gnashrc
  232. %{_bindir}/dumpshm
  233. %{_bindir}/fb-gnash
  234. %{_bindir}/flvdumper
  235. %{_bindir}/gtk-gnash
  236. %{_bindir}/sdl-gnash
  237. %{_bindir}/soldumper
  238. %{_bindir}/gnash
  239. %{_bindir}/gprocessor
  240. %{_bindir}/findmicrophones
  241. %{_bindir}/findwebcams
  242. %dir %{_libdir}/gnash
  243. %{_libdir}/gnash/*.so*
  244. %{_mandir}/man1/gnash.1*
  245. %{_mandir}/man1/dumpshm.1*
  246. %{_mandir}/man1/gprocessor.1*
  247. %{_mandir}/man1/soldumper.1*
  248. %{_mandir}/man1/flvdumper.1*
  249. %{_mandir}/man1/findmicrophones.1*
  250. %{_mandir}/man1/findwebcams.1*
  251. %{_mandir}/man1/gtk-gnash.1*
  252. %{_infodir}/gnash*
  253. %{_datadir}/gnash/
  254. %{_datadir}/icons/hicolor/32x32/apps/*.png
  255. %{_datadir}/applications/*.desktop
  256. %{_libexecdir}/gnash-wrapper
  257. %if %{scrollkeeper}
  258. %{_datadir}/omf/gnash/
  259. %endif
  260. %files plugin
  261. %defattr(-,root,root,-)
  262. %{_libdir}/mozilla/plugins/libgnashplugin.so
  263. %if %{kde_support}
  264. %files klash
  265. %defattr(-,root,root,-)
  266. %{_kde4_bindir}/kde4-gnash
  267. %{_kde4_libdir}/kde4/libklashpart.so
  268. %{_kde4_appsdir}/klash/
  269. %{_kde4_datadir}/kde4/services/klash_part.desktop
  270. %{_mandir}/man1/kde4-gnash.1*
  271. %endif
  272. %files cygnal
  273. %defattr(-,root,root,-)
  274. %config(noreplace) %{_sysconfdir}/cygnalrc
  275. %{_bindir}/cygnal
  276. %{_mandir}/man1/cygnal.1*
  277. %{_mandir}/man1/rtmpget.1*
  278. %dir %{_libdir}/cygnal
  279. %{_libdir}/cygnal/plugins/*.so*
  280. %files devel
  281. %defattr(-,root,root,-)
  282. %{_includedir}/gnash/
  283. %{_libdir}/pkgconfig/gnash.pc
  284. %files -n python-gnash
  285. %defattr(-,root,root,-)
  286. %{python_sitearch}/gtk-2.0/*
  287. %changelog
  288. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-5
  289. - rebuild with python-2.7.2
  290. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
  291. - add BuildRequires: python-devel, libXv-devel
  292. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
  293. - rebuilt with libboost-1.45.0
  294. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
  295. - rebuilt with rpm-4.8.1 for pkg-config
  296. * Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
  297. - initial build for Vine Linux: based Fedora 0.8.7-1.fc14
  298. * Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
  299. - update to 0.8.7
  300. - make scrollkeeper a conditional (still disabled as it's not working)
  301. - drop gnash-0.8.3-manual.patch, should no longer be needed
  302. - drop gnash-0.8.6-python-install-dir.patch, fixed upstream
  303. * Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
  304. - delete bundled libltdl stuff to make sure it's not used
  305. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
  306. - don't build libltdlc.a
  307. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
  308. - --without-included-ltdl (CVE-2009-3736)
  309. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
  310. - Rebuild for new Boost (1.41.0)
  311. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
  312. - Add missing Epoch to Requires
  313. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
  314. - Install icon to the correct place (#551621)
  315. * Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
  316. - One more try at using the correct dir
  317. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
  318. - Patch was reversed
  319. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
  320. - Patch Makefile.in, not Makefile.am
  321. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
  322. - Pick up python modules from the right dir
  323. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
  324. - Install python modules in the right dir
  325. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
  326. - Add cygnal plugins
  327. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
  328. - Update to 0.8.6, increase epoch.
  329. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
  330. - update to HEAD
  331. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
  332. - update to HEAD
  333. * Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
  334. - don't package headers in -widget, only in -devel (no duplicate files)
  335. - own %%{_includedir}/gnash/ in -devel
  336. - add missing %%defattr for -devel and -widget
  337. - make -devel and -widget require the main package (with exact VR)
  338. - fix -devel group and description
  339. - rename gnash-widget to python-gnash as per the naming guidelines
  340. * Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
  341. - use %%{_includedir}, not %%{_prefix}/include
  342. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
  343. - Install the python module in the sitearch dir
  344. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
  345. - One more 64bit fix
  346. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
  347. - Fix the packaging in 64bits
  348. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
  349. - upload the .swf file
  350. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
  351. - merge upstream changes into the spec
  352. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
  353. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  354. * Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
  355. - rebuild for new Boost
  356. * Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
  357. - explicitly link the KlashPart against the libraries it uses
  358. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
  359. - add missing speex-devel and gstreamer-plugins-base-devel BR
  360. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
  361. - update to 0.8.5
  362. - remove use_kde3_executable_hack
  363. - remove autoreconf
  364. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
  365. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  366. * Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
  367. - rebuild for new boost
  368. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
  369. - add missing portions of KDE 4 port from upstream kde4 branch
  370. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
  371. - add 3 more patches from bero to fix the KDE 4 viewer executable
  372. - disable use_kde3_executable hack
  373. * Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
  374. - add a desktop file
  375. * Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
  376. - update KDE 4 patch (undo the backporting and use original patch)
  377. - patch to make autoreconf work
  378. - add missing BR giflib-devel, gettext
  379. - omit unrecognized --with-qtdir
  380. * Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
  381. - update to 0.8.4
  382. * Thu Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
  383. - use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
  384. so it can easily be disabled or removed once the KDE 4 executable is fixed)
  385. * Thu Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
  386. - register KComponentData properly in KDE 4 KPart
  387. * Wed Oct 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
  388. - KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
  389. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
  390. - include %%_libdir/gnash directory
  391. * Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
  392. - add glib in the link, thanks Daniel Drake (#452767)
  393. * Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
  394. - update to 0.8.3
  395. * Wed Apr 9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
  396. - ship libklashpart (#441601)
  397. * Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
  398. - don't ship libltdl.so.3 (#436725)
  399. * Fri Mar 7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
  400. - update to 0.8.2
  401. * Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
  402. - add patch from Martin Stransky to fix wrapped plugin #281061
  403. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
  404. - info files are empty, don't install them
  405. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
  406. - omf/scrollkeeper doc is broken, remove it
  407. * Fri Sep 7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
  408. - better documentation generation
  409. * Wed Sep 5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
  410. - update to 0.8.1
  411. - agg is now the default renderer
  412. * Fri Aug 3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
  413. - rebuild for boost soname change
  414. * Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
  415. - update to 0.8.0
  416. * Wed May 9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
  417. - fix CVE-2007-2500 (fix 239213)
  418. * Sat Nov 6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
  419. - update for 0.7.2 release.
  420. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
  421. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  422. * Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
  423. - plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
  424. temporarily, but there is no better solution yet) #207613
  425. * Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
  426. - add defattr for klash
  427. - add warnings in the description about stability
  428. * Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
  429. - remove superfluous buildrequires autoconf
  430. - rename last patch to gnash-plugin-tempfile-dir.patch
  431. - add README.fedora to plugin to explain tmpdirs
  432. * Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
  433. - source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
  434. - add plugin-tempfile-dir.patch for plugin to use a safe tempdir
  435. * Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
  436. - buildrequire autotools (Michael Knox)
  437. * Fri Jun 2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
  438. - add gnash-continue_on_info_install_error.patch to avoid
  439. - buildrequire libXmu-devel
  440. * Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
  441. - configure with --disable-rpath
  442. - buildrequire docbook2X
  443. - remove devel files
  444. * Sun May 7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
  445. - update to 0.7.1 alpha release
  446. * Sat Apr 22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
  447. - install the info file. Various tweaks for my system based on
  448. Patrice's latest patch,
  449. * Fri Feb 3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
  450. - initial packaging