gnome-python-extras-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define glib_version 2.20.0
  3. %define gtk_version 2.16.0
  4. %define gnome_panel_version 2.26.0
  5. %define gnome_python_version 2.26.0
  6. %define gtkhtml2_version 2.3.1
  7. %define gecko_version 1.9.1
  8. %define gtkspell_version 2.0.7
  9. %define libgda_version 4.0
  10. %define libgdl_version 0.7.1
  11. %define build_gdl 0
  12. ### Abstract ###
  13. Name: gnome-python-extras
  14. Version: 2.25.3
  15. Release: 4%{?_dist_release}
  16. License: GPL/LGPL
  17. Group: Development/Languages
  18. Summary: The sources for additional. PyGNOME Python extension modules.
  19. URL: http://www.pygtk.org/
  20. Source: gnome-python-extras-%{version}.tar.bz2
  21. Patch1: gnome-python-extras-2.10.0-gtkspell-static.patch
  22. Patch4: gnome-python-extras-2.19.1-buildfix.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. ### Dependencies ###
  25. Requires: gnome-python >= %{gnome_python_version}
  26. ### Build Dependencies ###
  27. BuildRequires: gecko-devel >= %{gecko_version}
  28. BuildRequires: glib2 >= %{glib_version}
  29. BuildRequires: gnome-panel >= %{gnome_panel_version}
  30. BuildRequires: gnome-python-devel >= %{gnome_python_version}
  31. BuildRequires: gtk2 >= %{gtk_version}
  32. BuildRequires: gtkhtml2-devel >= %{gtkhtml2_version}
  33. BuildRequires: gtkspell-devel >= %{gtkspell_version}
  34. BuildRequires: libbonoboui-devel
  35. BuildRequires: libgda-devel >= %{libgda_version}
  36. BuildRequires: libgksu-devel
  37. BuildRequires: pygtk2-devel
  38. BuildRequires: python-devel
  39. %if %{build_gdl}
  40. BuildRequires: libgdl-devel >= %{libgdl_version}
  41. %endif
  42. %description
  43. The gnome-python-extra package contains the source packages for additional
  44. Python bindings for GNOME. It should be used together with gnome-python.
  45. %if %{build_gdl}
  46. %package -n gnome-python-gdl
  47. Summary: Python bindings for the GNOME Development Library
  48. Group: Development/Languages
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: libgdl >= %{libgdl_version}
  51. %description -n gnome-python-gdl
  52. This module contains a wrapper that allows the use of the GNOME Development
  53. Library (gdl) via Python.
  54. %endif
  55. %package -n gnome-python-gtkhtml2
  56. Summary: Python bindings for interacting with gtkhtml2
  57. Group: Development/Languages
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: gtkhtml2 >= %{gtkhtml2_version}
  60. Obsoletes: pygnome-gtkhtml
  61. %description -n gnome-python-gtkhtml2
  62. This module contains a wrapper that allows the use of gtkhtml2 via Python.
  63. %package -n gnome-python-gtkmozembed
  64. Summary: Python bindings for interacting with gtkmozembed
  65. Group: Development/Languages
  66. Requires: %{name} = %{version}-%{release}
  67. Requires: gecko-libs >= %{gecko_version}
  68. %description -n gnome-python-gtkmozembed
  69. This module contains a wrapper that allows the use of gtkmozembed via Python.
  70. %package -n gnome-python-gtkspell
  71. Summary: Python bindings for interacting with gtkspell
  72. Group: Development/Languages
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: gtkspell >= %{gtkspell_version}
  75. %description -n gnome-python-gtkspell
  76. This module contains a wrapper that allows the use of gtkspell via Python.
  77. %package -n gnome-python-libegg
  78. Summary: Python bindings for recent files and tray icons
  79. Group: Development/Languages
  80. Requires: %{name} = %{version}-%{release}
  81. %description -n gnome-python-libegg
  82. This module contains a wrapper that allows the use of recent files and tray
  83. icons via Python.
  84. %package -n gnome-python-libgksu
  85. Summary: Python bindings for interacting with libgksu
  86. Group: Development/Languages
  87. Requires: %{name} = %{version}-%{release}
  88. Requires: libgksu
  89. %description -n gnome-python-libgksu
  90. This module contains a wrapper that allows the use of libgksu via Python.
  91. %package -n gnome-python-gda
  92. Summary: Python bindings for interacting with libgda
  93. Group: Development/Languages
  94. Requires: %{name} = %{version}-%{release}
  95. Requires: libgda >= %{libgda_version}
  96. %description -n gnome-python-gda
  97. This module contains a wrapper that allows the use of libgda via Python.
  98. %package -n gnome-python-gda-devel
  99. Summary: Headers for developing programs that will use gnome-python-gda
  100. Group: Development/Libraries
  101. Requires: gnome-python-gda = %{version}-%{release}
  102. Requires: pkgconfig
  103. Requires: pygobject-devel
  104. Requires: libgda-devel >= %{libgda_version}
  105. %description -n gnome-python-gda-devel
  106. This module contains files needed for developing applications using
  107. gnome-python-gda.
  108. %prep
  109. %setup -q -n gnome-python-extras-%{version}
  110. %patch1 -p1 -b .gtkspell-static
  111. %patch4 -p1 -b .buildfix
  112. %build
  113. %if %{build_gdl}
  114. %configure --with-gtkmozembed=mozilla
  115. %else
  116. %configure --with-gtkmozembed=mozilla --disable-gdl
  117. %endif
  118. make
  119. %install
  120. rm -rf $RPM_BUILD_ROOT
  121. make install DESTDIR=$RPM_BUILD_ROOT
  122. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  123. rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/gtk-2.0/gksu
  124. %clean
  125. rm -rf $RPM_BUILD_ROOT
  126. %files
  127. %defattr(-,root,root,-)
  128. %doc AUTHORS ChangeLog NEWS
  129. %{_libdir}/pkgconfig/gnome-python-extras-2.0.pc
  130. %{_datadir}/pygtk
  131. %if %{build_gdl}
  132. %files -n gnome-python-gdl
  133. %defattr(-,root,root,-)
  134. %{python_sitearch}/gtk-2.0/gdl.so
  135. %endif
  136. %files -n gnome-python-gtkhtml2
  137. %defattr(-,root,root,-)
  138. %{python_sitearch}/gtk-2.0/gtkhtml*
  139. %defattr(644,root,root,755)
  140. %doc examples/gtkhtml2/*
  141. %files -n gnome-python-gtkmozembed
  142. %defattr(-,root,root,-)
  143. %{python_sitearch}/gtk-2.0/gtkmozembed.so
  144. %files -n gnome-python-gtkspell
  145. %defattr(-,root,root,-)
  146. %{python_sitearch}/gtk-2.0/gtkspell.so
  147. %files -n gnome-python-libegg
  148. %defattr(-,root,root,-)
  149. %{python_sitearch}/gtk-2.0/egg
  150. %defattr(644,root,root,755)
  151. %doc examples/egg/*
  152. %files -n gnome-python-libgksu
  153. %defattr(-,root,root,-)
  154. %{python_sitearch}/gtk-2.0/gksu2
  155. %files -n gnome-python-gda
  156. %defattr(-,root,root,-)
  157. %{python_sitearch}/gtk-2.0/gda.so
  158. %files -n gnome-python-gda-devel
  159. %defattr(-,root,root,-)
  160. %{_includedir}/pygda-?.?/
  161. %{_libdir}/pkgconfig/pygda-?.?.pc
  162. %changelog
  163. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.25.3-4
  164. - rebuild with python-2.7.2
  165. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.25.3-3
  166. - rebuild with rpm-4.8.1 for pkg-config file
  167. * Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.25.3-2
  168. - rebuilt with python-2.6
  169. - added --disable-gdl option to configure
  170. * Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.25.3-1
  171. - new upstream release
  172. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.1-1
  173. - new upstream release
  174. - split to subpackages
  175. - build with xulrunner
  176. * Sat Aug 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.12.0-0vl3
  177. - added missing BuildRequires for gtkspell
  178. * Thu Jul 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl2
  179. - rebuilt
  180. * Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.0-0vl1
  181. - Initial build.