gnome-python-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. # libzvt is in Extras but not Core
  3. %define buildzvt 0
  4. Summary: The sources for the PyGNOME Python extension module.
  5. Name: gnome-python
  6. Version: 2.28.1
  7. Release: 4%{?_dist_release}
  8. Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
  9. License: LGPL
  10. Group: Development/Libraries
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: pygtk2-devel >= 2.14.0
  13. BuildRequires: python-devel >= 2.5
  14. BuildRequires: pyorbit-devel >= 2.24.0
  15. BuildRequires: pygobject-devel >= 2.17.0
  16. BuildRequires: libbonobo-devel >= 2.24.1
  17. BuildRequires: libbonoboui-devel >= 2.24.1
  18. BuildRequires: libgnome-devel >= 2.26.0
  19. BuildRequires: gnome-vfs2-devel >= 2.24.0
  20. BuildRequires: GConf2-devel >= 2.26.0
  21. BuildRequires: libgnomeui-devel >= 2.8.0
  22. BuildRequires: libSM-devel
  23. %if %{buildzvt}
  24. BuildRequires: libzvt-devel >= 2.0.2
  25. %endif
  26. ## needed for automake/autoconf to work right with multilib python
  27. #BuildRequires: automake >= 1.9.6, libtool, autoconf
  28. #Obsoletes: gnome-python-applet
  29. Obsoletes: gnome-python-bonobo
  30. Obsoletes: gnome-python-canvas
  31. Obsoletes: gnome-python-gconf
  32. #Obsoletes: gnome-python-gnomeprint
  33. Obsoletes: gnome-python-gnomevfs
  34. #Obsoletes: gnome-python-gtkhtml2
  35. Obsoletes: gnome-python-nautilus
  36. %if %{buildzvt}
  37. Obsoletes: gnome-python-zvt
  38. %endif
  39. Requires: pyorbit >= 2.24.0
  40. Requires: pygtk2 >= 2.14.1
  41. %description
  42. The gnome-python package contains the source packages for the Python
  43. bindings for GNOME called PyGNOME.
  44. PyGNOME is an extension module for Python that provides access to the
  45. base GNOME libraries, so you have access to more widgets, a simple
  46. configuration interface, and metadata support.
  47. %package devel
  48. Summary: Development files for building add-on libraries
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: gnome-vfs2-devel >= 2.24.0
  52. Requires: pkgconfig
  53. Requires: python-devel >= %{pyver}
  54. %description devel
  55. This package contains files required to build wrappers for GNOME add-on
  56. libraries so that they interoperate with gnome-python.
  57. %prep
  58. %setup -q -n gnome-python-%{version}
  59. %build
  60. # libtoolize --force
  61. # aclocal && automake && autoconf
  62. #export PYTHON=/usr/bin/python%{pyver}
  63. #CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
  64. # ./configure --prefix=%{_prefix}
  65. %configure
  66. make
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make install DESTDIR=$RPM_BUILD_ROOT
  70. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
  76. %{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
  77. %{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
  78. %{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
  79. %{_libdir}/python?.?/site-packages/gtk-2.0/gnome
  80. %{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
  81. %{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
  82. %if %{buildzvt}
  83. %{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
  84. %endif
  85. %{_datadir}/pygtk/*
  86. %files devel
  87. %defattr(-,root,root,-)
  88. %{_includedir}/gnome-python-2.0
  89. %{_libdir}/pkgconfig/gnome-python-2.0.pc
  90. %{_datadir}/gtk-doc/html/pygnomevfs
  91. ## old versions did not have .pyc and .pyo files in their file list
  92. ## remove them now, or bad things will now happen because of the new
  93. ## paths. This trigger must remain until upgrading from RHL 8.0 is no
  94. ## longer supported.
  95. #%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
  96. #rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
  97. %changelog
  98. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-4
  99. - rebuild with python-2.7.2
  100. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-3
  101. - rebuild with rpm-4.8.1 for pkg-config file
  102. - add BuildRequires: libSM-devel
  103. * Sat Jun 05 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.28.1-2
  104. - add BuildRequires: libgnomeui-devel >= 2.8.0
  105. * Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-1
  106. - new upstream release
  107. - dropt "Obsoletes: gnome-python-gtkhtml2" (provided by gnome-python-extras)
  108. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  109. - rebuild for python-2.6
  110. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  111. - new upstream release
  112. * Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  113. - new upstream release
  114. - add Requires: pygtk2, pyorbit
  115. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  116. - new upstream release
  117. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
  118. - new upstream release
  119. * Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
  120. - rebuilt with python-2.5
  121. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  122. - new upstream release
  123. - split devel package
  124. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
  125. - new upstream release
  126. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  127. - new upstream release
  128. * Mon May 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
  129. - new upstream release 2.12.4
  130. * Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
  131. - new upstream release 2.12.1
  132. - obsolete all sub-packages
  133. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
  134. - dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
  135. -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
  136. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
  137. - new upstream release 2.10.0
  138. - rebuilt with python 2.4.1
  139. - dropped gnome-python-applet
  140. - dropped gnome-python-capplet
  141. - dropped gnome-python-nautilus
  142. - dropped gnome-python-gtkhtml2
  143. - dropped gnome-python-gnomeprint
  144. see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
  145. * Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
  146. - fixed BuildRequires/Requires for pyorbit's version
  147. * Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
  148. - new upstream release
  149. * Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
  150. - new upstream release
  151. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
  152. - rebuild with python-2.3.3-0vl1
  153. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
  154. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  155. * Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
  156. - sync with Fedora 2.0.0-2
  157. * Thu Oct 2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
  158. - fix segv in gnome.ui.About() (#104396)
  159. - rebuild with new toolchain and pyorbit
  160. - s/Copyright/License/
  161. * Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
  162. - build for Vine Linux
  163. * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
  164. - 2.0.0
  165. * Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
  166. - update to 1.99.16
  167. - add gnomeprint subpackage
  168. - don't double include the gnome-vfs module (#102074)
  169. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
  170. - Fix libtool
  171. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  172. - rebuilt
  173. * Thu Feb 6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
  174. - added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
  175. * Thu Feb 6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
  176. - rebuilt against new python
  177. * Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
  178. - libdir-ify
  179. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  180. - rebuilt
  181. * Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
  182. - update to 1.99.14
  183. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
  184. - update to 1.99.13
  185. - add gnomevfs subpackage
  186. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  187. - use %%configure
  188. * Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
  189. - add gnome-python-2.0.pc to file list
  190. * Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
  191. - bind gnome_client_set_*_command
  192. * Wed Aug 28 2002 Tim Powers <timp@redhat.com>
  193. - rebuilt
  194. * Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
  195. - obsolete pygtk-applet (#69830)
  196. * Thu Aug 1 2002 Jonathan Blandford <jrb@redhat.com>
  197. - make the GnomeDruid's fields accessible from python
  198. * Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
  199. - official 1.99.11 release
  200. * Thu May 30 2002 Matt Wilson <msw@redhat.com>
  201. - s/Gconf/GConf/
  202. * Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
  203. - add gtkhtml2 and gconf subpackages
  204. * Wed May 29 2002 Bill Nottingham <notting@redhat.com>
  205. - add some defattrs
  206. * Fri May 24 2002 Matt Wilson <msw@redhat.com>
  207. - added bonobo, nautilus subpackages. re-enabled applet subpackage
  208. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
  209. - subpackages will need __init__ included in them
  210. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  211. - doesn't obsolete pygnome - it can be installed side-by-side
  212. - added _gnomemodule.so to base package filelist
  213. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  214. - added __init__ files to gnome-python main package
  215. * Mon Oct 8 2001 Matt Wilson <msw@redhat.com>
  216. - new gnome-python package based on old pygtk package.