gnome-specimen-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: gnome-specimen
  3. Version: 0.4
  4. Release: 2%{?_dist_release}
  5. Summary: A simple tool to view and compare fonts installed on your system
  6. Summary(ja): システムにインストールされているフォントを閲覧・比較するシンプルなツール
  7. Group: Applications/System
  8. License: GPLv2+
  9. URL: http://uwstopia.nl/geek/projects/gnome-specimen/
  10. Source0: http://uwstopia.nl/geek/projects/gnome-specimen/releases/%{name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: GConf2-devel
  14. BuildRequires: gnome-python
  15. BuildRequires: pygtk2-libglade
  16. BuildRequires: perl-XML-Parser
  17. BuildRequires: pkgconfig
  18. BuildRequires: gettext
  19. BuildRequires: desktop-file-utils
  20. Requires(pre): GConf2
  21. Requires(post): GConf2
  22. Requires(preun): GConf2
  23. %description
  24. Gnome Specimen is a simple tool to view and compare fonts installed on
  25. your system
  26. %description -l ja
  27. Gnome Specimen はあなたのシステムにインストールされているフォントを
  28. 閲覧・比較するためのシンプルなツールです。
  29. %prep
  30. %setup -q
  31. %build
  32. %configure
  33. %__make %{?_smp_mflags}
  34. %install
  35. %__rm -rf $RPM_BUILD_ROOT
  36. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  37. ## %__make install DESTDIR=$RPM_BUILD_ROOT
  38. %__make install DESTDIR=$RPM_BUILD_ROOT pyexecdir=%{python_sitelib}
  39. desktop-file-install --vendor="vine" --delete-original \
  40. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  41. $RPM_BUILD_ROOT%{_datadir}/applications//%{name}.desktop
  42. %find_lang %{name}
  43. %clean
  44. %__rm -rf $RPM_BUILD_ROOT
  45. %pre
  46. if [ "$1" -gt 1 ]; then
  47. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  48. gconftool-2 --makefile-uninstall-rule \
  49. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  50. killall -HUP gconfd-2 || :
  51. fi
  52. %post
  53. touch --no-create %{_datadir}/icons/hicolor || :
  54. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  55. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  56. gconftool-2 --makefile-install-rule \
  57. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  58. killall -HUP gconfd-2 || :
  59. %postun
  60. touch --no-create %{_datadir}/icons/hicolor || :
  61. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  62. %preun
  63. if [ "$1" -eq 0 ]; then
  64. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  65. gconftool-2 --makefile-uninstall-rule \
  66. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  67. killall -HUP gconfd-2 || :
  68. fi
  69. %files -f %{name}.lang
  70. %defattr(-,root,root,-)
  71. %doc AUTHORS ChangeLog COPYING NEWS README
  72. %{_bindir}/%{name}
  73. %{python_sitelib}/specimen
  74. %{_datadir}/%{name}
  75. %{_datadir}/applications/*.desktop
  76. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  77. %config(noreplace) %{_sysconfdir}/gconf/schemas/%{name}.schemas
  78. %changelog
  79. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  80. - rebuild with python-2.7.2
  81. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  82. - new upstream release
  83. * Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 0.3-2
  84. - rebuilt with python-2.6.4-3
  85. - fixed install directory
  86. * Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.3-1
  87. - initial build
  88. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.3-3
  89. - Rebuild for Python 2.6
  90. * Wed Jul 23 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3-2
  91. - fix license tag
  92. * Wed Jul 18 2007 Damien Durand <splinux@fedoraproject.org> - 0.3-1
  93. - Update to 0.3
  94. * Wed Jul 11 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-4
  95. - Fix desktop-file section
  96. * Wed Jun 27 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-3
  97. - Fix owned directories
  98. * Fri Jun 09 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-2
  99. - Fix gconf shemas
  100. - Set BuildArch to noarch
  101. - Fix wrong entries from desktop file
  102. * Fri Jun 08 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-1
  103. - Initial RPM release