gtk-vnc-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272
  1. # Plugin isn't ready for real world use yet - it needs
  2. # a security audit at very least
  3. %define with_plugin 0
  4. Summary: A GTK widget for VNC clients
  5. Summary(ja): VNCクライアント用 GTK ウィジェット
  6. Name: gtk-vnc
  7. Version: 0.4.4
  8. Release: 2%{?_dist_release}
  9. License: LGPLv2+
  10. Group: Development/Libraries
  11. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
  12. Patch100: gtk-vnc-0.3.8-fast.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. URL: http://gtk-vnc.sf.net/
  15. BuildRequires: gtk3-devel pygtk2-devel python-devel zlib-devel
  16. BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
  17. BuildRequires: vala-tools
  18. %if %{with_plugin}
  19. BuildRequires: xulrunner-devel
  20. %endif
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: Takemikaduchi
  24. %description
  25. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  26. allowing it to be completely asynchronous while remaining single threaded.
  27. %package devel
  28. Summary: Development filesdor gtk-vnc library
  29. Summary(ja): gtk-vnc ライブラリの開発ファイル
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. Requires: pkgconfig
  33. Requires: pygtk2-devel gtk3-devel gnutls-devel
  34. %description devel
  35. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  36. allowing it to be completely asynchronous while remaining single threaded.
  37. Libraries, includes, etc. to compile with the gtk-vnc library
  38. %package python
  39. Summary: Python bindings for the gtk-vnc library
  40. Summary(ja): gtk-vnc ライブラリの python バインディング
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. %description python
  44. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  45. allowing it to be completely asynchronous while remaining single threaded.
  46. A module allowing use of the GTK-VNC widget from python
  47. %package vala
  48. Summary: Vala bindings for gtk-vnc
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: vala
  52. %description vala
  53. Vala bindings for gtk-vnc
  54. %if %{with_plugin}
  55. %package plugin
  56. Summary: Mozilla plugin for the gtk-vnc library
  57. Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
  58. Group: Development/Libraries
  59. Requires: %{name} = %{version}-%{release}
  60. %description plugin
  61. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  62. allowing it to be completely asynchronous while remaining single threaded.
  63. This package provides a web browser plugin for Mozilla compatible
  64. browsers.
  65. %endif
  66. %prep
  67. %setup -q
  68. ## %patch100 -p1
  69. %build
  70. %if %{with_plugin}
  71. %configure --enable-plugin=yes --with-gtk=3.0
  72. %else
  73. %configure --with-gtk=3.0
  74. %endif
  75. %__make %{?_smp_mflags}
  76. %install
  77. rm -fr %{buildroot}
  78. %__make install DESTDIR=%{buildroot}
  79. rm -f %{buildroot}%{_libdir}/*.a
  80. rm -f %{buildroot}%{_libdir}/*.la
  81. rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
  82. rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
  83. %if %{with_plugin}
  84. rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
  85. rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
  86. %endif
  87. %find_lang %{name}
  88. %clean
  89. rm -fr %{buildroot}
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %files -f %{name}.lang
  93. %defattr(-, root, root)
  94. %doc AUTHORS ChangeLog NEWS README COPYING.LIB
  95. %{_bindir}/gvnccapture
  96. %{_libdir}/lib*.so.*
  97. %{_libdir}/girepository-1.0/*.typelib
  98. %{_mandir}/man1/gvnccapture.1.gz
  99. %files devel
  100. %defattr(-, root, root)
  101. %doc examples/gvncviewer.c
  102. %{_libdir}/lib*.so
  103. %dir %{_includedir}/%{name}-2.0/
  104. %dir %{_includedir}/gvnc-1.0/
  105. %{_includedir}/%{name}-2.0/*.h
  106. %{_includedir}/gvnc-1.0/*.h
  107. %{_libdir}/pkgconfig/%{name}-2.0.pc
  108. %{_libdir}/pkgconfig/gvnc-1.0.pc
  109. %{_datadir}/gir-1.0/*.gir
  110. %files python
  111. %defattr(-, root, root)
  112. %doc examples/gvncviewer.py
  113. # %{_libdir}/python*/site-packages/gtkvnc.so
  114. %files vala
  115. %defattr(-, root, root)
  116. %{_datadir}/vala/vapi/gtk-vnc-2.0.*
  117. %{_datadir}/vala/vapi/gvnc-1.0.*
  118. %if %{with_plugin}
  119. %files plugin
  120. %defattr(-, root, root)
  121. %{_libdir}/mozilla/plugins/%{name}-plugin.so
  122. %endif
  123. %changelog
  124. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-2
  125. - rebuild with python-2.7.2
  126. * Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
  127. - new upstream release
  128. - add BuildRequires: vala-tools
  129. - create %%{name}-vala sub package
  130. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-2
  131. - change BuildRequires: gtk3-devel instead of gtk2-devel
  132. - add configure option: --with-gtk=3.0
  133. * Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
  134. - new upstream release
  135. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-2
  136. - rebuild with rpm-4.8.1 for pkg-config file
  137. * Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
  138. - new upstream release
  139. - drop Patch100
  140. - fix %files
  141. * Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
  142. - new upstream release
  143. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
  144. - rebuild with python-2.6
  145. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
  146. - new upstream release
  147. - add Patch100 to speed up
  148. - add BR: cyrus-sasl-devel
  149. * Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
  150. - rebuild with gnutls-2.6.3
  151. * Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
  152. - new upstream release
  153. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
  154. - initial build for Vine Linux
  155. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.7-1
  156. - Update to 0.3.7
  157. * Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
  158. - Fix key/mouse event propagation (rhbz #454627)
  159. * Mon Jul 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
  160. - fix conditional comparison
  161. * Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
  162. - Rebuild for GNU TLS ABI change
  163. * Wed May 7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
  164. - Updated to 0.3.6 release
  165. * Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
  166. - Update to 0.3.5
  167. * Fri Apr 4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
  168. - Remove bogus chunk of render patch
  169. * Thu Apr 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
  170. - Fix OpenGL rendering artifacts (rhbz #440184)
  171. * Thu Apr 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
  172. - Fixed endianness conversions
  173. - Fix makecontext() args crash on x86_64
  174. - Fix protocol version negotiation
  175. * Thu Mar 6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
  176. - Update to 0.3.4 release
  177. - Fix crash with OpenGL scaling code
  178. * Sun Feb 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
  179. - Update to 0.3.3 release
  180. * Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
  181. - Track keystate to avoid stuck modifier keys
  182. * Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
  183. - Update to 0.3.2 release
  184. - Added dep on zlib-devel
  185. * Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
  186. - Update to 0.3.1 release
  187. * Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
  188. - Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
  189. * Thu Oct 4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
  190. - Fixed coroutine caller to avoid SEGV
  191. * Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
  192. - Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
  193. * Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
  194. - Update to 0.2.0 release
  195. * Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
  196. - Fixed handling of mis-matched client/server colour depths
  197. * Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
  198. - Fix mixed endian handling & BGR pixel format (rhbz #253597)
  199. - Clear widget areas outside of framebuffer (rhbz #253599)
  200. - Fix off-by-one in python demo
  201. * Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
  202. - Tweaked post scripts
  203. - Removed docs from sub-packages
  204. - Explicitly set license to LGPLv2+
  205. - Remove use of macro for install rule
  206. * Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
  207. - Added gnutls-devel requirement to -devel package
  208. * Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
  209. - Initial official release