libproxy-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. %{!?python_sitelib: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Summary: A library handling all the details of proxy configuration
  3. Name: libproxy
  4. Version: 0.4.7
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://code.google.com/p/libproxy/
  9. Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
  10. Patch0: libproxy-0.4.7-cmake-modules.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: python-devel
  13. #Virtual Provides - We need either mozjs or WebKit
  14. Requires: %{name}-pac >= %{version}
  15. #
  16. Requires: libproxy-python = %{version}-%{release}
  17. Requires: libproxy-bin = %{version}-%{release}
  18. BuildRequires: cmake
  19. # gnome
  20. BuildRequires: GConf2-devel
  21. # mozjs
  22. BuildRequires: js-devel
  23. # NetworkManager
  24. BuildRequires: NetworkManager-devel
  25. BuildRequires: dbus-devel
  26. # webkit (gtk)
  27. BuildRequires: WebKit3-gtk-devel
  28. # kde
  29. BuildRequires: kdelibs-devel
  30. BuildRequires: libXmu-devel
  31. BuildRequires: libX11-devel
  32. Provides: %{name}-webkit = %{version}-%{release}
  33. Obsoletes: %{name}-webkit < %{version}-%{release}
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. libproxy offers the following features:
  38. * extremely small core footprint (< 35K)
  39. * no external dependencies within libproxy core
  40. (libproxy plugins may have dependencies)
  41. * only 3 functions in the stable external API
  42. * dynamic adjustment to changing network topology
  43. * a standard way of dealing with proxy settings across all scenarios
  44. * a sublime sense of joy and accomplishment
  45. Non-default rpmbuild options:
  46. --with webkit: Enable WebKit-gtk support
  47. %package bin
  48. Summary: Binary to test %{name}
  49. Group: Applications/System
  50. Requires: %{name} = %{version}-%{release}
  51. %description bin
  52. The %{name}-bin package contains the proxy binary for %{name}
  53. %package python
  54. Summary: Binding for %{name} and python
  55. Group: System Environment/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. %description python
  58. The %{name}-python package contains the python binding for %{name}
  59. %package gnome
  60. Summary: Plugin for %{name} and gnome
  61. Group: System Environment/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. %description gnome
  64. The %{name}-gnome package contains the %{name} plugin for gnome.
  65. %package kde
  66. Summary: Plugin for %{name} and kde
  67. Group: System Environment/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. %description kde
  70. The %{name}-kde package contains the %{name} plugin for kde.
  71. %package mozjs
  72. Summary: Plugin for %{name} and mozjs
  73. Group: System Environment/Libraries
  74. Requires: %{name} = %{version}
  75. #Tweak this according to the current gecko-libs version
  76. Requires: js
  77. Provides: %{name}-pac = %{version}-%{release}
  78. %description mozjs
  79. The %{name}-mozjs package contains the %{name} plugin for mozjs.
  80. %package webkitgtk3
  81. Summary: Plugin for %{name} and webkitgtk3
  82. Group: System Environment/Libraries
  83. Requires: %{name} = %{version}
  84. Provides: %{name}-pac = %{version}-%{release}
  85. %description webkitgtk3
  86. The %{name}-webkitgtk3 package contains the %{name} plugin for
  87. webkitgtk3.
  88. %package devel
  89. Summary: Development files for %{name}
  90. Group: Development/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. Requires: pkgconfig
  93. %description devel
  94. The %{name}-devel package contains libraries and header files for
  95. developing applications that use %{name}.
  96. %prep
  97. %setup -q
  98. %patch0 -p1 -b .old_cmake
  99. %build
  100. %cmake \
  101. -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
  102. -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
  103. -DWITH_PERL=OFF \
  104. -DWITH_WEBKIT3=ON \
  105. .
  106. make VERBOSE=1 %{?_smp_mflags}
  107. %install
  108. rm -rf $RPM_BUILD_ROOT
  109. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  110. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  111. %clean
  112. rm -rf $RPM_BUILD_ROOT
  113. %post -p /sbin/ldconfig
  114. %postun -p /sbin/ldconfig
  115. %files
  116. %defattr(-,root,root,-)
  117. %doc AUTHORS COPYING README
  118. %{_libdir}/*.so.*
  119. %dir %{_libdir}/%{name}
  120. %dir %{_libdir}/%{name}/%{version}
  121. %dir %{_libdir}/%{name}/%{version}/modules
  122. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  123. %files bin
  124. %defattr(-,root,root,-)
  125. %{_bindir}/proxy
  126. %files python
  127. %defattr(-,root,root,-)
  128. %{python_sitelib}/libproxy.py
  129. %files gnome
  130. %defattr(-,root,root,-)
  131. %{_libdir}/%{name}/%{version}/modules/config_gnome3.so
  132. %{_libexecdir}/pxgsettings
  133. %files kde
  134. %defattr(-,root,root,-)
  135. %{_libdir}/%{name}/%{version}/modules/config_kde4.so
  136. %files mozjs
  137. %defattr(-,root,root,-)
  138. %{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
  139. %files webkitgtk3
  140. %defattr(-,root,root,-)
  141. %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
  142. %files devel
  143. %defattr(-,root,root,-)
  144. %{_includedir}/proxy.h
  145. %{_libdir}/*.so
  146. %{_libdir}/pkgconfig/libproxy-1.0.pc
  147. %{_datadir}/cmake/Modules/Findlibproxy.cmake
  148. %changelog
  149. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
  150. - rebuild with python-2.7.2
  151. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
  152. - new upstream release
  153. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  154. - change BuildRequires: js-devel instead of gecko-devel
  155. - replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
  156. - detele -webkit sub package
  157. - create -webkitgtk3 sub package
  158. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  159. - new upstream release
  160. - drop Patch0
  161. - add BuildRequires: cmake, kdelibs-devel
  162. - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
  163. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
  164. - rebuild with rpm-4.8.1 for pkg-config file
  165. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  166. - rebuild with python-2.6
  167. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  168. - rebuild with gecko-1.9.1
  169. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  170. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  171. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  172. - initial build for Vine Linux
  173. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  174. - Rebuild for webkit
  175. - Raise requirement for xulrunner to 1.9.1
  176. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  178. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  179. - Merge NetworkManager module into the main libproxy package
  180. - Main Requires the -python and -bin subpackage
  181. (splitted for multilibs compliance).
  182. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  183. - Disable Gnome/KDE default support via builtin modules.
  184. (it needs to be integrated via Gconf2/neon instead).
  185. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  186. - Disable Obsoletes.
  187. - Requires ev instead of evr for optionnals sub-packages.
  188. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  189. - Use conditionals build.
  190. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  191. - Remove plugin- in the name of the packages
  192. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  193. - Move proxy.h to libproxy/proxy.h
  194. This will prevent it to be included in the default include path
  195. - Split main to libs and util and use libproxy to install all
  196. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  197. - Rename binding-python to python
  198. - Add Requires: gecko-libs >= %%{gecko_version}
  199. - Fix some descriptions
  200. - Add plugin-webkit package
  201. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  202. - Convert to Fedora spec
  203. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  204. - Updated to version 0.2.3
  205. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  206. - Extended spec file to build all available plugins
  207. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  208. - Initial spec file for Version 0.2.2