libuser-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510
  1. %define WITH_SELINUX 0
  2. %define python %(python -c 'import sys;print(sys.version[0:3])')
  3. Name: libuser
  4. Version: 0.56.9
  5. Release: 5%{?_dist_release}
  6. Summary: A user and group account administration library.
  7. Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
  8. Group: System Environment/Base
  9. License: LGPL
  10. URL: https://fedorahosted.org/libuser/
  11. Source: libuser-%{version}.tar.bz2
  12. Patch0: libuser-selinux.patch
  13. BuildRoot: %{_tmppath}/%{name}-root
  14. BuildRequires: pam-devel
  15. BuildRequires: popt
  16. BuildRequires: python-devel
  17. BuildRequires: gtk-doc
  18. BuildRequires: linuxdoc-tools
  19. BuildRequires: pkgconfig
  20. BuildRequires: glib2-devel
  21. BuildRequires: popt-devel
  22. #BuildPrereq: cyrus-sasl-devel, openldap-devel
  23. %description
  24. The libuser library implements a standardized interface for manipulating
  25. and administering user and group accounts. The library uses pluggable
  26. back-ends to interface to its data sources.
  27. Sample applications modeled after those included with the shadow password
  28. suite are included.
  29. %package devel
  30. Group: Development/Libraries
  31. Summary: Files needed for developing applications which use libuser.
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The libuser-devel package contains header files, static libraries, and other
  35. files useful for developing applications with libuser.
  36. %prep
  37. %setup -q
  38. %if %{WITH_SELINUX}
  39. #SELinux
  40. %patch0 -p1 -b .selinux
  41. %endif
  42. %build
  43. CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
  44. %configure \
  45. --with-python-version=%{python} \
  46. --with-python-path=%{_includedir}/python%{python} \
  47. --with-html-dir=%{_datadir}/gtk-doc/html \
  48. --with-pic
  49. make
  50. %clean
  51. rm -fr $RPM_BUILD_ROOT
  52. %install
  53. rm -fr $RPM_BUILD_ROOT
  54. make install DESTDIR=$RPM_BUILD_ROOT
  55. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  56. LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
  57. export LD_LIBRARY_PATH
  58. # Verify that all python modules load, just in case.
  59. pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
  60. python%{python} -c "import libuser"
  61. popd
  62. # remove .la
  63. rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
  64. rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
  65. %find_lang %{name}
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files -f %{name}.lang
  69. %defattr(-,root,root)
  70. %doc AUTHORS COPYING NEWS README TODO docs/*.txt python/modules.txt
  71. %config(noreplace) %{_sysconfdir}/libuser.conf
  72. %attr(0755,root,root) %{_bindir}/*
  73. %attr(0755,root,root) %{python_sitearch}/*.so
  74. %attr(0755,root,root) %{_libdir}/*.so.*
  75. %dir %attr(0755,root,root) %{_libdir}/%{name}
  76. %attr(0755,root,root) %{_libdir}/%{name}/*.so
  77. #%attr(0644,root,root) %{_libdir}/%{name}/*.la
  78. %attr(0755,root,root) %{_sbindir}/*
  79. %files devel
  80. %defattr(-,root,root)
  81. %attr(0755,root,root) %dir %{_includedir}/libuser
  82. %attr(0644,root,root) %{_includedir}/libuser/*
  83. #attr(0644,root,root) %{_libdir}/*.la
  84. %attr(0755,root,root) %{_libdir}/*.so
  85. #%attr(0644,root,root) %{_mandir}/man3/*
  86. %attr(0644,root,root) %{_mandir}/man5/*
  87. %attr(0644,root,root) %{_libdir}/pkgconfig/*
  88. %{_datadir}/gtk-doc/html/*
  89. %{_mandir}/man1/*
  90. %changelog
  91. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-5
  92. - rebuild with python-2.7.2
  93. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
  94. - rebuild with rpm-4.8.1 for pkg-config file
  95. * Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
  96. - add BuildRequires: pkgconfig, glib2-devel, popt-devel
  97. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
  98. - rebuild for python-2.6
  99. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
  100. - new upstream release
  101. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
  102. - rebuilt with python-2.5.2
  103. - removed *.la
  104. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
  105. - applied new versioning policy
  106. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
  107. - new upstream release
  108. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
  109. - rebuild with python-2.4.1-0vl1
  110. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
  111. - rebuild with python-2.3.3-0vl1
  112. * Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
  113. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  114. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
  115. - resync to fedora
  116. * Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
  117. - initial build for Vine Linux
  118. * Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
  119. - degrade gracefully
  120. - build with --with-pic and -fPIC
  121. - remove unpackaged man page
  122. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
  123. - translation updates
  124. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
  125. - doc updates -- cvs tree moved
  126. - language updates
  127. - disallow weird characters in account names
  128. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  129. - automated rebuild
  130. * Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
  131. - files: ignore blank lines in files
  132. - libuser: disallow creation of accounts with names containing whitespace,
  133. control characters, or non-ASCII characters
  134. * Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
  135. - refresh translations
  136. - fix a heap-corruption bug in the python bindings
  137. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
  138. - bump version
  139. - refresh translations
  140. * Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
  141. - ldap: cache an entity's dn in the entity structure to try to speed things up
  142. * Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
  143. - rebuild in new environment
  144. * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
  145. - add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
  146. - translation refresh
  147. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
  148. - fix python bindings of enumerateFull functions
  149. - adjust prompter wrapping to not error out on successful returns
  150. * Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
  151. - be more careful about printing error messages
  152. - fix refreshing after adding of accounts
  153. - ldap: try to use a search to convert names to DNs, and only fall back to
  154. guessing if it turns up nothing
  155. - files: fix an off-by-one in removal of entries
  156. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
  157. - refresh translations
  158. - fix admin() constructor comments in the python module
  159. * Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
  160. - automatically refresh entities after add, modify, setpass, removepass,
  161. lock, and unlock operations
  162. - remove debug spewage when creating and removing mail spools
  163. - files: fix saving of multi-valued attributes
  164. - rename MEMBERUID attribute for groups to MEMBERNAME
  165. * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
  166. - files: fix bug in removals
  167. - ldap: revert attempts at being smart at startup time, because it makes UIs
  168. very messy (up the three whole dialogs just to start the ldap stuff!)
  169. * Sun Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
  170. - fix thinko in dispatch routines
  171. * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
  172. - lgroupmod: fix thinko
  173. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
  174. - rebuild in new environment
  175. * Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
  176. - move shadow initialization for groups to the proper callback
  177. - rework locking in the files module to not require that files be writable
  178. * Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
  179. - expose lu_strerror()
  180. - add various typedefs for types used by the library
  181. * Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
  182. - add removepass() functions
  183. * Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
  184. - lchfn,lchsh,lpasswd - reorder PAM authentication calls
  185. - include API docs in the package
  186. * Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
  187. - ldap: finish port to new API
  188. - sasl: finish port to new API (needs test)
  189. - libuser: don't commit object changes before passing data to service
  190. functions which might need differing data sets to figure out what to
  191. change (for example, ldap)
  192. * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
  193. - bind the internal mail spool creation/removal functions for python
  194. * Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
  195. - renamed the python module
  196. - revamped internals to use gobject's gvalues and gvaluearrays instead of
  197. glists of cached strings
  198. - add enumeration-with-data functions to the C library
  199. * Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  200. - require linuxdoc-tools instead of sgml-tools for rawhide
  201. * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  202. - fixup build files to allow building for arbitrary versions of python
  203. * Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
  204. - link the python module against libpam
  205. - attempt to import the python modules at build-time to verify dependencies
  206. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
  207. - fix a file-parsing bug that popped up in 0.29's mmap modifications
  208. * Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
  209. - quotaq: fix argument order when reading quota information
  210. - user_quota: set quota grace periods correctly
  211. - luseradd: never create home directories for system accounts
  212. * Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  213. - add da translation files
  214. - update translations
  215. * Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
  216. - add an explicit build dependency on jade (for the docs)
  217. * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  218. - HUP nscd on modifications
  219. - userutil.c: mmap files we're reading for probable speed gain
  220. - userutil.c: be conservative with the amount of random data we read
  221. - docs fixes
  222. * Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
  223. - apps: print usage on errors
  224. - lnewusers.c: initialize groups as groups, not users
  225. - lnewusers.c: set passwords for new accounts
  226. - luseradd.c: accept group names in addition to IDs for the -g flag
  227. - luseradd.c: allow the primary GID to be a preexisting group
  228. * Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
  229. - add ko translation files
  230. - files.c: fix a heap corruption bug in lock/unlock (#51750)
  231. - files.c: close a memory leak in reading of files
  232. * Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  233. - files.c: remove implementation limits on lengths of lines
  234. * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
  235. - lusermod: change user name in groups the user is a member of during renames
  236. - lgroupmod: change primary GID for users who are in the group during renumbers
  237. - ldap.c: handle new attributes more gracefully if possible
  238. - add ru translation files
  239. * Tue Aug 7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
  240. - rename the quota source files to match the library, which clears up a
  241. file conflict with older quota packages
  242. - add ja translation files
  243. * Thu Aug 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  244. - add lu_ent_clear_all() function
  245. * Thu Aug 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
  246. - close up some memory leaks
  247. - add the ability to include resident versions of modules in the library
  248. * Wed Aug 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
  249. - fix incorrect Py_BuildValue invocation in python module
  250. * Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
  251. - stop leaking descriptors in the files module
  252. - speed up user creation by reordering some checks for IDs being in use
  253. - update the shadowLastChanged attribute when we set a password
  254. - adjust usage of getXXXXX_r where needed
  255. - fix assorted bugs in python binding which break prompting
  256. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
  257. - install sv translation
  258. - make lpasswd prompt for passwords when none are given on the command line
  259. - make sure all user-visible strings are marked for translation
  260. - clean up some user-visible strings
  261. - require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
  262. * Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  263. - print uids and gids of users and names in lid app
  264. - fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
  265. - implement enumerate_by_group and enumerate_by_user in ldap module
  266. - fix id-based lookups in the ldap module
  267. - implement islocked() method in ldap module
  268. - implement setpass() method in ldap module
  269. - add lchfn and lchsh apps
  270. - add %%d substitution to libuser.conf
  271. * Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
  272. - finish adding a sasldb module which manipulates a sasldb file
  273. - add users_enumerate_by_group and groups_enumerate_by_users
  274. * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  275. - luserdel: remove the user's primary group if it has the same name as
  276. the user and has no members configured (-G disables)
  277. - fixup some configure stuff to make libuser.conf get generated correctly
  278. even when execprefix isn't specified
  279. * Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
  280. - only call the auth module when setting passwords (oops)
  281. - use GTrees instead of GHashTables for most internal tables
  282. - files: complain properly about unset attributes
  283. - files: group passwords are single-valued, not multiple-valued
  284. - add lpasswd app, make sure all apps start up popt with the right names
  285. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
  286. - actually make the new optional arguments optional
  287. - fix lu_error_new() to actually report errors right
  288. - fix part of the python bindings
  289. - include tools in the binary package again
  290. - fixup modules so that password-changing works right again
  291. - add a "key" field to prompt structures for use by apps which like to
  292. cache these things
  293. - add an optional "mvhomedir" argument to userModify (python)
  294. * Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
  295. - finish home directory population
  296. - implement home directory moving
  297. - change entity get semantics in the python bindings to allow default values for .get()
  298. - add lu_ent_has(), and a python has_key() method to Entity types
  299. - don't include tools in the binary package
  300. - add translated strings
  301. * Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
  302. - lib/user.c: catch and ignore errors when running stacks
  303. - lusermod: fix slightly bogus help messages
  304. - luseradd: when adding a user and group, use the gid of the group
  305. instead of the user's uid as the primary group
  306. - properly set the password field in user accounts created using
  307. auth-only auth modules (shadow needs "x" instead of "!!")
  308. - implement home directory removal, start on population
  309. * Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  310. - fix group password setting in the files module
  311. - setpass affects both auth and info, so run both stacks
  312. * Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  313. - make the testbed apps noinst
  314. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  315. - fix errors due to uninitialized fields in the python bindings
  316. - add kwargs support to all python wrappers
  317. - add a mechanism for passing arguments to python callbacks
  318. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  319. - stub out the krb5 and ldap modules so that they'll at least compile again
  320. * Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  321. - don't bail when writing empty fields to colon-delimited files
  322. - use permissions of the original file when making backup files instead of 0600
  323. * Fri Jul 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  324. - finish implementing is_locked methods in files/shadow module
  325. - finish cleanup of the python bindings
  326. - allow conditional builds of modules so that we can build without
  327. all of the prereqs for all of the modules
  328. * Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  329. - add error reporting facilities
  330. - split public header into pieces by function
  331. - backend cleanups
  332. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  333. - make %%{name}-devel require %%{name} and not %%{name}-devel
  334. * Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  335. - clean up quota bindings some more
  336. - finish most of the ldap bindings
  337. - fix a subtle bug in the files module that would show up when renaming accounts
  338. - fix mapping methods for entity structures in python
  339. * Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
  340. - get bindings for prompts to work correctly
  341. - clean up some of the add/remove semantics (set source on add)
  342. - ldap: implement enumeration
  343. - samples/enum: fix the argument order
  344. * Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  345. - clean up python bindings for quota
  346. * Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
  347. - finish up python bindings for quota support
  348. * Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  349. - finish up quota support libs
  350. * Fri Jun 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  351. - start quota support library to get some type safety
  352. * Thu Jun 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  353. - start looking at quota manipulation
  354. * Wed Jun 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  355. - add functions for enumerating users and groups, optionally per-module
  356. - lusermod.c: -s should specify the shell, not the home directory
  357. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
  358. - finish the python bindings and verify that the file backend works again
  359. * Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  360. - remove a redundant check which was breaking modifications
  361. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  362. - finish adding setpass methods
  363. * Wed May 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
  364. - get a start on some Python bindings
  365. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
  366. - make binary-incompatible change in headers
  367. * Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
  368. - add doxygen docs and a "doc" target for them
  369. * Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
  370. - add a "quiet" prompter
  371. - add --interactive flag to sample apps and default to using quiet prompter
  372. - ldap: attempt a "self" bind if other attempts fail
  373. - krb5: connect to the password-changing service if the user principal has
  374. the NULL instance
  375. * Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  376. - the great adding-of-the-copyright-statements
  377. - take more care when creating backup files in the files module
  378. * Wed Jan 3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
  379. - add openldap-devel as a buildprereq
  380. - krb5: use a continuous connection
  381. - krb5: add "realm" config directive
  382. - ldap: use a continuous connection
  383. - ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
  384. - ldap: actually finish the account deletion function
  385. - ldap: don't send cleartext passwords to the directory
  386. - fix naming attribute for users (should be uid, not gid)
  387. - refine the search-by-id,convert-to-name,search-by-name logic
  388. - fix handling of defaults when the config file is read in but contains no value
  389. - implement an LDAP information store
  390. - try to clean up module naming with libtool
  391. - luseradd: pass plaintext passwords along
  392. - luseradd: use symbolic attribute names instead of hard-coded
  393. - lusermod: pass plaintext passwords along
  394. - lgroupadd: pass plaintext passwords along
  395. - lgroupmod: pass plaintext passwords along
  396. - add libuser as a dependency of libuser-devel
  397. * Tue Jan 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
  398. - initial packaging