pygtk2-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
  3. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  4. Summary: Python bindings for the GTK+ widget set.
  5. Summary(ja): GTK+ ウィジットセットの Python 実装
  6. Name: pygtk2
  7. Version: 2.24.0
  8. Release: 2%{?_dist_release}
  9. Group: Development/Languages
  10. License: LGPLv2
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Buildrequires: python-devel >= 2.5
  14. Buildrequires: libglade2-devel >= 2.5.0
  15. BuildRequires: gtk2-devel >= 2.16.0
  16. BuildRequires: pygobject-devel >= 2.16.0
  17. BuildRequires: pycairo-devel >= 1.8.2
  18. BuildRequires: python-numeric
  19. BuildRequires: docbook-style-xsl
  20. BuildRequires: libxslt
  21. Buildrequires: automake >= 1.6.3-5
  22. Requires: pygobject
  23. Requires: pycairo
  24. Requires: python-numeric
  25. Obsoletes: pygtk
  26. %description
  27. PyGTK is an extension module for python that gives you access to the GTK+
  28. widget set. Just about anything you can write in C with GTK+ you can write
  29. in python with PyGTK (within reason), but with all the benefits of python.
  30. %description -l ja
  31. PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
  32. です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
  33. けます。 python のおかげでもあります。
  34. %package libglade
  35. Summary: A wrapper for the libglade library for use with PyGTK
  36. Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
  37. Group: Development/Libraries
  38. Requires: pygtk2 = %{version}
  39. %description libglade
  40. This module contains a wrapper for the libglade library. Libglade allows
  41. a program to construct its user interface from an XML description, which
  42. allows the programmer to keep the UI and program logic separate.
  43. %description -l ja libglade
  44. このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
  45. プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
  46. ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
  47. %package devel
  48. Summary: files needed to build wrappers for GTK+ addon libraries
  49. Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
  50. Group: Development/Libraries
  51. Requires: pygtk2 = %{version}
  52. Requires: pygobject-devel >= 2.12.0
  53. Requires: gtk2-devel
  54. %description devel
  55. This package contains files required to build wrappers for GTK+ addon
  56. libraries so that they interoperate with pygtk.
  57. %description -l ja devel
  58. このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
  59. みます。これらは PyGTK との仲介をします。
  60. %prep
  61. %setup -q -n pygtk-%{version}
  62. %build
  63. [ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
  64. #aclocal && automake && autoconf
  65. %configure --enable-thread --enable-numpy
  66. export tagname=CC
  67. make LIBTOOL=/usr/bin/libtool
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. export tagname=CC
  71. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
  72. find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %defattr(-,root,root)
  77. %doc AUTHORS NEWS README MAPPING ChangeLog
  78. %doc examples
  79. %defattr(644, root, root, 755)
  80. %dir %{python_sitearch}/gtk-2.0
  81. %dir %{python_sitearch}/gtk-2.0/gtk
  82. %{python_sitearch}/gtk-2.0/gtk/*.py*
  83. %dir %{_libdir}/pygtk
  84. %dir %{_libdir}/pygtk/2.0
  85. %{_libdir}/pygtk/2.0/*
  86. %defattr(755, root, root, 755)
  87. %{_bindir}/pygtk-demo
  88. %{python_sitearch}/gtk-2.0/atk.so
  89. %{python_sitearch}/gtk-2.0/pango.so
  90. %{python_sitearch}/gtk-2.0/gtk/_gtk.so
  91. %{python_sitearch}/gtk-2.0/gtkunixprint.so
  92. %{python_sitearch}/gtk-2.0/pangocairo.so
  93. %if %{buildglade}
  94. %files libglade
  95. %defattr(755, root, root, 755)
  96. %{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
  97. %endif
  98. %files devel
  99. %defattr(644, root, root, 755)
  100. %dir %{_includedir}/pygtk-2.0
  101. %dir %{_includedir}/pygtk-2.0/pygtk
  102. %{_includedir}/pygtk-2.0/pygtk/*.h
  103. %{_libdir}/pkgconfig/pygtk-2.0.pc
  104. %dir %{_datadir}/pygtk
  105. %dir %{_datadir}/pygtk/2.0
  106. %dir %{_datadir}/pygtk/2.0/defs
  107. %{_datadir}/pygtk/2.0/defs/*.defs
  108. %{_datadir}/pygtk/2.0/defs/pangocairo.override
  109. %{_datadir}/gtk-doc/html/pygtk
  110. %defattr(755, root, root, 755)
  111. %{_bindir}/pygtk-codegen-2.0
  112. %changelog
  113. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-2
  114. - rebuild with python-2.7.2
  115. * Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  116. - new upstream release
  117. * Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-2
  118. - add Requires: gtk2-devel (-devel package)
  119. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  120. - new upstream release
  121. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  122. - new upstream release
  123. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  124. - new upstream release
  125. - rebuild with python-2.6
  126. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  127. - new upstream release
  128. * Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
  129. - rebuilt with python-2.5.2
  130. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
  131. - rebuilt with python-2.4.5
  132. - used %%{?_dist_release} macro
  133. * Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
  134. - new upstream release
  135. * Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
  136. - new upstream release
  137. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
  138. - new upstream release
  139. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
  140. - added Requires pygobject-devel to devel package
  141. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
  142. - new upstream release
  143. - add Requires/BuildRequires pygobject,pycairo
  144. * Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
  145. - new upstream release 2.8.6
  146. * Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
  147. - new upstream release 2.8.4
  148. - added japanese summary and description
  149. * Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
  150. - new upstream release 2.8.2
  151. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  152. - new upstream release 2.8.1
  153. - added %clean sectioin
  154. * Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
  155. - new upstream release 2.8.0
  156. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
  157. - new upstream release 2.6.1
  158. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
  159. - rebuild with python-2.4.1-0vl1
  160. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  161. - new upstream release
  162. * Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
  163. - updated to 2.2.0
  164. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
  165. - rebuild with python-2.3.3-0vl1
  166. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
  167. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  168. * Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
  169. - added missing %%defattr
  170. * Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
  171. - added Provides and Obsoletes pygtk
  172. * Sun Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
  173. - new upstream release (based on Redhat Rawhide 2.0.0-1)
  174. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
  175. - Fix libtool
  176. * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
  177. - part of the fixnew patch wasn't applied upstream, apply it (#99400)
  178. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
  179. - new upstream release
  180. - build for Vine Linux
  181. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  182. - rebuild for multilib
  183. - use %%configure
  184. * Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
  185. - fix pixbuf leaks (#72137)
  186. - five more pixbuf leaks plugged
  187. * Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
  188. - remover Packager tag
  189. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  190. - add binding for gdk_atom_intern
  191. * Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
  192. - 0.99.12
  193. * Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
  194. - new version from CVS
  195. * Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
  196. - Fix bug #65770.
  197. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  198. - automated rebuild
  199. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  200. - new version from CVS
  201. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  202. - automated rebuild
  203. * Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
  204. - 1.99.10
  205. * Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
  206. - 1.99.8
  207. * Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
  208. - added atkmodule.so to file list
  209. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  210. - fix devel filelist to match new header location
  211. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  212. - get the headers from their new version-specific location
  213. * Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
  214. - fixed typo in devel filelist
  215. - added macro that tests to see if we have libglade2, make the
  216. filelist a condition of that
  217. - changed name to 'pygtk2' to avoid name conflict with pygtk