pyrenamer-vl.spec 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. # -*- encoding: utf-8 -*-
  2. %define ver 0.6.0
  3. %define rel 2
  4. Summary: an application for mass renaming files
  5. Summary: 大量のファイルの名前を変更するためのアプリケーション
  6. Name: pyrenamer
  7. Version: %{ver}
  8. Release: %{rel}%{?_dist_release}
  9. License: GPLv2
  10. Group: Applications/Accessories
  11. URL: http://www.infinicode.org/code/pyrenamer/
  12. Source0: http://www.infinicode.org/code/pyrenamer/files/%{name}-%{version}.tar.gz
  13. Source1: pyrenamer_trunk-ja.po
  14. Source2: pyrenamer-0.6.0-LINGUAS
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  16. BuildRequires: pygtk2-devel GConf2-devel
  17. BuildRequires: desktop-file-utils
  18. Requires: pygtk2 GConf2
  19. Requires(post,postun): desktop-file-utils
  20. BuildArch: noarch
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: iwaim
  24. %description
  25. pyRenamer is an application for mass renaming files.
  26. You can rename files using patterns, substitutions,
  27. insert or delete text, or even rename files manually.
  28. You can also rename images using their EXIF tags
  29. and music using their internal tags.
  30. %prep
  31. %setup -q
  32. %__cp -a %{SOURCE1} po/ja.po
  33. %__rm -f po/LINGUAS
  34. %__cp -a %{SOURCE2} po/LINGUAS
  35. %configure
  36. %build
  37. make
  38. %install
  39. %__rm -rf %{buildroot}
  40. %makeinstall
  41. %__rm -rf %{buildroot}%{_docdir}/%{name}
  42. %find_lang %{name}
  43. %check
  44. make check
  45. %{_bindir}/desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
  46. %clean
  47. %__rm -rf %{buildroot}
  48. %post
  49. if [ -x %{_bindir}/update-desktop-database ] ; then
  50. %{_bindir}/update-desktop-database %{_datadir}/applications
  51. fi
  52. %postun
  53. if [ -x %{_bindir}/update-desktop-database ] ; then
  54. %{_bindir}/update-desktop-database %{_datadir}/applications
  55. fi
  56. %files -f %{name}.lang
  57. %defattr(-,root,root,-)
  58. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  59. %{_bindir}/pyrenamer
  60. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  61. %{python_sitelib}/%{name}
  62. %{_datadir}/applications/%{name}.desktop
  63. %{_mandir}/man1/%{name}.1*
  64. %{_datadir}/pixmaps/*.png
  65. %{_datadir}/%{name}
  66. %changelog
  67. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
  68. - rebuild with python-2.7.2
  69. * Mon Jun 7 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.0-1
  70. - Initial build.