pysvn-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Name: pysvn
  3. Version: 1.7.0
  4. Release: 4%{?_dist_release}
  5. Summary: Pythonic style bindings for Subversion
  6. Summary(ja): Subversion 用の python バインディング
  7. Group: Development/Languages
  8. License: ASL 1.1
  9. URL: http://pysvn.tigris.org/
  10. Source0: http://pysvn.barrys-emacs.org/source_kits/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: python-devel
  13. BuildRequires: PyXML
  14. BuildRequires: subversion-devel
  15. BuildRequires: krb5-devel
  16. BuildRequires: neon-devel
  17. BuildRequires: apr-devel
  18. BuildRequires: openssl-devel
  19. Packager: kazutaka
  20. %description
  21. Pythonic style bindings for Subversion
  22. %description -l ja
  23. Subversion 用の python バインディングです。
  24. %prep
  25. %setup -q -n %{name}-%{version}
  26. %build
  27. pushd Source
  28. %{__python} setup.py backport
  29. CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py configure --enable-debug --verbose --norpath --fixed-module-name
  30. # Set correct build flags
  31. %{__sed} -i -e 's/-Wall -fPIC -fexceptions -frtti/%{optflags} -fPIC -frtti/' Makefile
  32. %{__make} %{?_smp_mflags}
  33. %install
  34. %{__rm} -rf %{buildroot}
  35. %{__install} -d -m 755 %{buildroot}%{python_sitearch}/%{name}
  36. %{__install} -p -m 644 Source/pysvn/__init__.py %{buildroot}%{python_sitearch}/%{name}
  37. %{__install} -p -m 755 Source/pysvn/_pysvn.so %{buildroot}%{python_sitearch}/%{name}
  38. %check
  39. #pushd Tests
  40. #%{__make} %{?_smp_mflags}
  41. %clean
  42. %{__rm} -rf %{buildroot}
  43. %files
  44. %defattr(-, root, root, -)
  45. %doc Docs/pysvn.html Docs/pysvn_prog_guide.html Docs/pysvn_prog_ref.html
  46. %doc Docs/pysvn_prog_ref.js
  47. %doc Examples
  48. %doc LICENSE.txt
  49. %{python_sitearch}/%{name}
  50. %changelog
  51. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-4
  52. - rebuild with python-2.7.2
  53. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-3
  54. - rebuild with openssl-1.0.0c
  55. * Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.0-2
  56. - rebuild with python-2.6 (Seed only)
  57. * Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.7.0-1
  58. - initial build for Vine Linux based of fedora development
  59. - add japanese description and summary
  60. - run backport command to skip reserved keyword check for python 2.6
  61. * Wed Mar 04 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-2
  62. - Remove the benchmark patch. Changes included in this release.
  63. * Tue Mar 03 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-1
  64. - Update to 1.6.3
  65. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-4
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  67. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.2-3
  68. - rebuild with new openssl
  69. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.6.2-2
  70. - Rebuild for Python 2.6
  71. * Tue Oct 28 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.2-1
  72. - Upstream to 1.6.2, upstream provided some build fixes to remove patches
  73. - (Thanks Barry!). Re-enabled testing with provided patch to fix whitespace
  74. * Sat Oct 11 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-2
  75. - Fixed lingering module versioning in __init__
  76. * Mon Oct 06 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-1
  77. - Update to 1.6.1, fix F10 FBFS
  78. - Disabled tests, might be because of subversion 1.5
  79. * Wed Feb 27 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.3-1
  80. - Update to 1.5.3
  81. * Thu Feb 14 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-6
  82. - Clean up. Name change (back to upstream)
  83. * Tue Feb 12 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-5
  84. - Temporary fix for tests. Need to work with upstream for permanent fix.
  85. * Fri Feb 08 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-4
  86. - Fixed build requires, libgssapi-devel was still in there (for EL5 support)
  87. * Fri Jan 11 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-3
  88. - Merged patches and spec changes by Terje Røsten <terje.rosten@ntnu.no>
  89. - Fixed the test failures
  90. * Fri Jan 04 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-2
  91. - Attempting to make the spec work with different versions of Python
  92. * Mon Sep 03 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-1
  93. - Update to 1.5.2
  94. - Some spec clean up
  95. * Fri Jan 12 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.0-1
  96. - Initial spec creation