python-BeautifulSoup-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?pyver: %global pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
  3. %define oname BeautifulSoup
  4. Name: python-BeautifulSoup
  5. Version: 3.0.8.1
  6. Release: 2%{?_dist_release}
  7. Summary: HTML/XML parser for quick-turnaround applications like screen-scraping
  8. Group: Development/Languages
  9. License: BSD
  10. URL: http://www.crummy.com/software/BeautifulSoup/
  11. Source0: http://www.crummy.com/software/BeautifulSoup/download/3.x/BeautifulSoup-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildArch: noarch
  14. BuildRequires: python-devel
  15. %description
  16. Beautiful Soup is a Python HTML/XML parser designed for quick
  17. turnaround projects like screen-scraping. Three features make it
  18. powerful:
  19. Beautiful Soup won't choke if you give it bad markup.
  20. Beautiful Soup provides a few simple methods and Pythonic idioms for
  21. navigating, searching, and modifying a parse tree.
  22. Beautiful Soup automatically converts incoming documents to Unicode
  23. and outgoing documents to UTF-8.
  24. Beautiful Soup parses anything you give it.
  25. Valuable data that was once locked up in poorly-designed websites is
  26. now within your reach. Projects that would have taken hours take only
  27. minutes with Beautiful Soup.
  28. #'
  29. %prep
  30. %setup -q -n %{oname}-%{version}
  31. %build
  32. %{__python} setup.py build
  33. %{__python} -c 'import %{oname} as bs; print bs.__doc__' > COPYING
  34. touch -r %{oname}.py COPYING
  35. %install
  36. %__rm -rf $RPM_BUILD_ROOT
  37. %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  38. #Files installed by error
  39. %__rm -rf $RPM_BUILD_ROOT%{_bindir}
  40. %clean
  41. %__rm -rf $RPM_BUILD_ROOT
  42. %check
  43. %{__python} BeautifulSoupTests.py
  44. %files
  45. %defattr(-,root,root,-)
  46. %doc COPYING
  47. %{python_sitelib}/%{oname}.py*
  48. %exclude %{python_sitelib}/%{oname}Tests.py*
  49. %if 0%{?fedora} >= 9 || 0%{?rhel} >= 6
  50. %{python_sitelib}/%{oname}-%{version}-py%{pyver}.egg-info
  51. %endif
  52. %changelog
  53. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8.1-2
  54. - rebuild with python-2.7.2
  55. * Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.0.8.1-1
  56. - initial build based on Fedora development
  57. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:3.0.8.1-2
  58. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  59. * Sun Jun 20 2010 Terje Rosten <terje.rosten@ntnu.no> - 1:3.0.8.1-1
  60. - 3.0.8.1
  61. * Sun Dec 6 2009 Terje Rosten <terje.rosten@ntnu.no> - 1:3.0.8-1
  62. - 3.0.8
  63. - Fix source url
  64. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.0.7a-2
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  66. * Wed Jun 10 2009 kwizart < kwizart at gmail.com > - 1:3.0.7a-1
  67. - Revert to 3.0.7a and bump Epoch - Fix #505043
  68. http://www.crummy.com/software/BeautifulSoup/3.1-problems.html
  69. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.0.1-3
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  71. * Mon Jan 12 2009 kwizart < kwizart at gmail.com > - 3.1.0.1-2
  72. - Fix installed files.
  73. * Mon Jan 12 2009 kwizart < kwizart at gmail.com > - 3.1.0.1-1
  74. - Update to 3.1.0.1
  75. * Thu Dec 4 2008 kwizart < kwizart at gmail.com > - 3.0.7a-3
  76. - ReTag
  77. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.0.7a-2
  78. - Rebuild for Python 2.6
  79. * Wed Oct 15 2008 kwizart < kwizart at gmail.com > - 3.0.7a-1
  80. - Update to 3.0.7a
  81. * Mon Jun 30 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.7-2
  82. - Rebuild
  83. * Mon Jun 23 2008 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.0.7-1
  84. - Update to 3.0.7
  85. * Tue Feb 5 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.5-3
  86. - Fix typo
  87. * Tue Feb 5 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.5-2
  88. - Handle egg info
  89. - Bump release
  90. * Tue Feb 5 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.5-1
  91. - Update to 3.0.5
  92. - Minor tweaks to spec file
  93. * Wed Apr 18 2007 kwizart < kwizart at gmail.com > - 3.0.4-1
  94. - Update to 3.0.4
  95. * Wed Nov 29 2006 TC Wan <tcwan@cs.usm.my>
  96. - Initial SPEC file for Fedora Core 5