nspr-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Netscape Portable Runtime
  3. Summary(ja): Netscape ポータブルランタイム
  4. Name: nspr
  5. Version: 4.35
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: MPLv2.0
  12. URL: http://www.mozilla.org/projects/nspr/
  13. Source0: https://archive.mozilla.org/pub/nspr/releases/v%{version}/src/%{name}-%{version}.tar.gz
  14. Patch1: nspr-config-pc.patch
  15. Patch2: nspr-gcc-atomics.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Provides: mozilla-nspr
  18. Obsoletes: mozilla-nspr
  19. %description
  20. NSPR provides platform independence for non-GUI operating system
  21. facilities. These facilities include threads, thread synchronization,
  22. normal file and network I/O, interval timing and calendar time, basic
  23. memory management (malloc and free) and shared library linking.
  24. %package devel
  25. Summary: Development libraries for the Netscape Portable Runtime
  26. Group: programming
  27. Requires: nspr = %{version}-%{release}
  28. Requires: pkgconfig
  29. Provides: mozilla-nspr-devel
  30. Obsoletes: mozilla-nspr-devel
  31. %description devel
  32. Header files for doing development with the Netscape Portable Runtime.
  33. ## to build compat32 for x86_64 architecture support
  34. %package -n compat32-%{name}
  35. Summary: Netscape Portable Runtime
  36. Group: system,legacy
  37. %description -n compat32-%{name}
  38. NSPR provides platform independence for non-GUI operating system
  39. facilities. These facilities include threads, thread synchronization,
  40. normal file and network I/O, interval timing and calendar time, basic
  41. memory management (malloc and free) and shared library linking.
  42. %debug_package
  43. %prep
  44. %setup -q
  45. # Original nspr-config is not suitable for our distribution,
  46. # because on different platforms it contains different dynamic content.
  47. # Therefore we produce an adjusted copy of nspr-config that will be
  48. # identical on all platforms.
  49. # However, we need to use original nspr-config to produce some variables
  50. # that go into nspr.pc for pkg-config.
  51. cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
  52. %patch1 -p0
  53. pushd nspr
  54. %patch2 -p1
  55. popd
  56. %build
  57. %define _configure ./nspr/configure
  58. %configure \
  59. --prefix=%{_prefix} \
  60. --libdir=%{_libdir} \
  61. --includedir=%{_includedir}/nspr4 \
  62. %ifarch x86_64 ppc64 ia64 s390x
  63. --enable-64bit \
  64. %endif
  65. --enable-optimize="$RPM_OPT_FLAGS" \
  66. --disable-debug
  67. make
  68. %install
  69. %{__rm} -Rf $RPM_BUILD_ROOT
  70. DESTDIR=$RPM_BUILD_ROOT \
  71. make install
  72. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  73. NSPR_LIBS=`./config/nspr-config --libs`
  74. NSPR_CFLAGS=`./config/nspr-config --cflags`
  75. NSPR_VERSION=`./config/nspr-config --version`
  76. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  77. # Get rid of the things we don't want installed (per upstream)
  78. %{__rm} -rf \
  79. $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
  80. $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
  81. $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
  82. $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
  83. $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
  84. $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
  85. $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
  86. %clean
  87. %{__rm} -rf $RPM_BUILD_ROOT
  88. %files
  89. %defattr(-,root,root)
  90. %{_libdir}/libnspr4.so
  91. %{_libdir}/libplc4.so
  92. %{_libdir}/libplds4.so
  93. %files devel
  94. %defattr(-, root, root)
  95. %{_includedir}/nspr4
  96. %{_libdir}/pkgconfig/nspr.pc
  97. %{_bindir}/nspr-config
  98. %if %{build_compat32}
  99. %files -n compat32-%{name}
  100. %defattr(-,root,root)
  101. %{_libdir}/*.so
  102. %endif
  103. %changelog
  104. * Mon Oct 30 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.35-2
  105. - rebuilt with current environment.
  106. * Sun Nov 20 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.35-1
  107. - update to 4.35.
  108. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.32-1
  109. - update to 4.32.
  110. * Fri Jun 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.31-1
  111. - update to 4.31.
  112. - dropped ldconfig scriptlets.
  113. * Fri Oct 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.29-1
  114. - update to 4.29.
  115. * Sun Apr 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.25-1
  116. - update to 4.25.
  117. * Fri Sep 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.22-1
  118. - update to 4.22.
  119. * Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20-1
  120. - update to 4.20.
  121. - dropped Patch2.
  122. * Sat Oct 07 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.13.1-1
  123. - update to 4.13.1.
  124. * Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11-1
  125. - update to 4.11
  126. * Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.10.6-1
  127. - update to 4.10.6
  128. * Thu Oct 17 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.10.1-1
  129. - update to 4.10.1
  130. * Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.6-1
  131. - update to 4.9.6
  132. * Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.4-1
  133. - update to 4.9.4
  134. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.2
  135. - new upstream release
  136. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9-1
  137. - new upstram release
  138. - update Patch1 (nspr-config-pc.patch)
  139. * Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.9-1
  140. - new upstram release
  141. * Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.8-1
  142. - new upstream release
  143. * Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
  144. - new upstream release
  145. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
  146. - rebuild with rpm-4.8.1 for pkg-config file
  147. * Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
  148. - new upstream release
  149. * Wed Apr 7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
  150. - new upstream release
  151. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
  152. - new upstream release
  153. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
  154. - added compat32 subpackages
  155. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
  156. - new upstream release
  157. * Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
  158. - new upstream release
  159. * Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
  160. - new upstream release
  161. * Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
  162. - new upstream release
  163. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
  164. - initial build for Vine Linux
  165. * Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
  166. - Update to 4.6.6
  167. - Adjust IPv6 patch to latest upstream version
  168. * Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
  169. - Update to latest ipv6 upstream patch
  170. - Add upstream patch to fix a thread cleanup issue
  171. - Now requires pkgconfig
  172. * Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
  173. - Update to 4.6.5
  174. * Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
  175. - Include upstream patch to fix ipv6 support (rhbz 222554)
  176. * Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
  177. - Update to 4.6.4
  178. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
  179. - Update to 4.6.3
  180. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
  181. - rebuild
  182. * Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
  183. - Update to 4.6.2
  184. - Tweak nspr-config to be identical on all platforms.
  185. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
  186. - bump again for double-long bug on ppc(64)
  187. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
  188. - rebuilt for new gcc4.1 snapshot and glibc changes
  189. * Thu Jan 5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
  190. - Do not use -ansi when compiling, because of a compilation
  191. problem with latest glibc and anonymous unions.
  192. See also bugzilla.mozilla.org # 322427.
  193. * Wed Jan 4 2006 Kai Engert <kengert@redhat.com>
  194. - Add an upstream patch to fix gcc visibility issues.
  195. * Tue Jan 3 2006 Christopher Aillon <caillon@redhat.com>
  196. - Stop shipping static libraries; NSS and dependencies no longer
  197. require static libraries to build.
  198. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
  199. - Update to 4.6.1
  200. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  201. - rebuilt
  202. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
  203. - Use the NSPR version numbering scheme reported by NSPR,
  204. which unfortunately is not exactly the same as the real
  205. version (4.6 != 4.6.0 according to RPM and pkgconfig).
  206. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
  207. - Correct the CFLAGS reported by pkgconfig
  208. * Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
  209. - Temporarily include the static libraries allowing nss and
  210. its dependencies to build.
  211. * Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
  212. - Update to NSPR 4.6
  213. * Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
  214. - NSPR doesn't have make install, but it has make real_install. Use it.
  215. * Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
  216. - Let's make an RPM.