yajl-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. Name: yajl
  2. Summary: Yet Another JSON Library (YAJL)
  3. Version: 1.0.12
  4. Release: 2%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: BSD
  7. URL: http://lloyd.github.com/yajl/
  8. #
  9. # NB, upstream does not provide pre-built tar.gz downloads. Instead
  10. # they make you use the 'on the fly' generated tar.gz from GITHub's
  11. # web interface
  12. #
  13. # The Source0 for any version is obtained by a URL
  14. #
  15. # http://github.com/lloyd/yajl/tarball/1.0.7
  16. #
  17. # Which causes a download of a archive named after
  18. # the GIT hash corresponding to the version tag
  19. #
  20. # eg lloyd-yajl-45a1bdb.tar.gz
  21. #
  22. # NB even though the tar.gz is generated on the fly by GITHub it
  23. # will always have identical md5sum
  24. #
  25. # So for new versions, update 'githash' to match the hash of the
  26. # GIT tag associated with updated 'Version:' field just above
  27. %global githash 17b1790
  28. Source0: lloyd-%{name}-%{version}-0-g%{githash}.tar.gz
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. BuildRequires: cmake
  31. %description
  32. Yet Another JSON Library. YAJL is a small event-driven
  33. (SAX-style) JSON parser written in ANSI C, and a small
  34. validating JSON generator.
  35. %package devel
  36. Summary: Libraries, includes, etc to develop with YAJL
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description devel
  40. Yet Another JSON Library. YAJL is a small event-driven
  41. (SAX-style) JSON parser written in ANSI C, and a small
  42. validating JSON generator.
  43. This sub-package provides the libraries and includes
  44. necessary for developing against the YAJL library
  45. %prep
  46. %setup -q -n lloyd-%{name}-%{githash}
  47. %build
  48. # NB, we are not using upstream's 'configure'/'make'
  49. # wrapper, instead we use cmake directly to better
  50. # align with Fedora standards
  51. mkdir build
  52. cd build
  53. %cmake ..
  54. make VERBOSE=1 %{?_smp_mflags}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. cd build
  58. make install DESTDIR=$RPM_BUILD_ROOT
  59. # No static libraries
  60. rm -f $RPM_BUILD_ROOT%{_libdir}/libyajl_s.a
  61. %check
  62. cd test
  63. ./run_tests.sh
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files
  69. %defattr(-,root,root,-)
  70. %doc COPYING ChangeLog README TODO
  71. %{_bindir}/json_reformat
  72. %{_bindir}/json_verify
  73. %{_libdir}/libyajl.so.1
  74. %{_libdir}/libyajl.so.1.*
  75. %files devel
  76. %defattr(-,root,root,-)
  77. %doc COPYING
  78. %dir %{_includedir}/yajl
  79. %{_includedir}/yajl/yajl_common.h
  80. %{_includedir}/yajl/yajl_gen.h
  81. %{_includedir}/yajl/yajl_parse.h
  82. %{_includedir}/yajl/yajl_version.h
  83. %{_libdir}/libyajl.so
  84. %changelog
  85. * Thu Aug 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.12-2
  86. - Initial build for Vine Linux
  87. * Tue May 3 2011 Daniel P. Berrange <berrange@redhat.com> - 1.0.12-1
  88. - Update to 1.0.12 release
  89. * Fri Dec 17 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.11-1
  90. - Update to 1.0.11 release
  91. * Mon Jan 11 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-3
  92. - Fix ignoring of cflags (rhbz #547500)
  93. * Tue Dec 8 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-2
  94. - Change use of 'define' to 'global'
  95. * Mon Dec 7 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-1
  96. - Initial Fedora package