mariadb-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797
  1. %define mysqld_user mysql
  2. %define mysqld_group mysql
  3. %define mysqldatadir /var/lib/mysql
  4. # Working around perl dependency problem
  5. %global __perl_requires %{SOURCE998}
  6. %global __perllib_requires %{SOURCE998}
  7. %define _unpackaged_files_terminate_build 1
  8. %define mariadb_base_version 10.0
  9. %define mariadb_version 10.0.14
  10. %define client_version 18
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop
  14. Name: mariadb
  15. Summary: MariaDB: a very fast and robust SQL database server
  16. Version: %{mariadb_version}
  17. Release: 1%{_dist_release}
  18. Group: Applications/Databases
  19. License: GPL2
  20. URL: http://www.mariadb.org/
  21. Source: mariadb-%{version}.tar.gz
  22. # Don't depend on lib::mtr*
  23. Source998: perl-requires.sh
  24. Source1000: macros.mariadb.in
  25. Patch0: mysql-5.5.15-jp-all.patch
  26. Patch100: mysql-srv_buf_size.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: bison, cmake, gcc-c++, groff
  29. BuildRequires: libaio-devel, libboost-devel, libevent-devel, libxml2-devel
  30. BuildRequires: ncurses-devel, perl, openssl-devel, readline-devel
  31. BuildRequires: zlib-devel
  32. Requires: fileutils sh-utils
  33. Provides: msqlormysql MySQL mysql
  34. Obsoletes: mysql MySQL5
  35. # From the manual
  36. %description
  37. MariaDB: a very fast and robust SQL database server
  38. It is GPL v2 licensed, which means you can use the it free of charge under the
  39. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  40. MariaDB documentation can be found at http://kb.askmonty.org/
  41. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  42. %package server
  43. Release: %{release}
  44. Summary: MariaDB: a very fast and robust SQL database server
  45. Group: Applications/Databases
  46. Requires: fileutils sh-utils net-tools mariadb-common
  47. Requires(post): mariadb-common
  48. Provides: mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
  49. Obsoletes: MySQL mysql mysql-server
  50. Obsoletes: MySQL-server < 5.6.0
  51. %description server
  52. MariaDB: a very fast and robust SQL database server
  53. It is GPL v2 licensed, which means you can use the it free of charge under the
  54. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  55. MariaDB documentation can be found at http://kb.askmonty.org/
  56. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  57. %package client
  58. Summary: MariaDB - Client
  59. Group: Applications/Databases
  60. Obsoletes: mysql-client MySQL-client < 5.6.0
  61. Provides: mysql-client MySQL-client mariadbclient-%{mariadb_base_version}
  62. %description client
  63. This package contains the standard MariaDB clients and administration tools.
  64. %package devel
  65. Summary: MariaDB - Development libraries and headers
  66. Group: Development/Libraries
  67. Requires: %{name}-static, openssl-devel, zlib-devel
  68. Conflicts: MySQL-devel < 5.6.0
  69. Conflicts: libmysqlclient-devel
  70. %description devel
  71. This package contains the development libraries and headers to develop
  72. MariaDB server components (e.g. plugins or embedded applications).
  73. %package static
  74. Summary: MariaDB - static libraries
  75. Group: Development/Libraries
  76. Requires: %{name}-devel
  77. %description static
  78. This package provides static libraries of MariaDB.
  79. %package source
  80. Summary: MariaDB - Source
  81. Group: Development/Libraries
  82. Requires: mariadb-devel = %{version}-%{release}
  83. Obsoletes: MySQL-source < 5.6.0
  84. AutoReqProv: no
  85. %description source
  86. This package contains the sources files of MariaDB.
  87. %package test
  88. Requires: %{name}-client = %{version}-%{release} perl-DBI perl
  89. Summary: MariaDB - Test suite
  90. Group: Applications/Databases
  91. Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
  92. Provides: perl(mtr_misc.pl)
  93. %description test
  94. This package contains the MariaDB regression test suite.
  95. %package embedded
  96. Summary: MariaDB as an embeddable library
  97. Group: System Environment/Libraries
  98. Obsoletes: mysql-embedded MySQL-embedded
  99. Provides: mysql-embedded MySQL-embedded
  100. %description embedded
  101. This package contains a version of the MariaDB server that can be embedded
  102. into a client application instead of running as a separate process.
  103. %prep
  104. %setup -q
  105. #%patch0 -p1 -b .jp
  106. %patch100 -p1 -b .srv_buf_size
  107. %build
  108. # Be strict about variables, bail at earliest opportunity, etc.
  109. set -eu
  110. # Optional package files
  111. touch optional-files-devel
  112. export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
  113. export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
  114. # Build full release
  115. mkdir release
  116. (
  117. cd release
  118. cmake ../ \
  119. -DINSTALL_LAYOUT=RPM \
  120. -DBUILD_CONFIG=mysql_release \
  121. -DCMAKE_BUILD_TYPE=Release \
  122. -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
  123. -DMANUFACTURER="Vine Linux" \
  124. -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
  125. -DWITH_PIC="ON" \
  126. -DWITH_EMBEDDED_SERVER="ON" \
  127. -DWITH_ZLIB="system" \
  128. -DWITH_LIBEVENT="system" \
  129. -DWITH_LOCALES="yes" \
  130. -DWITH_UNIT_TESTS="no" \
  131. -DWITH_CONNECT_STORAGE_ENGINE="ON" \
  132. -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
  133. -DWITH_XTRADB_STORAGE_ENGINE="ON" \
  134. -DWITHOUT_TOKUDB=1 \
  135. -DWITH_JEMALLOC="no"
  136. # -DWITH_PCRE="system"
  137. echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
  138. make %{?_smp_mflags} VERBOSE=1
  139. )
  140. %install
  141. rm -rf %{buildroot}
  142. install -d %{buildroot}%{mysqldatadir}/mysql
  143. install -d %{buildroot}%{_infodir}
  144. # Install all binaries
  145. (
  146. cd release
  147. make DESTDIR=%{buildroot} install
  148. )
  149. install -m 0644 Docs/mysql.info %{buildroot}%{_infodir}
  150. rm -rf ./doc
  151. mv -f %{buildroot}%{_docdir} ./
  152. mkdir -p %{buildroot}%{_datadir}/%{name}-source
  153. pushd %{buildroot}%{_datadir}/%{name}-source
  154. tar zxf %{SOURCE0}
  155. find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
  156. popd
  157. install -d %{buildroot}%{_sysconfdir}/rpm
  158. sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
  159. rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
  160. rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
  161. rm -f %{buildroot}%{_sysconfdir}/my.cnf
  162. rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
  163. rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
  164. rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
  165. # force linking statically.
  166. perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
  167. perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
  168. ##############################################################################
  169. %pre server
  170. # Create a MySQL user and group. Do not report any problems if it already
  171. # exists.
  172. datadir=/var/lib/mysql
  173. groupadd -r mysql 2> /dev/null || true
  174. useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
  175. # The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
  176. usermod -g mysql mysql 2> /dev/null || true
  177. %post server
  178. # Make MySQL start/shutdown automatically when the machine does it.
  179. if [ $1 = 1 ] ; then
  180. if [ -x /sbin/chkconfig ] ; then
  181. /sbin/chkconfig --add mysql
  182. fi
  183. basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
  184. if [ -z "$basedir" ] ; then
  185. basedir=/usr
  186. fi
  187. datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
  188. if [ -z "$datadir" ] ; then
  189. datadir=/var/lib/mysql
  190. else
  191. # datadir may be relative to a basedir!
  192. if ! expr $datadir : / > /dev/null; then
  193. datadir=$basedir/$datadir
  194. fi
  195. fi
  196. # Change permissions so that the user that will run the MySQL daemon
  197. # owns all database files.
  198. chown -R mysql:mysql $datadir
  199. if [ ! -e $datadir/mysql ]; then
  200. # Create data directory
  201. mkdir -p $datadir/{mysql,test}
  202. # Initiate databases
  203. /usr/bin/mysql_install_db --rpm --user=mysql
  204. fi
  205. # Change permissions again to fix any new files.
  206. chown -R mysql:mysql $datadir
  207. # Fix permissions for the permission database so that only the user
  208. # can read them.
  209. chmod -R og-rw $datadir/mysql
  210. fi
  211. %preun server
  212. if [ $1 = 0 ] ; then
  213. # Stop MySQL before uninstalling it
  214. if [ -x /etc/init.d/mysql ] ; then
  215. /etc/init.d/mysql stop > /dev/null
  216. fi
  217. # Don't start it automatically anymore
  218. if [ -x /sbin/chkconfig ] ; then
  219. /sbin/chkconfig --del mysql
  220. fi
  221. fi
  222. %postun server
  223. if [ $1 -ge 1 ]; then
  224. if [ -x /etc/init.d/mysql ] ; then
  225. # only restart the server if it was alredy running
  226. /etc/init.d/mysql status > /dev/null 2>&1 && \
  227. /etc/init.d/mysql restart
  228. fi
  229. fi
  230. # Clean up the BuildRoot
  231. %clean
  232. [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
  233. %files server
  234. %defattr(-,root,root)
  235. %doc doc/*
  236. %doc release/support-files/my-*.cnf
  237. %doc %{_infodir}/mysql.info*
  238. %doc %{_mandir}/man1/aria_*.1*
  239. %doc %{_mandir}/man1/innochecksum.1*
  240. %doc %{_mandir}/man1/my_print_defaults.1*
  241. %doc %{_mandir}/man1/myisam_ftdump.1*
  242. %doc %{_mandir}/man1/myisamchk.1*
  243. %doc %{_mandir}/man1/myisamlog.1*
  244. %doc %{_mandir}/man1/myisampack.1*
  245. %doc %{_mandir}/man1/mysql_convert_table_format.1*
  246. %doc %{_mandir}/man1/mysql_fix_extensions.1*
  247. %doc %{_mandir}/man8/mysqld.8*
  248. %doc %{_mandir}/man1/mysqld_multi.1*
  249. %doc %{_mandir}/man1/mysqld_safe.1*
  250. %doc %{_mandir}/man1/mysqldumpslow.1*
  251. %doc %{_mandir}/man1/mysql_install_db.1*
  252. %doc %{_mandir}/man1/mysql_plugin.1*
  253. %doc %{_mandir}/man1/mysql_secure_installation.1*
  254. %doc %{_mandir}/man1/mysql_setpermission.1*
  255. %doc %{_mandir}/man1/mysql_upgrade.1*
  256. %doc %{_mandir}/man1/mysqlhotcopy.1*
  257. %doc %{_mandir}/man1/mysql.server.1*
  258. %doc %{_mandir}/man1/mysqltest.1*
  259. %doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
  260. %doc %{_mandir}/man1/mysql_zap.1*
  261. %doc %{_mandir}/man1/mysqlbug.1*
  262. %doc %{_mandir}/man1/perror.1*
  263. %doc %{_mandir}/man1/replace.1*
  264. %doc %{_mandir}/man1/resolve_stack_dump.1*
  265. %doc %{_mandir}/man1/resolveip.1*
  266. %{_bindir}/aria_*
  267. %{_bindir}/innochecksum
  268. %{_bindir}/my_print_defaults
  269. %{_bindir}/myisam_ftdump
  270. %{_bindir}/myisamchk
  271. %{_bindir}/myisamlog
  272. %{_bindir}/myisampack
  273. %{_bindir}/mysql_convert_table_format
  274. %{_bindir}/mysql_fix_extensions
  275. %{_bindir}/mysql_install_db
  276. %{_bindir}/mysql_plugin
  277. %{_bindir}/mysql_secure_installation
  278. %{_bindir}/mysql_setpermission
  279. %{_bindir}/mysql_tzinfo_to_sql
  280. %{_bindir}/mysql_upgrade
  281. %{_bindir}/mysql_zap
  282. %{_bindir}/mysqlbug
  283. %{_bindir}/mysqld_multi
  284. %{_bindir}/mysqld_safe
  285. %{_bindir}/mysqldumpslow
  286. %{_bindir}/mysqlhotcopy
  287. %{_bindir}/mysqltest
  288. %{_bindir}/perror
  289. %{_bindir}/replace
  290. %{_bindir}/resolve_stack_dump
  291. %{_bindir}/resolveip
  292. #%{_bindir}/tokuftdump
  293. %{_sbindir}/mysqld
  294. %{_libdir}/mysql
  295. %config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
  296. #%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
  297. %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
  298. %{_sysconfdir}/init.d/mysql
  299. %{_datadir}/mysql
  300. %attr(755, mysql, mysql) %dir %{mysqldatadir}
  301. %files client
  302. %defattr(-, root, root)
  303. %config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
  304. %{_bindir}/msql2mysql
  305. %{_bindir}/mysql
  306. %{_bindir}/mysql_find_rows
  307. %{_bindir}/mysql_waitpid
  308. %{_bindir}/mysqlaccess
  309. %{_bindir}/mysqladmin
  310. %{_bindir}/mysqlbinlog
  311. %{_bindir}/mysqlcheck
  312. %{_bindir}/mysqldump
  313. %{_bindir}/mysqlimport
  314. %{_bindir}/mysqlshow
  315. %{_bindir}/mysqlslap
  316. %{_bindir}/mytop
  317. %doc %{_mandir}/man1/msql2mysql.1*
  318. %doc %{_mandir}/man1/mysql.1*
  319. %doc %{_mandir}/man1/mysql_find_rows.1*
  320. %doc %{_mandir}/man1/mysql_waitpid.1*
  321. %doc %{_mandir}/man1/mysqlaccess.1*
  322. %doc %{_mandir}/man1/mysqladmin.1*
  323. %doc %{_mandir}/man1/mysqlbinlog.1*
  324. %doc %{_mandir}/man1/mysqlcheck.1*
  325. %doc %{_mandir}/man1/mysqldump.1*
  326. %doc %{_mandir}/man1/mysqlimport.1*
  327. %doc %{_mandir}/man1/mysqlshow.1*
  328. %doc %{_mandir}/man1/mysqlslap.1*
  329. %files devel -f optional-files-devel
  330. %defattr(-, root, root)
  331. %doc %{_mandir}/man1/mysql_config.1*
  332. %{_bindir}/mysql_config
  333. %{_includedir}/mysql
  334. %{_datadir}/aclocal/mysql.m4
  335. %{_libdir}/*.so
  336. %{_sysconfdir}/rpm/*
  337. %{_bindir}/mysql_embedded
  338. %files static
  339. %defattr(-,root,root)
  340. %{_libdir}/lib*.a
  341. %files source
  342. %defattr(-, root, root)
  343. %{_datadir}/mariadb-source
  344. %files test
  345. %defattr(-, root, root)
  346. %attr(-, root, root) %{_datadir}/mysql-test
  347. %{_bindir}/mysql_client_test
  348. %{_bindir}/mysql_client_test_embedded
  349. %{_bindir}/mysqltest_embedded
  350. %doc %{_mandir}/man1/mysql_client_test.1*
  351. %doc %{_mandir}/man1/mysql-stress-test.pl.1*
  352. %doc %{_mandir}/man1/mysql-test-run.pl.1*
  353. %doc %{_mandir}/man1/mysql_client_test_embedded.1*
  354. %doc %{_mandir}/man1/mysqltest_embedded.1*
  355. %files embedded
  356. %defattr(-,root,root)
  357. %{_libdir}/libmysqld.so.*
  358. %changelog
  359. * Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
  360. - new upstream release.
  361. * Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
  362. - new upstream release.
  363. * Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
  364. - fixed Conflicts: and Obsoletes:.
  365. * Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
  366. - new upstream release.
  367. * Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
  368. - new upstream release.
  369. * Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
  370. - new upstream release.
  371. * Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
  372. - removed duplicated files.
  373. * Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
  374. - switched to MariaDB.
  375. * Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
  376. - new upstream release.
  377. * Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
  378. - new upstream release.
  379. * Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
  380. - new upstream release.
  381. - added a sub-package 'MySQL-source".
  382. - added some macros for rpm.
  383. * Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
  384. - new upstream release.
  385. * Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
  386. - new upstream release.
  387. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
  388. - new upstream release.
  389. - added "Vendor:" and "Distribution:" tag.
  390. * Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
  391. - new upstream release.
  392. - removed NDB cluster support.
  393. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
  394. - Added "BR: zlib-devel" to MySQL-devel.
  395. * Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
  396. - Added "BR: openssl-devel" to MySQL-devel.
  397. * Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
  398. - new upstream release.
  399. * Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
  400. - new upstream release.
  401. - updated jp-patch.
  402. - added ssl support.
  403. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
  404. - new upstream release.
  405. - replaced '%%__find_requires' to '%%__perl_requires'.
  406. - updated jp-patch.
  407. * Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
  408. - added mysql-5.1.44-lib64.patch (on x86_64)
  409. - added -fPIC (on x86_64)
  410. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
  411. - made embedded package again
  412. * Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
  413. - new upstream release.
  414. - updated jp-patch.
  415. * Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
  416. - VineSeed: rebuilt with new toolchain.
  417. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
  418. - new upstream release.
  419. - fixed CVE-2009-4484.
  420. * Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
  421. - new upstream release.
  422. * Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
  423. - added net-tools to 'Requires'.
  424. - added groff to 'BuildRequires'.
  425. - renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
  426. * Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
  427. - new upstream release.
  428. * Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
  429. - new upstream release.
  430. * Sun Jul 5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
  431. - new upstream release.
  432. - dropped %%Patch100 (fixed in upstream).
  433. * Sat Jun 6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
  434. - new upstream release.
  435. - add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
  436. * Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
  437. - new upstream release.
  438. - rename 'MySQL-bench' to 'MySQL-test'.
  439. - update Patch0.
  440. - change default charset to 'utf8'.
  441. * Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
  442. - new upstream release.
  443. - update Patch0.
  444. - add "--with-client-charset=ujis".
  445. - sync %%files to official RPM.
  446. - remove MySQL-Max.
  447. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
  448. - for VineSeed
  449. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
  450. - move shared library from /usr/lib/ to /usr/lib/mysql/
  451. - add /etc/ld.so.conf.d/*.conf
  452. - fix broken libmysqlcient*.la files (or should we remove them permanently?)
  453. * Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
  454. - rebuild <BTS:VineLinux:534>
  455. * Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
  456. - added -fPIC
  457. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
  458. - fixed dependency. <BTS:338>
  459. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
  460. - add %%Patch1. <BTS:320>
  461. * Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
  462. - new upstream release.
  463. * Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
  464. - new upstream release.
  465. * Sat Jun 3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
  466. - new upstream release.
  467. * Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
  468. - release++.
  469. * Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
  470. - new upstream release.
  471. - for VineSeed.
  472. * Wed Feb 8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
  473. - new upstream release.
  474. - replace Patch0 for MySQL-4.1.16.
  475. * Thu Oct 6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
  476. - new upstream release.
  477. - add Patch0.
  478. * Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
  479. - new upstream version
  480. -- mysql-4.0.25
  481. * Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
  482. - new upstream version
  483. -- mysql-4.0.23
  484. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
  485. - new upstream version
  486. -- mysql-4.0.22
  487. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
  488. - new upstream version
  489. -- mysql-4.0.21
  490. * Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
  491. - new upstream version
  492. -- mysql-4.0.20
  493. * Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
  494. - modify CFLAGS, CXXFLAGS and configure options for alpha
  495. * Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
  496. - Upgraded to MySQL-4
  497. - added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
  498. - merged to MySQL Official packages
  499. -- renamed package "MySQL" to "MySQL-server"
  500. -- when using gcc, _always_ use CXX=gcc
  501. -- replaced Copyright with License field (Copyright is obsolete)
  502. -- added myisam_ftdump to the Server package
  503. -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
  504. -- fixed file permissions (BUG 1672)
  505. -- removed dependency on MySQL-client from the MySQL-devel subpackage
  506. -- as it is not really required. (BUG 1610)
  507. -- Fixed BUG 1162 (removed macro names from the changelog)
  508. -- Really fixed BUG 998 (disable the checking for installed but
  509. -- unpackaged files)
  510. -- Fixed BUG 959 (libmysqld not being compiled properly)
  511. -- Fixed BUG 998 (RPM build errors): added missing files to the
  512. -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
  513. -- mysql_fix_privilege_tables.1), removed "-n" from install section.
  514. -- removed the GIF Icon (file was not included in the sources anyway)
  515. -- removed unused variable shared_lib_version
  516. -- do not run automake before building the standard binary
  517. -- (should not be necessary)
  518. -- add server suffix '-standard' to standard binary (to be in line
  519. -- with the binary tarball distributions)
  520. -- allow overriding CC and CXX (required when building
  521. -- with other compilers)
  522. * Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
  523. - added BuildRequires: automake16
  524. * Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
  525. - add '-fPIC -DPIC' to CFLAGS on alpha
  526. - little fix of spec file
  527. * Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
  528. - enable MySQL-shared subpackage for alpha
  529. - delete 'BuildPrereq: kernel24-headers' for alpha
  530. - fix shared %files (exclude sparc)
  531. * Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
  532. - new upstream version
  533. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
  534. - fixed devel %files (dropped *.la files)
  535. * Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
  536. - new upstream version
  537. - fixed document permission
  538. * Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
  539. - new upstream version
  540. * Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
  541. - dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
  542. -- don't work
  543. * Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
  544. - new upstream version
  545. - diseble-assembler in configure on sparc,sparc64,alpha
  546. * Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
  547. - new upstream version
  548. - moved some man files to main package
  549. - added enable-local-infile in configure
  550. - changed --with-extra-charsets=all in configure
  551. * Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
  552. - fixed changelog
  553. * Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
  554. - updated to mysql-3.23.51
  555. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
  556. - rebuild on zlib-1.1.4(security fix.)
  557. * Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
  558. - updated to mysql-2.23.49
  559. * Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
  560. - add 'BuildPrereq: kernel24-headers' on alpha
  561. - remove shared library and max on alpha
  562. * Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
  563. - updated to mysql-3.23.48
  564. * Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
  565. - updated to mysql-3.23.47
  566. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
  567. - updated to mysql-3.23.46
  568. * Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
  569. - updated to mysql-3.23.45
  570. * Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
  571. - updated to mysql-3.23.44
  572. * Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
  573. - updated to mysql-3.23.43
  574. - removed shared library and max on sparc
  575. * Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
  576. - updated to mysql-3.23.42
  577. - changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
  578. * Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
  579. - updated to mysql-3.23.41
  580. * Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
  581. - updated to mysql-3.23.40
  582. * Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
  583. - updated to mysql-3.23.39
  584. * Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  585. - added configure --with-charset=ujis
  586. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  587. - used some rpmmacro
  588. * Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
  589. - updated to MySQL-3.23.38
  590. * Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
  591. - removed Bench pakages
  592. * Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
  593. - removed pt_BR locale
  594. - build on Vine Linux
  595. - partially used rpmmacros
  596. - added %clean tag
  597. * Fri Aug 18 2000 Tim Smith <tim@mysql.com>
  598. - Added separate libmysql_r directory; now both a threaded
  599. and non-threaded library is shipped.
  600. * Tue Sep 28 1999 David Axmark <davida@mysql.com>
  601. - Added the support-files/my-example.cnf to the docs directory.
  602. - Removed devel dependency on base since it is about client
  603. development.
  604. * Wed Sep 8 1999 David Axmark <davida@mysql.com>
  605. - Cleaned up some for 3.23.
  606. * Thu Jul 1 1999 David Axmark <davida@mysql.com>
  607. - Added support for shared libraries in a separate sub
  608. package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
  609. - The --enable-assembler switch is now automatically disables on
  610. platforms there assembler code is unavailable. This should allow
  611. building this RPM on non i386 systems.
  612. * Mon Feb 22 1999 David Axmark <david@detron.se>
  613. - Removed unportable cc switches from the spec file. The defaults can
  614. now be overridden with environment variables. This feature is used
  615. to compile the official RPM with optimal (but compiler version
  616. specific) switches.
  617. - Removed the repetitive description parts for the sub rpms. Maybe add
  618. again if RPM gets a multiline macro capability.
  619. - Added support for a pt_BR translation. Translation contributed by
  620. Jorge Godoy <jorge@bestway.com.br>.
  621. * Wed Nov 4 1998 David Axmark <david@detron.se>
  622. - A lot of changes in all the rpm and install scripts. This may even
  623. be a working RPM :-)
  624. * Sun Aug 16 1998 David Axmark <david@detron.se>
  625. - A developers changelog for MySQL is available in the source RPM. And
  626. there is a history of major user visible changed in the Reference
  627. Manual. Only RPM specific changes will be documented here.