audit0-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define sca_version 0.4.10
  3. %define sca_release 4
  4. Summary: User space tools for 2.6 kernel auditing
  5. Name: audit0
  6. Version: 1.7.18
  7. Release: 5%{?_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Daemons
  10. URL: http://people.redhat.com/sgrubb/audit/
  11. Source0: http://people.redhat.com/sgrubb/audit/audit-%{version}.tar.gz
  12. Source1: system-config-audit-ja.po
  13. Patch10: audit-1.7.18-pthread.patch
  14. Patch11: audit-1.7.18-krb5.patch
  15. Patch12: audit-1.7.18-libaudit.patch
  16. Patch100: audit-deprecated.patch
  17. Obsoletes: audit < 1.7.18-5vl7
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: gettext intltool libtool swig python-devel
  20. BuildRequires: openldap-devel tcp_wrappers
  21. BuildRequires: tcp_wrappers
  22. BuildRequires: krb5-devel
  23. BuildRequires: kernel-headers >= 2.6.18
  24. BuildRequires: automake >= 1.9
  25. BuildRequires: autoconf >= 2.59
  26. Requires: %{name}-libs = %{version}-%{release}
  27. Requires: chkconfig
  28. Requires(pre): coreutils
  29. %description
  30. The audit package contains the user space utilities for
  31. storing and searching the audit records generate by
  32. the audit subsystem in the Linux 2.6 kernel.
  33. %package libs
  34. Summary: Dynamic library for libaudit
  35. License: LGPLv2+
  36. Group: Development/Libraries
  37. Requires: audit-libs >= 2.7.7
  38. Obsoletes: audit-libs < 1.7.18-5vl7
  39. %description libs
  40. The audit-libs package contains the dynamic libraries needed for
  41. applications to use the audit framework.
  42. %package -n compat32-%{name}-libs
  43. Summary: Dynamic library for libaudit
  44. License: LGPLv2+
  45. Group: Development/Libraries
  46. Requires: compat32-audit-libs >= 2.7.7
  47. Obsoletes: compat32-%{name}-libs < 1.7.18-5vl7
  48. %description -n compat32-%{name}-libs
  49. The audit-libs package contains the dynamic libraries needed for
  50. applications to use the audit framework.
  51. %prep
  52. %setup -q -n audit-%{version}
  53. %patch10 -p1
  54. %patch11 -p1
  55. %patch12 -p1
  56. %patch100 -p1
  57. cp -f %{SOURCE1} system-config-audit/po/ja.po
  58. %build
  59. %configure --sbindir=/sbin --libdir=/%{_lib} --with-libwrap --enable-gssapi-krb5=yes
  60. make %{?_smp_mflags}
  61. %install
  62. rm -rf $RPM_BUILD_ROOT
  63. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d}}
  64. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  65. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  66. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  67. mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
  68. make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
  69. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  70. # This winds up in the wrong place when libtool is involved
  71. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  72. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  73. curdir=`pwd`
  74. cd $RPM_BUILD_ROOT/%{_libdir}
  75. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  76. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  77. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  78. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  79. cd $curdir
  80. # Remove these items so they don't get picked up.
  81. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  82. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  83. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.la
  84. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.la
  85. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.a
  86. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.la
  87. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.a
  88. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.la
  89. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.a
  90. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.la
  91. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  92. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  93. #% check
  94. #make check
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. rm -rf zos-remote-policy
  98. %post libs -p /sbin/ldconfig
  99. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  100. %postun libs -p /sbin/ldconfig
  101. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  102. %files libs
  103. %defattr(-,root,root)
  104. %attr(755,root,root) /%{_lib}/libaudit.*
  105. #%attr(755,root,root) /%{_lib}/libauparse.*
  106. #%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  107. #%files
  108. %if %{build_compat32}
  109. %files -n compat32-%{name}-libs
  110. %defattr(-,root,root)
  111. %attr(755,root,root) /%{_lib}/libaudit.*
  112. #%attr(755,root,root) /%{_lib}/libauparse.*
  113. %endif
  114. %changelog
  115. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.18-5
  116. - new package for compatibility.
  117. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
  118. - fix sca_release
  119. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
  120. - create compat32-audit-libs subpackage
  121. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
  122. - rebuild with python-2.7.2
  123. - add Patch12 (audit-1.7.18-libaudit.patch)
  124. * Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
  125. - new upstream release
  126. - rebuild with krb5-1.8.2
  127. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  128. - forgot to increment sca_release macro (why on earth is sca_release
  129. individually defined from main package's release number anyway?)
  130. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  131. - rebuilt with gcc-4.4.3-3 on ppc
  132. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  133. - rebuilt with rpm-4.8.0-3 (on ppc)
  134. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  135. - rebuild with python-2.6
  136. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  137. - rebuild with openldap-2.4.11
  138. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  139. - initial build for Vine Linux
  140. - disable krb5, prelude and selinux
  141. - add ja.po (XXX: minimal)
  142. * Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  143. - Add subject to audit daemon events (Chu Li)
  144. - Add tcp_wrappers support for auditd
  145. - Updated syscall tables for 2.6.27 kernel
  146. - Audit connect/disconnect of remote clients
  147. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  148. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  149. - Update system-config-audit to 0.4.8
  150. - Whole lot of bug fixes - see ChangeLog for details
  151. - Reimplement auditd main loop using libev
  152. - Add TCP listener to auditd to receive remote events
  153. - Fix scheduler problem (#457061)
  154. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  155. - Move ausearch-expression to main package (#453437)
  156. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  157. - Fix interpreting of keys in syscall records
  158. - Don't error on name=(null) PATH records in ausearch/report
  159. - Add key report to aureport
  160. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  161. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  162. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  163. - Fix output of keys in ausearch interpretted mode
  164. - Fix ausearch/report --start now to not be reset to midnight
  165. - audispd now has a priority boost config option
  166. - Look for laddr in avcs reported via prelude
  167. - Detect page 0 mmaps and alert via prelude
  168. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  169. - Fix overflow in audit_log_user_command, better (#438840)
  170. - ausearch was not matching path in avc records
  171. - audisp-prelude attempt to reposition index after examining each type
  172. - correct building of mls policy
  173. - Fix auparse iterating in auparse_find_field and next_field
  174. - Don't alert on USER_AVC's - they are not quite right
  175. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  176. - Fix buffer overflow in audit_log_user_command, again (#438840)
  177. - Fix memory leak in EOE code in auditd (#440075)
  178. - In auditctl, don't use new operators in legacy rule format
  179. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  180. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  181. - Fix memleak in auditd eoe code
  182. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  183. - Remove LSB headers from init scripts
  184. - Fix buffer overflow in audit_log_user_command again
  185. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  186. - Handle user space avcs in prelude plugin
  187. - Fix watched account login detection for some failed login attempts
  188. - Couple fixups in audit logging functions (Miloslav Trmac)
  189. - Add support in auditctl for virtual keys
  190. - auparse_find_field_next was not iterating correctly, fixed it
  191. - Add idmef alerts for access or execution of watched file
  192. - Fix buffer overflow in audit_log_user_command
  193. - Add basic remote logging plugin - only sends & no flow control
  194. - Update ausearch with interpret fixes from auparse
  195. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  196. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  197. - Apply auparse expression interface patch (Miloslav Trmac)
  198. - Fix potential memleak in audit event dispatcher
  199. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  200. - audisp-prelude alerts now controlled by config file
  201. - Updated syscall table for 2.6.25 kernel
  202. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  203. - Added watched account login detection for prelude plugin
  204. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  205. - Update for gcc 4.3
  206. - Cleanup descriptors in audispd before running plugin
  207. - Fix 'recent' keyword for aureport/search
  208. - Fix SE Linux policy for zos_remote plugin
  209. - Add event type for group password authentication attempts
  210. - Couple of updates to the translation tables
  211. - Add detection of failed group authentication to audisp-prelude
  212. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  213. - In ausearch/report, prefer -if to stdin
  214. - In ausearch/report, add new command line option --input-logs (#428860)
  215. - Updated audisp-prelude based on feedback from prelude-devel
  216. - Added prelude alert for promiscuous socket being opened
  217. - Added prelude alert for SE Linux policy enforcement changes
  218. - Added prelude alerts for Forbidden Login Locations and Time
  219. - Applied patch to auparse fixing error handling of searching by
  220. interpreted value (Miloslav Trmac)
  221. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  222. - Add prelude IDS plugin for IDMEF alerts
  223. - Add --user option to aulastlog command
  224. - Use desktop-file-install for system-config-audit
  225. - Avoid touching auditd.conf most of the time (#408501)
  226. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  227. - Updates for spec file review
  228. - Adjust permission on selinux policy file
  229. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  230. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  231. - Check for audit log being writable by owner in auditd
  232. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  233. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  234. - Added aulastlog utility
  235. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  236. - Allow 0600 file perms for audit logs
  237. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  238. - fchmod of log file was on wrong variable (#426934)
  239. - Allow use of errno strings for exit codes in audit rules
  240. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  241. - Don't fchmod() /dev/null to mode 0400 (#426934)
  242. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  243. - Add kernel release string to DEAMON_START events
  244. - Fix keep_logs when num_logs option disabled (#325561)
  245. - Fix auparse to handle node fields for syscall records
  246. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  247. - Add keyword week-ago to aureport & ausearch start/end times
  248. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  249. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  250. - Add event queue overflow action to audispd
  251. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  252. - Don't retry if the rt queue is full.
  253. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  254. - Add support for searching by posix regular expressions in auparse
  255. - Route DEAMON events into rt interface
  256. - If event pipe is full, try again after doing local logging
  257. - Optionally add node/machine name to records in audit daemon
  258. - Update ausearch/aureport to specify nodes to search on
  259. - Fix segfault interpretting saddr fields in avcs
  260. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  261. - Fix uninitialized variable in auparse (John Dennis)
  262. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  263. - External plugin support in place
  264. - Fix reference counting in auparse python bindings (#263961)
  265. - Moved default af_unix plugin socket to /var/run/audispd_events
  266. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  267. - Add newline to audispd string formatted events
  268. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  269. - spec file cleanups
  270. - Update to s-c-audit 0.4.3
  271. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  272. - Update Licence tags
  273. - Adding perm field should not set syscall added flag in auditctl
  274. - Fix segfault when aureport -if option is used
  275. - Fix auditctl to better check keys on rule lines
  276. - Add support for audit by TTY and other new event types
  277. - Auditd config option for group permission of audit logs
  278. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  279. - New audit event dispatcher
  280. - Update syscall tables for 2.6.23 kernel
  281. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  282. - Fix potential buffer overflow in print clone flags of auparse
  283. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  284. - Update auditctl to handle legacy kernels when putting a watch on a dir
  285. - Fix acct interpretation in auparse
  286. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  287. - Fix a double free when auditd receives SIGHUP
  288. - Move the system-config-audit menu entry to the Administration menu
  289. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  290. - Add system-config-audit (Miloslav Trmac)
  291. - Correct bug in audit_make_equivalent function (Al Viro)
  292. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  293. - Add feed interface to auparse library (John Dennis)
  294. - Apply patch to libauparse for unresolved symbols (#241178)
  295. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  296. - Change seresults to seresult in libauparse (John Dennis)
  297. - Add unit32_t definition to swig (#244210)
  298. - Add support for directory auditing
  299. - Update acct field to be escaped
  300. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  301. - Change buffer size to prevent truncation of DAEMON events with large labels
  302. - Fix memory leaks in auparse (John Dennis)
  303. - Update syscall tables for 2.6.21 kernel
  304. - Update capp & lspp rules
  305. - New python bindings for libauparse (John Dennis)
  306. * Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  307. - New event dispatcher (James Antill)
  308. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  309. - Apply patch correcting python libs permissions (Philipp Hahn)
  310. - Fix auditd segfault on reload
  311. - Fix bug in auparse library for file pointers and descriptors
  312. - Extract subject information out of daemon events for ausearch
  313. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  314. - Remove requires kernel-headers for python-libs
  315. - Apply patch to prevent segfaults on auditd reload
  316. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  317. - Updated autrace to monitor *at syscalls
  318. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  319. - Finish reworking auditd config parser
  320. - In auparse, interpret open, fcntl, and clone flags
  321. - In auparse, when interpreting execve record types, run args through unencode
  322. - Add support for OBJ_PID message type
  323. - Event dispatcher updates
  324. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  325. - rebuild
  326. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  327. - NEW audit dispatcher program & plugin framework
  328. - Correct hidden variables in libauparse
  329. - Added NISPOM sample rules
  330. - Verify accessibility of files passed in auparse_init
  331. - Fix bug in parser library interpreting socketcalls
  332. - Add support for stdio FILE pointer in auparse_init
  333. - Adjust init script to allow anyone to status auditd (#230626)
  334. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  335. - Add man pages
  336. - Reduce text relocations in parser library
  337. - Add -n option to auditd for no fork
  338. - Add exec option to space_left, admin_space_left, disk_full,
  339. and disk_error - eg EXEC /usr/local/script
  340. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  341. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  342. - Finished search options for audit parsing library
  343. - Fix ausearch -se to work correctly
  344. - Fix auditd init script for /usr on netdev (#228528)
  345. - Parse avc seperms better when there are more than one
  346. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  347. - New report about authentication attempts
  348. - Updates for python 2.5
  349. - update autrace to have resource usage mode
  350. - update auditctl to support immutable config
  351. - added audit_log_user_command function to libaudit api
  352. - interpret capabilities
  353. - added audit event parsing library
  354. - updates for 2.6.20 kernel
  355. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  356. - Make more adjustments for python 2.5
  357. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  358. - Fix a couple parsing problems (#217952)
  359. - Add tgkill to S390* syscall tables (#218484)
  360. - Fix error messages in ausearch/aureport
  361. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  362. - rebuild against python 2.5
  363. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  364. - Fix timestamp for libaudit.conf (#218053)
  365. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  366. - Fix minor parsing problem and add new msg types
  367. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  368. - ausearch & aureport implement uid/gid caching
  369. - In ausearch & aureport, extract addr when hostname is unknown
  370. - In ausearch & aureport, test audit log presence O_RDONLY
  371. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  372. - Added --add & --delete option to aureport
  373. - Update res parsing in config change events
  374. - Increase the size on audit daemon buffers
  375. - Parse avc_path records in ausearch/aureport
  376. - ausearch has new output mode, raw, for extracting events
  377. - ausearch/aureport can now read stdin
  378. - Rework AVC processing in ausearch/aureport
  379. - Added long options to ausearch and aureport
  380. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  381. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  382. - Fix some defines in libaudit.h
  383. - Some auditd config strings were not initialized in aureport (#211443)
  384. - Updated man pages
  385. - Add Netlabel event types to libaudit
  386. - Update aureports to current audit event types
  387. - Update autrace a little
  388. - Deprecated all the old audit_rule functions from public API
  389. - Drop auparse library for the moment
  390. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  391. - Add dist tag and bump version (#208532)
  392. - Make internal auditd buffers bigger for context info
  393. - Correct address resolving of hostname in logging functions
  394. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  395. - Only =, != operators for arch & inode fields in auditctl (#206427)
  396. - Updated audit message type table
  397. - Remove watches from aureport since FS_WATCH is deprecated
  398. - Add audit_log_avc back temporarily (#208152)