dev86-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. Summary: A real mode 80x86 assembler and linker
  2. Summary(ja): リアルモード 80x86 アセンブラとリンカ
  3. Name: dev86
  4. Version: 0.16.21
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Languages
  8. URL: https://github.com/lkundrak/dev86
  9. Source: %{name}-%{version}.tar.gz
  10. Patch0: dev86-noelks.patch
  11. Patch1: dev86-x86_64.patch
  12. Patch2: dev86-nostrip.patch
  13. Patch3: dev86-long.patch
  14. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Obsoletes: bin86
  16. BuildRequires: gawk
  17. %define __os_install_post /usr/lib/rpm/brp-compress /usr/lib/rpm/brp-strip %{__strip} /usr/lib/rpm/brp-strip-comment-note %{__strip} %{__objdump} %{nil}
  18. %description
  19. The dev86 package provides an assembler and linker for real mode 80x86
  20. instructions. You'll need to have this package installed in order to
  21. build programs that run in real mode, including LILO and the kernel's
  22. bootstrapping code, from their sources.
  23. You should install dev86 if you intend to build programs that run in real
  24. mode from their source code.
  25. %description -l ja
  26. dev86 パッケージは リアルモード 80x86 命令のアセンブラとリンカを提供
  27. します。LILO や kernel のブートストラップコードを含むリアルモードで
  28. 走るプログラムをソースから作成するときにはこのパッケージがインストー
  29. ルされている必要があります。
  30. リアルモードで走るプログラムをソースから作成するつもりなら dev86 を
  31. インストールしてください。
  32. %prep
  33. %setup -q
  34. %patch0 -p1 -b .noelks
  35. %ifarch x86_64
  36. %patch1 -p1 -b .x86_64
  37. %endif
  38. %patch2 -p1 -b .nostrip
  39. %patch3 -p1 -b .long
  40. %build
  41. make <<EOF
  42. 5
  43. quit
  44. EOF
  45. %install
  46. rm -rf ${RPM_BUILD_ROOT}
  47. make DIST=${RPM_BUILD_ROOT} \
  48. MANDIR=%{_mandir} \
  49. LIBDIR=%{_libdir}/bcc \
  50. INCLDIR=%{_libdir}/bcc \
  51. LOCALPREFIX=%{_prefix} \
  52. install install-man
  53. # preserve READMEs
  54. for i in bootblocks copt dis88 unproto bin86 ; do cp $i/README README.$i ; done
  55. cp bin86/README-0.4 README-0.4.bin86
  56. cp bin86/ChangeLog ChangeLog.bin86
  57. pushd ${RPM_BUILD_ROOT}%{_bindir}
  58. rm -f nm86 size86
  59. ln -s objdump86 nm86
  60. ln -s objdump86 size86
  61. popd
  62. %clean
  63. rm -rf ${RPM_BUILD_ROOT}
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc README MAGIC Contributors README.bootblocks README.copt README.dis88
  67. %doc README.unproto README-0.4.bin86 README.bin86 ChangeLog.bin86
  68. %dir %{_libdir}/bcc
  69. %{_bindir}/bcc
  70. %{_bindir}/ar86
  71. %{_bindir}/as86
  72. %{_bindir}/ld86
  73. %{_bindir}/objdump86
  74. %{_bindir}/nm86
  75. %{_bindir}/size86
  76. %{_libdir}/bcc/*
  77. %{_mandir}/man1/*
  78. %changelog
  79. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.21-1
  80. - update to 0.16.21
  81. - add Patch3 (dev86-long.patch) from fedora
  82. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 0.16.17-3
  83. - rebuilt with rpm-4.8.1-3
  84. * Tue Jan 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.16.17-2
  85. - remove ExclusiveArch to allow to run dev86 on different arches
  86. * Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.17-1vl5
  87. - applied new versioning policy, spec in utf-8
  88. * Tue Nov 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.17-0vl1
  89. - new upstream release
  90. * Sat Sep 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.3-9vl1
  91. - based on Rawhide 0.16.3-9
  92. * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 0.16.3-9
  93. - preserve README files with separate names
  94. * Fri Jan 31 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  95. - do not strip static archive to get rebuild working again
  96. * Sat Aug 10 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  97. - add ar86 to filelist
  98. * Wed Jun 19 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  99. - do not strip apps
  100. - rebuild with new toolchains
  101. - s/Copyright/License/
  102. * Sat Jul 14 2001 <sagami@vinelinux.org>
  103. - 0.15.5-1vl2: use %%{ix86} for ExclusiveArch instead of i386
  104. - enabled %%clean (why was it disabled?)
  105. * Sun May 27 2001 <sagami@vinelinux.org>
  106. - 0.15.5-1vl1: added Japanese summary and description
  107. * Mon May 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.15.5-1
  108. - Update to 0.15.5, lots of fixes
  109. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  110. - automatic rebuild
  111. * Mon Jun 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  112. - add defattr
  113. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  114. - use %%{_mandir}
  115. * Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
  116. - change default header directory to match libs and fix bug #9121
  117. * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
  118. - version 0.15.0
  119. - man pages are compressed
  120. * Mon Sep 20 1999 Donnie Barnes <djb@redhat.com>
  121. - removed "Distribution:" line (was RHCN)
  122. - changed description and summary to the ones from bin86 with s/bin/dev/
  123. done throughout
  124. - added patch to keep from installing in /usr/bcc and simply in /usr
  125. - moved include files to /usr/lib/bcc/include
  126. * Tue Sep 07 1999 Erik Troan <ewt@redhat.com>
  127. - updated to Dev86src
  128. - included in Red Hat 6.1
  129. * Sat Nov 14 1998 Simon Weijgers <simon@mbit.doa.org>
  130. - First release of this package to be shipped to rhcn.
  131. - To be fixed: Bug in Makefile which installs headerfiles
  132. double. E.g. /usr/bcc/include/arch is also installed under
  133. /usr/bcc/include/arch/arch. This doesn't hinder operation,
  134. just eats a tiny bit of diskspace.