docutils-vl.spec 2.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. %define name docutils
  2. %define version 0.5
  3. %define release 3%{?_dist_release}
  4. Summary: an open-source text processing system written in Python
  5. Summary(ja): Pythonで書かれたテキスト処理システム
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. Source0: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. License: public domain
  11. Group: Applications/Text
  12. URL: http://docutils.sourceforge.net/
  13. Requires: python
  14. BuildRequires: python-devel
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildArch: noarch
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Docutils is an open-source text processing system for processing
  21. plaintext documentation into useful formats, such as HTML or LaTeX.
  22. It includes reStructuredText, the easy to read, easy to use,
  23. what-you-see-is-what-you-get plaintext markup language.
  24. %description -l ja
  25. Docutilsはオープンソースのテキスト処理システムで、プレーンテキストの
  26. 文書をHTMLやLaTeXなどの使いやすいフォーマットに変換するものです。
  27. 読みやすく使いやすくWYSIWYGなプレーンテキストのマークアップ言語である
  28. reStructuresTextを含んでいます。
  29. %prep
  30. %setup -q
  31. %build
  32. %{__python} setup.py build
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. %{__python} setup.py install --root=${RPM_BUILD_ROOT}
  36. for file in %{buildroot}/%{_bindir}/*.py; do
  37. mv $file `dirname $file`/`basename $file .py`
  38. ln -sf `basename $file .py` `dirname $file`/`basename $file`
  39. done
  40. install -D -m644 extras/roman.py ${RPM_BUILD_ROOT}/%{python_sitelib}/roman.py
  41. %clean
  42. rm -rf $RPM_BUILD_ROOT
  43. %files
  44. %defattr(-,root,root)
  45. %doc BUGS.txt HISTORY.txt RELEASE-NOTES.txt docs COPYING.txt THANKS.txt FAQ.txt README.txt
  46. %{_bindir}/*
  47. %{python_sitelib}/%{name}/
  48. %{python_sitelib}/roman.*
  49. %{python_sitelib}/docutils-*.egg-info
  50. %changelog
  51. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.5-3
  52. - rebuilt with python-2.6.4
  53. * Thu Aug 6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5-2
  54. - rename /usr/bin/*.py to /usr/bin/*
  55. (keep symlinking to *.py for compatibility - should be removed in the future)
  56. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.5-1
  57. - updated docutils to 0.5
  58. - added BuildArch: noarch
  59. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
  60. - rebuilt with python-2.5.2
  61. - applied new versioning policy and spec in utf-8
  62. * Thu Jan 31 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-0vl4
  63. - defined python_sitelib by using distutils.sysconfig.get_python_lib()
  64. - updated module directory with platform-independent path
  65. - added script to install extras/roman.py (missing if it's already on the system)
  66. * Sun Sep 9 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.4-0vl2
  67. - initial build for Vine Linux