flac-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: flac
  3. Summary: FLAC - Free Lossless Audio Codec
  4. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  5. Version: 1.3.3
  6. Release: 1%{?_dist_release}
  7. Group: Applications/Multimedia
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. License: BSD and GPLv2+
  12. URL: https://xiph.org/flac/
  13. Source: https://github.com/xiph/flac/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. BuildRequires: libogg-devel
  15. BuildRequires: automake autoconf libtool gettext-devel
  16. %ifarch %ix86
  17. # 2.0 supports symbol visibility
  18. BuildRequires: nasm >= 2.0
  19. %endif
  20. %description
  21. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  22. similar to MP3, but lossless.
  23. The FLAC project consists of:
  24. * the stream format
  25. * libFLAC - reference encoders and decoders in library form
  26. * flac - a command-line program to encode and decode FLAC files
  27. * metaflac - a command-line metadata editor for FLAC files
  28. %description -l ja
  29. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  30. MP3 に似ていますが、音質が劣化しません。
  31. FLAC プロジェクトは以下により構成されています。
  32. * ストリーム形式
  33. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  34. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  35. プログラム。
  36. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  37. %package devel
  38. Summary: Development libraries and header files from FLAC
  39. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}
  42. Requires: pkgconfig
  43. %description devel
  44. This package contains all the files needed to develop applications that
  45. will use the Free Lossless Audio Codec (FLAC).
  46. %description -l ja devel
  47. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  48. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  49. # compat32
  50. %package -n compat32-%{name}
  51. Summary: FLAC - Free Lossless Audio Codec
  52. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  53. Group: System Environment/Libraries
  54. %description -n compat32-%{name}
  55. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  56. similar to MP3, but lossless.
  57. The FLAC project consists of:
  58. * the stream format
  59. * libFLAC - reference encoders and decoders in library form
  60. * flac - a command-line program to encode and decode FLAC files
  61. * metaflac - a command-line metadata editor for FLAC files
  62. %description -n compat32-%{name} -l ja
  63. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  64. MP3 に似ていますが、音質が劣化しません。
  65. FLAC プロジェクトは以下により構成されています。
  66. * ストリーム形式
  67. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  68. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  69. プログラム。
  70. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  71. %package -n compat32-%{name}-devel
  72. Summary: Development libraries and header files from FLAC
  73. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  74. Group: Development/Libraries
  75. Requires: %{name}-devel = %{version}-%{release}
  76. Requires: compat32-%{name} = %{version}-%{release}
  77. Requires: compat32-pkgconfig
  78. %description -n compat32-%{name}-devel
  79. This package contains all the files needed to develop applications that
  80. will use the Free Lossless Audio Codec (FLAC).
  81. %description -n compat32-%{name}-devel -l ja
  82. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  83. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  84. %prep
  85. %define srcver %{version}%{?extraver:-%extraver}
  86. %setup -q -n %{name}-%{srcver}
  87. %build
  88. ./autogen.sh -V
  89. %configure \
  90. --disable-static \
  91. --disable-xmms-plugin \
  92. %ifarch ppc
  93. --disable-asm-optimizations \
  94. %endif
  95. --disable-thorough-tests
  96. make %{?_smp_mflags}
  97. %install
  98. %__rm -rf %{buildroot}
  99. make install DESTDIR=%{buildroot}
  100. rm -rf ./htmldoc
  101. mv -f %{buildroot}%{_docdir}/flac ./htmldoc
  102. # remove unneeded files
  103. %{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
  104. %check
  105. make check
  106. %clean
  107. %__rm -rf %{buildroot}
  108. %post -p %{_syssbindir}/ldconfig
  109. %postun -p %{_syssbindir}/ldconfig
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %files
  113. %defattr(-,root,root)
  114. %license COPYING.*
  115. %doc AUTHORS README
  116. %{_bindir}/*
  117. %{_libdir}/*.so.*
  118. %{_mandir}/*/*
  119. %files devel
  120. %defattr(-,root,root)
  121. %license COPYING.*
  122. %doc doc/html
  123. %{_includedir}/*
  124. %{_libdir}/*.so
  125. %{_libdir}/pkgconfig/*.pc
  126. %{_datadir}/aclocal/*.m4
  127. # compat32
  128. %if %{build_compat32}
  129. %files -n compat32-%{name}
  130. %defattr(-,root,root)
  131. %license COPYING.*
  132. %doc AUTHORS README
  133. %{_libdir}/*.so.*
  134. %files -n compat32-%{name}-devel
  135. %defattr(-,root,root,-)
  136. %{_libdir}/*.so
  137. %endif
  138. %changelog
  139. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
  140. - new upstream release.
  141. * Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
  142. - new upstream release.
  143. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-3
  144. - rebuilt with new toolchain.
  145. * Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.1-2
  146. - added compat32 subpackages
  147. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
  148. - new upstream release
  149. - remove old patches
  150. * Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  151. - new upstream release
  152. - remove Patch1-6
  153. - add Patch1,2 from Fedora
  154. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
  155. - rebuilt with rpm-4.8.1 for pkg-config
  156. - added Patch1-6 from Fedora
  157. * Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  158. - applied new versioning policy
  159. - spec in UTF-8
  160. * Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
  161. - new upstream release
  162. - drop bmp-plugin.patch (patch1)
  163. - disable xmms plugin
  164. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  165. - new upsteram release
  166. - dropped Patch2 (merged into upstream)
  167. - do not build beepmp plugin
  168. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
  169. - rebuilt with new toolchain
  170. * Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
  171. - add '--disable-static' option to %%configure
  172. - remove *.la
  173. * Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
  174. - rebuild
  175. * Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
  176. - --disable-asm-optimizations on ppc
  177. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
  178. - rebuild
  179. * Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
  180. - initialize flac_cfg.stream with NULL to avoid crashing (patch2)
  181. * Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
  182. - upstream release
  183. - update bmp-plugin.patch
  184. * Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
  185. - upstream release
  186. - update bmp-plugin.patch
  187. * Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
  188. - fix typo
  189. * Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
  190. - move html docs to devel package
  191. * Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
  192. - add input plugin for beepmp based on for xmms (patch1)
  193. - BuildRequires: beepmp-devel >= 0.9.7
  194. - define build_*_plugin macros to build input plugin sub-packages
  195. - update description
  196. * Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
  197. - drop BuildRequires: zlib-devel (was required to build with id3lib)
  198. * Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
  199. - upstream release
  200. - drop (Build)Requires: id3lib(-devel)
  201. * Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
  202. - 1.1.1-beta1
  203. - add BuildRequires: gtk+-devel, zlib-devel
  204. * Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
  205. - xmms-flac
  206. - enable to convert charset from/to EUC-JP-MS (Patch0)
  207. - Requires: glibc >= 2.3.3
  208. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
  209. - fix docs
  210. * Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
  211. - first build for Vine Linux
  212. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  213. - Rebuilt for Red Hat Linux 9.
  214. - Exclude .la files.
  215. - Updated description.
  216. * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  217. - Fix nasm dep to be only for ix86.
  218. * Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  219. - Update to 1.1.0.
  220. * Sun Jan 5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  221. - Rebuilt against the latest id3lib for the xmms plugin.
  222. * Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  223. - Fixed location of include files, doh!
  224. * Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  225. - Rebuilt for Red Hat Linux 8.0.
  226. * Wed Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  227. - Update to 1.0.4.
  228. - Removed obsolete build patch, the xmms plugin builds cleanly at last!
  229. * Thu Jul 4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  230. - Update to 1.0.3.
  231. * Tue Apr 23 2002 Daniel Resare <noa@resare.com>
  232. - Fixed plugin build when flac is not already installed
  233. * Mon Apr 8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  234. - Replaced the hard-coded xmms input path with an expansion.
  235. - Fixed spec (License tag and redundant Group for devel package).
  236. - Fixed defattr for the xmms plugin.
  237. * Sat Apr 6 2002 Daniel Resare <noa@resare.com>
  238. - Update to 1.0.2.
  239. - Splitted out xmms plugin to a separate subpackage.
  240. * Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  241. - Update to 1.0.1.
  242. * Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  243. - Rebuilt for Red Hat 7.2 and added xmms dependency.
  244. * Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  245. - Initial RPM release.
  246. - You cannot rebuild this SRPM easily if you want the xmms plugin.