gnome-initial-setup-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574
  1. %bcond_with systemd
  2. %global nm_version 1.2
  3. %global nma_version 1.0
  4. %global glib_required_version 2.63.1
  5. %global gtk_required_version 3.11.3
  6. %global geoclue_version 2.3.1
  7. Name: gnome-initial-setup
  8. Version: 3.36.4
  9. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  10. Summary: Bootstrapping your OS
  11. License: GPLv2+
  12. URL: https://wiki.gnome.org/Design/OS/InitialSetup
  13. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  14. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  15. Source1: vendor.conf
  16. Patch0: honor-firstboot-disabled.patch
  17. BuildRequires: meson
  18. BuildRequires: gcc
  19. BuildRequires: krb5-devel
  20. BuildRequires: desktop-file-utils
  21. BuildRequires: libpwquality-devel
  22. BuildRequires: NetworkManager-libnm-devel >= %{nm_version}
  23. BuildRequires: pkgconfig(libnma) >= %{nma_version}
  24. BuildRequires: pkgconfig(accountsservice)
  25. BuildRequires: pkgconfig(gnome-desktop-3.0)
  26. BuildRequires: pkgconfig(gstreamer-1.0)
  27. BuildRequires: pkgconfig(cheese)
  28. BuildRequires: pkgconfig(cheese-gtk) >= 3.3.5
  29. BuildRequires: pkgconfig(fontconfig)
  30. BuildRequires: pkgconfig(geocode-glib-1.0)
  31. BuildRequires: pkgconfig(gweather-3.0)
  32. BuildRequires: pkgconfig(goa-1.0)
  33. BuildRequires: pkgconfig(goa-backend-1.0)
  34. BuildRequires: pkgconfig(gtk+-3.0) >= %{gtk_required_version}
  35. BuildRequires: pkgconfig(glib-2.0) >= %{glib_required_version}
  36. BuildRequires: pkgconfig(gio-2.0) >= %{glib_required_version}
  37. BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib_required_version}
  38. BuildRequires: pkgconfig(gdm)
  39. BuildRequires: pkgconfig(iso-codes)
  40. BuildRequires: geoclue2-devel >= %{geoclue_version}
  41. BuildRequires: pkgconfig(packagekit-glib2)
  42. BuildRequires: pkgconfig(webkit2gtk-4.0)
  43. BuildRequires: krb5-devel
  44. BuildRequires: ibus-devel
  45. BuildRequires: rest-devel
  46. BuildRequires: polkit-devel
  47. BuildRequires: libsecret-devel
  48. # gnome-initial-setup is being run by gdm
  49. Requires: gdm
  50. Requires: geoclue2%{?_isa} >= %{geoclue_version}
  51. Requires: glib2%{?_isa} >= %{glib_required_version}
  52. # we install a rules file
  53. Requires: polkit
  54. Requires: libgnomekbd
  55. Requires(pre): shadow-utils
  56. Provides: user(%name)
  57. %description
  58. GNOME Initial Setup is an alternative to firstboot, providing
  59. a good setup experience to welcome you to your system, and walks
  60. you through configuring it. It is integrated with gdm.
  61. %debug_package
  62. %prep
  63. %autosetup -p1
  64. %build
  65. %meson \
  66. -Dparental_controls=disabled \
  67. -Dvendor-conf-file=%{_datadir}/gnome-initial-setup/vendor.conf \
  68. %if %{with systemd}
  69. -Dsystemd=true
  70. %else
  71. -Dsystemd=false
  72. %endif
  73. %meson_build
  74. %install
  75. %meson_install
  76. # Desktop file does not (and probably will not) ever validate, as it uses
  77. # an absolute path /tmp/-style trigger to determine whether to autostart.
  78. # desktop-file-validate %%{buildroot}/%%{_sysconfdir}/xdg/autostart/gnome-welcome-tour.desktop
  79. desktop-file-validate %{buildroot}%{_sysconfdir}/xdg/autostart/gnome-initial-setup-copy-worker.desktop
  80. desktop-file-validate %{buildroot}%{_datadir}/gdm/greeter/applications/gnome-initial-setup.desktop
  81. mkdir -p %{buildroot}%{_datadir}/gnome-initial-setup
  82. cp %{SOURCE1} %{buildroot}%{_datadir}/gnome-initial-setup/
  83. %if !%{with systemd}
  84. rm -f %{buildroot}/usr/lib/systemd
  85. %endif
  86. %find_lang %{name}
  87. %pre
  88. useradd -rM -d /run/gnome-initial-setup/ -s /sbin/nologin %{name} &>/dev/null || :
  89. %files -f %{name}.lang
  90. %license COPYING
  91. %doc README
  92. %{_libexecdir}/gnome-initial-setup
  93. %{_libexecdir}/gnome-initial-setup-copy-worker
  94. %{_libexecdir}/gnome-welcome-tour
  95. %{_sysconfdir}/xdg/autostart/gnome-welcome-tour.desktop
  96. %{_sysconfdir}/xdg/autostart/gnome-initial-setup-copy-worker.desktop
  97. %{_sysconfdir}/xdg/autostart/gnome-initial-setup-first-login.desktop
  98. %{_datadir}/gdm/greeter/applications/gnome-initial-setup.desktop
  99. %{_datadir}/gnome-session/sessions/gnome-initial-setup.session
  100. %{_datadir}/gnome-shell/modes/initial-setup.json
  101. %{_datadir}/polkit-1/rules.d/20-gnome-initial-setup.rules
  102. %if %{with systemd}
  103. %{_userunitdir}/*
  104. %endif
  105. %dir %{_datadir}/gnome-initial-setup
  106. %{_datadir}/gnome-initial-setup/vendor.conf
  107. %changelog
  108. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.4-2
  109. - initial build for Vine Linux.
  110. * Mon Jul 20 2020 Kalev Lember <klember@redhat.com> - 3.36.4-1
  111. - Update to 3.36.4
  112. * Tue Jun 23 2020 Adam Williamson <awilliam@redhat.com> - 3.36.3-2
  113. - Backport MR #89 to fix 'disabled' timezone page setting timezone
  114. * Mon Jun 01 2020 Kalev Lember <klember@redhat.com> - 3.36.3-1
  115. - Update to 3.36.3
  116. * Mon Apr 27 2020 Kalev Lember <klember@redhat.com> - 3.36.2-1
  117. - Update to 3.36.2
  118. * Sat Mar 28 2020 Kalev Lember <klember@redhat.com> - 3.36.1-1
  119. - Update to 3.36.1
  120. * Fri Mar 06 2020 Kalev Lember <klember@redhat.com> - 3.36.0-1
  121. - Update to 3.36.0
  122. * Mon Mar 02 2020 Kalev Lember <klember@redhat.com> - 3.35.92-1
  123. - Update to 3.35.92
  124. * Mon Feb 17 2020 Kalev Lember <klember@redhat.com> - 3.35.91-1
  125. - Update to 3.35.91
  126. * Tue Feb 04 2020 Kalev Lember <klember@redhat.com> - 3.35.90-1
  127. - Update to 3.35.90
  128. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.35.3-3
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  130. * Thu Jan 16 2020 Kalev Lember <klember@redhat.com> - 3.35.3-2
  131. - Rebuilt for libgnome-desktop soname bump
  132. * Tue Jan 07 2020 Kalev Lember <klember@redhat.com> - 3.35.3-1
  133. - Update to 3.35.3
  134. * Tue Jan 07 2020 Kalev Lember <klember@redhat.com> - 3.34.3-1
  135. - Update to 3.34.3
  136. * Mon Oct 07 2019 Kalev Lember <klember@redhat.com> - 3.34.1-1
  137. - Update to 3.34.1
  138. * Mon Sep 09 2019 Benjamin Berg <bberg@redhat.com> - 3.34.0-2
  139. - Fix g-i-s starting in GDM
  140. Upstream MR https://gitlab.gnome.org/GNOME/gnome-initial-setup/merge_requests/59
  141. - Resolves: 1750237
  142. * Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 3.34.0-1
  143. - Update to 3.34.0
  144. * Wed Sep 04 2019 Benjamin Berg <bberg@redhat.com> - 3.33.92-2
  145. - Include upstream patches to fix systemd support
  146. https://gitlab.gnome.org/GNOME/gnome-initial-setup/merge_requests/58
  147. - Resolves: 1746563
  148. * Tue Sep 03 2019 Kalev Lember <klember@redhat.com> - 3.33.92-1
  149. - Update to 3.33.92
  150. * Tue Aug 20 2019 Kalev Lember <klember@redhat.com> - 3.33.91-1
  151. - Update to 3.33.91
  152. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.33.4-3
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  154. * Sun Jul 21 2019 Kalev Lember <klember@redhat.com> - 3.33.4-2
  155. - Rebuilt for libgnome-desktop soname bump
  156. * Mon Jul 15 2019 Kalev Lember <klember@redhat.com> - 3.33.4-1
  157. - Update to 3.33.4
  158. * Mon Jul 08 2019 Kalev Lember <klember@redhat.com> - 3.33.2-2
  159. - Rebuilt for libgweather soname bump
  160. * Tue May 21 2019 Kalev Lember <klember@redhat.com> - 3.33.2-1
  161. - Update to 3.33.2
  162. * Tue Apr 16 2019 Adam Williamson <awilliam@redhat.com> - 3.32.1-2
  163. - Rebuild with Meson fix for #1699099
  164. * Sat Apr 06 2019 Kalev Lember <klember@redhat.com> - 3.32.1-1
  165. - Update to 3.32.1
  166. * Thu Apr 04 2019 Ray Strode <rstrode@redhat.com> - 3.32.0-1
  167. - Update to 3.32.0
  168. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.30.0-2
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  170. * Sat Sep 22 2018 Kalev Lember <klember@redhat.com> - 3.30.0-1
  171. - Update to 3.30.0
  172. * Fri Sep 07 2018 Kalev Lember <klember@redhat.com> - 3.29.92-1
  173. - Update to 3.29.92
  174. - Drop upstreamed patches reduce-initial-setup-redundancy.patch and
  175. allow-weak-passwords.patch
  176. - Rebase honor-firstboot-disabled.patch
  177. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.28.0-8
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  179. * Mon Apr 30 2018 Adam Williamson <awilliam@redhat.com> - 3.28.0-7
  180. - Drop unnecessary pkgconfig(NetworkManager) BuildRequire
  181. - Run autoreconf to avoid automake version mismatch
  182. * Wed Apr 11 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-6
  183. - Allow setting weak passwords
  184. * Mon Apr 02 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-5
  185. - Move vendor.conf to /usr/share
  186. * Sat Mar 31 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-4
  187. - Forgot to update vendor.conf in the previous build
  188. * Sat Mar 31 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-3
  189. - Update reduce initial setup redundancy patch again
  190. * Sat Mar 31 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-2
  191. - Update reduce initial setup redundancy patches
  192. * Tue Mar 13 2018 Kalev Lember <klember@redhat.com> - 3.28.0-1
  193. - Update to 3.28.0
  194. * Fri Feb 16 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.27.90-2
  195. - Install vendor.conf to conditionally suppress certain pages
  196. * Fri Feb 16 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.27.90-1
  197. - Upgrade to 3.27.90 and add reduce initial setup redundancy patches
  198. * Tue Feb 13 2018 Björn Esser <besser82@fedoraproject.org> - 3.26.0-5
  199. - Rebuild against newer gnome-desktop3 package
  200. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.26.0-4
  201. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  202. * Mon Feb 05 2018 Kalev Lember <klember@redhat.com> - 3.26.0-3
  203. - Rebuilt for libgweather soname bump
  204. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 3.26.0-2
  205. - Rebuilt for switch to libxcrypt
  206. * Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 3.26.0-1
  207. - Update to 3.26.0
  208. * Thu Sep 07 2017 Kalev Lember <klember@redhat.com> - 3.25.92-1
  209. - Update to 3.25.92
  210. * Mon Jul 31 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
  211. - Update to 3.25.4
  212. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.3-2
  213. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  214. * Sun Jun 25 2017 Kalev Lember <klember@redhat.com> - 3.25.3-1
  215. - Update to 3.25.3
  216. * Wed May 10 2017 Kalev Lember <klember@redhat.com> - 3.24.2-1
  217. - Update to 3.24.2
  218. * Tue Mar 21 2017 Rui Matos <rmatos@redhat.com> - 3.24.0-1
  219. - Update to 3.24.0
  220. * Tue Mar 14 2017 Florian Müllner <fmuellner@redhat.com> - 3.23.92-1
  221. - Update to 3.23.92
  222. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.23.1-3
  223. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  224. * Tue Jan 31 2017 Rui Matos <rmatos@redhat.com> - 3.23.1-2
  225. - Honor anaconda's firstboot being disabled
  226. * Sun Oct 30 2016 Kalev Lember <klember@redhat.com> - 3.23.1-1
  227. - Update to 3.23.1
  228. * Wed Oct 12 2016 Kalev Lember <klember@redhat.com> - 3.22.1-1
  229. - Update to 3.22.1
  230. * Mon Sep 19 2016 Kalev Lember <klember@redhat.com> - 3.22.0-1
  231. - Update to 3.22.0
  232. * Tue Sep 13 2016 Kalev Lember <klember@redhat.com> - 3.21.92-1
  233. - Update to 3.21.92
  234. * Mon Sep 05 2016 Kalev Lember <klember@redhat.com> - 3.21.91-2
  235. - Build the software sources page
  236. * Sat Sep 03 2016 Kalev Lember <klember@redhat.com> - 3.21.91-1
  237. - Update to 3.21.91
  238. - Update project URL
  239. * Wed Apr 13 2016 Kalev Lember <klember@redhat.com> - 3.20.1-1
  240. - Update to 3.20.1
  241. * Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
  242. - Update to 3.20.0
  243. * Tue Mar 15 2016 Kalev Lember <klember@redhat.com> - 3.19.92-1
  244. - Update to 3.19.92
  245. * Tue Mar 01 2016 Richard Hughes <rhughes@redhat.com> - 3.19.91-1
  246. - Update to 3.19.91
  247. * Tue Feb 16 2016 Richard Hughes <rhughes@redhat.com> - 3.19.2-1
  248. - Update to 3.19.2
  249. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.1-2
  250. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  251. * Wed Oct 28 2015 Kalev Lember <klember@redhat.com> - 3.19.1-1
  252. - Update to 3.19.1
  253. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 3.18.0-1
  254. - Update to 3.18.0
  255. * Mon Aug 31 2015 Kalev Lember <klember@redhat.com> - 3.17.91-1
  256. - Update to 3.17.91
  257. * Mon Aug 17 2015 Kalev Lember <klember@redhat.com> - 3.17.90-1
  258. - Update to 3.17.90
  259. - Use make_install macro
  260. * Mon Aug 17 2015 Kalev Lember <klember@redhat.com> - 3.17.4-2
  261. - Rebuilt for libcheese soname bump
  262. * Mon Jul 27 2015 David King <amigadave@amigadave.com> - 3.17.4-1
  263. - Update to 3.17.4
  264. * Wed Jul 22 2015 David King <amigadave@amigadave.com> - 3.16.3-3
  265. - Bump for new gnome-desktop3
  266. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.16.3-2
  267. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  268. * Mon May 18 2015 Matthias Clasen <mclasen@redhat.com> - 3.16.3-1
  269. - Update to 3.16.3
  270. * Tue May 12 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-1
  271. - Update to 3.16.2
  272. * Wed Apr 15 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.1-1
  273. - Update to 3.16.1
  274. * Mon Mar 23 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.0-1
  275. - Update to 3.16.0
  276. * Wed Mar 18 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
  277. - Update to 3.15.92
  278. * Thu Mar 05 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91.1-1
  279. - Update to 3.15.91.1
  280. * Mon Mar 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91-1
  281. - Update to 3.15.91
  282. - Use the %%license macro for the COPYING file
  283. * Thu Feb 19 2015 Matthias Clasen <mclasen@redhat.com> - 3.15.90.1-1
  284. - Update to 3.15.90.1
  285. * Tue Dec 16 2014 Rui Matos <rmatos@redhat.com> - 3.14.2.1-2
  286. - Resolves: rhbz#1172363
  287. * Tue Nov 11 2014 Rui Matos <rmatos@redhat.com> - 3.14.2.1-1
  288. - Update to 3.14.2.1
  289. * Mon Nov 10 2014 Rui Matos <rmatos@redhat.com> - 3.14.2-1
  290. - Update to 3.14.2
  291. - Resolves: rhbz#1158442
  292. * Fri Oct 31 2014 Rui Matos <rmatos@redhat.com> - 3.14.1-3
  293. - Resolves: rhbz#1151519
  294. * Tue Oct 21 2014 Rui Matos <rmatos@redhat.com> - 3.14.1-2
  295. - Resolves: rhbz#1154206
  296. * Sat Oct 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
  297. - Update to 3.14.1
  298. * Tue Sep 23 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
  299. - Update to 3.14.0
  300. * Wed Sep 17 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.7-1
  301. - Update to 3.13.7
  302. * Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.6-1
  303. - Update to 3.13.6
  304. * Mon Sep 08 2014 Adam Williamson <awilliam@redhat.com> - 3.13.5-2
  305. - backport upstream patch to offer full list of keyboard layouts (BGO #729208)
  306. * Wed Sep 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.5-1
  307. - Update to 3.13.5
  308. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.13.4-3
  309. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  310. * Wed Aug 13 2014 Matthias Clasen <mclasen@redhat.com> - 3.13.4-2
  311. - Drop the yelp focus patch (we've dropped the yelp patch it depends on)
  312. * Fri Jul 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-1
  313. - Update to 3.13.4
  314. * Thu Jul 24 2014 Matthias Clasen <mclasen@redhat.com> - 3.12.1-3
  315. - Fix a memory corruption crash (#1116478)
  316. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.12.1-2
  317. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  318. * Thu May 15 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.1-1
  319. - Update to 3.12.1
  320. * Tue Mar 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.0-1
  321. - Update to 3.12.0
  322. * Thu Mar 20 2014 Richard Hughes <rhughes@redhat.com> - 3.11.92-1
  323. - Update to 3.11.92
  324. * Sat Mar 08 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-1
  325. - Update to 3.11.91
  326. * Fri Feb 28 2014 Richard Hughes <rhughes@redhat.com> - 3.11.90-1
  327. - Update to 3.11.90
  328. * Wed Feb 19 2014 Kalev Lember <kalevlember@gmail.com> - 3.10.1.1-5
  329. - Rebuilt for libgnome-desktop soname bump
  330. * Fri Nov 29 2013 Rui Matos <rmatos@redhat.com> - 3.10.1.1-4
  331. - Resolves: rhbz#1035548 - Disables the GOA page in new user mode
  332. * Thu Nov 28 2013 Rui Matos <rmatos@redhat.com> - 3.10.1.1-3
  333. - Resolves: rhbz#1027507 - [abrt] gnome-initial-setup-3.10.1.1-2.fc20: magazine_chain_pop_head
  334. * Fri Nov 1 2013 Matthias Clasen <mclasen@redhat.com> - 3.10.1.1-2
  335. - Fix goa add dialog to not be empty
  336. * Mon Oct 28 2013 Richard Hughes <rhughes@redhat.com> - 3.10.1.1-1
  337. - Update to 3.10.1.1
  338. * Thu Sep 26 2013 Kalev Lember <kalevlember@gmail.com> - 3.10.0.1-1
  339. - Update to 3.10.0.1
  340. * Wed Sep 25 2013 Kalev Lember <kalevlember@gmail.com> - 3.10.0-1
  341. - Update to 3.10.0
  342. * Tue Sep 03 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-7
  343. - Rebuilt for libgnome-desktop soname bump
  344. * Fri Aug 23 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-6
  345. - Rebuilt for gnome-online-accounts soname bump
  346. * Fri Aug 09 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-5
  347. - Rebuilt for cogl 1.15.4 soname bump
  348. * Tue Aug 06 2013 Adam Williamson <awilliam@redhat.com> - 0.12-4
  349. - rebuild for new libgweather
  350. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-3
  351. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  352. * Fri Jun 21 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-2
  353. - Rebuilt for libgweather 3.9.3 soname bump
  354. * Mon Jun 17 2013 Rui Matos <rmatos@redhat.com> - 0.12-1
  355. - Update to 0.12
  356. * Fri Jun 7 2013 Matthias Clasen <mclasen@redhat.com> - 0.11-2
  357. - Require polkit-js-engine
  358. * Tue May 28 2013 Matthias Clasen <mclasen@redhat.com> - 0.11-1
  359. - Update to 0.11
  360. * Tue May 14 2013 Rui Matos <rmatos@redhat.com> - 0.10-1
  361. - Update to 0.10
  362. - Add BuildRequires on polkit-devel
  363. - Update files list
  364. * Thu May 2 2013 Rui Matos <rmatos@redhat.com> - 0.9-2
  365. - Remove unused patches
  366. - Add build requires for ibus
  367. * Tue Apr 16 2013 Matthias Clasen <mclasen@redhat.com> - 0.9-1
  368. - Update to 0.9
  369. * Tue Apr 16 2013 Ray Strode <rstrode@redhat.com> 0.8-4
  370. - Add requires for keyboard viewer app
  371. * Wed Mar 20 2013 Ray Strode <rstrode@redhat.com> 0.8-3
  372. - Add cosimoc fix for gd page transitions
  373. * Wed Mar 20 2013 Ray Strode <rstrode@redhat.com> 0.8-2
  374. - Disable gd page transitions for now since they don't
  375. completely work right (ask adamw).
  376. - Fix crasher when realmd goes away
  377. * Tue Mar 19 2013 Matthias Clasen <mclasen@redhat.com> - 0.8-1
  378. - Update to 0.8
  379. * Tue Mar 12 2013 Matthias Clasen <mclasen@redhat.com> - 0.7-1
  380. - Update to 0.7
  381. * Thu Feb 21 2013 Kalev Lember <kalevlember@gmail.com> - 0.6-4
  382. - Rebuilt for cogl soname bump
  383. * Wed Feb 20 2013 Kalev Lember <kalevlember@gmail.com> - 0.6-3
  384. - Rebuilt for libgnome-desktop soname bump
  385. * Fri Jan 25 2013 Peter Robinson <pbrobinson@fedoraproject.org> 0.6-2
  386. - Rebuild for new cogl
  387. * Wed Jan 16 2013 Matthias Clasen <mclasen@redhat.com> - 0.6-1
  388. - 0.6
  389. * Fri Jan 11 2013 Matthias Clasen <mclasen@redhat.com> - 0.5-1
  390. - 0.5
  391. * Fri Dec 21 2012 Kalev Lember <kalevlember@gmail.com> - 0.4-2
  392. - Rebuilt for libgweather soname bump
  393. * Thu Nov 22 2012 Matthias Clasen <mclasen@redhat.com> - 0.4-1
  394. - 0.4
  395. * Fri Oct 26 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.3-3
  396. - Add krb5
  397. * Fri Oct 26 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.3-2
  398. - 0.3-2
  399. * Thu Oct 18 2012 Matthias Clsaen <mclasen@redhat.com> - 0.3-1
  400. - 0.3
  401. * Fri Sep 14 2012 Matthias Clasen <mclasen@redhat.com> - 0.2-2
  402. - Add Requires: gdm
  403. * Wed Aug 29 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.2-1
  404. - Update to 0.2
  405. * Fri Jun 08 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.1
  406. - Initial packaging.