inkscape-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. %define filever A6N0YOn
  2. Name: inkscape
  3. Summary: A Vector Drawing Application
  4. Summary(ja): ベクター描画アプリケーション
  5. Version: 0.92.4
  6. Release: 3%{?_dist_release}
  7. Group: Applications/Graphics
  8. License: GPLv2+
  9. URL: https://launchpad.net/inkscape
  10. Source0: https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}_%{filever}.tar.bz2
  11. # # to fix compile error with poppler>=0.58
  12. # Patch1000: poppler-0.58.x.patch
  13. # Patch1001: poppler-0.58.x-autotools.patch
  14. # # to fix compile error with poppler>=0.76.0
  15. # https://gitlab.com/inkscape/inkscape/issues/220
  16. Patch1002: poppler-0.76.x.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: gtk2-devel >= 2.8.0
  19. BuildRequires: gnome-vfs2-devel >= 2.0
  20. BuildRequires: libxml2-devel >= 2.6.11
  21. BuildRequires: libxslt-devel >= 1.0.15
  22. BuildRequires: gc-devel >= 6.4
  23. BuildRequires: dbus-glib-devel
  24. BuildRequires: libsigc++-devel >= 2.0.12
  25. BuildRequires: gtkmm2-devel >= 2.8.0
  26. BuildRequires: libpng-devel >= 1.2.0
  27. BuildRequires: libwpg-devel
  28. BuildRequires: libexif-devel
  29. BuildRequires: libjpeg-turbo-devel
  30. BuildRequires: perl-XML-Parser
  31. BuildRequires: lcms2-devel
  32. BuildRequires: poppler-devel >= 0.14.2
  33. BuildRequires: pango-devel, cairo-devel
  34. BuildRequires: gsl-devel
  35. BuildRequires: libboost-devel
  36. BuildRequires: popt-devel
  37. BuildRequires: ImageMagick-c++-devel
  38. BuildRequires: dos2unix
  39. BuildRequires: automake autoconf
  40. Requires: python-lxml
  41. Requires: perl-XML-RegExp
  42. Requires: perl-XML-DOM
  43. Requires: perl-XML-XQL
  44. # the package requires libperl.so, so it also has to require this:
  45. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  46. # Filter out perl requires and provides
  47. # XXX: For now _all_
  48. %global __perl_provides %{nil}
  49. %global __perl_requires %{nil}
  50. Vendor: Project Vine
  51. Distribution: Vine Linux
  52. %description
  53. Inkscape is a SVG based generic vector-drawing program for
  54. Linux/Unix/Windows/Mac.
  55. %description -l ja
  56. Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
  57. Linux/Unix/Windows/Mac で動作します。
  58. %prep
  59. %setup -q -n %{name}-%{version}
  60. # %patch1000 -p1
  61. # %patch1001 -p1
  62. %patch1002 -p1 -b .poppler0.76.x
  63. # https://bugs.launchpad.net/inkscape/+bug/314381
  64. # A couple of files have executable bits set,
  65. # despite not being executable
  66. find . -name '*.cpp' | xargs chmod -x
  67. find . -name '*.h' | xargs chmod -x
  68. find share/extensions -name '*.py' | xargs chmod -x
  69. # Fix end of line encodings
  70. dos2unix -k -q share/extensions/*.py
  71. %build
  72. ./autogen.sh
  73. export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
  74. %configure \
  75. --with-gnome-vfs \
  76. --with-inkjar \
  77. --enable-poppler-cairo \
  78. --disable-strict-build
  79. make %{?_smp_mflags}
  80. %install
  81. rm -rf %{buildroot}
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  84. %find_lang %{name}
  85. %clean
  86. rm -rf %{buildroot}
  87. %post
  88. /sbin/ldconfig
  89. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  90. %postun
  91. if [ $1 -eq 0 ] ; then
  92. update-desktop-database -q &> /dev/null
  93. touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
  94. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  95. fi
  96. %posttrans
  97. update-desktop-database -q &> /dev/null
  98. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  99. %files -f %{name}.lang
  100. %defattr(-, root, root)
  101. %doc AUTHORS COPYING ChangeLog NEWS README
  102. %{_bindir}/inkscape
  103. %{_bindir}/inkview
  104. %{_datadir}/appdata/inkscape.appdata.xml
  105. %{_datadir}/applications/*.desktop
  106. %{_datadir}/icons/hicolor/*
  107. %{_datadir}/inkscape
  108. %{_mandir}/man1/*
  109. %{_mandir}/*/man1/*
  110. %changelog
  111. * Sun Oct 27 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-3
  112. - rebuild with OpenEXR-libs-2.4.0 (required by ImageMagick)
  113. * Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-2
  114. - rebuild with poppler-0.81.0 and gsl-2.6
  115. - add Patch1002 for poppler >= 0.76.0
  116. * Mon May 20 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-1
  117. - update to 0.92.4
  118. - drop unrecognized options: --with-python, --enable-lcms2
  119. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
  120. - updated to 0.92.3
  121. - drop Patch1000,1001
  122. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
  123. - updated to 0.92.2
  124. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
  125. - rebuild with gcc-5.4.0
  126. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
  127. - rebuild with poppler-0.43.0
  128. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
  129. - update to 0.91
  130. - remove old patches
  131. - add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
  132. * Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
  133. - rebuild with ImageMagick-6.9.1.1
  134. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
  135. - rebuilt with libwpd 0.3.0
  136. - added Patch14 to build with libwpd 0.3.0
  137. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
  138. - rebuild with poppler-0.26.2
  139. * Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
  140. - new upstream release
  141. - add BuildRequires: libwpg-devel
  142. - remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  143. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
  144. - rebuild with poppler-0.24.5
  145. - add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  146. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
  147. - rebuild with ImageMagick-6.8.7.5
  148. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
  149. - rebuild with poppler-0.24.2
  150. * Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
  151. - rebuild with ImageMagick-6.8.6.8
  152. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
  153. - new upstream release
  154. - remove Patch0 (inkscape-0.48.2-poppler_020.patch)
  155. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
  156. - rebuild with poppler-0.20.4
  157. - add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
  158. - change BuildRequires: lcms2-devel instead of lcms-devel
  159. * Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
  160. - new upstream release
  161. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
  162. - rebuild with ImageMagick-6.7.5.10
  163. * Sat Feb 4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
  164. - new upstream release
  165. * Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
  166. - add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
  167. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
  168. - new upstream release
  169. - built with poppler-0.16.3
  170. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
  171. - rebuild with poppler-0.14.2
  172. - add BuildRequires: popt-devel, ImageMagick-c++-devel
  173. * Sun Oct 3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
  174. - new upstream release
  175. - rebuilt with ImageMagick-6.6.4.8
  176. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
  177. - added Patch0 for building with poppler-0.12.2+
  178. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  179. - removed BR: libgnomeprint-devel, libgnomeprintui-devel
  180. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
  181. - rebuild with poppler-0.12.1
  182. * Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
  183. - new upstream release
  184. - add BR: libboost-devel
  185. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
  186. - update to 0.47pre2
  187. - drop obsolete patches
  188. - add BR: gsl-devel
  189. * Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
  190. - rebuild with poppler-0.10.2
  191. * Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
  192. - add Patch[1-6]
  193. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
  194. - added inkscape-0.46-poppler-0.8.3.patch
  195. - spec in utf-8
  196. - added option %%{?_smp_mflags} at make
  197. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
  198. - new upstream release
  199. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
  200. - rebuild with new environment/toolchain
  201. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
  202. - new upstream release
  203. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
  204. - add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
  205. - update required version of gtk2-devel
  206. * Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
  207. - new upstream release
  208. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
  209. - new upstream release
  210. * Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
  211. - new upstream release
  212. * Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
  213. - new upstream release
  214. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
  215. - new upstream release
  216. * Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
  217. - new upstream release
  218. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
  219. - new upstream release
  220. - add Japanese summary and description
  221. - fixed dependancy of libsigc++12 to libsigc++ >= 2.0
  222. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
  223. - fixed dependancy of libsigc++ to libsigc++12
  224. - fixed %files section
  225. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
  226. - rebuild for Vine Linux
  227. - s/Copyright/License/
  228. - added Requires and BuildRequires
  229. * Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
  230. - Removing _libdir and TODO, updating description
  231. * Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
  232. - Fix up the spec file for current release
  233. * Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
  234. - Update to 0.2.6
  235. * Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
  236. - Update to 0.2.5
  237. - Changed SPEC to benefit from macros