make-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. Summary: A GNU tool which simplifies the build process for users.
  2. Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
  3. Name: make
  4. Epoch: 1
  5. Version: 4.3
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPL
  11. URL: http://www.gnu.org/software/make/
  12. Source: https://ftp.gnu.org/gnu/make/make-%{version}.tar.gz
  13. Source1: http://translationproject.org/PO-files/ja/make-4.2.93.ja.po
  14. Patch0: make-4.3-getcwd.patch
  15. # Assume we don't have clock_gettime in configure, so that
  16. # make is not linked against -lpthread (and thus does not
  17. # limit stack to 2MB).
  18. Patch2: make-4.0-noclock_gettime.patch
  19. # BZs #142691, #17374
  20. Patch3: make-4.3-j8k.patch
  21. # https://bugzilla.redhat.com/show_bug.cgi?id=1827850
  22. # https://savannah.gnu.org/bugs/?58232
  23. # Remove on next make rebase
  24. Patch4: make-4.3-cloexec.patch
  25. Buildroot: %{_tmppath}/%{name}-%{version}-root
  26. Requires(post): /sbin/install-info
  27. Requires(preun): /sbin/install-info
  28. BuildRequires: automake >= 1.7.3
  29. BuildRequires: guile-devel
  30. BuildRequires: perl
  31. BuildRequires: procps
  32. BuildRequires: texinfo
  33. %description
  34. A GNU tool for controlling the generation of executables and other
  35. non-source files of a program from the program's source files. Make
  36. allows users to build and install packages without any significant
  37. knowledge about the details of the build process. The details about
  38. how the program should be built are provided for make in the program's
  39. makefile.
  40. The GNU make tool should be installed on your system because it is
  41. commonly used to simplify the process of installing programs.
  42. %description -l ja
  43. プログラムのソースファイルから実行ファイル及びその他のファイルを
  44. 生成する GNU ツールです.Make を使うことでユーザは build 時の
  45. 細かいプロセスを気にせず build しインストールすることが出来ます.
  46. プログラムがどの様に build されるのかは,プログラムの Makefile に
  47. 書かれています.
  48. GNU make ツールは,プログラムのインストールを容易にするのに
  49. 非常によく使われますので,このパッケージは是非インストールして下さい.
  50. %debug_package
  51. %prep
  52. %autosetup -p1
  53. rm -f tests/scripts/features/parallelism.orig
  54. cp -f %{SOURCE1} po/ja.po
  55. %build
  56. autoreconf -vfi
  57. %configure --with-guile
  58. make -C po ja.gmo
  59. make %{?_smp_mflags}
  60. %install
  61. rm -rf ${RPM_BUILD_ROOT}
  62. make DESTDIR=$RPM_BUILD_ROOT install
  63. ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
  64. ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
  65. rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
  66. %find_lang %name
  67. %check
  68. echo ============TESTING===============
  69. /usr/bin/env LANG=C make check
  70. echo ============END TESTING===========
  71. %clean
  72. rm -rf ${RPM_BUILD_ROOT}
  73. %post
  74. /sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  75. %preun
  76. if [ $1 = 0 ]; then
  77. /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  78. fi
  79. %files -f %{name}.lang
  80. %defattr(-,root,root)
  81. %doc NEWS README COPYING AUTHORS
  82. %{_bindir}/*
  83. %{_mandir}/man*/*
  84. %{_infodir}/*.info*
  85. %{_includedir}/gnumake.h
  86. %changelog
  87. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3-1
  88. - new upstream release.
  89. - updated ja.po.
  90. - dropped Patch1, 4-9.
  91. - updated Patch0 and 3.
  92. - imported Patch4 from rawhide.
  93. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.1-1
  94. - new upstream release.
  95. - updated patches.
  96. - updated ja.po.
  97. * Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
  98. - new upstream release.
  99. - dropped all patches.
  100. - imported patches from rawhide.
  101. - added Patch1000 to fix ja.po.
  102. * Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
  103. - rebuild with VineSeed environment
  104. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
  105. - new upstream release
  106. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
  107. - rebuild for Vine6
  108. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
  109. - applied new versioning policy
  110. - added BuildRequires: perl (for %%check)
  111. - spec in UTF-8
  112. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
  113. - updated to 3.81 based on Fedora packages
  114. * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
  115. - Always run testsuite with C locale.
  116. - Resolves: #232607
  117. * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
  118. - Fix newline handling for quoted SHELL.
  119. - Resolves: #219409
  120. * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
  121. - Upstream 3.81:
  122. - Contains several backwards incompatible changes. See NEWS inside
  123. the source package to find out more.
  124. - memory patch and error reporting patch were ported to this version.
  125. - updated ja.po
  126. * Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
  127. - added URL
  128. - s/Copyright/License/
  129. - added some patches from fedora development 3.80-8
  130. * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
  131. - make sure errno for error reporting is not lost accross _() calls
  132. - report EOF on read pipe differently from read returning < 0 reporting
  133. * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
  134. - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
  135. * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  136. - add important bug-fixes from make home-page
  137. * Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
  138. - some patches was included from 3.79.1-17
  139. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
  140. - update ja.po
  141. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
  142. - new upstream release
  143. * Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  144. - 3.79.1-5vl1
  145. - based on 3.79.1-5 from Rawhide
  146. - rebuilt for Vine Linux
  147. - added Japanese summary and description
  148. * Mon Aug 7 2000 Tim Waugh <twaugh@redhat.com>
  149. - change info-dir entry so that 'info make' works (#15029).
  150. * Tue Aug 1 2000 Jakub Jelinek <jakub@redhat.com>
  151. - assume we don't have clock_gettime in configure, so that
  152. make is not linked against -lpthread (and thus does not
  153. limit stack to 2MB).
  154. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  155. - add locale files (#14362).
  156. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  157. - automatic rebuild
  158. * Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
  159. - 3.79.1 bugfix release
  160. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  161. - FHS packaging.
  162. * Sun May 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  163. - Fix build for some odd situations, such as
  164. - previously installed make != GNU make
  165. - /bin/sh != bash
  166. * Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  167. - update to 3.79
  168. * Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
  169. - add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
  170. builds)
  171. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  172. - compress man page.
  173. * Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
  174. - apply patch to fix a /tmp race condition from Thomas Biege
  175. - simplify %install
  176. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  177. - update to 3.78.1.
  178. * Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
  179. - added a serial tag so it upgrades right
  180. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  181. - auto rebuild in the new build environment (release 5)
  182. * Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
  183. - added a patch for large file support in glob
  184. * Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
  185. - update to 3.77
  186. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  187. - translations modified for de, fr, tr
  188. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  189. - udpated from 3.75 to 3.76
  190. - various spec file cleanups
  191. - added install-info support
  192. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  193. - built against glibc