mpfr-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. Summary: A C library for multiple-precision floating-point computations
  2. Name: mpfr
  3. Version: 4.1.0
  4. Release: 1%{?_dist_release}
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: inagaki, kenta
  9. License: LGPLv3+
  10. URL: https://www.mpfr.org/
  11. Source0: https://www.mpfr.org/mpfr-%{version}/mpfr-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gmp-devel
  14. Requires: gmp >= 4.2.3
  15. %description
  16. The MPFR library is a C library for multiple-precision floating-point
  17. computations with "correct rounding". The MPFR is efficient and
  18. also has a well-defined semantics. It copies the good ideas from the
  19. ANSI/IEEE-754 standard for double-precision floating-point arithmetic
  20. (53-bit mantissa). MPFR is based on the GMP multiple-precision library.
  21. %package devel
  22. Summary: Development tools A C library for mpfr library
  23. Group: programming
  24. Requires: %{name} = %{version}-%{release}
  25. Requires: gmp-devel >= 4.2.3
  26. Requires(post): /sbin/install-info
  27. Requires(preun): /sbin/install-info
  28. %description devel
  29. The static libraries, header files and documentation for using the MPFR
  30. multiple-precision floating-point library in applications.
  31. If you want to develop applications which will use the MPFR library,
  32. you'll need to install the mpfr-devel package. You'll also need to
  33. install the mpfr package.
  34. %debug_package
  35. %prep
  36. %autosetup -p1
  37. %build
  38. %configure --disable-assert --disable-static
  39. # Get rid of undesirable hardcoded rpaths; workaround libtool reordering
  40. # -Wl,--as-needed after all the libraries.
  41. sed -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
  42. -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
  43. -e 's|CC="\(g..\)"|CC="\1 -Wl,--as-needed"|' \
  44. -i libtool
  45. make %{?_smp_mflags}
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. %make_install
  49. rm -f %{buildroot}%{_libdir}/*.la
  50. rm -f %{buildroot}%{_infodir}/dir
  51. #these go into licenses, not doc
  52. rm -f %{buildroot}%{_datadir}/doc/COPYING{,.LESSER}
  53. %check
  54. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
  55. make %{?_smp_mflags} check
  56. %post -p /sbin/ldconfig
  57. %postun -p /sbin/ldconfig
  58. %post devel
  59. /sbin/install-info %{_infodir}/mpfr.info.gz %{_infodir}/dir || :
  60. %preun devel
  61. if [ "$1" = 0 ]; then
  62. /sbin/install-info --delete %{_infodir}/mpfr.info.gz %{_infodir}/dir || :
  63. fi
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %files
  67. %defattr(-,root,root,-)
  68. %license COPYING COPYING.LESSER
  69. %doc NEWS README
  70. %{_libdir}/libmpfr.so.*
  71. %{_datadir}/doc/mpfr
  72. %files devel
  73. %defattr(-,root,root,-)
  74. %{_libdir}/libmpfr.so
  75. %{_libdir}/pkgconfig/*
  76. %{_includedir}/*.h
  77. %{_infodir}/mpfr.info*
  78. %changelog
  79. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.0-1
  80. - new upstream release.
  81. - dropped Patch0: fixed in upstream.
  82. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-1
  83. - new upstream release.
  84. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  85. - update to 3.1.4
  86. * Sun Dec 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  87. - rebuild with VineSeed environment
  88. * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
  89. - update to 3.1.2
  90. * Sun Oct 30 2011 NAKAMURA Kenta <kenta@vinelinux.org> 3.1.0-1
  91. - new upstream release
  92. * Tue Apr 19 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-2
  93. - rebuild for Vine 6
  94. * Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-1
  95. - new upstream release
  96. - add Requires: gmp-devel (devel package)
  97. * Sat Nov 28 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1
  98. - new upstream release
  99. * Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.1-1
  100. - new upstream release
  101. - applied new versioning policy
  102. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.0-1vl1
  103. - initial build for Vine Linux
  104. * Thu Sep 20 2007 Ivana Varekova <varekova@redhat.com> 2.3.0-1
  105. - update to 2.3.0
  106. - fix license flag
  107. * Mon Aug 20 2007 Ivana Varekova <varekova@redhat.com> 2.2.1-2
  108. - spec file cleanup (#253440)
  109. * Tue Jan 16 2007 Ivana Varekova <varekova@redhat.com> 2.2.1-1
  110. - started