perl-Class-Singleton-vl.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. Name: perl-Class-Singleton
  2. Version: 1.5
  3. Release: 1%{?_dist_release}
  4. Summary: Implementation of a "Singleton" class
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Class-Singleton/
  8. Source0: http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(ExtUtils::MakeMaker)
  12. BuildRequires: perl(Test::More)
  13. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Packager: yasumichi, inagaki
  17. %description
  18. This is the Class::Singleton module. A Singleton describes an object class
  19. that can have only one instance in any system. An example of a Singleton
  20. might be a print spooler or system registry. This module implements a
  21. Singleton class from which other classes can be derived. By itself, the
  22. Class::Singleton module does very little other than manage the
  23. instantiation of a single object. In deriving a class from
  24. Class::Singleton, your module will inherit the Singleton instantiation
  25. method and can implement whatever specific functionality is required.
  26. %prep
  27. %setup -q -n Class-Singleton-%{version}
  28. %build
  29. %{__perl} Makefile.PL INSTALLDIRS=vendor
  30. make %{?_smp_mflags}
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  34. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
  35. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
  36. %{_fixperms} $RPM_BUILD_ROOT/*
  37. %check
  38. make test
  39. %clean
  40. rm -rf $RPM_BUILD_ROOT
  41. %files
  42. %defattr(-,root,root,-)
  43. %doc Changes README
  44. %{perl_vendorlib}/*
  45. %{_mandir}/man3/*
  46. %changelog
  47. * Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.5-1
  48. - new upstream release
  49. - built with perl 5.16.3
  50. * Wed Jan 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4-7
  51. - rebuild with perl-5.12.3
  52. * Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-6
  53. - initial build for Vine Linux
  54. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
  55. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  56. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-4
  57. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  58. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4-3
  59. - Rebuild for perl 5.10 (again)
  60. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4-2
  61. - rebuild for new perl
  62. * Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.4-1
  63. - Update to 1.4.
  64. - Update License tag.
  65. - Drop our copy of the license text.
  66. - Improve Summary.
  67. - Make description match cpanspec output.
  68. - BR Test::More.
  69. * Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.03-4
  70. - Use fixperms macro instead of our own chmod incantation.
  71. - BR ExtUtils::MakeMaker.
  72. * Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 1.03-3
  73. - Canonicalize Source0 URL.
  74. - Fix find option order.
  75. * Thu Sep 08 2005 Steven Pritchard <steve@kspei.com> 1.03-2
  76. - Fix permissions on Singleton.pm.
  77. * Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
  78. - Specfile autogenerated.