stone-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. # ----------------------------------------------------------
  2. # (1) Data definition
  3. # ----------------------------------------------------------
  4. %define _mandir %{_datadir}/man
  5. %define _source_dir stone-2.3d-2.3.2.7
  6. Summary: The stone is TCP and UDP packet repeater.
  7. Summary(ja): TCP & UDP パケットリピータ stone
  8. Name: stone
  9. Version: 2.3e
  10. Release: 5%{_dist_release}
  11. License: GPL
  12. Group: Applications/Internet
  13. URL: http://www.gcd.org/sengoku/stone/
  14. Source0: http://www.gcd.org/sengoku/stone/%{name}-%{version}.tar.gz
  15. # 'rfc1321.txt', 'global.h', 'md5.h', and 'md5c.c'
  16. Source1: stone-Source1.tar.gz
  17. Source2: stone.init
  18. Source3: stone.conf
  19. Source4: stone.1.gz
  20. Source5: stone.1.ja.gz
  21. # adapted for Vine Linux
  22. Patch0: stone-%{version}-Makefile.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: nkf
  25. BuildRequires: openssl-devel
  26. Requires: openssl
  27. Requires: gcc-cpp
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: iwamoto
  31. %description
  32. Stone is a TCP/IP packet repeater in the application layer. It
  33. repeats TCP and UDP packets from inside to outside of a firewall, or
  34. from outside to inside.
  35. %description -l ja
  36. stone は、アプリケーションレベルの TCP & UDP パケットリピーターです。
  37. ファイアウォールの内から外へ、あるいは外から内へ、TCP パケットあるいは
  38. UDP パケットを中継します。
  39. # ----------------------------------------------------------
  40. # (2) Scripts
  41. # ----------------------------------------------------------
  42. # --- prep
  43. %prep
  44. rm -rf ${RPM_BUILD_ROOT}
  45. # %setup -a 1 -n ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}
  46. %setup -a 1 -n %{_source_dir}
  47. %patch0 -p0 -b .vine
  48. nkf -w README.txt > README.txt.utf8
  49. mv README.txt.utf8 README.txt
  50. nkf -w GPL.txt > GPL.txt.utf8
  51. mv GPL.txt.utf8 GPL.txt
  52. # --- build
  53. %build
  54. make linux-ssl SSL_FLAGS='-DUSE_SSL -DOPENSSL_NO_SSL2 ' SSL_LIBS='-lssl -lcrypto'
  55. # --- install
  56. %install
  57. rm -rf ${RPM_BUILD_ROOT}
  58. install -d --mode=0755 ${RPM_BUILD_ROOT}%{_bindir}
  59. install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/man1
  60. install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/ja/man1
  61. install --mode=0755 stone ${RPM_BUILD_ROOT}%{_bindir}/stone
  62. install --mode=0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_mandir}/man1/stone.1.gz
  63. install --mode=0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/stone.1.gz
  64. mkdir -p %{buildroot}/etc/rc.d/init.d
  65. install --mode=0755 %{SOURCE2} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/stone
  66. install --mode=0644 %{SOURCE3} ${RPM_BUILD_ROOT}/etc/stone.conf
  67. # --- clean
  68. %clean
  69. rm -rf ${RPM_BUILD_ROOT}
  70. # ----------------------------------------------------------
  71. # (3) File Lists
  72. # ----------------------------------------------------------
  73. %files
  74. %defattr(-,root,root)
  75. %doc README.txt README.en.txt GPL.txt rfc1321.txt
  76. %{_bindir}/stone
  77. %{_mandir}/man1/stone.1*
  78. %{_mandir}/ja/man1/stone.1*
  79. %config /etc/rc.d/init.d/stone
  80. %config(noreplace) /etc/stone.conf
  81. # ----------------------------------------------------------
  82. # (4) Change Log
  83. # ----------------------------------------------------------
  84. %changelog
  85. * Tue Mar 15 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-5
  86. - rebuilt with openssl 1.0.2g and disable SSL2
  87. * Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3e-4
  88. - rebuilt on current VineSeed
  89. - added BR: nkf to convert document encoding to UTF
  90. * Mon Dec 30 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-3
  91. - add R:gcc-cpp (cpp is required to parse conf file)
  92. - add Distri/Vendor/Packager tags
  93. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3e-2
  94. - rebuild with openssl-1.0.0c
  95. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-1
  96. - new upstream release
  97. - new versioning policy and spec in UTF-8
  98. - update patch0 (_GNU_SOURCE macro is required glibc >= 2.8)
  99. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3c-0vl4
  100. - rebuild with new environment
  101. * Wed Oct 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3c-0vl3
  102. - rebuilt for Vine Linux 4.0
  103. * Fri Oct 6 2006 Takeru INOUE <takeru.inoue@ieee.org>
  104. - 2.3c-0vl1
  105. - Updated
  106. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3b-0vl2
  107. - rebuilt for VineSeed (4.0)
  108. * Sun Jul 16 2006 Takeru INOUE <takeru.inoue@ieee.org>
  109. - 2.3b-0vl1
  110. - Build for Vine 3.2
  111. * Sat Jul 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl2
  112. - rebuilt for VineSeed
  113. - changed Group to Applications/Internet
  114. * Mon Mar 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  115. - 2.3-0vl1
  116. - new upstream release
  117. - update Patch0
  118. - Build for Vine 3.2
  119. * Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
  120. - 2.1x-0vl0
  121. - updated
  122. - add /etc/rc.d/init.d/stone and /etc/stone.conf
  123. * Fri Dec 6 2002 Takashi `Muneharu' Sugimoto <muneharu@raug.net>
  124. - 2.1w-0vl1
  125. - change the file list
  126. * Thu Oct 31 2002 Takashi Sugimoto
  127. - 2.1w-0vl0
  128. - updated
  129. * Mon Aug 19 2002 Takashi Sugimoto
  130. - 2.1v-0vl0
  131. - updated
  132. * Wed Apr 10 2002 Takashi Sugimoto
  133. - 2.1r-0.1vl3