suitesparse-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598
  1. %define pkg_name suitesparse
  2. %define pkg_version 5.4.0
  3. %define pkg_release 1%{?_dist_release}
  4. %global amd_version_major 2
  5. %global btf_version_major 1
  6. %global camd_version_major 2
  7. %global ccolamd_version_major 2
  8. %global cholmod_version_major 3
  9. %global colamd_version_major 2
  10. %global csparse_version_major 3
  11. %global cxsparse_version_major 3
  12. %global klu_version_major 1
  13. %global ldl_version_major 2
  14. %global rbio_version_major 2
  15. %global spqr_version_major 2
  16. %global SuiteSparse_config_major 5
  17. %global umfpack_version_major 5
  18. ### CXSparse is a superset of CSparse, and the two share common header
  19. ### names, so it does not make sense to build both. CXSparse is built
  20. ### by default, but CSparse can be built instead by defining
  21. ### enable_csparse as 1 below.
  22. %define enable_csparse 0
  23. # Whether to build a separate version of libraries linked against an ILP64 BLAS
  24. %if 0%{?__isa_bits} == 64
  25. %global build64 1
  26. %endif
  27. Name: %{pkg_name}
  28. Version: %{pkg_version}
  29. Release: %{pkg_release}
  30. Summary: A collection of sparse matrix libraries
  31. Summary(ja): 疎行列ライブラリ集
  32. Group: System Environment/Libraries
  33. License: (LGPLv2+ or BSD) and LGPLv2+ and GPLv2+
  34. URL: http://faculty.cse.tamu.edu/davis/suitesparse.html
  35. Source0: http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-%{version}.tar.gz
  36. # # Move #include <math.h> out of StuiteSparse_config.h and into SuiteSparse_config.c
  37. # Patch0: suitesparse-math.patch
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  39. BuildRequires: openblas-devel
  40. %if 0%{?build64}
  41. BuildRequires: openblas64-devel
  42. %endif
  43. BuildRequires: tbb-devel
  44. Provides: ufsparse = %{version}-%{release}
  45. %description
  46. suitesparse is a collection of libraries for computations involving sparse
  47. matrices. The package includes the following libraries:
  48. AMD approximate minimum degree ordering
  49. BTF permutation to block triangular form (beta)
  50. CAMD constrained approximate minimum degree ordering
  51. COLAMD column approximate minimum degree ordering
  52. CCOLAMD constrained column approximate minimum degree ordering
  53. CHOLMOD sparse Cholesky factorization
  54. CSparse a concise sparse matrix package
  55. CXSparse CSparse extended: complex matrix, int and long int support
  56. KLU sparse LU factorization, primarily for circuit simulation
  57. LDL a simple LDL factorization
  58. SQPR a multithread, multifrontal, rank-revealing sparse QR
  59. factorization method
  60. UMFPACK sparse LU factorization
  61. SuiteSparse_config configuration file for all the above packages.
  62. RBio read/write files in Rutherford/Boeing format
  63. %package devel
  64. Summary: Development headers for SuiteSparse
  65. Summary(ja): SuiteSparse の開発用ヘッダファイル集
  66. Group: Development/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. %description devel
  69. The suitesparse-devel package contains files needed for developing
  70. applications which use the suitesparse libraries.
  71. %package static
  72. Summary: Static version of SuiteSparse libraries
  73. Summary(ja): SuiteSparse の静的ライブラリ
  74. Group: Development/Libraries
  75. Requires: %{name}-devel = %{version}-%{release}
  76. %description static
  77. The suitesparse-static package contains the statically linkable
  78. version of the suitesparse libraries.
  79. %if 0%{?build64}
  80. %package -n %{name}64
  81. Summary: A collection of sparse matrix libraries (ILP64 version)
  82. %description -n %{name}64
  83. The suitesparse collection compiled against an ILP64 BLAS library.
  84. %package -n %{name}64-devel
  85. Summary: Development headers for SuiteSparse (ILP64 version)
  86. Requires: %{name}-devel = %{version}-%{release}
  87. Requires: %{name}64 = %{version}-%{release}
  88. %description -n %{name}64-devel
  89. The suitesparse64-devel package contains files needed for developing
  90. applications which use the suitesparse libraries (ILP64 version).
  91. %package -n %{name}64-static
  92. Summary: Static version of SuiteSparse libraries (ILP64 version)
  93. Requires: %{name}-devel = %{version}-%{release}
  94. %description -n %{name}64-static
  95. The suitesparse64-static package contains the statically linkable
  96. version of the suitesparse libraries (ILP64 version).
  97. %package -n %{name}64_
  98. Summary: A collection of sparse matrix libraries (ILP64 version)
  99. %description -n %{name}64_
  100. The suitesparse collection compiled against an ILP64 BLAS library.
  101. %package -n %{name}64_-devel
  102. Summary: Development headers for SuiteSparse (ILP64 version)
  103. Requires: %{name}-devel = %{version}-%{release}
  104. Requires: %{name}64_ = %{version}-%{release}
  105. %description -n %{name}64_-devel
  106. The suitesparse64_-devel package contains files needed for developing
  107. applications which use the suitesparse libraries (ILP64 version) compiled
  108. against a BLAS library with the "64_" symbol name suffix (see openblas-*64_
  109. packages).
  110. %package -n %{name}64_-static
  111. Summary: Static version of SuiteSparse libraries (ILP64 version)
  112. Requires: %{name}-devel = %{version}-%{release}
  113. %description -n %{name}64_-static
  114. The suitesparse64_-static package contains the statically linkable
  115. version of the suitesparse libraries (ILP64 version) compiled against a
  116. BLAS library with the "64_" symbol name suffix (see openblas-*64_ packages).
  117. %endif
  118. %package doc
  119. Summary: Documentation files for SuiteSparse
  120. BuildArch: noarch
  121. Requires: %{name} = %{version}-%{release}
  122. %description doc
  123. This package contains documentation files for %{name}.
  124. %prep
  125. %setup -c -q
  126. pushd SuiteSparse
  127. # Remove bundled metis
  128. rm -r metis*
  129. # Makefiles look for metis.h specifically
  130. ln -s %{_includedir}/metis/*.h include/
  131. # Fix pragma ivdep so gcc understands it.
  132. for fil in $(grep -Frl 'pragma ivdep' .); do
  133. sed -i.orig 's/pragma ivdep/pragma GCC ivdep/' $fil
  134. touch -r ${fil}.orig $fil
  135. rm -f ${fil}.orig
  136. done
  137. # drop non-standard -O3 and duplicate -fexceptions from default CFLAGS
  138. sed -i -e '/^ CF =/ s/ -O3 -fexceptions//' SuiteSparse_config/SuiteSparse_config.mk
  139. # Allow adding a suffix to the library name
  140. sed -i -e '/SO.*=/s/$(LIBRARY).so/$(LIBRARY)$(LIBRARY_SUFFIX).so/' \
  141. -e '/AR_TARGET *=/s/$(LIBRARY).a/$(LIBRARY)$(LIBRARY_SUFFIX).a/' SuiteSparse_config/SuiteSparse_config.mk
  142. sed -i -e 's/-l\(amd\|btf\|camd\|ccolamd\|cholmod\|colamd\|csparse\|cxsparse\|klu\|ldl\|rbio\|spqr\|suitesparseconfig\|umfpack\)/-l\1$(LIBRARY_SUFFIX)/g' \
  143. $(find -name Makefile\* -o -name \*.mk)
  144. popd
  145. %if 0%{?build64}
  146. cp -a SuiteSparse SuiteSparse64
  147. cp -a SuiteSparse SuiteSparse64_
  148. %endif
  149. %build
  150. for build in SuiteSparse %{?build64:SuiteSparse64 SuiteSparse64_}
  151. do
  152. pushd $build
  153. # TODO - Try to use upstream makefile - will build more components
  154. mkdir -p Doc/{AMD,BTF,CAMD,CCOLAMD,CHOLMOD,COLAMD,KLU,LDL,UMFPACK,SPQR,RBio} Include
  155. export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/metis"
  156. export LAPACK=""
  157. # Set flags for ILP64 build
  158. if [ $build = SuiteSparse64 ]
  159. then
  160. export CFLAGS="$CFLAGS -DBLAS64"
  161. export BLAS=-lopenblas64
  162. export LIBRARY_SUFFIX=64
  163. elif [ $build = SuiteSparse64_ ]
  164. then
  165. export CFLAGS="$CFLAGS -DBLAS64 -DSUN64"
  166. export BLAS=-lopenblas64_
  167. export LIBRARY_SUFFIX=64_
  168. else
  169. export BLAS=-lopenblas
  170. fi
  171. # SuiteSparse_config needs to come first
  172. pushd SuiteSparse_config
  173. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  174. cp -p *.h ../Include
  175. popd
  176. pushd AMD
  177. pushd Lib
  178. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  179. popd
  180. cp -p Include/*.h ../Include
  181. cp -p README.txt Doc/License.txt Doc/lesser.txt Doc/ChangeLog Doc/*.pdf ../Doc/AMD
  182. popd
  183. pushd BTF
  184. pushd Lib
  185. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  186. popd
  187. cp -p Include/*.h ../Include
  188. cp -p README.txt Doc/* ../Doc/BTF
  189. popd
  190. pushd CAMD
  191. pushd Lib
  192. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  193. popd
  194. cp -p Include/*.h ../Include
  195. cp -p README.txt Doc/ChangeLog Doc/License.txt Doc/*.pdf ../Doc/CAMD
  196. popd
  197. pushd CCOLAMD
  198. pushd Lib
  199. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  200. popd
  201. cp -p Include/*.h ../Include
  202. cp -p README.txt Doc/* ../Doc/CCOLAMD
  203. popd
  204. pushd COLAMD
  205. pushd Lib
  206. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  207. popd
  208. cp -p Include/*.h ../Include
  209. cp -p README.txt Doc/* ../Doc/COLAMD
  210. popd
  211. pushd CHOLMOD
  212. pushd Lib
  213. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  214. popd
  215. cp -p Include/*.h ../Include
  216. cp -p README.txt Doc/*.pdf ../Doc/CHOLMOD
  217. cp -p Cholesky/lesser.txt ../Doc/CHOLMOD/Cholesky_License.txt
  218. cp -p Core/lesser.txt ../Doc/CHOLMOD/Core_License.txt
  219. cp -p MatrixOps/gpl.txt ../Doc/CHOLMOD/MatrixOps_License.txt
  220. cp -p Partition/lesser.txt ../Doc/CHOLMOD/Partition_License.txt
  221. cp -p Supernodal/gpl.txt ../Doc/CHOLMOD/Supernodal_License.txt
  222. popd
  223. %if "%{?enable_csparse}" == "1"
  224. pushd CSparse
  225. pushd Source
  226. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  227. cp -p cs.h ../../Include
  228. popd
  229. mkdir ../Doc/CSparse/
  230. cp -p Doc/* ../Doc/CSparse
  231. popd
  232. %else
  233. pushd CXSparse
  234. pushd Lib
  235. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  236. popd
  237. cp -p Include/cs.h ../Include
  238. mkdir ../Doc/CXSparse/
  239. cp -p Doc/* ../Doc/CXSparse
  240. popd
  241. %endif
  242. pushd KLU
  243. pushd Lib
  244. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  245. popd
  246. cp -p Include/*.h ../Include
  247. cp -p README.txt Doc/lesser.txt ../Doc/KLU
  248. popd
  249. pushd LDL
  250. pushd Lib
  251. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  252. popd
  253. cp -p Include/*.h ../Include
  254. cp -p README.txt Doc/ChangeLog Doc/lesser.txt Doc/*.pdf ../Doc/LDL
  255. popd
  256. pushd UMFPACK
  257. pushd Lib
  258. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  259. popd
  260. cp -p Include/*.h ../Include
  261. cp -p README.txt Doc/License.txt Doc/ChangeLog Doc/gpl.txt Doc/*.pdf ../Doc/UMFPACK
  262. popd
  263. pushd SPQR
  264. pushd Lib
  265. %make_build CFLAGS="$CFLAGS -DHAVE_TBB -DNPARTITION" TBB=-ltbb \
  266. BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  267. popd
  268. cp -p Include/*.h* ../Include
  269. cp -p README{,_SPQR}.txt
  270. cp -p README_SPQR.txt Doc/* ../Doc/SPQR
  271. popd
  272. pushd RBio
  273. pushd Lib
  274. %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
  275. popd
  276. cp -p Include/*.h ../Include
  277. cp -p README.txt Doc/ChangeLog Doc/License.txt ../Doc/RBio
  278. popd
  279. popd
  280. done
  281. %install
  282. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  283. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  284. cp -a SuiteSparse/Include/*.{h,hpp} ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  285. for build in SuiteSparse %{?build64:SuiteSparse64 SuiteSparse64_}
  286. do
  287. pushd $build
  288. cp -a */Lib/*.a lib/*.so* ${RPM_BUILD_ROOT}%{_libdir}/
  289. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/*.so.*
  290. # collect licenses in one place to ship as base package documentation
  291. rm -rf Licenses
  292. mkdir Licenses
  293. find */ -iname lesser.txt -o -iname license.txt -o -iname gpl.txt -o \
  294. -iname license | while read f; do
  295. b="${f%%/*}"
  296. r="${f#$b}"
  297. x="$(echo "$r" | sed 's|/doc/|/|gi')"
  298. install -m0644 -D "$f" "./Licenses/$b/$x"
  299. done
  300. # hardlink duplicate documentation files
  301. hardlink -cvf Docs/ Licenses/
  302. popd
  303. done
  304. %check
  305. TESTDIRS="AMD CAMD CCOLAMD CHOLMOD COLAMD KLU LDL SPQR RBio UMFPACK"
  306. %if "%{?enable_csparse}" == "1"
  307. TESTDIRS="$TESTDIRS CSparse"
  308. %else
  309. TESTDIRS="$TESTDIRS CXSparse"
  310. %endif
  311. for build in SuiteSparse %{?build64:SuiteSparse64 SuiteSparse64_}
  312. do
  313. pushd $build
  314. export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/metis"
  315. export LAPACK=""
  316. # Set flags for ILP64 build
  317. if [ $build = SuiteSparse64 ]
  318. then
  319. export CFLAGS="$CFLAGS -DBLAS64"
  320. export BLAS=-lopenblas64
  321. export LIBRARY_SUFFIX=64
  322. elif [ $build = SuiteSparse64_ ]
  323. then
  324. export CFLAGS="$CFLAGS -DBLAS64 -DSUN64"
  325. export BLAS=-lopenblas64_
  326. export LIBRARY_SUFFIX=64_
  327. else
  328. export BLAS=-lopenblas
  329. fi
  330. for d in $TESTDIRS ; do
  331. %make_build -C $d/Demo \
  332. CFLAGS="$CFLAGS" LIB="%{?__global_ldflags} -lm -lrt" \
  333. BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX" \
  334. SPQR_CONFIG=-DHAVE_TBB TBB=-ltbb
  335. done
  336. popd
  337. done
  338. %clean
  339. rm -rf ${RPM_BUILD_ROOT}
  340. %post -p /sbin/ldconfig
  341. %postun -p /sbin/ldconfig
  342. %files
  343. %license SuiteSparse/Licenses
  344. %{_libdir}/libamd.so.%{amd_version_major}*
  345. %{_libdir}/libbtf.so.%{btf_version_major}*
  346. %{_libdir}/libcamd.so.%{camd_version_major}*
  347. %{_libdir}/libccolamd.so.%{ccolamd_version_major}*
  348. %{_libdir}/libcholmod.so.%{cholmod_version_major}*
  349. %{_libdir}/libcolamd.so.%{colamd_version_major}*
  350. %if "%{?enable_csparse}" == "1"
  351. %{_libdir}/libcsparse.so.%{csparse_version_major}*
  352. %endif
  353. %{_libdir}/libcxsparse.so.%{cxsparse_version_major}*
  354. %{_libdir}/libklu.so.%{klu_version_major}*
  355. %{_libdir}/libldl.so.%{ldl_version_major}*
  356. %{_libdir}/librbio.so.%{rbio_version_major}*
  357. %{_libdir}/libspqr.so.%{spqr_version_major}*
  358. %{_libdir}/libsuitesparseconfig.so.%{SuiteSparse_config_major}*
  359. %{_libdir}/libumfpack.so.%{umfpack_version_major}*
  360. %files devel
  361. %{_includedir}/%{name}
  362. %{_libdir}/lib*.so
  363. %if 0%{?build64}
  364. %exclude %{_libdir}/lib*64*.so
  365. %endif
  366. %files static
  367. %{_libdir}/lib*.a
  368. %if 0%{?build64}
  369. %exclude %{_libdir}/lib*64*.a
  370. %endif
  371. %if 0%{?build64}
  372. %files -n %{name}64
  373. %license SuiteSparse64/Licenses
  374. %{_libdir}/libamd64.so.%{amd_version_major}*
  375. %{_libdir}/libbtf64.so.%{btf_version_major}*
  376. %{_libdir}/libcamd64.so.%{camd_version_major}*
  377. %{_libdir}/libccolamd64.so.%{ccolamd_version_major}*
  378. %{_libdir}/libcholmod64.so.%{cholmod_version_major}*
  379. %{_libdir}/libcolamd64.so.%{colamd_version_major}*
  380. %if "%{?enable_csparse}" == "1"
  381. %{_libdir}/libcsparse64.so.%{csparse_version_major}*
  382. %endif
  383. %{_libdir}/libcxsparse64.so.%{cxsparse_version_major}*
  384. %{_libdir}/libklu64.so.%{klu_version_major}*
  385. %{_libdir}/libldl64.so.%{ldl_version_major}*
  386. %{_libdir}/librbio64.so.%{rbio_version_major}*
  387. %{_libdir}/libspqr64.so.%{spqr_version_major}*
  388. %{_libdir}/libsuitesparseconfig64.so.%{SuiteSparse_config_major}*
  389. %{_libdir}/libumfpack64.so.%{umfpack_version_major}*
  390. %files -n %{name}64-devel
  391. %{_libdir}/lib*64.so
  392. %files -n %{name}64-static
  393. %{_libdir}/lib*64.a
  394. %files -n %{name}64_
  395. %license SuiteSparse64_/Licenses
  396. %{_libdir}/libamd64_.so.%{amd_version_major}*
  397. %{_libdir}/libbtf64_.so.%{btf_version_major}*
  398. %{_libdir}/libcamd64_.so.%{camd_version_major}*
  399. %{_libdir}/libccolamd64_.so.%{ccolamd_version_major}*
  400. %{_libdir}/libcholmod64_.so.%{cholmod_version_major}*
  401. %{_libdir}/libcolamd64_.so.%{colamd_version_major}*
  402. %if "%{?enable_csparse}" == "1"
  403. %{_libdir}/libcsparse64_.so.%{csparse_version_major}*
  404. %endif
  405. %{_libdir}/libcxsparse64_.so.%{cxsparse_version_major}*
  406. %{_libdir}/libklu64_.so.%{klu_version_major}*
  407. %{_libdir}/libldl64_.so.%{ldl_version_major}*
  408. %{_libdir}/librbio64_.so.%{rbio_version_major}*
  409. %{_libdir}/libspqr64_.so.%{spqr_version_major}*
  410. %{_libdir}/libsuitesparseconfig64_.so.%{SuiteSparse_config_major}*
  411. %{_libdir}/libumfpack64_.so.%{umfpack_version_major}*
  412. %files -n %{name}64_-devel
  413. %{_libdir}/lib*64_.so
  414. %files -n %{name}64_-static
  415. %{_libdir}/lib*64_.a
  416. %endif
  417. %files doc
  418. %doc SuiteSparse/Doc/*
  419. %changelog
  420. * Sun Nov 03 2019 Toshiaki Ara <ara_t@384.jp> 5.4.0-1
  421. - update to 5.4.0
  422. - Build ILP64 version
  423. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 4.4.6-2
  424. - rebuild with gfortran-8.2.0
  425. * Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> 4.4.6-1
  426. - update to 4.4.6
  427. - drop Patch0
  428. * Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.3.1-3
  429. - rebuild with gcc-5.4.0
  430. * Thu Mar 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.1-2
  431. - built with tbb 4.3u3
  432. * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.1-1
  433. - updated to 4.3.1
  434. * Thu Mar 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.7.0-1
  435. - Updated to 3.7.0
  436. * Mon Dec 01 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.6.1-1
  437. - Updated to 3.6.1
  438. * Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.0-3vl5
  439. - applied new versioning policy
  440. * Wed Jan 02 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.1.0-2vl1
  441. - New release.
  442. * Wed Jan 02 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-2vl1
  443. - Rebuild for VineSeed
  444. * Fri Aug 24 2007 Quentin Spencer <qspencer@users.sourceforge.net> 3.0.0-2
  445. - Rebuild for F8.
  446. * Tue Jul 3 2007 Quentin Spencer <qspencer@users.sourceforge.net> 3.0.0-1
  447. - Change package name to match upstream, including provides and obsoletes.
  448. - New release. Numerous changes in build to reflect source reorganization.
  449. - Moved static libs into separate package.
  450. * Mon Oct 16 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.1.1-1
  451. - New release, and package name change from UFsparse to SuiteSparse. Fixes
  452. bug #210846. Keep the ufsparse package name for now.
  453. * Thu Sep 7 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.1.0-1
  454. - New release. Increment versions of some libraries.
  455. - Rearrange and clean up spec file so all definitions are in one place.
  456. * Mon Aug 7 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.0.0-1
  457. - New release.
  458. - Build newly added CAMD library.
  459. - Misc minor spec changes.
  460. * Tue Mar 7 2006 Quentin Spencer <qspencer@users.sourceforge.net> 1.2-1
  461. - New release.
  462. - Build newly added library CXSparse (but not CSparse--see comments
  463. in build section).
  464. * Wed Feb 15 2006 Quentin Spencer <qspencer@users.sourceforge.net> 0.93-2
  465. - Rebuild for Fedora Extras 5.
  466. * Thu Feb 9 2006 Quentin Spencer <qspencer@users.sourceforge.net> 0.93-1
  467. - New release. Remove old patch.
  468. * Wed Dec 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.92-2
  469. - Add patch0--fixes LDL/Makefile so CFLAGS are used when compiling ldl.a.
  470. * Wed Dec 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.92-1
  471. - Update to Dec 8 2005 version.
  472. * Tue Oct 25 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.91-2
  473. - Rebuild.
  474. * Tue Oct 18 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.91-1
  475. - New upstream release, incorporating previous patches
  476. - chmod the build directory to ensure all headers are world readable
  477. * Fri Oct 07 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.9-3
  478. - Build cholmod, but disable METIS using -DNPARTITION flag.
  479. * Sat Oct 01 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.9-2
  480. - Modify description, other modifications for import into FE.
  481. - Add dist tag, cosmetic changes.
  482. * Thu Sep 08 2005 David Bateman <dbateman@free.fr> 0.9-1
  483. - First version.