tzdata-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411
  1. Summary: Timezone data
  2. Summary(ja): タイムゾーンのデータ
  3. Name: tzdata
  4. Version: 2019c
  5. %define tzdata_version 2019c
  6. %define tzcode_version 2019c
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Base
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: Public Domain
  12. URL: https://www.iana.org/time-zones
  13. # These are official upstream.
  14. Source0: https://data.iana.org/time-zones/releases/tzdata%{tzdata_version}.tar.gz
  15. Source1: https://data.iana.org/time-zones/releases/tzcode%{tzcode_version}.tar.gz
  16. Source2: javazic.tar.gz
  17. Source3: javazic-1.8-37392f2f5d59.tar.xz
  18. Patch002: 0002-Fix-have-snprintf-error.patch
  19. Patch100: javazic-fixup.patch
  20. Patch101: rebase-01.patch
  21. Patch102: rebase-02.patch
  22. Patch103: 7090844.patch
  23. Patch104: 7133138.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildArch: noarch
  26. BuildRequires: gawk, glibc, perl
  27. BuildRequires: java-1.8.0-openjdk-devel
  28. BuildRequires: glibc-common >= 2.5.90-7
  29. Conflicts: glibc-common <= 2.3.2-63
  30. %description
  31. This package contains data files with rules for various timezones around
  32. the world.
  33. %description -l ja
  34. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  35. %package java
  36. Summary: Timezone data for Java
  37. Group: System Environment/Base
  38. %description java
  39. This package contains timezone information for use by Java runtimes.
  40. %prep
  41. %setup -q -c -a 1
  42. %patch002 -p1
  43. # tzdata-2018g introduce 25:00 transition times. This breaks OpenJDK.
  44. # Use rearguard for tzdata-2018g java
  45. mkdir rearguard
  46. make VERSION=%{version} tzdata%{version}-rearguard.tar.gz
  47. mv tzdata%{version}-rearguard.tar.gz rearguard
  48. pushd rearguard
  49. tar zxf tzdata%{version}-rearguard.tar.gz
  50. popd
  51. mkdir javazic
  52. tar zxf %{SOURCE2} -C javazic
  53. pushd javazic
  54. %patch100
  55. %patch101
  56. %patch102
  57. %patch103
  58. %patch104
  59. # Hack alert! sun.tools may be defined and installed in the
  60. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  61. # for creating the zoneinfo files, rebase all the packages
  62. # from "sun." to "rht.". Unfortunately, gcj does not support
  63. # any of the -Xclasspath options, so we must go this route
  64. # to ensure the greatest compatibility.
  65. mv sun rht
  66. find . -type f -name '*.java' -print0 \
  67. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  68. -e 's:sun\.util\.:rht.util.:g'
  69. popd
  70. tar xf %{SOURCE3}
  71. echo "%{name}%{tzdata_version}" >> VERSION
  72. %build
  73. # Run make to create the tzdata.zi file
  74. make tzdata.zi
  75. FILES="africa antarctica asia australasia europe northamerica southamerica
  76. pacificnew etcetera backward"
  77. mkdir zoneinfo/{,posix,right}
  78. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  79. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  80. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  81. # tzdata-2018g uses 25:00 which breaks java - use the rearguard files for java
  82. JAVA_FILES="rearguard/africa rearguard/antarctica rearguard/asia \
  83. rearguard/australasia rearguard/europe rearguard/northamerica \
  84. rearguard/southamerica rearguard/pacificnew rearguard/etcetera \
  85. rearguard/backward"
  86. # Java 6/7 tzdata
  87. pushd javazic
  88. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  89. popd
  90. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  91. -d javazi \
  92. $JAVA_FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  93. # Java 8 tzdata
  94. pushd javazic-1.8
  95. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  96. popd
  97. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  98. -srcdir . -dstfile tzdb.dat \
  99. -verbose \
  100. $JAVA_FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  101. %install
  102. rm -fr $RPM_BUILD_ROOT
  103. install -d $RPM_BUILD_ROOT%{_datadir}
  104. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  105. install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  106. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  107. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  108. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  109. %clean
  110. rm -fr $RPM_BUILD_ROOT
  111. %files
  112. %defattr(-,root,root)
  113. %{_datadir}/zoneinfo
  114. %license LICENSE
  115. %doc README
  116. %doc theory.html
  117. %doc tz-link.html
  118. %doc tz-art.html
  119. %files java
  120. %defattr(-,root,root)
  121. %{_datadir}/javazi
  122. %{_datadir}/javazi-1.8
  123. %changelog
  124. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2019c-1
  125. - updated to 2019c.
  126. * Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2018i-1
  127. - updated to 2018i.
  128. * Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
  129. - update to 2017b
  130. * Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
  131. - updated to 2016j.
  132. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
  133. - fixed changelog.
  134. - added Vendor and Distribution tag.
  135. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
  136. - updated to 2016f.
  137. * Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
  138. - updated to 2016e.
  139. - enabled java18 stuff.
  140. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
  141. - updated to 2016d.
  142. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  143. - updated to 2015f.
  144. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  145. - updated to 2015e.
  146. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  147. - update to tzdata-2012c, tzcode-2012b
  148. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  149. - rebuilt with rpm-4.8.1-3
  150. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  151. - update to tzdata-2010l, tzcode-2010l
  152. - added java subpackage
  153. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  154. - update to tzdata-2009d, tzcode-2009d
  155. - spec in utf-8
  156. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  157. - update to tzdata-2008b, tzcode-2008a
  158. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  159. - initial build for VineSeed
  160. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  161. - Upstream 2007d
  162. - Mongolia has abolished DST.
  163. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  164. than 01:00 standard time.
  165. - Cuba observed DST starting Sunday.
  166. - Resolute, Nunavut switched from Central to Eastern time last
  167. November.
  168. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  169. - Upstream 2007c
  170. - Pulaski County, Indiana, switched back to eastern time.
  171. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  172. - Upstream 2007b
  173. - Changes to the commentary in "leapseconds".
  174. - Upstream 2007a
  175. - Updates to Bahamas, they will be in sync with 2007 US DST change
  176. - New zone Australia/Eucla
  177. - Africa/Asmera renamed to Africa/Asmara, link created
  178. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  179. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  180. - Upstream 2006p
  181. - Covers changes from 2006m-2 and 2006m-3
  182. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  183. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  184. - Patch for Western Australia DST trial
  185. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  186. - Proposed upstream patch (#210058)
  187. - Jordan will switch to winter time on October 27, not September 29
  188. - Brazil's DST this year is the first Sunday in November to the last
  189. Sunday in February. (Thanks to Frederico A. C. Neves.)
  190. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  191. - Commentary and past timestamps changes
  192. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  193. - Upstream 2006m:
  194. - Adjustments for Egypt, Palestine, Uruguay
  195. - Better description of `until' field in zic (8) manpage
  196. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  197. - Upstream 2006k, 2006l:
  198. - Adjustments for Egypt, Palestine, Cuba, Honduras
  199. - Documentation changes
  200. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  201. - Upstream 2006j
  202. - Honduras stopped observing DST on Monday at 00:00
  203. - America/Bermuda will follow the US's lead next year
  204. - America/Moncton will use US-style rules next year
  205. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  206. year
  207. - New zone: America/Atikokan instead of America/Coral_Harbour
  208. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  209. - Historical changes
  210. - Commentary updates
  211. - Upstream 2006i
  212. - localtime.c fixes
  213. - Upstream 2006h
  214. - zic leapsecond fix
  215. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  216. - rebuild
  217. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  218. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  219. - Nicaragua updates
  220. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  221. - Upstream 2006f
  222. - America/Guatemala observes DST between Apr/30 and Oct/1
  223. - Historical changes for Nicaragua
  224. - Update of America/Indiana/Vincennes in zone table
  225. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  226. - Upstream 2006d
  227. - Haiti observes DST
  228. - Sri Lanka change actually took effect Apr/15
  229. - All Canada is now scheduled for 2007 US DST rules
  230. - Some historical fixes
  231. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  232. - Upstream 2006c
  233. - Time-related changes:
  234. - dozens of historical and commentary changes
  235. - Iran stopped observing DST
  236. - Sri Lanka switches from UTC+6 to UTC+5:30
  237. - America/Thule and America/Edmonton will adopt new US rules,
  238. starting 2007
  239. - Tunisia is adopting regular DST
  240. - Code:
  241. - asctime.c: Chages in format strings to silent gcc warnings
  242. - removing K&R notation from function signatures
  243. - few fixes across the code
  244. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  245. - Patch for Sri Lanka time zone change (#184514)
  246. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  247. - Upstream 2006b:
  248. - using tz64code version, as 32 is legacy according to tzdata ML
  249. - new manual pages for ctime, strftime, tzset
  250. - some source code reorganizations
  251. - no timezone/dst rule updates
  252. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  253. - Small changes in tst-timezone.c
  254. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  255. - Upstream 2006a:
  256. - private.h(scheck): changing char* to char const*
  257. - Rule changes for Palestine, zone changes for Indiana/US, both
  258. changes for Canada.
  259. - Many related doc changes.
  260. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  261. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  262. - 2005r-3
  263. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  264. so that it won't clash across updates.
  265. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  266. - 2005r
  267. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  268. northamerica to guard against old files with obsolete information
  269. being left in the time zone binary directory.
  270. - Changes for countries that are supposed to join 2007 US DST
  271. change. This includes most of Canada, however entries already in
  272. the database (Alberta, British Columbia, Newfoundland, Northwest
  273. Territories, and Yukon) were left alone for the time being.
  274. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  275. is checked for emptiness.
  276. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  277. - 2005q
  278. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  279. - SystemV timezone changes
  280. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  281. - 2005n
  282. - changes for Kyrgyzstan and Uruguay
  283. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  284. make check), update tst-timezone.c from glibc CVS (#172102)
  285. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  286. - 2005m
  287. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  288. Australia, Kazakhstan
  289. - historical timezone data changes for Japan, Poland, Northern Ireland and
  290. Mali
  291. - timezone name change for East Timor
  292. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  293. - 2005k
  294. - leap seconds update
  295. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  296. - 2005i
  297. - updates for Iran, Haiti and Nicaragua
  298. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  299. - 2005h
  300. - fixes for Kazakhstan
  301. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  302. - 2005g
  303. - fixes for Uruguay
  304. - include README and Theory from tzcode tarball in %{_docdir};
  305. Theory includes a good summary of how the timezone data files
  306. are supposed to be named
  307. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  308. - 2005f
  309. - more updates for Israel, updates for Azerbaijan
  310. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  311. - 2005c
  312. - updates for Israel and Paraguay
  313. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  314. - 2004g (#141107)
  315. - updates for Cuba
  316. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  317. - 2004e (#135194)
  318. - updates for Brazil, Uruguay and Argentina
  319. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  320. - 2004b
  321. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  322. - 2003d
  323. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  324. - 2003c
  325. - updates for Brazil (#104840)
  326. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  327. - rebuilt
  328. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  329. - initial package