nginx-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.2.5
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.3
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. %define passenger_version 3.0.17
  51. Source1020: passenger-%{passenger_version}.tar.gz
  52. %define upstream_fair_version 2131c73
  53. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  54. %define mod_wsgi_version 6975f0ec7eeb
  55. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  56. # removes -Werror in upstream build scripts. -Werror conflicts with
  57. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  58. Patch0: nginx-auto-cc-gcc.patch
  59. # configuration patch to match all the Vine Linux paths for logs, pid files
  60. # etc.
  61. Patch1: nginx-conf.patch
  62. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  63. BuildRequires: pcre-devel
  64. BuildRequires: zlib-devel
  65. BuildRequires: openssl-devel
  66. BuildRequires: gd-devel
  67. BuildRequires: perl
  68. BuildRequires: perl(ExtUtils::Embed)
  69. BuildRequires: libxml2-devel
  70. BuildRequires: libxslt-devel
  71. BuildRequires: curl-devel
  72. %if %{with geoip}
  73. BuildRequires: GeoIP-devel
  74. %endif
  75. %if "%{?_dist_release}" == "vl4"
  76. Requires: perl >= 5.8.6
  77. %else
  78. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  79. %endif
  80. # for /usr/sbin/useradd
  81. Requires(pre): shadow-utils
  82. Requires(post): chkconfig
  83. # for /sbin/service
  84. Requires(preun): chkconfig, initscripts
  85. Requires(postun): initscripts
  86. %if "%{_dist_release}" > "vl6"
  87. Requires(pre): www-common
  88. %endif
  89. Provides: webserver
  90. Vendor: Project Vine
  91. Distribution: Vine Linux
  92. Packager: daisuke
  93. %description
  94. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  95. proxy server written by Igor Sysoev.
  96. %description -l ja
  97. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  98. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  99. - HTTP(S) サーバ
  100. - HTTP(S) リバースプロキシサーバ
  101. - IMAP/POP3 プロキシサーバ
  102. %package passenger
  103. Summary: Nginx with mod_passenger support
  104. Summary(ja): Passenger サポート入りの Nginx
  105. Group: System Environment/Daemons
  106. BuildRequires: ruby, rubygem-rake
  107. Requires: ruby, rubygem-rake
  108. %if "%{_dist_release}" >= "vl7"
  109. BuildRequires: ruby-devel, ruby-rubygems
  110. Requires: ruby-rubygems
  111. %else
  112. BuildRequires: rubygems
  113. Requires: rubygems
  114. %endif
  115. Requires: nginx
  116. %description passenger
  117. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  118. This package contains nginx server with passenger support.
  119. %description -l ja passenger
  120. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  121. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  122. - HTTP(S) サーバ
  123. - HTTP(S) リバースプロキシサーバ
  124. - IMAP/POP3 プロキシサーバ
  125. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  126. %prep
  127. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  128. %patch0 -p0
  129. %patch1 -p1
  130. %build
  131. # nginx does not utilize a standard configure script. It has its own
  132. # and the standard configure options cause the nginx configure script
  133. # to error out. This is is also the reason for the DESTDIR environment
  134. # variable. The configure script(s) have been patched (Patch1 and
  135. # Patch2) in order to support installing into a build environment.
  136. export DESTDIR=%{buildroot}
  137. ## build with passenger
  138. ./configure \
  139. --user=%{nginx_user} \
  140. --group=%{nginx_group} \
  141. --prefix=%{nginx_datadir} \
  142. --sbin-path=%{_sbindir}/%{name} \
  143. --conf-path=%{nginx_confdir}/%{name}.conf \
  144. --error-log-path=%{nginx_logdir}/error.log \
  145. --http-log-path=%{nginx_logdir}/access.log \
  146. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  147. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  148. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  149. --pid-path=%{_localstatedir}/run/%{name}.pid \
  150. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  151. --with-file-aio \
  152. --with-ipv6 \
  153. --with-http_ssl_module \
  154. --with-http_realip_module \
  155. --with-http_addition_module \
  156. --with-http_xslt_module \
  157. --with-http_image_filter_module \
  158. --with-http_sub_module \
  159. --with-http_dav_module \
  160. --with-http_flv_module \
  161. --with-http_gzip_static_module \
  162. --with-http_random_index_module \
  163. --with-http_secure_link_module \
  164. --with-http_stub_status_module \
  165. --with-http_perl_module \
  166. %if %{with geoip}
  167. --with-http_geoip_module \
  168. %endif
  169. --with-mail \
  170. --with-mail_ssl_module \
  171. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  172. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  173. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  174. %if %{with wsgi}
  175. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  176. %endif
  177. --add-module=passenger-%{passenger_version}/ext/nginx \
  178. %ifarch i686
  179. --with-cpu-opt=pentiumpro \
  180. --with-zlib-asm=pentiumpro \
  181. --with-md5-asm \
  182. --with-sha1-asm \
  183. %endif
  184. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  185. make %{?_smp_mflags}
  186. mv objs/nginx objs/nginx.passenger
  187. ## build without passenger
  188. ./configure \
  189. --user=%{nginx_user} \
  190. --group=%{nginx_group} \
  191. --prefix=%{nginx_datadir} \
  192. --sbin-path=%{_sbindir}/%{name} \
  193. --conf-path=%{nginx_confdir}/%{name}.conf \
  194. --error-log-path=%{nginx_logdir}/error.log \
  195. --http-log-path=%{nginx_logdir}/access.log \
  196. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  197. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  198. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  199. --pid-path=%{_localstatedir}/run/%{name}.pid \
  200. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  201. --with-file-aio \
  202. --with-ipv6 \
  203. --with-http_ssl_module \
  204. --with-http_realip_module \
  205. --with-http_addition_module \
  206. --with-http_xslt_module \
  207. --with-http_image_filter_module \
  208. --with-http_sub_module \
  209. --with-http_dav_module \
  210. --with-http_flv_module \
  211. --with-http_gzip_static_module \
  212. --with-http_random_index_module \
  213. --with-http_secure_link_module \
  214. --with-http_stub_status_module \
  215. --with-http_perl_module \
  216. %if %{with geoip}
  217. --with-http_geoip_module \
  218. %endif
  219. --with-mail \
  220. --with-mail_ssl_module \
  221. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  222. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  223. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  224. %if %{with wsgi}
  225. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  226. %endif
  227. %ifarch i686
  228. --with-cpu-opt=pentiumpro \
  229. --with-zlib-asm=pentiumpro \
  230. --with-md5-asm \
  231. --with-sha1-asm \
  232. %endif
  233. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  234. make %{?_smp_mflags}
  235. %install
  236. rm -rf %{buildroot}
  237. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  238. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  239. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  240. find %{buildroot} -type f -empty -exec rm -f {} \;
  241. find %{buildroot} -type f -exec chmod 0644 {} \;
  242. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  243. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  244. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  245. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  246. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  247. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  248. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  249. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  250. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  251. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  252. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  253. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  254. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  255. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  256. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  257. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  258. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  259. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  260. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  261. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  262. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  263. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  264. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  265. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  266. %if %{with wsgi}
  267. %{__install} -p -m 0644 \
  268. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  269. %{buildroot}%{nginx_confdir}
  270. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  271. %endif
  272. # upstream fair module document
  273. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  274. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  275. # convert to UTF-8 all files that give warnings.
  276. for textfile in CHANGES
  277. do
  278. mv $textfile $textfile.old
  279. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  280. rm -f $textfile.old
  281. done
  282. %clean
  283. rm -rf %{buildroot}
  284. %post
  285. if [ $1 == 1 ]; then
  286. /sbin/chkconfig --add %{name}
  287. fi
  288. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  289. %post passenger
  290. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  291. %preun
  292. if [ $1 = 0 ]; then
  293. /sbin/service %{name} stop >/dev/null 2>&1
  294. /sbin/chkconfig --del %{name}
  295. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  296. fi
  297. %preun passenger
  298. if [ $1 = 0 ]; then
  299. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  300. fi
  301. %postun
  302. if [ $1 == 2 ]; then
  303. /sbin/service %{name} upgrade || :
  304. fi
  305. %files
  306. %defattr(-,root,root,-)
  307. %doc LICENSE CHANGES README
  308. %doc README.upstream_fair
  309. %doc %{?with_wsgi:README.mod_wsgi}
  310. %{nginx_datadir}/
  311. %{_sbindir}/%{name}.normal
  312. %{_mandir}/man3/%{name}.3pm.gz
  313. %{_initrddir}/%{name}
  314. %dir %{nginx_confdir}
  315. %dir %{nginx_confdir}/conf.d
  316. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  317. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  318. %config(noreplace) %{nginx_confdir}/sites.d/*
  319. %config(noreplace) %{nginx_confdir}/win-utf
  320. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  321. %config(noreplace) %{nginx_confdir}/mime.types.default
  322. %config(noreplace) %{nginx_confdir}/fastcgi_params
  323. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  324. %config(noreplace) %{nginx_confdir}/koi-win
  325. %config(noreplace) %{nginx_confdir}/koi-utf
  326. %config(noreplace) %{nginx_confdir}/%{name}.conf
  327. %config(noreplace) %{nginx_confdir}/mime.types
  328. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  329. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  330. %config(noreplace) %{nginx_confdir}/scgi_params
  331. %config(noreplace) %{nginx_confdir}/scgi_params.default
  332. %config(noreplace) %{nginx_confdir}/uwsgi_params
  333. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  334. %if %{with wsgi}
  335. %config(noreplace) %{nginx_confdir}/wsgi_vars
  336. %endif
  337. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  338. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  339. %dir %{perl_vendorarch}/auto/%{name}
  340. %{perl_vendorarch}/%{name}.pm
  341. %{perl_vendorarch}/auto/%{name}/%{name}.so
  342. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  343. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  344. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  345. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  346. %files passenger
  347. %defattr(-,root,root,-)
  348. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  349. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  350. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  351. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  352. %doc passenger-%{passenger_version}/doc/template
  353. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  354. %doc passenger-%{passenger_version}/doc/images
  355. %{_sbindir}/%{name}.passenger
  356. %changelog
  357. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  358. - new upstream release
  359. - update passenger to 3.0.17
  360. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  361. - rebuild with pcre-8.31
  362. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  363. - added http_geoip_module.
  364. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  365. - update to 1.2.4
  366. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  367. - update to 1.2.2
  368. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  369. - update to 1.2.1
  370. - change nginx user from nginx to www-data
  371. - R(pre): www-common
  372. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  373. - update to 1.2.0
  374. - update passenger to 3.0.12
  375. - drop http_upstream_keepalive
  376. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  377. - new upstream release
  378. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  379. - update to 1.0.12
  380. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  381. - update to 1.0.11
  382. - update passenger to 3.0.11
  383. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  384. - update to 1.0.10
  385. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  386. - update passenger to 3.0.9
  387. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  388. - update to 1.0.6
  389. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  390. - update to 1.0.4
  391. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  392. - add gnosek-nginx-upstream-fair module
  393. - add ngx_http_upstream_keepalive module
  394. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  395. - add nginx-passenger sub pakckage
  396. - use alternatives to choose nginx with or without passenger
  397. - add BR: ruby, rubygems, rubygem-rake
  398. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  399. - update to 1.0.2
  400. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  401. - update to 1.0.1
  402. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  403. - add bcond_with wsgi for mod_wsgi
  404. - add bcond_with passenger
  405. - you need to install rake.gem to build with this option.
  406. - add Provides: webserver
  407. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  408. - new upstream release 1.0.0!
  409. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  410. - rebuild with perl-5.12.3
  411. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  412. - update to 0.8.54
  413. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  414. - update to 0.8.53
  415. - add nginx_accept_language_module
  416. * Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  417. - update to 0.8.50
  418. - update ngx-fancyindex to 0.3
  419. - add BR: libxml2-devel, libxslt-devel
  420. - add scgi_params* and uwsgi_params* to %%files
  421. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  422. - update to 0.8.35 (development version)
  423. - add sites.d/ to store vitualhost settings
  424. - split out default server settings to sites.d/default
  425. - add fancyindex module
  426. * Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  427. - new upstream release
  428. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  429. - update to 0.7.62 (included security fix: VU#180065)
  430. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  431. - fix typo
  432. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  433. - add translated descriptions
  434. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  435. - update 404.html/50x.html to use powered by vine logo.
  436. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  437. - initial build for Vine Linux
  438. - update to 0.7.61
  439. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  440. - init script updates from Gena Makhomed
  441. - remove nginx-upstream-fair
  442. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  443. - update to 0.6.36
  444. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  445. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  446. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  447. - rebuild
  448. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  449. - update to 0.6.35
  450. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  451. - rebuild with new openssl
  452. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  453. - update to 0.6.34
  454. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  455. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  456. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  457. - update to 0.6.33
  458. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  459. - update to 0.6.32
  460. - nginx now supports DESTDIR so removed the patches that enabled it
  461. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  462. - init script fixes
  463. - resolve 'listen 80 default' [#447873]
  464. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  465. - update to 0.6.31
  466. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  467. - upate to new upstream stable branch 0.6
  468. - added 3rd party module nginx-upstream-fair
  469. - added default webpages
  470. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  471. - update init script to match recommended guidelines
  472. - add /etc/nginx/conf.d support [#443280]
  473. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  474. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  475. - add Requires for versioned perl (libperl.so)
  476. - drop silly file Requires
  477. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  478. - Autorebuild for GCC 4.3
  479. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  480. - update to 0.5.35
  481. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  482. - update to 0.5.34
  483. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  484. - Rebuild for deps
  485. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  486. - update to 0.5.33
  487. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  488. - updated to 0.5.32
  489. - fixed rpmlint UTF-8 complaints.
  490. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  491. - added --with-http_stub_status_module build option.
  492. - added --with-http_sub_module build option.
  493. - added use of pcre-config --cflags
  494. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  495. - Update to 0.5.31
  496. - specify license is BSD
  497. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  498. - Add BuildRequires: perl-devel - fixing rawhide build
  499. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  500. - Update to 0.5.30
  501. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  502. - Update to 0.5.29
  503. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  504. - Update to 0.5.28
  505. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  506. - Update to 0.5.27
  507. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  508. - Update to 0.5.26
  509. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  510. - Update to 0.5.19
  511. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  512. - Update to 0.5.17
  513. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  514. - Update to 0.5.16
  515. - add ownership of /usr/share/nginx/html (#233950)
  516. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  517. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  518. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  519. - fixed package review bugs (#233522) given by kevin@tummy.com
  520. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  521. - create patches to assist with building for Fedora
  522. - initial packaging for Fedora