totem-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.34.0
  5. %define _gtk_ver 3.4.0
  6. %define _gnomeicon_ver 3.4.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.4.0
  9. %define _gst_ver 0.11.93
  10. %define _gstpb_ver 0.11.93
  11. %define _gstpg_ver 0.11.93
  12. %define _gstpbad_ver 0.11.93
  13. %define _xulrunner_ver 1.9
  14. %define _nautilus_ver 3.4.0
  15. %define _shared_mime_info_ver 0.17
  16. %define _unique_ver 1.0
  17. %define _totem_pl_parser_ver 2.32.0
  18. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  19. %define mozplug_dir %{_libdir}/mozilla/plugins
  20. Summary: Movie player for GNOME 3
  21. Summary(ja): GNOME3 用動画プレイヤー
  22. Name: totem
  23. Version: 3.6.3
  24. Release: 1%{?_dist_release}
  25. License: GPL
  26. Group: Applications/Multimedia
  27. URL: http://www.gnome.org/projects/totem/
  28. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/3.6/totem-%{version}.tar.xz
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: Takemikaduchi
  33. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: dbus-devel >= %{_dbus_ver}
  36. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  37. BuildRequires: gettext, scrollkeeper
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  41. BuildRequires: grilo-devel
  42. BuildRequires: bluez-libs-devel >= 4.15
  43. BuildRequires: lirc
  44. BuildRequires: unique-devel >= %{_unique_ver}
  45. BuildRequires: python-devel
  46. BuildRequires: pylint
  47. BuildRequires: pygobject3-devel
  48. BuildRequires: libpeas-devel
  49. BuildRequires: libXtst-devel
  50. BuildRequires: gsettings-desktop-schemas-devel
  51. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  52. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  53. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  54. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  55. BuildRequires: gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
  56. BuildRequires: clutter-gtk-devel
  57. BuildRequires: clutter-gst-devel
  58. BuildRequires: libmx-devel
  59. %if %{build_plugin}
  60. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  61. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  62. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  63. %endif
  64. Requires: gstreamer1 >= %{_gst_ver}
  65. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  66. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  67. Requires: gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
  68. Requires: iso-codes
  69. Obsoletes: nautilus-media
  70. Obsoletes: %{name}-gstreamer < 2.30.1-2
  71. Obsoletes: %{name}-xine < 2.30.1-2
  72. Obsoletes: %{name}-common < 2.30.1-3
  73. Provides: nautilus-media
  74. Provides: %{name}-common = %{version}-%{release}
  75. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  76. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils
  77. Requires(preun): GConf2
  78. %description
  79. Totem is simple movie player for the Gnome desktop. It features a
  80. simple playlist, a full-screen mode, seek and volume controls, as well as
  81. a pretty complete keyboard navigation.
  82. %if %{build_plugin}
  83. %package mozilla
  84. Summary: Totem movie plugin for Mozilla
  85. Summary(ja): Mozilla 用 Totem 動画プラグイン
  86. Group: Applications/Internet
  87. Requires: %{name} = %{version}-%{release}
  88. Obsoletes: %{name}-mozilla-common
  89. Obsoletes: %{name}-mozilla-gstreamer
  90. Obsoletes: %{name}-mozilla-xine
  91. %description mozilla
  92. Totem is simple movie player for the Gnome desktop. It features a
  93. simple playlist, a full-screen mode, seek and volume controls, as well as
  94. a pretty complete keyboard navigation.
  95. This package contains a Totem video plugin for Mozilla. It allows Totem
  96. movie player to be embedded into a web browser.
  97. %endif
  98. %package devel
  99. Summary: Plugin writer's documentation for totem
  100. Group: Development/Libraries
  101. Requires: %{name} = %{version}-%{release}
  102. %description devel
  103. The %{name}-devel package contains API documentation for
  104. developing developing plugins for %{name}.
  105. %prep
  106. %setup -q
  107. %build
  108. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  109. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  110. %configure \
  111. --disable-scrollkeeper \
  112. --enable-python \
  113. --disable-vala \
  114. --enable-nautilus \
  115. --enable-gmp-plugin \
  116. --enable-narrowspace-plugin \
  117. --enable-mully-plugin \
  118. --disable-vegas-plugin \
  119. %if %{build_plugin}
  120. --enable-browser-plugins
  121. %else
  122. --disable-browser-plugins
  123. %endif
  124. make %{?_smp_mflags}
  125. %install
  126. rm -rf $RPM_BUILD_ROOT
  127. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  128. make install DESTDIR=$RPM_BUILD_ROOT
  129. # remove unneeded files
  130. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  131. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  132. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  133. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  134. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  135. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  136. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  137. # remove unused file
  138. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  139. %find_lang %{name} --with-gnome
  140. # save space by linking identical images in translated docs
  141. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  142. for f in $helpdir/C/figures/*.png; do
  143. b="$(basename $f)"
  144. for d in $helpdir/*; do
  145. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  146. g="$d/figures/$b"
  147. if [ -f "$g" ]; then
  148. if cmp -s $f $g; then
  149. rm "$g"; ln -s "../../C/figures/$b" "$g"
  150. fi
  151. fi
  152. fi
  153. done
  154. done
  155. %clean
  156. %__rm -rf %{buildroot}
  157. %post
  158. %{_bindir}/scrollkeeper-update -q
  159. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  160. touch %{_datadir}/icons/hicolor
  161. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  162. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  163. fi
  164. %postun
  165. %{_bindir}/scrollkeeper-update -q
  166. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  167. touch %{_datadir}/icons/hicolor
  168. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  169. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  170. fi
  171. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  172. %posttrans
  173. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  174. %files -f %{name}.lang
  175. %defattr(-,root,root,-)
  176. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  177. %{_bindir}/totem
  178. %{_bindir}/totem-audio-preview
  179. %{_bindir}/totem-video-thumbnailer
  180. %{_datadir}/GConf/gsettings/opensubtitles.convert
  181. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  182. %{_datadir}/GConf/gsettings/totem.convert
  183. %{_datadir}/applications/%{name}.desktop
  184. %{_datadir}/glib-2.0/schemas/*.xml
  185. %{_datadir}/icons/*/*/*/*
  186. %{_datadir}/thumbnailers/totem.thumbnailer
  187. %{_datadir}/%{name}
  188. %{_datadir}/gtk-doc/html/totem
  189. %{_libdir}/libtotem.so.*
  190. %{_libdir}/girepository-1.0/*.typelib
  191. %dir %{_libdir}/totem
  192. %dir %{_libdir}/totem/plugins
  193. %{_libdir}/totem/plugins/apple-trailers/
  194. %{_libdir}/totem/plugins/autoload-subtitles
  195. %{_libdir}/totem/plugins/brasero-disc-recorder
  196. %{_libdir}/totem/plugins/chapters
  197. %{_libdir}/totem/plugins/dbus
  198. %{_libdir}/totem/plugins/grilo
  199. %{_libdir}/totem/plugins/gromit
  200. %{_libdir}/totem/plugins/lirc
  201. %{_libdir}/totem/plugins/media-player-keys
  202. %{_libdir}/totem/plugins/ontop
  203. %{_libdir}/totem/plugins/opensubtitles
  204. %{_libdir}/totem/plugins/properties
  205. %{_libdir}/totem/plugins/pythonconsole
  206. %{_libdir}/totem/plugins/recent
  207. %{_libdir}/totem/plugins/screensaver
  208. %{_libdir}/totem/plugins/screenshot
  209. %{_libdir}/totem/plugins/skipto
  210. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  211. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  212. %{_libdir}/totem/plugins/save-file/libsave-file.so
  213. %{_libdir}/totem/plugins/save-file/save-file.plugin
  214. %if %{build_plugin}
  215. %{_libdir}/nautilus/extensions-3.0/*.so*
  216. %endif
  217. %{_libexecdir}/%{name}/totem-bugreport.py
  218. %{_mandir}/man1/*
  219. %if %{build_plugin}
  220. %files mozilla
  221. %defattr(-,root,root,-)
  222. %{mozplug_dir}/*
  223. %{_libexecdir}/totem-plugin-viewer
  224. %endif
  225. %files devel
  226. %defattr(-, root, root,-)
  227. %{_includedir}/totem
  228. %{_libdir}/libtotem.so
  229. %{_libdir}/pkgconfig/totem.pc
  230. %{_datadir}/gir-1.0/Totem-1.0.gir
  231. %{_datadir}/gtk-doc/html/totem
  232. %changelog
  233. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  234. - new upstream release
  235. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  236. - new upstream release
  237. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  238. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  239. - new upstream release
  240. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  241. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  242. - new upstream release
  243. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  244. - add configure option (--disable-vegas-plugin)
  245. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  246. - new upstream release
  247. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  248. - new upstream release
  249. - add BuildRequires: pylint
  250. - remove BuildRequires: libgdata-devel
  251. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  252. - new upstream release
  253. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  254. - new upstream release
  255. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  256. - new upstream release
  257. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  258. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  259. - new upstream release
  260. - change BuildRequires: gtk3-devel instead of gtk2-devel
  261. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  262. clutter-gst-devel, libmx-devel
  263. - change configure option (--disable-vala)
  264. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  265. - new upstream release
  266. - fix %files
  267. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  268. - new upstream release
  269. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  270. - clean up spec file
  271. - remove totem-common and merged to totem main package.
  272. - add Obsoletes: totem-common
  273. - remove unneeded BR: and R:
  274. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  275. - libmusicbrainz, alternatives
  276. - remove explicit dependency
  277. - gtk2, glib2, dbus
  278. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  279. - add R: gstreamer-plugins-good
  280. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  281. - rebuild with libgdata (add youtube plugin)
  282. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  283. - add Obsolete: totem-gstreamer, totem-xine)
  284. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  285. - new upstream release
  286. - chagnge _gst_ver from 0.10.19 to 0.10.29
  287. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  288. - new upstream release
  289. - drop totem-tracker package
  290. - add BuildRequires: unique-devel
  291. - remove BuildRequires: hal-devel
  292. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  293. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  294. - remove unneeded autoreconf
  295. - add BR: lirc
  296. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  297. - new upstream release
  298. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  299. - remove bemused plugin
  300. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  301. - new upstream release
  302. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  303. - added tracker video search sub-package
  304. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  305. - new upstream release
  306. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  307. - new upstream release
  308. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  309. - remove libxine dependency from totem-common
  310. - build xine backend with minimum dependency
  311. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  312. - add BR: bluez-libs-devel >= 4.15
  313. - fix typo in %%postun xine
  314. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  315. - rebuild with bluez-libs-devel-4.15
  316. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  317. - new upstream release
  318. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  319. - new upstream release
  320. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  321. - new upstream release
  322. - add patch1 to build with xulrunner-1.9
  323. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  324. - new upstream release
  325. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  326. - new upstream release
  327. - disabled devel package (replaced by totem-pl-parser-devel)
  328. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  329. - new upstream release
  330. - update version macros
  331. - enable browser plugins on x86_64
  332. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  333. - new upstream release
  334. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  335. - upstream release
  336. - drop obsolete ja.po.patch (patch0)
  337. - revert change of 1.4.4-0vl2
  338. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  339. - upstream release
  340. - enable browser plugins (exclude x86_64 arch)
  341. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  342. - upstream release
  343. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  344. - update configure options
  345. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  346. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  347. - fix mistranslation (patch0)
  348. - add icon symlink
  349. - add BuildRequires: gstreamer-plugins-good
  350. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  351. - upstream release
  352. - update %%_glib_ver, %%_xine_ver
  353. - add BuildRequires: hal
  354. - update %%configure options
  355. - update %%files
  356. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  357. - upstream release
  358. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  359. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  360. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  361. - upstream release
  362. - drop obsolete patch0
  363. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  364. - upstream release
  365. - add patch0 to build with intltool-0.35
  366. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  367. - upstream release
  368. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  369. - upstream release
  370. - update alternatives entry
  371. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  372. - upstream release
  373. - drop fix-sort-function.patch (was merged to upstream, #331426)
  374. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  375. - rebuild with gnome-2.14rc
  376. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  377. - upstream release
  378. - add macros
  379. - _gtk_ver, _glib_ver
  380. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  381. - _dbus_ver
  382. - _gst_ver, gstpb_ver, _xine_ver
  383. - add fix-sort-function.patch to build with glib < 2.9.1
  384. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  385. - upstream release
  386. - add BuildRequires:
  387. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  388. - gnome-vfs2-devel >= 2.9.92
  389. - dbus-devel >= 0.35
  390. - use gstreamer-0.10 as backend for totem-gstreamer
  391. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  392. - use gstreamer08 instead of gstreamer
  393. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  394. - upstream release
  395. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  396. - fix missing links
  397. - update file list
  398. - update update-alternatives scripts
  399. - fix totem-gstreamer's %%postun script
  400. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  401. - upstream release
  402. - add BuildRequires: iso-codes, libmusicbrainz-devel
  403. - add Requires: iso-codes, libmusicbrains to -common package
  404. - remove BuildRequires: nautilus-cd-burner
  405. - remove Requires: nautilus-cd-burner from -common package
  406. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  407. - totem-gstreamer obsoletes nautilus-media
  408. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  409. - upstream release
  410. - add Requires(post,postun): alternatives for gstreamer,xine
  411. - add Requires(postun,triggers): alternatives for common
  412. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  413. - upstream release
  414. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  415. - build xine backend
  416. - move common files to common package
  417. - move GStreamer related files to gstreamer package
  418. - install xine related files to xine package
  419. - fix scripts
  420. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  421. - upstream release
  422. - update URL
  423. - move *.{a,la} to devel package
  424. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  425. - fix %%{post,preun} script (video-thumbnail.schemas)
  426. - sync with Fedora Core's 1.0.1-1
  427. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  428. - Update to upstream version 1.0.1
  429. - Break out devel package
  430. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  431. - add %%{post,pre}un script
  432. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  433. - initial build for Vine Linux
  434. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  435. - fix %%post
  436. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  437. - Obsolete nautilus-media
  438. - Install property page and thumbnailer
  439. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  440. - Update to 0.101
  441. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  442. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  443. missing menu entry (144088)
  444. - Remove workaround for desktop file being misinstalled, fixed
  445. by above patch
  446. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  447. - New upstream version 0.100
  448. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  449. - update to 0.99.22
  450. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  451. - Add patch to remove removed items from package from help
  452. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  453. - New upstream 0.99.19
  454. - Fixes crasher with CD playback (see NEWS)
  455. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  456. - Call update-desktop-database in post
  457. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  458. - update to 0.99.18
  459. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  460. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>