xchat-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587
  1. # Nobody likely uses this so we disable it
  2. %define with_tclplugin 0
  3. %define name xchat
  4. %define version 2.8.8
  5. %define release 1%{?_dist_release}
  6. Summary: GTK2 based graphical IRC client
  7. Summary(ja): GTK2 ベースのグラフィカル IRC クライアント
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Group: Applications/Internet
  12. License: GPL
  13. URL: http://www.xchat.org/
  14. Source0: http://www.xchat.org/files/source/2.8/xchat-%{version}.tar.xz
  15. #Patch10: http://xchat.org/files/source/2.8/patches/xc286-smallfixes.diff
  16. # Patches 0-9 reserved for official xchat.org patches
  17. Patch12: xchat-1.8.7-use-sysconf-to-detect-cpus.patch
  18. # see #241923
  19. Patch35: xchat-2.8.4-disable-tray-icon-by-default.patch
  20. # Upstream XChat 2.8.6 defaults to Latin1 (what upstream calls the "IRC"
  21. # encoding). Default to UTF-8 instead (as previous versions did, at least when
  22. # running under a UTF-8 locale).
  23. # Both the "IRC" and "UTF-8" settings will try to accept both Latin1 and UTF-8
  24. # when it comes in, however "IRC" sends Latin1, "UTF-8" sends UTF-8.
  25. Patch41: xchat-2.8.6-default-utf8.patch
  26. # patch to add ability to change to tab with most recent activity
  27. # See http://sourceforge.net/tracker/?func=detail&aid=2022871&group_id=239&atid=350239
  28. Patch50: xchat-2.8.6-change-page-activity.patch
  29. # add port numbers for Freenode (Debarshi Ray)
  30. Patch51: xchat-2.8.6-freenode-ports.patch
  31. # work with libnotify 0.7
  32. # https://sourceforge.net/tracker/?func=detail&aid=3109838&group_id=239&atid=100239
  33. Patch52: xchat-2.8.8-libnotify07.patch
  34. # Vine
  35. #Source100: xchat-2.4.5-ja.po
  36. Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
  37. Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
  38. Patch200: xchat-2.8.6_defaultserver-vine.patch
  39. #Patch201: xchat-2.8.6-x86_64.patch
  40. # xchat MUST have the version of perl installed which was used to compile
  41. # it, or else the embeded perl interpreter will break.
  42. Requires: %(perl -le 'use Config; print $Config{archlibexp}')
  43. BuildRequires: glib2-devel >= 2.2.0
  44. BuildRequires: gtk2-devel >= 2.2.0
  45. BuildRequires: bison >= 1.35
  46. BuildRequires: gettext, sed
  47. BuildRequires: perl, python-devel, openssl-devel, pkgconfig
  48. BuildRequires: autoconf
  49. BuildRequires: GConf2-devel
  50. BuildRequires: dbus-devel >= 1.0
  51. BuildRequires: tcl
  52. Requires(post): GConf2 >= 2.14
  53. Requires(preun): GConf2 >= 2.14
  54. Buildroot: %{_tmppath}/%{name}-%{version}-root
  55. %description
  56. X-Chat is an easy to use graphical IRC chat client for the X Window
  57. System.
  58. %description -l ja
  59. X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
  60. %prep
  61. %setup -q
  62. ##%patch10 -p1
  63. %patch12 -p0 -b .use-sysconf-to-detect-cpus
  64. %patch35 -p1 -b .tray-icon
  65. %patch41 -p1 -b .default-utf8
  66. %patch50 -p1 -b .active-channel-switch
  67. %patch51 -p1 -b .freenode-ports
  68. %patch52 -p1 -b .libnotify07
  69. %patch100 -p1 -b .plus
  70. %patch110 -p1 -b .dialog
  71. %patch200 -p1 -b .servlist
  72. #%patch201 -p1 -b .x86_64
  73. sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
  74. sed -i -e 's/GETTEXT_MACRO_VERSION = 0\.17/GETTEXT_MACRO_VERSION = 0.18/g' po/Makefile.in.in
  75. %build
  76. touch NEWS ABOUT-NLS
  77. libtoolize --copy --force
  78. aclocal
  79. automake
  80. autoconf
  81. # Remove CVS files from source dirs so they're not installed into doc dirs.
  82. find . -name CVS -type d | xargs rm -rf
  83. export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
  84. export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
  85. if pkg-config openssl ; then
  86. export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
  87. export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
  88. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  89. fi
  90. %configure --disable-textfe \
  91. --enable-openssl \
  92. --enable-python \
  93. --disable-spell \
  94. %if %{with_tclplugin}
  95. --enable-tcl \
  96. %endif
  97. --enable-ipv6
  98. make %{?_smp_mflags}
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. make DESTDIR=$RPM_BUILD_ROOT install
  102. # Remove unwanted stuff
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  104. rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
  105. #rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
  106. #rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
  107. %find_lang %name
  108. %files -f %{name}.lang
  109. %defattr(-,root,root)
  110. %doc README ChangeLog
  111. %{_sysconfdir}/gconf/schemas/*
  112. %{_bindir}/xchat
  113. %{_libdir}/xchat/plugins/*.so
  114. %{_datadir}/applications/xchat.desktop
  115. %{_datadir}/dbus-1/services/*
  116. %{_datadir}/pixmaps/*
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %post
  120. # Install schema
  121. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  122. gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  123. %pre
  124. if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
  125. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  126. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  127. fi
  128. %preun
  129. if [ "$1" -eq 0 ]; then
  130. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  131. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  132. fi
  133. %changelog
  134. * Sun Mar 27 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.8-1
  135. - new upstream release.
  136. - shipped some patches from Fedora development.
  137. * Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-5
  138. - rebuild with openssl-1.0.0c
  139. - add BuildRequires: tcl
  140. - add Patch201 (xchat-2.8.6-x86_64.patch)
  141. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
  142. - rebuilt with python-2.6.4-3
  143. * Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
  144. - updated Patch200 (Vine channel's default encoding to UTF-8)
  145. * Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
  146. - rebuilt with gtk2-2.16.0
  147. - don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
  148. - add Patch200 (set default server connection for Vine people)
  149. - TODO: update ja.po
  150. * Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
  151. - updated to 2.8.6
  152. - drop/add patches
  153. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
  154. - new versioning policy
  155. - rebuilt with perl-5.10.0
  156. - spec in UTF-8
  157. * Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
  158. - updated to 2.8.4 with updated plus patch and upstream patches (14-16)
  159. * Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
  160. - updated to 2.8.2 with plus patch
  161. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
  162. - rebuild with dbus-1.0
  163. * Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
  164. - build without libsexy.
  165. * Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
  166. - added Patch10 and Patch20 for possible crashes under certain environments
  167. * Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
  168. - updated to 2.6.8 with plus patch
  169. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
  170. - new upstream release
  171. - updated ja.po
  172. - added Patch1 from http://www.xchat.org/files/source/2.4/patches/
  173. - added Patches from Fedora
  174. * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
  175. - Prevent interception of down arrow during Input Method (#144588 tagoh)
  176. * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
  177. - fix plugins on lib64 (#113188 Ville Skytta)
  178. * Tue Jan 4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
  179. - Add Dan Reed's CTCP patch to support multiline messages (#136545)
  180. * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
  181. - #125846 Change xchat.desktop names to "IRC"
  182. * Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
  183. - rebuild with perl-5.8.6-0vl2
  184. * Tue Jul 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
  185. - rebuild with perl-5.8.2-0vl2
  186. - updated ja.po
  187. * Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
  188. - resume othersview patch (Patch21)
  189. * Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
  190. - new upstream release
  191. - updated Patch10
  192. - dropped unneeded patches
  193. - updated ja.po
  194. * Fri Nov 7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
  195. - build with perl-5.8.2
  196. * Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
  197. - build with perl-5.8.1
  198. - change spec file's encoding: shift_jis -> euc-jp
  199. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
  200. - add ja.po
  201. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
  202. - add patch21 from debian to support othersview.
  203. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
  204. - build for Vine Linux based on rawhide
  205. - some parts is merged with Vine Linux 1.8.10-0vl2
  206. * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
  207. - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
  208. - add BuildRequires: automake14, autoconf213
  209. - modified source10 (openprojects has been renamed to freenode)
  210. * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
  211. - upstream update
  212. - updated plus patch
  213. - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
  214. * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
  215. - use source10 instead of patch10 for server list
  216. - default server for #VineUsers changed to OpenProjects Network's
  217. * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
  218. - now with 1.8.8 plus patch
  219. * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
  220. - upstream release
  221. - updated vine-serverlist.patch
  222. - stop to apply plus patch
  223. ( xchat-1.8.4 has the security hole... )
  224. * Tue Oct 2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
  225. - removed backup files for %%patch0 in Document Directory
  226. * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
  227. - updated to 1.8.4 release with plus patch :-)
  228. * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
  229. - upstream release
  230. * Mon Sep 3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  231. - 1.8.3-0vl1
  232. - upstream release
  233. - add xchat-text
  234. - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
  235. * Fri Aug 3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  236. - 1.8.2-0vl1
  237. - upstream release
  238. * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
  239. - 1.8.1-0vl1
  240. - upstream release
  241. - modified server.vine patch
  242. * Sun Jul 15 2001 <sagami@vinelinux.org>
  243. - 1.6.4.1-0vl3: prefix -> _prefix
  244. - OLD_PO_FILE_INPUT=yes to build with new gettext
  245. - use %%{find_lang}
  246. * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  247. - 1.6.4.1-0vl2
  248. - fix CFLAGS for e-paned
  249. * Tue Feb 6 2001 Takuo KITAME <kitame@northeye.org>
  250. - 1.6.3.1-0vl1
  251. - New upstream release
  252. * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
  253. - 1.5.9.4-0vl1
  254. - This is the first release of xchat-plus.
  255. * Mon Jul 3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  256. - added w3m patch
  257. * Wed Apr 12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  258. - updated to 1.4.2
  259. * Thu Mar 14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  260. - updated to 1.4.1
  261. - separated ja_nls patch to more_ja_nls and libjcode patches.
  262. * Sat Mar 04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  263. - modified mb_fix patch for cut & paste.
  264. * Fri Feb 11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  265. - updated to 1.4.0
  266. * Wed Feb 2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  267. - updated to 1.3.13
  268. * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  269. - modified mb_fix patch
  270. * Wed Jan 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  271. - updated to 1.3.10
  272. * Wed Dec 8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  273. - updated to 1.3.8
  274. - added mb_fix patch
  275. * Tue Nov 9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  276. - update to 1.3.6
  277. * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
  278. - merge ja-patch
  279. * Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
  280. - Added back BuildRequires autoconf, and call autoconf prior to ./configure
  281. as it seems to make xchat build successfully. Have not bothered to figure
  282. out why calling autoconf is needed. Something for a rainy day.
  283. * Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
  284. - Removed gnome-libs BuildRequires as it is bogus now
  285. - Removed autoconf BuildRequires and usage, as it should be unneeded
  286. - Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
  287. gtk2-devel >= 2.0.3, /bin/sed (#91676 - Warren Togami)
  288. - Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
  289. * Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
  290. - Removed xchat.desktop file, as it was earlier replacedwith a patch
  291. - Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
  292. instead of the various random legacy mix of encodings it was, updating
  293. the following: es, ko, uk, zh_TW
  294. * Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
  295. - Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
  296. with a more robust and generic solution of querying perl for the archlibexp
  297. dir during building, and requiring it instead
  298. * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
  299. - rebuild against new (old?) perl, add epoch to dependency
  300. * Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
  301. - Updated to new xchat 2.0.2 based on GTK2
  302. - Dropped unneeded patches xchat-1.8.1-konqueror.patch,
  303. xchat-1.8.4-fix-USE_GNOME.patch
  304. - Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
  305. - Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
  306. - Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
  307. desktop file, instead of replacing it and trying to stay in sync
  308. - Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
  309. on lib64 archs, and replaces xchat-multilib.patch
  310. - Added with_tclplugin macro and default it to disabled
  311. * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
  312. - Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
  313. sent to me by Rik van Riel
  314. * Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
  315. - ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
  316. * Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
  317. - Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
  318. to freenode.net in the default server list. Patch courtesy of Dan Burcaw
  319. from bug (#81704)
  320. * Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
  321. - Removed double .desktop file (#81874,82315)
  322. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
  323. - rebuilt
  324. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
  325. - Add bugfix from xchat.org xc1811fixststint.diff
  326. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
  327. - Remove CVS files from source dirs so they're not installed into doc dirs.
  328. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
  329. - Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
  330. - Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
  331. xchat-1.8.10-beep-beep-beep.patch
  332. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
  333. - Pick up OpenSSL configuration from pkgconfig, if available
  334. - Add openssl-devel and pkgconfig as buildreqs
  335. * Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
  336. - Fix broken libpython path on multilibbed systems (patch13)
  337. - _smp_mflags
  338. * Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
  339. - Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
  340. opening a URL in a new tab of an existing browser window rather than a new
  341. window
  342. * Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
  343. - Added BuildRequires: python-devel to hopefully pick up a missing dep
  344. causing package build failure in timp's nightly builds.
  345. - Removed dead patches
  346. - Updated package summary and description to be more user friendly by
  347. rewording, and removing scary words like GNOME, GTK and other irrelevance
  348. * Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
  349. - Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
  350. - Removed some conditional weirdness in %%files list. This may break xchat
  351. erratum releases on Red Hat Linux 7.x. May need to be fixed in future.
  352. * Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
  353. - Added Requires line so that xchat requires the exact version of perl
  354. be installed, that was used to compile it, since the embedded perl
  355. interpreter will break, if you upgrade perl
  356. * Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
  357. - Fix Bill's beep beep beep bug (#71651)
  358. * Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
  359. - actually install the desktop file.
  360. * Fri Aug 9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
  361. - Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
  362. bug with using /ME in a /QUERY window. (#71179)
  363. * Wed Aug 7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
  364. - Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
  365. the xchat client to crash. This is a bugfix only release.
  366. * Tue Aug 6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
  367. - Added Korean fontset support to fix bug (#69771)
  368. * Mon Aug 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
  369. - Enabled python scripting which was somehow disabled somewhere along the
  370. line by default in upstream sources, and we missed catching it. (#70816)
  371. * Sun Aug 4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
  372. - Created new-style net-xchat.desktop file (#69541)
  373. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
  374. - automated rebuild
  375. * Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
  376. - updated the package description
  377. - Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
  378. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  379. - automated rebuild
  380. * Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
  381. - Updated to xchat 1.8.9
  382. * Mon Apr 8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
  383. - Re-enabled GNOME support due to user complaints of pixmaps missing, key
  384. bindings, and other fairly important features no longer working.
  385. * Tue Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
  386. - Disabled GNOME support since it doesn't seem too useful anyways, and forces
  387. all xchat users to install GNOME libs even if they use KDE. (#59626)
  388. - Updated URL and source lines in spec.
  389. * Wed Mar 6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
  390. - Updated to xchat 1.8.8
  391. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
  392. - Built in new buildroot
  393. * Tue Feb 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
  394. - Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
  395. to detect the number of processors available.
  396. * Mon Feb 4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
  397. - Enabled IPv6 support as per the request for enhancement (#52124)
  398. * Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
  399. - Rebuilt in new build environment
  400. * Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
  401. - Updated to xchat 1.8.7
  402. - New release fixes security vulnerability in CTCP reply
  403. - Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
  404. 1.8.7-1.71.0, 1.8.7-1.72.0)
  405. - Removed konqueror patch as it is integrated now.
  406. * Sat Jan 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
  407. - Enabled ssl support with --enable-openssl
  408. - Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
  409. * Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
  410. - Updated to xchat 1.8.6
  411. * Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
  412. - Updated to xchat 1.8.5
  413. - Added f to rm -r in install and clean sections
  414. * Sun Oct 7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
  415. - Updated to 1.8.4, now using tar.bz2
  416. - Removed kanjiconv-fix patch as it is integrated now
  417. - Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
  418. * Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
  419. - fixed check locale.
  420. - don't save kanji_conv.
  421. always check locale. however anyone can change the option from
  422. the settings menu.
  423. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  424. - upgrade to 1.8.1
  425. - remove autoconnect patch since it's upstream
  426. - remove japanese patch, upstream seems to have applied
  427. parts of it and changelog says there's upstream support.
  428. (this patch was pretty huge to maintain in an SRPM anyway...)
  429. - put scripts-python scripts-perl in docs bug #28521
  430. - remove patch to include locale.h, gone upstream
  431. - upgrade konqueror patch
  432. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  433. - nevermind, BuildRequires gnome-libs, that should
  434. close #48923
  435. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  436. - fix file list to not include absolute path "/usr/share/..."
  437. no idea how that ever worked at all. closes #48923
  438. * Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
  439. - use konqueror, not kfmclient on URLs
  440. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  441. - langify
  442. - use %%{_tmppath}
  443. - make it compile
  444. * Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
  445. - Added Japanese patch.
  446. * Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
  447. - patch that may fix autoconnections (bug 27093)
  448. * Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
  449. - 1.6.3
  450. - remove patch to desktop file (Internet->Application), seems to
  451. have gone upstream
  452. * Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
  453. - Remove security fix which has been merged upstream
  454. - upgrade to 1.6.1
  455. * Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
  456. - Don't use /bin/sh to interpret URLs from the net
  457. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  458. - Updated Epoch
  459. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  460. - automatic rebuild
  461. * Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
  462. - Install HTML docs
  463. * Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
  464. - fix desktop entry
  465. * Fri May 19 2000 Havoc Pennington <hp@redhat.com>
  466. - rebuild for the Winston tree, update to 1.4.2