xorg-x11-xsm-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define pkgname xsm
  2. Summary: X.Org X11 X Session Manager
  3. Summary(ja): X.Org X11 X セッションマネージャ
  4. Name: xorg-x11-%{pkgname}
  5. # NOTE: The Version field should be the version of the xsm tarball.
  6. Version: 1.0.2
  7. # Bump the release on rebuilds/bugfixes/etc.
  8. Release: 5%{?_dist_release}
  9. License: MIT
  10. Group: User Interface/X
  11. URL: http://www.x.org
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.2.tar.bz2
  14. Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.5.tar.bz2
  15. Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
  16. # Patches for xsm (10-19)
  17. Patch10: xsm-1.0.2-xsm-installation-location-fixes.patch
  18. # Patches for smproxy (20-29)
  19. # Patches for rstart (30-39)
  20. Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
  21. # FIXME: Temporary dependency on automake/autoconf while they're still needed.
  22. BuildRequires: automake autoconf
  23. BuildRequires: pkgconfig
  24. BuildRequires: xorg-x11-util-macros
  25. BuildRequires: xorg-x11-proto-devel
  26. BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
  27. BuildRequires: rsh
  28. # NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
  29. # monolithic X releases to modular X releases to work properly.
  30. Requires(pre): xorg-x11-filesystem
  31. # rstart script invokes xauth, rsh
  32. Requires: xauth, rsh
  33. Provides: xsm, smproxy, rstart, rstartd
  34. # NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
  35. Obsoletes: XFree86
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. %description
  39. X.Org X11 X Session Manager
  40. %prep
  41. %setup -q -c %{name}-%{version} -a1 -a2
  42. %patch10 -p0 -b .xsm-installation-location-fixes
  43. %patch30 -p0 -b .rstart-installation-location-fixes
  44. %build
  45. # Build everything
  46. {
  47. for pkg in xsm smproxy rstart ; do
  48. pushd $pkg-*
  49. sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
  50. aclocal ; automake ; autoconf
  51. %configure --disable-xprint
  52. make
  53. popd
  54. done
  55. }
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. # Install everything
  59. {
  60. for pkg in xsm smproxy rstart ; do
  61. pushd $pkg-*
  62. make install DESTDIR=$RPM_BUILD_ROOT
  63. popd
  64. done
  65. }
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %files
  69. %defattr(-,root,root,-)
  70. # FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
  71. # can't use the %%version macro here until a upstream xsm is released as
  72. # version 1.0.2 or higher.
  73. #%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
  74. #%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
  75. %doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
  76. %doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
  77. %{_bindir}/rstart
  78. %{_bindir}/rstartd
  79. %{_bindir}/smproxy
  80. %{_bindir}/xsm
  81. %dir %{_datadir}/X11
  82. %dir %{_datadir}/X11/rstart
  83. %dir %{_datadir}/X11/rstart/commands
  84. %{_datadir}/X11/rstart/commands/@List
  85. %{_datadir}/X11/rstart/commands/ListContexts
  86. %{_datadir}/X11/rstart/commands/ListGenericCommands
  87. %dir %{_datadir}/X11/rstart/commands/x11r6
  88. %{_datadir}/X11/rstart/commands/x11r6/@List
  89. %{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
  90. %{_datadir}/X11/rstart/commands/x11r6/Terminal
  91. %dir %{_datadir}/X11/rstart/contexts
  92. %{_datadir}/X11/rstart/contexts/@List
  93. %{_datadir}/X11/rstart/contexts/default
  94. %{_datadir}/X11/rstart/contexts/x
  95. %{_datadir}/X11/rstart/contexts/x11
  96. %{_datadir}/X11/rstart/contexts/x11r6
  97. %{_datadir}/X11/app-defaults/XSm
  98. %dir %{_libdir}/X11
  99. %dir %{_libdir}/X11/rstart
  100. # NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
  101. %{_libdir}/X11/rstart/rstartd.real
  102. #%dir %{_mandir}/man1x
  103. %{_mandir}/man1/rstart.1*
  104. %{_mandir}/man1/rstartd.1*
  105. %{_mandir}/man1/smproxy.1*
  106. %{_mandir}/man1/xsm.1*
  107. %dir %{_sysconfdir}/X11
  108. %dir %{_sysconfdir}/X11/rstart
  109. %config %{_sysconfdir}/X11/rstart/config
  110. %dir %{_sysconfdir}/X11/xsm
  111. %config %{_sysconfdir}/X11/xsm/system.xsm
  112. %changelog
  113. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-5
  114. - smproxy-1.0.5
  115. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
  116. - delete Obsoletes: xorg-x11
  117. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
  118. - xsm-1.0.2
  119. - smproxy-1.0.4
  120. - rstart-1.0.4
  121. - update Patch10, Patch30
  122. - fix %%files
  123. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  124. - smproxy-1.0.3
  125. - rstart-1.0.3
  126. * Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  127. - initial build for Vine Linux
  128. * Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
  129. - Fix license tag.
  130. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
  131. - Autorebuild for GCC 4.3
  132. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
  133. - Rebuild for build id
  134. * Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
  135. - Fix man page globs and rebuild for FC7.
  136. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
  137. - Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
  138. - Add 'dist' tag to package release string.
  139. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
  140. - rebuild
  141. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
  142. - Added xsm documentation to doc macro.
  143. - The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
  144. an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
  145. in a few places temporarily until xsm-1.0.2 is available.
  146. * Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
  147. - Fix BuildRequires (#191802)
  148. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  149. - Update smproxy and rstart
  150. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  151. - bump again for double-long bug on ppc(64)
  152. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  153. - rebuilt for new gcc4.1 snapshot and glibc changes
  154. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  155. - Updated all apps to version 1.0.1 from X11R7.0
  156. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  157. - Updated all apps to version 1.0.0 from X11R7 RC4.
  158. - Changed manpage dir from man1x to man1 to match upstream default.
  159. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
  160. - Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
  161. - Added rstart-0.99.1-rstart-installation-location-fixes.patch and
  162. xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
  163. /etc and data files in /usr/share where they belong.
  164. - Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
  165. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
  166. - require newer filesystem package (#172610)
  167. * Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
  168. - Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
  169. - Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
  170. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  171. - Initial build of xsm, smproxy, and rstart from X11R7 RC1