php-ext-mailparse-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. %bcond_without php83
  2. %bcond_without php82
  3. %bcond_with php81
  4. %bcond_with php74
  5. %define extname mailparse
  6. Summary: Email message manipulation for PHP
  7. Summary(ja): PHP用e-mailメッセージ操作拡張
  8. Name: php-ext-%{extname}
  9. Version: 3.1.6
  10. Release: 1%{_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: tomop
  15. License: The PHP License
  16. URL: https://pecl.php.net/package/mailparse
  17. Source: https://pecl.php.net/get/%{extname}-%{version}.tgz
  18. %description
  19. Mailparse is an extension for parsing and working with email messages.
  20. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  21. %description -l ja
  22.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  23. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  24. %if %{with php74}
  25. %package -n php74-ext-mailparse
  26. Summary: Email message manipulation for PHP-7.4
  27. Summary(ja): PHP-7.4用e-mailメッセージ操作拡張
  28. Group: programming
  29. BuildRequires: php74-devel
  30. %if "%{?req_php74_api}" != ""
  31. Requires: %{req_php74_api}
  32. %endif
  33. %description -n php74-ext-mailparse
  34. Mailparse is an extension for parsing and working with email messages.
  35. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  36. %description -n php74-ext-mailparse -l ja
  37.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  38. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  39. %endif
  40. %if %{with php83}
  41. %package -n php83-ext-mailparse
  42. Summary: Email message manipulation for PHP-8.3
  43. Summary(ja): PHP-8.3用e-mailメッセージ操作拡張
  44. Group: programming
  45. BuildRequires: php83-devel
  46. %if "%{?req_php83_api}" != ""
  47. Requires: %{req_php83_api}
  48. %endif
  49. %description -n php83-ext-mailparse
  50. Mailparse is an extension for parsing and working with email messages.
  51. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  52. %description -n php83-ext-mailparse -l ja
  53.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  54. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  55. %endif
  56. %if %{with php82}
  57. %package -n php82-ext-mailparse
  58. Summary: Email message manipulation for PHP-8.2
  59. Summary(ja): PHP-8.2用e-mailメッセージ操作拡張
  60. Group: programming
  61. BuildRequires: php82-devel
  62. %if "%{?req_php82_api}" != ""
  63. Requires: %{req_php82_api}
  64. %endif
  65. %description -n php82-ext-mailparse
  66. Mailparse is an extension for parsing and working with email messages.
  67. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  68. %description -n php82-ext-mailparse -l ja
  69.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  70. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  71. %endif
  72. %if %{with php81}
  73. %package -n php81-ext-mailparse
  74. Summary: Email message manipulation for PHP-8.0
  75. Summary(ja): PHP-8.1用e-mailメッセージ操作拡張
  76. Group: programming
  77. BuildRequires: php81-devel
  78. %if "%{?req_php81_api}" != ""
  79. Requires: %{req_php81_api}
  80. %endif
  81. %description -n php81-ext-mailparse
  82. Mailparse is an extension for parsing and working with email messages.
  83. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  84. %description -n php81-ext-mailparse -l ja
  85.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  86. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  87. %endif
  88. %debug_package
  89. %prep
  90. %setup -q -c -n %{extname}-%{version}
  91. cp %{extname}-%{version}/{LICENSE,README.md,CREDITS} ./
  92. %if %{with php74}
  93. cp -a %{extname}-%{version} php74
  94. pushd php74
  95. phpize74
  96. popd
  97. %endif
  98. %if %{with php83}
  99. cp -a %{extname}-%{version} php83
  100. pushd php83
  101. phpize83
  102. popd
  103. %endif
  104. %if %{with php82}
  105. cp -a %{extname}-%{version} php82
  106. pushd php82
  107. phpize82
  108. popd
  109. %endif
  110. %if %{with php81}
  111. cp -a %{extname}-%{version} php81
  112. pushd php81
  113. phpize81
  114. popd
  115. %endif
  116. %build
  117. %if %{with php74}
  118. pushd php74
  119. %configure --with-php-config=%{_bindir}/php-config74
  120. %__make %{?_smp_mflags}
  121. popd
  122. %endif
  123. %if %{with php83}
  124. pushd php83
  125. %configure --with-php-config=%{_bindir}/php-config83
  126. %__make %{?_smp_mflags}
  127. popd
  128. %endif
  129. %if %{with php82}
  130. pushd php82
  131. %configure --with-php-config=%{_bindir}/php-config82
  132. %__make %{?_smp_mflags}
  133. popd
  134. %endif
  135. %if %{with php81}
  136. pushd php81
  137. %configure --with-php-config=%{_bindir}/php-config81
  138. %__make %{?_smp_mflags}
  139. popd
  140. %endif
  141. %install
  142. rm -rf %{buildroot}
  143. %if %{with php74}
  144. mkdir -p %{buildroot}%{_libdir}/php74/
  145. mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
  146. pushd php74
  147. %makeinstall INSTALL_ROOT=%{buildroot}
  148. popd
  149. cat > %{buildroot}%{_sysconfdir}/php74/php.d/%{extname}.ini <<EOF
  150. ; Enable %{extname} extension module
  151. extension=%{extname}.so
  152. EOF
  153. %endif
  154. %if %{with php83}
  155. mkdir -p %{buildroot}%{_libdir}/php83/
  156. mkdir -p %{buildroot}%{_sysconfdir}/php83/php.d
  157. pushd php83
  158. %makeinstall INSTALL_ROOT=%{buildroot}
  159. popd
  160. cat > %{buildroot}%{_sysconfdir}/php83/php.d/%{extname}.ini <<EOF
  161. ; Enable %{extname} extension module
  162. extension=%{extname}.so
  163. EOF
  164. %endif
  165. %if %{with php82}
  166. mkdir -p %{buildroot}%{_libdir}/php82/
  167. mkdir -p %{buildroot}%{_sysconfdir}/php82/php.d
  168. pushd php82
  169. %makeinstall INSTALL_ROOT=%{buildroot}
  170. popd
  171. cat > %{buildroot}%{_sysconfdir}/php82/php.d/%{extname}.ini <<EOF
  172. ; Enable %{extname} extension module
  173. extension=%{extname}.so
  174. EOF
  175. %endif
  176. %if %{with php81}
  177. mkdir -p %{buildroot}%{_libdir}/php81/
  178. mkdir -p %{buildroot}%{_sysconfdir}/php81/php.d
  179. pushd php81
  180. %makeinstall INSTALL_ROOT=%{buildroot}
  181. popd
  182. cat > %{buildroot}%{_sysconfdir}/php81/php.d/%{extname}.ini <<EOF
  183. ; Enable %{extname} extension module
  184. extension=%{extname}.so
  185. EOF
  186. %endif
  187. %clean
  188. rm -rf %{buildroot}
  189. %if %{with php74}
  190. %files -n php74-ext-mailparse
  191. %defattr(-,root,root)
  192. %license LICENSE
  193. %doc README CREDITS
  194. %{_libdir}/php74/*
  195. %config(noreplace) %{_sysconfdir}/php74/php.d/*
  196. %endif
  197. %if %{with php83}
  198. %files -n php83-ext-mailparse
  199. %defattr(-,root,root)
  200. %license LICENSE
  201. %doc README CREDITS
  202. %{_libdir}/php83/*
  203. %config(noreplace) %{_sysconfdir}/php83/php.d/*
  204. %endif
  205. %if %{with php82}
  206. %files -n php82-ext-mailparse
  207. %defattr(-,root,root)
  208. %license LICENSE
  209. %doc README CREDITS
  210. %{_libdir}/php82/*
  211. %config(noreplace) %{_sysconfdir}/php82/php.d/*
  212. %endif
  213. %if %{with php81}
  214. %files -n php81-ext-mailparse
  215. %defattr(-,root,root)
  216. %license LICENSE
  217. %doc README CREDITS
  218. %{_libdir}/php81/*
  219. %config(noreplace) %{_sysconfdir}/php81/php.d/*
  220. %endif
  221. %changelog
  222. * Sat Jan 20 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.6-1
  223. - new upstream release.
  224. - added php83 support.
  225. - disabled php81 support.
  226. * Fri Mar 17 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.4-1
  227. - new upstream release.
  228. - added php82 support.
  229. - dropped php80 support.
  230. - disabled php74 support.
  231. * Fri Nov 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-2
  232. - added php81 support.
  233. * Mon Nov 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-1
  234. - new upstream release.
  235. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  236. - new upstream release.
  237. - added php80 support.
  238. - dropped php73 support.
  239. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
  240. - dropped Patch0: fixed in upstream.
  241. - added php74 support.
  242. - dropped php72 support.
  243. * Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-2
  244. - added php73 support.
  245. * Wed Dec 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-1
  246. - new upstream release.
  247. - built with php72.
  248. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-2
  249. - rebuilt with php5-5.6.7.
  250. * Fri Dec 13 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  251. - initial build.