glib-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # overwrite configure macro (remove --target option)
  3. %define configure CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; ./configure --host=%{_host} --build=%{_build} --program-prefix=%{?_program_prefix} --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
  4. Summary: A library of handy utility functions.
  5. Summary(ja): 便利なユーティリティ関数ライブラリ
  6. Name: glib
  7. Version: 1.2.10
  8. Release: 6%{?_dist_release}
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. URL: http://www.gtk.org
  12. Source: ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
  13. Patch1: glib-1.2.10-isowarning.patch
  14. Patch2: glib-1.2.10-gcc34.patch
  15. Patch3: glib-1.2.10-config.sub-x86_64.patch
  16. Patch4: glib-1.2.10-gcc5.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. %description
  19. Glib is a handy library of utility functions. This C
  20. library is designed to solve some portability problems
  21. and provide other useful functionality which most
  22. programs require.
  23. Glib is used by GDK, GTK+ and many applications.
  24. You should install Glib because many of your applications
  25. will depend on this library.
  26. This package rebuilds binaries with debug option.
  27. %description -l ja
  28. Glib は便利なユーティリティ関数ライブラリです。この C
  29. ライブラリはいくつかのよく遭遇する問題を解決し、多くの
  30. プログラムで必要な有用な機能を提供するために作られました。
  31. このパッケージでは debug option 付きで binary を 作成します。
  32. %package devel
  33. Summary: Libraries and header files for glib development
  34. Group: Development/Libraries
  35. Requires(post,preun): /sbin/install-info
  36. Requires: %{name} = %{version}-%{release}
  37. %description devel
  38. Static libraries and header files for the support library for the GIMP's X
  39. libraries, which are available as public libraries. GLIB includes generally
  40. useful data structures.
  41. %description devel -l ja
  42. GIMP の X ライブラリをサポートする静的関数およびヘッダファイルです。
  43. GLIB には使いやすいデータストラクチャーも含まれています。
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-%{name}
  46. Summary: A library of handy utility functions.
  47. Group: System Environment/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. %description -n compat32-%{name}
  50. Glib is a handy library of utility functions. This C
  51. library is designed to solve some portability problems
  52. and provide other useful functionality which most
  53. programs require.
  54. %package -n compat32-%{name}-devel
  55. Summary: Libraries and header files for glib development
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}-%{release}
  58. %description -n compat32-%{name}-devel
  59. Static libraries and header files for the support library for the GIMP's X
  60. libraries, which are available as public libraries. GLIB includes generally
  61. useful data structures.
  62. %prep
  63. %setup -q
  64. %patch1 -p1 -b .isowarning
  65. %patch2 -p1 -b .gcc34
  66. %patch3 -p1 -b .config.sub
  67. %patch4 -p0 -b .gcc5
  68. %build
  69. %configure
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf ${RPM_BUILD_ROOT}
  73. make install DESTDIR=${RPM_BUILD_ROOT}
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  76. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  77. # libgmodule-1.2.so.0* missing eXecute bit
  78. chmod -c a+x %{buildroot}%{_libdir}/lib*.so*
  79. #%find_lang %{name}
  80. %clean
  81. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %post devel
  85. /sbin/install-info %{_infodir}/glib.info* %{_infodir}/dir
  86. %preun devel
  87. if [ "$1" = 0 ]; then
  88. /sbin/install-info --delete %{_infodir}/glib.info* %{_infodir}/dir
  89. fi
  90. %post -n compat32-%{name} -p /sbin/ldconfig
  91. %postun -n compat32-%{name} -p /sbin/ldconfig
  92. %files
  93. %defattr(-, root, root)
  94. %doc AUTHORS COPYING ChangeLog NEWS README
  95. %{_libdir}/libglib-1.2.so.*
  96. %{_libdir}/libgthread-1.2.so.*
  97. %{_libdir}/libgmodule-1.2.so.*
  98. %files devel
  99. %defattr(-, root, root)
  100. %{_bindir}/*
  101. %{_libdir}/lib*.so
  102. %{_libdir}/glib
  103. %{_libdir}/pkgconfig/*
  104. %{_includedir}/*
  105. %{_datadir}/aclocal/*
  106. %{_infodir}/*
  107. %{_mandir}/man1/*
  108. ## to build compat32 for x86_64 architecture support
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-, root, root)
  112. %{_libdir}/libglib-1.2.so.*
  113. %{_libdir}/libgthread-1.2.so.*
  114. %{_libdir}/libgmodule-1.2.so.*
  115. %files -n compat32-%{name}-devel
  116. %defattr(-, root, root)
  117. %{_libdir}/lib*.so
  118. %{_libdir}/glib
  119. %endif
  120. %changelog
  121. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-6
  122. - add Patch4 (glib-1.2.10-gcc5.patch) from fc
  123. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-5
  124. - rebuild with VineSeed environment
  125. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-4
  126. - rebuild with rpm-4.8.1 for pkg-config file
  127. * Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-3
  128. - spec in UTF-8
  129. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-2
  130. - updated %%if %%{build_compat32} case related statements
  131. * Tue May 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
  132. - applied new versioning policy
  133. - moved Requires(post,preun): /sbin/install-info to devel package
  134. * Fri Feb 10 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl7
  135. - added compat32-* packages for x86_64 architecture support
  136. - added glib-1.2.10-config.sub-x86_64.patch
  137. * Tue Feb 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl6
  138. - rebuild
  139. - disable %%find_lang macro
  140. - refine %%configure macro
  141. - add PreReq: ldconfig, install-info instead of /sbin/install-info
  142. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl5
  143. - rebuilt
  144. - change from Copyright to License
  145. - add patch2
  146. - remove info/dir
  147. * Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl4
  148. - rebuilt with new toolchain
  149. - TODO: we better remove info files when glib2 be ready to ship...
  150. * Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
  151. - Applied RH patch (glib-1.2.10-isowarning.patch)
  152. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  153. - Add #pragma GCC system_header to supress warnings when in -pedantic
  154. mode. (41271)
  155. - Added %%{_libdir}/pkgconfig to devel file list.
  156. * Sat Jul 14 2001 <sagami@vinelinux.org>
  157. - 1.2.10-0vl2: put %%patch0 at %%setup, not %%build. But already applied:-)
  158. * Tue Apr 3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
  159. - New upstream release.
  160. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
  161. - New upstream release.
  162. * Mon Feb 05 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  163. - 1.2.8-0vl2
  164. - fixed files section so as not to own mandir itself
  165. - use better macros
  166. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  167. - updated to 1.2.8
  168. * Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  169. - [glib-1.2.7-0vl1]
  170. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  171. - [glib-1.2.6-1]
  172. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  173. - [glib-1.2.5-1]
  174. * Tue Sep 7 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  175. [glib-1.2.4-2.1]
  176. - added debug option to CFLAG.
  177. * Mon Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  178. [glib-1.2.4-2]
  179. - gzip info.
  180. * Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  181. [glib-1.2.4-1]
  182. - version 1.2.4.
  183. - bzip2 source.
  184. - info is installed in glib-devel.
  185. * Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
  186. - added Japanese summary and description
  187. - build for Vine-1.9
  188. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  189. - version 1.2.3
  190. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  191. - version 1.2.1
  192. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  193. - Version 1.2
  194. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  195. - version 1.2.0pre1
  196. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  197. - new description tags
  198. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  199. - removed libtoolize from %build
  200. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  201. - added libgthread to file list
  202. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  203. - version 1.1.15
  204. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  205. - version 1.1.14
  206. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  207. - version 1.1.13
  208. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  209. - version 1.1.12
  210. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  211. - updated in preparation for the GNOME freeze
  212. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  213. - Split out glib package